14:31:35 <samccann> #startmeeting DaWGs aka Docs Working Group
14:31:35 <zodbot> Meeting started Tue Oct 15 14:31:35 2019 UTC.
14:31:35 <zodbot> This meeting is logged and archived in a public location.
14:31:35 <zodbot> The chair is samccann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:31:35 <zodbot> The meeting name has been set to 'dawgs_aka_docs_working_group'
14:31:46 <samccann> Who's around to talk the docs??
14:32:13 * gundalow is only half around, so feel free to ping me if there is something specific
14:32:18 <samccann> abadger1999 gundalow alongchamps cyberpear ?
14:32:57 * samccann turns gundalow into comfy pillow... not quite a chair
14:33:15 <gundalow> :)
14:33:15 <acozine> o/
14:33:26 <samccann> #chair acozine
14:33:26 <zodbot> Current chairs: acozine samccann
14:34:13 * acozine told myself to "sit down" and immediately started singing "Sit Down You're Rocking the Boat"
14:34:20 <alongchamps> I'm here
14:34:25 * acozine it's a damnably catchy tune
14:34:29 <samccann> hellooooooo alongchamps !!
14:34:34 <samccann> #chair alongchamps
14:34:34 <zodbot> Current chairs: acozine alongchamps samccann
14:35:13 <samccann> our agenda is here - https://github.com/ansible/community/issues/389
14:35:30 <samccann> ooph this is better - https://github.com/ansible/community/issues/389#issuecomment-542220871
14:35:43 <thedoubl3j> I am here if needed as well
14:35:47 <acozine> the scrolling, the scrolling!
14:35:59 <samccann> kewl!! #chair thedoubl3j
14:36:04 <samccann> hmph.
14:36:15 <samccann> #chair thedoubl3j
14:36:15 <zodbot> Current chairs: acozine alongchamps samccann thedoubl3j
14:36:24 <samccann> there ya go! Furniture.
14:36:30 <acozine> ah, TIL, the command must be the beginning of the line
14:36:30 <samccann> #Topic Roles documentation
14:37:03 <samccann> So to start, we are moving Galaxy docs onto docs.ansible.com... one bit at a time, so that we can eventually retire the docsite associated with galaxy
14:37:39 <acozine> hooray! the Galaxy docs are a backwater, no links to the rest of the documentation
14:38:03 <thedoubl3j> one docs site to rule them all
14:38:04 <acozine> integrating those topics will be a much better user experience
14:38:06 <samccann> Yep. In that effort, we created a Galaxy section on docs.ansible.com, and moved up the galaxy info that was in an appendix - https://docs.ansible.com/ansible/devel/galaxy/user_guide/index.html
14:38:55 <samccann> heh yep, acozine == sauron... and that makes me the guy with the long white hair then has a sticky end in his lonely flooded tower
14:39:04 <felixfontein> hi!
14:39:09 <samccann> helloo!!
14:39:13 <acozine> hey, I object to both of those characterizations!
14:39:22 <samccann> #chair felixfontein
14:39:22 <zodbot> Current chairs: acozine alongchamps felixfontein samccann thedoubl3j
14:39:47 <samccann> info - acozine objects to being the Ruler of All Docs and associated evil empire ambitions
14:40:00 <acozine> I'm a Benevolent Overlord, really
14:40:06 <samccann> Meanwile... roles
14:40:10 <felixfontein> lol
14:40:38 <samccann> Those familiar, please do read that galaxy section and open PRs or issues against it. It probably hasn't seen the docs love it needs yet, so I'm sure there are issues with it.
14:40:45 <samccann> #link https://docs.ansible.com/ansible/devel/galaxy/user_guide/index.html
14:41:03 <samccann> #info looking for experienced roles folks to review that galaxy docs on docs.ansible.com
14:41:28 <samccann> And there is an open PR for installing docs - https://github.com/ansible/ansible/pull/63486
14:41:38 <acozine> do folks think we should promote the Galaxy docs to docs.ansible.com/galaxy? or keep them as a subsidiary to docs.ansible.com/ansible ?
14:41:39 <samccann> Please have a look
14:41:51 <samccann> oo good question
14:41:52 <acozine> I can't remember if we discussed that or not
14:41:59 <samccann> We haven't
14:42:21 <samccann> my initial thought - keep it on docs.ansible.com because people can't work galaxy "in a vacuum" so to speak
14:42:54 <acozine> yeah, i don't know how well we can integrate content at the docs.ansible.com/product level
14:43:14 <acozine> if it doesn't work well, then keeping galaxy under "core" seems smart
14:43:21 <samccann> it's part of Ansible itself if that makes sense. So if I'm creating a collection or a role, I still need to know how to write modules, document modules, etc etc and that's all on docs.ansible.com/ansible
14:43:35 <acozine> yeah, that makes sense
14:43:39 <alongchamps> if it's big enough, and it seems like it is, I like docs.ansible.com/galaxy
14:44:02 <alongchamps> but then there's the version part that ties to ansible
14:44:07 <thedoubl3j> it is almost half and half.
14:44:15 <samccann> imo it won't be that big. There is a user guide and a dev guide, but again, doesn't cover the ansible basics
14:44:29 <thedoubl3j> cli tool comes with ansible, but the site and finding content is a site.
14:44:48 <samccann> There may be a community guide, but I'd rather discuss that with the galaxy folks and see if they want to use the same community guidelines as ansible has
14:45:08 <thedoubl3j> I am fine with keeping it the way it is.
14:45:18 <samccann> thedouble3j - yeah the gui part will be added to the galaxy user guide etc over time. Inching our way there
14:45:51 <thedoubl3j> +1
14:45:57 <samccann> ooo alongchamps++ very good point - galaxy has a different version scheme than ansible core
14:46:16 * samccann ponders the ponderable about versions
14:47:30 <samccann> That has implications I didn't even consider. Right now I'm writing on a 2.9 version of ansible, but galaxy has its own release cycle (and numbering). gundalow - do you know if galaxy releases in the same timeframe as ansible engine? or are they entirely separate on when releases go out?
14:47:41 <acozine> yeah, good point, we may change the Galaxy UI on a different schedule than Ansible itself
14:47:41 <samccann> acozine: same question
14:47:56 <gundalow> Galaxy has it's own release train
14:48:14 <gundalow> ie releases independent to Ansible Core
14:48:18 <samccann> ok then that might push us to moving galaxy 'up' a level as acozine suggested
14:48:40 <samccann> so it can update separate from docs.ansible.com/ansible
14:48:54 <samccann> off the top of my head, that's a bit of work for sure
14:49:23 <samccann> and makes me wonder - if galaxy is its own tab, it's not much different than having it on galaxy website itself. It still may not get the docs love it needs
14:51:05 <samccann> might need to table this discussion for now, gonna take Deeper Thoughts (tm)
14:51:55 <samccann> #info - galaxy has an independent release cycle not tied to ansible engine - it may need its own landing page to reflect different versions etc
14:52:05 <samccann> ok moving on
14:52:33 <samccann> #topic Fix return value PRs
14:52:44 <samccann> These are a pair from felixfontein
14:52:56 <samccann> #link https://github.com/ansible/ansible/pull/63478
14:53:14 <samccann> #link https://github.com/ansible/ansible/pull/63477
14:53:36 <acozine> thank you to felixfontein for working to make the return values documentation more useful
14:53:44 <samccann> \o/
14:54:06 <samccann> they are both passing CI and have approvals... is there anything holding us up from hitting the merge button on these two?
14:54:47 <felixfontein> these two PRs are preparations (which should be safe to backport) for https://github.com/ansible/ansible/pull/63411
14:54:59 <felixfontein> maybe one more review for https://github.com/ansible/ansible/pull/63411 so that there are at least two reviews for each?
14:55:35 <felixfontein> ah wait one more for https://github.com/ansible/ansible/pull/63478 I meant
14:55:44 <felixfontein> sorry, my network connection is pretty crappy, so I'm slow at writing :)
14:56:19 <samccann> ok so one more review for #63478 and then both are safe for backporting?
14:56:31 <felixfontein> I would say so
14:56:34 <samccann> and once they are done, #63411 can be rebased and merged?
14:57:06 <felixfontein> I'with a bit of review, perhaps :)
14:57:06 <felixfontein> yes
14:57:07 <samccann> acozine and I are doing a batch of docs backporting later today. Do those two earlier ones need #63411 merged and backported as well?
14:57:18 <samccann> (with a review) :-)
14:57:41 <felixfontein> I'm not sure whether 63411 should be backported. also, it's using `elements:` for return values, which currently only exists in devel
14:57:47 <thedoubl3j> _looks at 63478_
14:57:56 <samccann> my point - the first two can easily be merged and backported today. #63411 requires more work, so could miss the 'backport window' so to speak
14:57:57 <felixfontein> (see last item of docs agenda for today ;) )
14:58:25 <samccann> ah ok. so the first two are safe to backport, the last one needs discussion
14:58:52 <felixfontein> I'm fine if new validation is only in devel (for 2.10), that probably shouldn't be beackported
14:58:55 <felixfontein> the other fixes from 63411, that's anohter story
14:58:58 <samccann> #agreed can review then merge #63478 and #63477 and backport to 2.9
14:58:59 <felixfontein> (after rebasing we'll see what's left)
14:59:21 <felixfontein> I would also rbackport them to 2.8, since the errors mostly exist there as well
14:59:38 <felixfontein> (63478 and 63477 that is, not 63411)
15:00:01 <samccann> #agreed 63478 and 63477 will be safe to backport to 2.8 as well
15:00:07 <acozine> felixfontein: if parts of 63411 should be backported and parts should not, should it be split again into 2 PRs?
15:00:32 * acozine apologizes if she missed part of the conversation
15:00:47 <acozine> my other meeting just ended, so I am 100% present now
15:01:11 <felixfontein> acozine, I can split it up, but first the others need to be merged, so I'll see what's left of all the changes :)
15:01:16 <acozine> gotcha
15:01:21 * acozine looks at the two PRs
15:01:47 <felixfontein> thedoubl3j: thanks for reviewing!
15:02:09 <acozine> 63477 has had plenty of eyes on it
15:02:27 <acozine> I'm happy to merge, unless someone is still reviewing it
15:02:33 <felixfontein> I think so too, but I didn't want to merge it before the meeting ;)
15:02:49 <acozine> heh, thanks
15:03:15 <acozine> merged
15:03:22 <felixfontein> \o/
15:03:26 <felixfontein> thanks :)
15:04:13 <acozine> wow, those vultr modules all did the same thing
15:04:40 <samccann> felixfontein - the pr you wanted to test first, is that related to this discussion?
15:04:50 <samccann> https://github.com/ansible/ansible/pull/63409
15:05:00 <samccann> wondering if we should jump to that topic next?
15:05:01 <acozine> so lib/ansible/modules/cloud/amazon/ec2_vpc_nacl_info.py now uses `elements` . . . is that dependent on a change we don't want to backport?
15:05:17 <felixfontein> samccann: yes partially, since 63411 is using the feature added there
15:06:30 <felixfontein> acozine: do you mean because of 63411?
15:06:52 <felixfontein> acozine: it should not be contained in 63477 and 63478
15:07:57 <acozine> felixfontein: as part of 63478 I see `elements` being added to that module
15:08:14 <acozine> I think . . . let me double-check that I wasn't looking at the wrong thing
15:08:54 <acozine> ah, no, my mistake
15:08:56 <thedoubl3j> I am not seeing anything touching elements there. _goes to double check_
15:09:00 <acozine> ETOOMANYTABS
15:09:34 <acozine> that's in 63411
15:09:51 <felixfontein> ok, then it's fine!
15:09:55 <samccann> phew
15:10:04 <samccann> are we okay to move to the next topic?
15:10:24 <acozine> sure
15:10:25 <felixfontein> abadger just merged https://github.com/ansible/ansible/pull/63409
15:10:33 <samccann> heh
15:10:48 <samccann> #topic should #63409 be tested?
15:10:51 <acozine> felixfontein: should https://github.com/ansible/ansible/pull/63478/files#diff-b8cfe9953f1b6756e8d4da425dd3232aR204 be 'sample' instead of 'example'?
15:11:01 <felixfontein> can someone from you rebuild the test docs site with that branch ()?ODODtemporary-2.9.1-branch-releng-only
15:11:04 <samccann> well, we can still put it on the docs test site if you want to see it in action
15:11:40 <acozine> samccann: you want to kick off a build to the test site, or shall I?
15:12:30 <samccann> hmm well abadger1999 merged it to a temp branch. ansible:temporary-2.9.1-branch-releng-only not sure how to find that?
15:12:47 <samccann> or is it just that - ansible/temporary-2.9.1-branch-releng-only
15:13:10 <abadger1999> yeah... you might want to build the temporary-2.9.1-branch-releng-only to the testing site?
15:13:12 <abadger1999> It is
15:13:27 <abadger1999> https://github.com/ansible/ansible/tree/temporary-2.9.1-branch-releng-only
15:14:31 <samccann> hmm what do I set as the GIT_BRANCH in the jenkins build abadger1999 ?
15:14:46 <abadger1999> I believe: temporary-2.9.1-branch-releng-only
15:15:00 <samccann> ok I'll give that a try, thanks!
15:15:18 <acozine> which fork is that branch on?
15:15:43 <samccann> oh I tried it as orgin/temporary-2.9.1-branch-releng-only
15:15:44 <abadger1999> It's in the main repository
15:15:46 <abadger1999> ansible/ansible
15:15:59 <abadger1999> I believe origin maps to ansible/ansible in jenkins
15:16:08 <felixfontein> should I create backports for #63477, or does anyone else wants to do that? the 2.8 backport will be annoying, since ignore.txt format changed and some new modules and new features are affected
15:16:39 <samccann> acozine and I are doing 2.9 backports for docs later today so feel free to handle that 2.8 fun if you want :-)
15:16:41 <abadger1999> @samccann Do you normally use origin/stable-2.8 or stable-2.8?
15:16:47 <felixfontein> also, how about https://github.com/ansible/ansible/pull/63478, any more reviews, or should we merge?
15:17:03 <felixfontein> samccann: ok, I'll enjoy that then ;)
15:17:15 <felixfontein> I'll backport both PRs (once the second is merged) to stable-2.8
15:17:16 <samccann> @abadger it defaults to origin/devel so i figured origin/<fillintheblank> would work. 12 minutes from now, we should know :-)
15:17:32 <samccann> thanks @felixfontein !!
15:18:03 <abadger1999> @samccann Okay, then origin/temporary-2.9.1-branch-releng-only will probably work.... origin is usually the default so it might work without the origin/ as well.
15:18:07 <samccann> #info putting #63409 onto the docs test site for review
15:18:20 <samccann> good to know abadger1999
15:18:36 <acozine> felixfontein: review added to 63478
15:19:11 <samccann> ooo felixfontein added a review already for the next topic (thanks!) so gonna skip that one
15:19:52 <samccann> The next agenda topic is issues triage, but before hopping to that. gonna do an Open Floor
15:19:58 <samccann> #topic Open Floor
15:20:10 <samccann> anyone have anything to discuss before we attempt a little docs issues triage?
15:21:34 <acozine> I have a quick topic
15:21:38 <samccann> go for it
15:21:53 <felixfontein> acozine: validation allows both `sample` and `example`, I guess we should normalize that (I think also that docs generation only uses one of them, probably `sample`)
15:22:19 <acozine> felixfontein: cool, i put suggestions for the two `example` ones in my review
15:22:41 <acozine> so I'm working on a fairly deep edit of the User Guide pages
15:22:58 <samccann> #topic User Guide revamp
15:23:11 <acozine> the first round was https://github.com/ansible/ansible/pull/63056
15:23:33 <acozine> the next round is going to touch a bunch of the playbooks pages
15:23:58 <acozine> and I'm thinking of reorganizing some of them around a theme of "working with data"
15:24:43 <acozine> I noticed that the mailing lists get a ton of questions about "how do I get the fact/variable value I need in my next task?"
15:24:59 <acozine> so . . . I'm looking for good examples
15:25:08 <acozine> real-world examples of complex return data
15:25:16 <acozine> suitably sanitized, of course
15:26:03 <acozine> ideally it would be a data set I could pull several different examples from
15:26:35 <samccann> #info - revamping the playbooks pages and loking for good examples of complex return data (sanitized) to pull several examples from for getting fact/variable values in tasks etc
15:26:49 <acozine> thanks samccann!
15:27:42 <acozine> if anyone here in DaWGs has suggestions of things in the User Guide that need updating, please ping me!
15:28:19 <samccann> #info if anyone has suggestions on what needs clarification/updating in the Ansible User Guide - ping acozine :-)
15:28:21 <acozine> or comments on the pages that have been edited/updated - all feedback/comments/suggestions welcome
15:28:25 <acozine> that's it
15:28:32 <samccann> Ok we have time to triage maybe one issue -
15:28:38 <samccann> #topic Issues triage
15:28:39 <samccann> https://github.com/ansible/ansible/issues/63495
15:28:53 <samccann> yum module can also run Python 3 `This module only works on Python 2.
15:29:11 <acozine> hmmm
15:29:18 <acozine> I thought I'd seen a bunch of other related issues
15:29:27 <acozine> IIRC the problem is that the module itself runs fine
15:29:28 <samccann> So seems simple, but do we know for sure yum works on python 3? I'm thinking we could label this an `easyfix` item if all that's needed is to remove that line
15:29:51 <acozine> but yum is not available for Python 3
15:30:00 <acozine> so it's not an Ansible restriction
15:30:06 * acozine searches for the other issues
15:30:17 <samccann> not at all? or is it working for the OP because RHEL 8 does a `dnf` under the covers?
15:30:34 <samccann> I seem to recall Fedora did that 'way back when' so maybe that's part of RHEL 8 now?
15:30:38 <acozine> https://github.com/ansible/ansible/issues/62722#issuecomment-540618529
15:31:18 <samccann> #info see https://github.com/ansible/ansible/issues/62722#issuecomment-540618529 for details
15:31:34 <acozine> As you can see above, the yum module is not available to the python3 runtime. In Ansible this is typically not an issue because we can allow the control system to use whatever python version is available and the remote hosts in the inventory to define their own python interpreter via ansible_python_interpreter, as @sivel mentioned and is documented here. This allows the controller and the remote hosts to use differing python versions
15:31:35 <acozine> without issue because Ansible abstracts away that concern. Therefore, Ansible can run in python3 "mode" on the control host and not worry about the remote hosts python version so long as the inventory takes this into account properly for the hosts.
15:31:47 <samccann> ok we are basically out of time, but thanks everyone for participating today and enjoying your time as a piece of docs furniture!
15:31:51 <acozine> ^^^ that's a quotation, just for the record
15:32:07 * acozine looks forward to being an armoire next week!
15:32:08 <samccann> thanks acozine we can review that and decide what to do with that new issue
15:32:24 <samccann> ok gonna close unless someone peeps...
15:32:30 <acozine> thanks samccann felixfontein alongchamps gundalow
15:32:39 <alongchamps> see ya
15:32:45 <acozine> ciao!
15:32:56 <felixfontein> thanks everyone!
15:32:59 <samccann> o/ and thanks again for the version comment on galaxy! that was a real blindspot for me
15:33:03 <samccann> #endmeeting