#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:31:22 UTC (full logs).

Meeting summary

    1. https://www.redhat.com/en/summit (samccann, 14:36:17)
    2. https://github.com/ansible/community/issues/521#issuecomment-617256701 (acozine, 14:36:58)

  1. changelogs for ACD (acozine, 14:38:27)
    1. ACD live mockups based on felixfontein's scripts - https://github.com/felixfontein/ansible-changelog/blob/master/acd/acd.rst (samccann, 14:42:24)
    2. ACD mockup with ACD version as first header - https://github.com/felixfontein/ansible-changelog/blob/master/acd/acd2.rst (samccann, 14:43:36)
    3. this is controlled by a config file - https://github.com/felixfontein/ansible-changelog/blob/master/acd/acd.yml (samccann, 14:45:35)
    4. https://github.com/ansible-collections/overview/issues/37 (samccann, 14:49:03)
    5. still need details on how collections will be versioned, especially from a git branching point of view. That's a dependency on finishing the changelog scripts/processes. (samccann, 14:50:07)
    6. ACTION: felixfontein to try and kickstart that branching etc conversation soon. (samccann, 14:50:54)
    7. ACTION: samccann to draft the changelog process as we know it so far into a docs PR for community review/feedback (samccann, 14:53:39)
    8. the collection changelog .yam format (looks like this: https://github.com/felixfontein/community.general/blob/changelog-1.0/changelogs/changelog.yaml as opposed to ansible 2.9 one: https://github.com/ansible/ansible/blob/stable-2.9/changelogs/.changes.yaml) contains the contents of the changelog fragments, and contains more info on the new plugins/modules (samccann, 15:24:32)
    9. 2.9 yaml only contains their names, collection one contains also short desc and namespace (samccann, 15:24:54)
    10. would be good if the formats could get more aligned (I don't mind the changelog fragments being separate files, but the missing additional info on the plugins is painful) - would also be good if there aren't 2 different changelog generators, but one that can handle both ansible-base and collections. (samccann, 15:25:47)
    11. possible categories in the changelog - Security Fixes, Breaking Changes/Porting Guide, Major Changes, Minor Changes, Deprecations, Removals, Bugfixes - will need clear guidance on what goes in each category. (samccann, 15:27:31)
    12. goal is that ansible-base would not have to change anything to start using the new changelog tool (samccann, 15:36:44)


Meeting ended at 15:40:26 UTC (full logs).

Action items

  1. felixfontein to try and kickstart that branching etc conversation soon.
  2. samccann to draft the changelog process as we know it so far into a docs PR for community review/feedback


Action items, by person

  1. felixfontein
    1. felixfontein to try and kickstart that branching etc conversation soon.
  2. samccann
    1. samccann to draft the changelog process as we know it so far into a docs PR for community review/feedback


People present (lines said)

  1. felixfontein (83)
  2. bcoca (56)
  3. acozine (55)
  4. samccann (33)
  5. relrod (16)
  6. zodbot (9)


Generated by MeetBot 0.1.4.