17:13:29 <rdieter> #startmeeting kde-sig
17:13:29 <zodbot> Meeting started Tue Dec 6 17:13:29 2011 UTC. The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:13:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:13:47 <rdieter> sorry I'm a little slow and late today
17:13:51 <rdieter> #topic roll call
17:13:57 <rdieter> so, who's present today?
17:13:59 * rnovacek is here
17:14:09 * nucleo here
17:14:35 <Kevin_Kofler> Present.
17:14:46 <rdieter> than, jreznik : ping
17:15:09 * than is present
17:15:35 * jreznik is here
17:15:44 <rdieter> #info rdieter rnovacek nucleo Kevin_Kofler than jreznik present today
17:15:52 <rdieter> #chair rdieter rnovacek nucleo Kevin_Kofler than jreznik
17:15:52 <zodbot> Current chairs: Kevin_Kofler jreznik nucleo rdieter rnovacek than
17:16:04 <rdieter> #topic agenda
17:16:20 <rdieter> sorry, no published agenda yet, topics for today?
17:16:42 <rdieter> kde-4.7.4/kde-4.7.90 status updates
17:16:59 <Kevin_Kofler> feature pages
17:17:11 <Kevin_Kofler> (status update)
17:17:44 <jreznik> added to agenda
17:18:10 <rdieter> kudos to jreznik for the speedy wiki editing :)
17:18:39 <rdieter> fyi, http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-12-06#Agenda
17:18:50 <rdieter> k, lets get started then.
17:18:58 <rdieter> #topic kde 4.7.4 status
17:19:24 <rdieter> finally got kde-1l0n tarballs, than whipped up a build quickly earlier today, and I queue'd it all for updates-testing
17:19:47 <rdieter> #info kde 4.7.4 queue'd for f16-updates-testing
17:20:21 <rdieter> anyone else have comments on that? (that's all I've got, else we'll move on...)
17:21:05 <jreznik> 4.7.90 builds are already done too?
17:21:12 <Kevin_Kofler> That's the next topic. :-)
17:21:14 <rdieter> it's in kde-redhat's kde-testing repo too, but my primary host there is down at the moment.
17:21:56 <rdieter> k, lets talk about 4.7.90 then...
17:22:01 <rdieter> #topic kde 4.7.90 status
17:22:34 <rdieter> pretty sure all (most!) of 4.7.90 is in rawhide now, pending a few new pkg review splits (for kdeutils, kdeaccessibility)
17:22:37 <nucleo> 4.7.4 from kde-testing works fine, solid-upnp enabled with setting SOLID_UPNP=1
17:23:01 <jreznik> I'll do kdeutils reviews, pls. someone should take care about kdeaccessibility reviews
17:23:16 * rdieter hopes to do some kdeaccessibility ones today too
17:23:31 <rdieter> #info most of kde 4.7.90 in rawhide now
17:24:01 <rdieter> #info some pkg reviews for split kdeaccessibility, kdeutils still need to be done
17:24:05 <rnovacek> 4.7.4 works fine for me, I'm not able reproduce the lokalize bug
17:24:25 <rdieter> rnovacek: which bug is that do you remember?
17:24:30 <rnovacek> but I didn't try earlier, so not sure if fixed
17:24:49 <Kevin_Kofler> IIRC, the Lokalize bug was simply a missing dependency.
17:25:04 <Kevin_Kofler> We added the dependency, so if everything is working now, everything should be fine.
17:25:08 <rdieter> .bug 753414
17:25:09 <rdieter> ?
17:25:10 <zodbot> rdieter: Bug 753414 Lokalize: Project overview doesn't work, missing dep on kdesdk-strigi-analyzer - https://bugzilla.redhat.com/show_bug.cgi?id=753414
17:25:21 <rnovacek> rdieter: yes
17:25:27 <rdieter> that one should be fixed now, yeah
17:25:56 <rdieter> my bad for doing package spilts, and not following README.PACKAGERS provided by upstream
17:26:05 <rnovacek> .bug 742583
17:26:09 <zodbot> rnovacek: Bug 742583 konsole with terminus font cuts off descenders of characters - https://bugzilla.redhat.com/show_bug.cgi?id=742583
17:26:17 <rnovacek> it's still broken
17:26:30 <Kevin_Kofler> So let's take this off the list of fixed bugs.
17:26:34 <rdieter> rnovacek: interesting, the upstream fix for that is included in kde-4.7.4 tarballs
17:26:45 <rdieter> will need to reopen upstream bug too then
17:26:47 <rnovacek> but can be fixed by checking bidirectional something in konsole setting
17:26:48 <Kevin_Kofler> So the fix doesn't work? :-/
17:27:09 <Kevin_Kofler> Hmmm, so they only fixed the BiDi case?
17:27:20 <rnovacek> I'll recheck later to be sure
17:27:37 <rdieter> maybe there's more than one bug here
17:28:01 <Kevin_Kofler> rdieter: Speaking of kdesdk, we should move the remaining files in the main package to 1 or 2 subpackages, so that it's really an empty metapackage.
17:28:14 <rnovacek> that BiDi was IMHO suggested as workaround for original bug, so it doesn't need the fix
17:28:17 <Kevin_Kofler> And we should probably change comps-f17 to list the subpackages rather than the metapackage.
17:28:51 <rdieter> Kevin_Kofler: feel free to suggest how to do the subpkgs then. I basically gave up trying to come up with something usefull, and just stuffed into the main pkg. :-/
17:28:51 <nucleo> metapackages still will be available?
17:29:12 <rdieter> nucleo: yes (for the foreseeable future)
17:29:17 <Kevin_Kofler> Yes, but sticking them into comps is not that helpful for people who want to customize their installation.
17:29:54 <rdieter> Kevin_Kofler: re: comps , if we're adding all the splits, yes, do keep the metapackages out of comps
17:30:08 <rdieter> imo
17:30:27 <rnovacek> rdieter: is 4.8.90 in kde-unstable? I'm considering giving it a try
17:30:47 <rdieter> rnovacek: not yet, I'd started the builds yesterday, not sure how far it got before my host died. :(
17:31:25 <rnovacek> rnovacek: ok, no rush
17:31:31 <rnovacek> rdieter: ^
17:31:45 <rdieter> Ill announce it when it's ready and available, promise. :)
17:32:09 <rnovacek> awesome :)
17:32:51 <rdieter> so, I'll take the task of adding to comps the split packaging... (the ones done so far anyway)
17:33:21 <rdieter> any objection to the idea to keep the metapackages out of comps?
17:34:35 <Kevin_Kofler> Not from me, as long as the metapackages really are empty.
17:34:43 <Kevin_Kofler> (which is not the case of kdesdk, which needs to be fixed)
17:35:09 <than> Kevin_Kofler: +1
17:35:23 <jreznik> Kevin_Kofler: +1
17:35:32 <Kevin_Kofler> The stuff in kdesdk needs to go to a kdesdk-kdeaccounts or kdesdk-kdeaccounts-plugin subpackage.
17:35:51 <Kevin_Kofler> Not sure about kdesdk-devel with that one header file in it.
17:36:29 <Kevin_Kofler> I'd suggest moving that to a new kdesdk-kprofilemethod-devel and have kdesdk-devel also be a metapackage.
17:37:01 <Kevin_Kofler> -common with the license files is fine, and the rest is already in subpackages.
17:38:17 <rdieter> ok, sounds reasonable to me
17:38:41 <Kevin_Kofler> I think kdesdk-kdeaccounts is probably sufficient for the first subpackage name.
17:38:50 <rdieter> agreed
17:41:02 <rdieter> #action rdieter to add split packaging to comps-f17
17:41:17 <rdieter> #topic Feature pages
17:41:34 <rdieter> Kevin_Kofler: update on gsoc feature page?
17:41:58 <Kevin_Kofler> https://fedoraproject.org/wiki/Features/Plasma_PackageKit_Integration was approved by FESCo in their latest meeting.
17:42:17 <Kevin_Kofler> (It didn't get moved to the accepted category yet, but it was accepted.)
17:42:46 <Kevin_Kofler> jreznik: You wanted to file a feature page for 4.8, didn't you? What's the status of that?
17:43:55 <rdieter> regardless, we do really want a kde48 one, whether the writeup is done by jreznik or not. :)
17:44:30 <Kevin_Kofler> Indeed.
17:44:31 <jreznik> ok, I'll start it, sorry it's not yet done...
17:44:52 <rdieter> jreznik: sucker, err, thanks!
17:44:57 <Kevin_Kofler> ;-)
17:45:23 <rdieter> #action jreznik to init a f17 kde48 feature page for fesco
17:45:54 <jreznik> what we want in f17 feature? big one or smaller ones (like active in separate one etc.)
17:46:02 <rdieter> #info fesco accepted Kevin_Kofler's https://fedoraproject.org/wiki/Features/Plasma_PackageKit_Integration
17:46:19 <jreznik> 2012-01-24 Feature Submission Deadline
17:46:28 <rdieter> jreznik: good question, I'd say whatever we're equiped to handle
17:46:30 <jreznik> but I'll try to send it to fesco asap
17:46:43 <rdieter> more feature pages mean more visibility, marketing yada yada, but it's also more work
17:46:52 <jreznik> rdieter: I'd do Active separate - for marketing purposes
17:47:11 <rdieter> active really isn't part of kde48, true
17:47:31 * rdieter is tempted to do something for kde-telepathy too
17:47:48 <rdieter> depends on how good it gets, and how much we end up integrating it into the default install I guess
17:48:02 <jreznik> then we want software composite effects rendering - it's standalone feature for gnome shell, I was tempted to do it for plasma too, but it's enough in 4.8 I think
17:48:25 <jreznik> rdieter: but good idea to promote it more
17:48:32 <jreznik> even we can't finish it by f17
17:48:38 <rdieter> ok
17:49:03 <jreznik> I'll do that 4.8 and active ones
17:49:03 <rdieter> #action init f17 kde-telepathy feature (rdieter)
17:49:13 <jreznik> can help with telepathy one
17:49:22 <rdieter> #action init f17 plasma-active feature (jreznik)
17:49:33 <rdieter> jreznik: thanks
17:49:37 <Kevin_Kofler> I think we should look for kdelibs features which didn't make it in due to the kdelibs freeze and backport them all, and loudly advertise that.
17:50:00 <Kevin_Kofler> There's a feature for improved cookie privacy settings, for example.
17:50:13 <rdieter> Kevin_Kofler: If you find anything worth doing the work for, and supporting it, can certainly consider it on a case-by-case basic
17:50:30 <rdieter> basis even
17:51:01 <Kevin_Kofler> Yeah, I already brought up the cookie stuff (and we agreed that it'd be nice to have), I'm going to look into patching that in for sure.
17:51:11 <jreznik> yep, if you volunteer to maintain it :)
17:51:13 <Kevin_Kofler> I need to see whether there's more stuff we could use.
17:51:20 <jreznik> Kevin_Kofler: ok
17:51:48 <Kevin_Kofler> The good thing about the freeze is that kdelibs is going to change very little, so feature backports shouldn't be hard to keep applying. :-p
17:53:00 <jreznik> ah, that's right indeed
17:54:55 <rdieter> ok, sounds like that's wrapped up
17:54:58 <rdieter> #topic open discussion
17:55:03 <rdieter> anything else today?
17:56:10 <Kevin_Kofler> Yes, one more thing…
17:56:31 <Kevin_Kofler> WTF is that libnepomukdatamanagement-copy.so in kdepim-runtime?
17:56:57 <Kevin_Kofler> Where is that copied from and would it be possible to change the non-copied version instead?
17:57:04 <rdieter> oh, the unversioned shlib you recently moved to -lib ?
17:57:08 <Kevin_Kofler> Yes.
17:57:14 <Kevin_Kofler> -copy sounds very bad to me.
17:57:17 <rdieter> no idea, honestly
17:57:35 <rdieter> I would assume/hope upstream did it for good reason
17:57:39 <nucleo> many devel packages installed when it was in -devel
17:57:58 * jreznik never understood reason for -copy bundled libs...
17:58:03 <Kevin_Kofler> The nepomukfeederlib you made static also looks suspicious to me.
17:58:15 <Kevin_Kofler> rdieter, jreznik: I suspect it is because of the kdelibs freeze…
17:58:27 <Kevin_Kofler> Is that a kdelibs lib? If so, can the copy in kdelibs be updated instead?
17:58:40 <rdieter> I checked wrt nepomukfeederlib, other distros are packaging the static lib.
17:59:03 <rdieter> the only reason we ended up with a shlib, was because of our default cmake macro unconditionally enabling shared libs
17:59:53 <rdieter> and that's a configuration upstream obviously didn't expect or test for (else, everyone would've seen the same ftbfs as we did)
18:00:05 <Kevin_Kofler> The "nepomuk" in the name makes this sound suspicious to me, but it might really belong into kdepim-runtime and just use Nepomuk.
18:00:16 <Kevin_Kofler> That -copy lib, OTOH, really sounds like it doesn't belong there.
18:00:49 <rdieter> feel free to poke upstream about it,they'd hopefully be able to definitively answer these questions
18:00:58 <Kevin_Kofler> For nepomukfeederlib, adding that explicit STATIC makes sense in any case, please upstream that if not already done.
18:01:10 * rdieter upstreamed it :)
18:01:45 <rdieter> if the -copy lib doesn't get linked in too many places, maybe it could be made static too
18:02:56 <Kevin_Kofler> I think that if we decide it belongs there, it's OK as shared.
18:03:32 <Kevin_Kofler> The reason nepomukfeederlib doesn't work as shared is because it's missing export macros, I presume.
18:03:39 <rdieter> we're hitting the top of the hour, Kevin_Kofler , you want to ask upstream about it?
18:04:05 <Kevin_Kofler> About that -copy lib? Yes, please ask what's up with that one.
18:04:28 <rdieter> I'm' asking if *you* want to do the asking. :)
18:05:03 <rdieter> else, I'll leave it as an open task in the log
18:06:00 <rdieter> #task ask kdepim upstream on the rationale/purpose for libnepomukdatamanagement-copy.so
18:06:36 <rdieter> ok, I'll wrap up, thanks everyone!
18:06:39 <rdieter> #endmeeting