15:05:02 <rdieter> #startmeeting kde-sig
15:05:02 <zodbot> Meeting started Tue Oct  2 15:05:02 2012 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:08 <rdieter> #topic roll call
15:05:30 <rdieter> hi, who's all around today?
15:05:35 <dvratil_n9> here...sort of
15:05:37 <Kevin_Kofler> Present.
15:05:45 <jgrulich> present
15:05:48 <rdieter> ping: ltinkl, than
15:05:51 <than> present
15:05:53 * ltinkl is present
15:06:07 <rdieter> jreznik sends regards, is busy @ another meeting
15:06:23 <rdieter> #chair Kevin_Kofler jgrulich than ltinkl dvratil_n9
15:06:23 <zodbot> Current chairs: Kevin_Kofler dvratil_n9 jgrulich ltinkl rdieter than
15:06:47 <rdieter> #info rdieter Kevin_Kofler jgrulich than ltinkl dvratil_n9 present, jreznik sends regards
15:07:03 <rdieter> #topic agenda
15:07:07 <rdieter> ok, what to discuss today
15:07:19 <rdieter> kde-4.9.2 status
15:08:23 <Kevin_Kofler> There was another regression reported a few hours ago.
15:08:28 <rdieter> bug #841471 (and friends), maybe time to consider reverting kdelibs' commits to start apps in ~/Documents
15:08:33 <Kevin_Kofler> But only on Rawhide, thankfully.
15:08:40 <rdieter> Kevin_Kofler: the kio-smb thing?
15:08:45 <Kevin_Kofler> Yes.
15:08:46 <rdieter> if so, I think I fixed that
15:08:50 <Kevin_Kofler> Good.
15:09:02 <rdieter> see recent kdelibs/kde-runtime commits
15:09:05 * Kevin_Kofler misses the days where he could check mails in near-realtime. :-(
15:09:21 <Kevin_Kofler> With Akonadi, it always takes several minutes until I can finally read my mails.
15:09:44 * rnovacek is late here
15:10:13 <rdieter> I was also seriously considering shipping a sysctl snippet in nepomuk-core to up the default inotify max_user_watches (needs discussion)
15:10:44 <ltinkl> rdieter: yup, perhaps it's a good idea to test it for F18
15:10:54 <rdieter> anything else for today?
15:11:07 <rdieter> rnovacek: hi!
15:11:35 <Kevin_Kofler> For ~/Documents, it's unfortunate that we're about to override an upstream change, dfaure generally knows what he's doing, but I'm not really opposed to reverting this anymore, for a simple reason:
15:11:49 <Kevin_Kofler> The feature is supposed to be for compatibiity with non-KDE apps, but no other desktop does that.
15:12:14 <Kevin_Kofler> So count me in as neutral (±0) on this.
15:12:35 <rdieter> #topic kde-4.9.2 status
15:12:54 <rdieter> queue'd for f18 updates-testing early yesterday, and it's been pushed in the meantime (yay)
15:13:02 <rdieter> oh, and it's all in kde-testing
15:13:21 <rdieter> f17 kde-4.9.2 update is pending, waiting for official announcement before queue'ing anywhere
15:13:33 <rnovacek> working fine for me on f17 from kde-testing
15:13:59 * than will update 4.9.2 from kde-testing
15:14:06 <rdieter> that's all, any questions/comments about 4.9.2 ?
15:14:31 <ltinkl> all's working fine :) no problem whatsoever
15:15:04 <ltinkl> personally I'm glad we sorted out the remaining systemd-related bits for F18
15:15:20 <rdieter> nepomuk-core-4.9.2-2 includes a nice patch that should help avoid a lot of the crashers being reported
15:15:28 <rdieter> ltinkl: yes!
15:15:39 <than> it means nepomuk regession is fixed in 4.9.2
15:16:00 <rdieter> but I discoverred too that many crashes go away if inotify max_user_watches is raised too
15:16:21 <rdieter> I suspect the deleteLater patch in -2 build is basically the case when max_user_watches are exceeded
15:16:26 <Kevin_Kofler> No surprise there, the bug is in the code which handles the case where you run out of inotify watches.
15:16:36 <Kevin_Kofler> Right, that's exactly it.
15:16:39 <rdieter> ok :)
15:17:05 <Kevin_Kofler> The code deletes the watch which isn't working due to the inotify limit, and the fix uses deleteLater instead of plain delete there.
15:17:16 <G__81> hi everyone
15:17:22 <rdieter> so I was going to propose 2 things:  include a sysctl snippet in nepomuk-core to up the default value
15:17:38 <ltinkl> agree on that (for F18)
15:17:51 <rdieter> either include/install that snippet automatically by default, or just include the .conf sample along with instructions on putting it into /etc/sysctl.d/
15:18:32 <Kevin_Kofler> Will the kernel team approve of us doing that?
15:19:02 <Kevin_Kofler> I'd rather not get flamed by the almighty kernel maintainers. ;-)
15:19:19 <rdieter> Kevin_Kofler: they were... ok with the idea generally when I'd asked way back when.
15:19:37 <rdieter> but generally against changing the "default" kernel value
15:19:43 <Kevin_Kofler> So let's try it, for upcoming releases (F18+) only.
15:19:45 <rdieter> to stray from upstream defaults anyway
15:20:05 <Kevin_Kofler> (or F19+ if you're feeling super-conservative ;-) )
15:20:16 <rdieter> and I ran out of time/energy to poke lkml
15:20:57 <rdieter> ok, I'll do so for f18, and only include a sample snippet for end-user installation on < f18 builds
15:21:16 <rdieter> anyless there are any objection?  than ?
15:21:26 <than> rdieter: it's fine with me
15:21:57 <rdieter> #action rdieter to include sysctl snippet to raise inotify max_user_watches in nepomuk-core
15:21:59 <Kevin_Kofler> It's better not to poke LKML anyway: poke them with a needle and they'll poke you with a giant lance. ;-)
15:22:34 <rdieter> i'd considered putting the snippet in kde-settings ... but seems putting it in nepomuk-core directly for now is the path of least resistance.
15:22:49 <Kevin_Kofler> Yeah, I think it's cleanest.
15:22:56 <Kevin_Kofler> nepomuk-core doesn't depend on kde-settings, does it?
15:23:11 <rdieter> no, *if* I were to do that, I'd make a kde-settings-nepomuk subpkg probably
15:23:15 <rdieter> and depend on that
15:23:49 <than> i think puting it in nepomuk* is cleanest
15:24:29 <rdieter> ok
15:24:41 <rdieter> next topic...
15:25:09 <rdieter> #topic konsole vs kdelibs ~/Document startup dir, deathmatch
15:25:46 <than> it looks like we agree to revent the change in kdelibs
15:25:54 <rdieter> so the konsole fix of adding Path=$HOME has it's own regression, making it not work on != kde
15:26:14 <rdieter> than: I think so, +1
15:27:00 <than> rdieter:so we have  revert the change in konsole from last update
15:27:04 <rdieter> we've discussed the issues at length a couple times before, but does anyone have anything else to add?
15:27:15 <rdieter> than: right, do both at the same time
15:27:20 <than> rdieter:  yes
15:27:24 <Kevin_Kofler> Yeah, I'm withdrawing my objection, for the reason given, I'm not a big fan of doing this, but I'm not going to stop you anymore.
15:27:48 <rdieter> Kevin_Kofler: I felt the same for a long time...
15:27:51 <Kevin_Kofler> (The reason: It looks like KDE is the only desktop behaving this way, which is a bit strange for a "compatibility" feature. ;-) )
15:28:25 <Kevin_Kofler> So I'm changing my -1 objection to a ±0 abstention.
15:28:34 <rdieter> if we're in general agreement, any volunteer to work on implementing it?
15:28:52 <than> ok, i can take care of this issues
15:29:02 <rdieter> probably best to include "contact upstream asking them to revert behavior too" as part of the job too
15:29:15 <rdieter> than: thanks
15:29:23 <than> rdieter: np
15:29:53 <rdieter> #action than to work on implementation of reverting ~/Documents startup behavior (and followup konsole workaround)
15:30:07 <Kevin_Kofler> FYI, I think the Konsole change is already included in 4.9.2.
15:30:12 <rdieter> yes it was
15:30:25 <rdieter> #topic open discussion
15:30:27 <Kevin_Kofler> So you have to revert it explicitly to fix the non-KDE-desktop regression.
15:30:33 <rdieter> yep
15:31:01 <rdieter> I think that covers the topics we mentioned already, anything else before ending the meeting?
15:31:10 <Kevin_Kofler> FYI, I closed the just-filed https://bugzilla.redhat.com/show_bug.cgi?id=862275 nepomuk-core ABRT trace as a duplicate of #858271.
15:31:38 <Kevin_Kofler> I'm pretty sure it's the same use-after-free as the already-addressed isEmpty crash, just with a different backtrace.
15:31:48 <Kevin_Kofler> I wonder if the ~QObject crashes are related, too.
15:31:52 <rdieter> close enough
15:33:43 <rdieter> Kevin_Kofler: I suspect they are
15:33:55 <rdieter> ok, thanks everyone!
15:33:56 <rdieter> #endmeeting