16:00:33 <coremodule> #startmeeting Fedora IoT Working Group Meeting
16:00:33 <zodbot> Meeting started Wed Feb 23 16:00:33 2022 UTC.
16:00:33 <zodbot> This meeting is logged and archived in a public location.
16:00:33 <zodbot> The chair is coremodule. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:33 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
16:00:33 <coremodule> #chair pwhalen pbrobinson bcotton tdawson puiterwijk coremodule
16:00:33 <coremodule> #topic roll call
16:00:33 <zodbot> Current chairs: bcotton coremodule pbrobinson puiterwijk pwhalen tdawson
16:00:59 <coremodule> Good morning/afternoon, who is around for an IoT meeting?
16:01:14 * pwhalen is here
16:01:18 <pwhalen> good morning coremodule
16:03:27 * pbrobinson o/
16:04:22 <coremodule> alright, let's get started
16:04:32 <coremodule> #topic 1) ==== Working Group process and admin ====
16:04:32 <coremodule> #link https://docs.fedoraproject.org/en-US/iot/
16:04:58 <coremodule> I have two things for this, one we touched on last week, but I need some clarification
16:06:02 <coremodule> I want to update the Hardware Tests section of the matrix to include more hardware, but am having trouble making a decision on what to include based on the reference platforms page: https://fedoraproject.org/wiki/Template:General_IoT_test_matrix#Hardware_Tests
16:06:22 <coremodule> Here is the reference platforms page
16:06:23 <coremodule> https://docs.fedoraproject.org/en-US/iot/reference-platforms/
16:07:01 <pbrobinson> I never did finish working out how to add images
16:07:26 <coremodule> since the IoT matrix was created, we have added to the list of reference platforms.
16:07:43 <pwhalen> by images do you mean pictures?
16:07:47 <pbrobinson> have we? Which devices
16:07:49 <pbrobinson> pwhalen: yes
16:08:36 <pwhalen> I think I did that at one point, I used one of the pages as a reference for doing it.
16:09:13 <coremodule> pbrobinson, rpi4 for sure, jetson xaver nx and agx, a few others... I'm just comparing the hardware tests page to the hardware listed on the reference platform page
16:09:13 <pwhalen> I think we should align the matrix with what we have in the docs
16:09:35 <pbrobinson> the AGX and NX are there
16:09:50 <pbrobinson> as is the RPi4
16:09:56 <coremodule> pwhalen, so add all the hardware in the reference page to the matrix?
16:10:05 <pwhalen> I think so
16:10:09 <coremodule> pbrobinson, they're not in the matrix
16:10:59 <coremodule> so I guess that raises another question: would we attempt to block the release if one of these reference platforms failed?
16:11:03 <pbrobinson> coremodule: as in the test matrix or the matrix of devices on the ref platforms page?
16:11:29 <pwhalen> the test matrix, its outdated
16:11:33 <coremodule> the test matrix. they're in the list of devices on the reference page, but not in the test matrix
16:11:41 <pbrobinson> coremodule: to quote that page: "These reference platforms have been tested and are known to work with Fedora IoT, however their inclusion on this list does not necessarily constitute a release-blocking issue should a bug that is specific to the hardware below be found."
16:11:57 <coremodule> yeah, haha, I wrote that
16:13:32 <pwhalen> I think its a good out for us
16:14:38 <coremodule> sorry, power outage
16:15:16 <coremodule> Okay, so I'll update the matrix to reflect all the hardware listed in the reference page.
16:16:08 <coremodule> #action coremodule to update test matrix to reflect all the hardware listed in the reference page
16:16:21 <pwhalen> coremodule++
16:16:21 <zodbot> pwhalen: Karma for coremodule changed to 1 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:16:22 <pwhalen> thanks
16:17:54 <coremodule> the other thing I wanted to talk about was adding a minimum ram amount on the for a virtualized IoT image onto the same reference page
16:18:52 <coremodule> pwhalen and I had trouble booting IoT in a VM with 2gb of ram, had to up it to 4gb to get the image to install.
16:19:05 <coremodule> and by "had trouble" I mean couldn't get it to boot
16:19:06 <pwhalen> the images will work with less ram, installations however require more to pull down the stage2 installer
16:19:38 <coremodule> ah, right, okay. I wonder if we should mention that somewhere in the docs.
16:19:51 <pwhalen> I think fedora recommends 3G? I know we had to bump it up in OpenQA
16:19:59 <pwhalen> yes, we should if its not already
16:20:18 <pbrobinson> yes, booting raw images in theory could do in 256-512mb of ram
16:20:36 <coremodule> okay, I'll do some digging to see where it's listed in general Fedora and then either link to it or write something specific to it in our docs
16:20:51 <pbrobinson> please propose a PR and we can tweak details there
16:21:03 <pwhalen> you can do installs with 1G too, but you need to nfs mount stage2
16:21:15 <coremodule> pbrobinson, wilco
16:22:03 <coremodule> good to know
16:22:52 <coremodule> okay, I'll step off the soapbox. anything else for admin?
16:23:19 * pwhalen has nothing
16:23:20 <pbrobinson> pwhalen: I would call that a hack, not necessarily supported, I would have thought 2gb would work as that's what the builders use
16:23:33 <pbrobinson> that may need a ks/text install though
16:25:27 <pwhalen> fair, I think its documented in our docs. It was recommended by the anaconda team when 1G wasn't enough
16:26:38 <coremodule> #topic 2) ==== Fedora 35 status ====
16:26:39 <coremodule> #info Fedora-IoT-35-20220112.0
16:26:39 <coremodule> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=35&build=Fedora-IoT-35-20220112.0&groupid=1&groupid=5
16:26:53 <coremodule> anything for F35?
16:27:34 <pbrobinson> still not seen a fix for the anaconda/systemd issue
16:27:58 <pwhalen> Right, I think fixes were posted but not yet built
16:28:44 <pbrobinson> I think they thought they were fixes and then revisited, I've lost track TBH. Updates are still getting composes, so not all bad
16:30:56 <coremodule> alright, moving to f36
16:30:57 <coremodule> #topic 3) ==== Fedora 36 status ====
16:30:58 <coremodule> #info Fedora-IoT-36-20220222.0
16:30:58 <coremodule> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=36&build=Fedora-IoT-36-20220222.0&groupid=1&groupid=5
16:31:24 <pbrobinson> there will be a compose when mainline finishes that should fix the naming
16:31:40 <pbrobinson> and with that I think we're looking OK for beta
16:31:54 <coremodule> cool, agreed, it does look good
16:32:57 <pwhalen> other than - PRETTY_NAME should be Fedora Linux 36.20220222.0 (IoT Edition Prerelease) and is Fedora Linux 36 (IoT Edition Prerelease) at fedora/tests/os_release.pm line 190.
16:33:39 <coremodule> I think that's what pbrobinson was saying will be fixed soon
16:33:40 <coremodule> https://bugzilla.redhat.com/show_bug.cgi?id=2055346
16:33:47 <pbrobinson> yes
16:33:58 <pbrobinson> I pushed a change, we'll see if it fixes it
16:34:02 <pwhalen> sorry, missed it
16:34:13 <pwhalen> cool
16:34:40 <coremodule> I wonder if that's whats affecting F37, but we'll get to that
16:35:22 <coremodule> #topic 4) ==== Fedora 37/Rawhide status ====
16:35:22 <coremodule> #info Fedora-IoT-36-20220222.0
16:35:22 <coremodule> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=37&build=Fedora-IoT-37-20220222.0&groupid=1&groupid=5
16:35:31 <coremodule> speaking of f37
16:35:43 <pwhalen> looks like needles need updating again
16:36:15 <coremodule> pwhalen, can I get with you after the meeting to talk about how to do that? I spent some time yesterday, but couldn't figure it out on my own
16:37:28 <pwhalen> sounds good
16:39:31 <coremodule> okay, moving to open floor
16:39:32 <coremodule> #topic 5) ==== Open Floor ====
16:39:35 <coremodule> anything for open floor?
16:40:09 <pbrobinson> nothing of note from me
16:40:16 <pwhalen> coremodule: do you have that systemd bug for f35? Wondering the status of a build
16:42:26 <coremodule> pwhalen, I don't, I tried finding it off the IoT tracker but either I'm missing it or it's not there
16:42:48 <coremodule> pbrobinson, do you have a link to the anaconda/systemd bug you mentioned in f35?
16:43:15 <pbrobinson> give me a sec
16:47:00 <pbrobinson> this one maybe? https://bugzilla.redhat.com/show_bug.cgi?id=2019579
16:47:39 <pwhalen> https://bugzilla.redhat.com/show_bug.cgi?id=2018913
16:47:48 <pwhalen> sorry, took me a while to find i t
16:50:47 <coremodule> thanks for coming pwhalen, pbrobinson
16:51:07 <coremodule> #endmeeting