21:56:45 <sdziallas> #startmeeting
21:56:45 <zodbot> Meeting started Mon Oct 25 21:56:45 2010 UTC. The chair is sdziallas. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:56:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:56:55 <sdziallas> #chair Jefro mchua sdziallas
21:56:55 <zodbot> Current chairs: Jefro mchua sdziallas
21:57:03 <sdziallas> there we go :)
21:57:07 <Jefro> cool, thanks
21:57:13 <Jefro> #topic Writing articles for publication
21:57:39 <Jefro> (is that how I set the topic? I confess I have never used meetbot)
21:57:47 <sdziallas> Yup yup!
21:57:54 <sdziallas> I was about to do the same, but you beat me to it. :)
21:58:02 <Jefro> ok, good, thanks
21:58:41 <Jefro> so... I'm assuming you have ideas that you'd like to work into articles for specific publications, and want to know the nuts and bolts of going from idea to published article
21:58:57 <sdziallas> Yeah, exactly. :)
21:58:58 <Jefro> (coming up with content ideas is a different kettle of fish altogether)
21:59:04 * sdziallas nods.
21:59:15 <Jefro> do you have ideas about which publications are appropriate for what you want to write about?
22:00:03 <sdziallas> Well, I was thinking (in terms of content) along the lines of community building, so not so much about hard-core coding. :)
22:00:23 <Jefro> different venues have different ideas about what they want, content-wise, and many of them are very clear about their needs, often publishing them in writer's guidelines on their websites
22:00:23 <sdziallas> Might that still be appropriate for the folks @ linux.com / linuxmag?
22:00:34 <Jefro> ok - community building
22:00:48 <sdziallas> Or rather: what folks currently do (for example in education).
22:01:01 <Jefro> linux.com would almost certainly be interested, but possibly not linux magazine or linux pro, who tend toward technical topics
22:01:37 * sdziallas nods. opensource.com will probably also fit, but... yeah.
22:01:54 <Jefro> yes, opensource.com is an excellent place for nontechnical stuff
22:02:09 * sdziallas opens linux.com, looks for submission guidelines.
22:02:55 <Jefro> you might also consider venues that specialize in education rather than technology. perhaps an educator on this list might know of a publication that would be interested in running an article on teaching open source concepts
22:03:05 <mchua> Would linux.com be interested in general open source (not necessarily Linux) stuff?
22:03:07 * Jefro knows nothing about education magazines, assumes they exist
22:03:23 <sdziallas> #link com be interested in general open source (not necessarily Linux) stuff?
22:03:25 <mchua> In terms of education magazines, the ones that would probably be most interested in this stuff (from the academic publications side):
22:03:30 <sdziallas> #undo
22:03:30 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2b523012b190>
22:03:33 <sdziallas> (meetbot, gah)
22:03:34 <mchua> <--- grad student of the future
22:03:52 <sdziallas> #link http://www.linux.com/tour
22:04:01 <mchua> #info Education publications to check out: ACM SIGCSE Transactions, ASEE Prism, Chronicle of Higher Education
22:04:09 <Jefro> linux.com is sort of an anomaly among Linux-centric publications in that they are open to side topics. lwn.net, for example, is not, although I did publish an article there on open hardware.
22:04:18 <Jefro> mchua excellent info
22:04:32 <sdziallas> #note Linux.com seems like a good place to look at.
22:04:48 <mchua> #info Education publications, continued: IEEE Spectrum... in general, these societies have "student magazines" but I think it'd be better to go straight for the real thing
22:05:07 <Jefro> mchua yes, the focus should be on educators rather than students I think
22:05:27 <Jefro> for articles on how to approach teaching open source
22:05:55 <Jefro> thus, obviously, the first task is to figure out the nature of the content you want to produce, and identify appropriate venues for that content
22:06:22 <sdziallas> yeah, that makes sense.
22:06:50 <Jefro> narrowing things down, it also helps to know in your head what your end goal is. are you writing these articles to promote an idea or a project? to promote yourself? for spare cash?
22:07:01 <mchua> Jefro: by 'student magazines' I mean "magazines that solicit articles by students"
22:07:09 <mchua> they're supposed to basically be training grounds for students to learn how to write.
22:07:11 <mchua> but sdziallas already knows that.
22:07:13 <Jefro> mchua I see, thanks
22:07:25 <mchua> and nobody reads 'em because the students, uh, usually have not quite learned how to write. :)
22:07:30 <Jefro> I wasn't aware that the IEEE or ACM mags ever solicited student content
22:07:35 <Jefro> hehehe exactly
22:07:39 <mchua> The audience for the publications I just listed is basically... professors.
22:07:47 <mchua> Professors interested in education and whatnot.
22:07:51 <Jefro> excellent - I am filing that list for my own future reference ;)
22:08:04 <mchua> They take scholarly articles, but they're more like magazines that assume a highly technical audience.
22:08:08 <sdziallas> mchua: that might be a good thing, but I think that shouldn't be the only places for me to look at.
22:08:15 <mchua> I'll try to find some examples online in a bit.
22:08:16 * mchua nods
22:08:20 <sdziallas> (I might be wrong, though.)
22:08:31 <mchua> sdziallas: No, no, just skip the student publications, write the non-student ones where the actual people (CC-BY-SA) hang out.
22:08:34 * mchua nods
22:09:23 <Jefro> so there are professorial publications like IEEE and ACM and the like; popular for-profit venues like magazines (linux pro et al); news organizations like lwn.net ; non-profit venues like linux.com and opensource.com
22:09:44 <Jefro> and industry venues like IBM developerWorks
22:10:24 <Jefro> the latter is probably outside the realm right now, although if you wanted to write an article on corporate training using open source concepts, that might be a good place to go
22:11:06 <sdziallas> Oh, that's interesting! :)
22:11:10 * sdziallas nods.
22:11:37 <Jefro> side note, not sure how necessary it is to note: developerWorks pays well, opensource.com doesn't pay at all, most are in between
22:11:50 <mchua> #info another option: industry venues like IBM developerWorks
22:11:56 <mchua> #note developerWorks pays well
22:12:28 <mchua> Jefro: Are there any other industry venues you'd look at? cnet, uh... techcrunch, I'm... not as up to speed on this stuff as I shoud be, honestly
22:12:32 <Jefro> by "pays well", think 40-50c/word for articles 1500-2000 words. I can be more specific if necessary, at least with the publications I have written for
22:12:49 * sdziallas thinks that articles on open source might be adopted for corporate training.
22:12:55 <Jefro> mchua very interesting idea. probably not techcrunch, as they were just bought by AOL :)
22:12:55 <mchua> #note 40-50c/word for 1500-2000 word articles is on the high end
22:13:38 <mchua> sdziallas: ...ooh. yeah. opensource.com articles could be compiled - some of them, anyway - into a *very* interesting corporate workshop list.
22:13:38 <Jefro> cnet might be interested, but the ROI might be very low considering that they are a popular portal mostly for consumers
22:13:41 <mchua> er, reading list.
22:14:50 <Jefro> going down the list: professorial venues would necessarily require a lot of research and they probably have very specific content guidelines, and they might also pay better than 50c/word. I haven't published in any of them, so I can't advise.
22:15:31 <Jefro> I was looking through records and I don't think I have ever actually published in any of the print mags, at least not recently
22:15:38 <mchua> For academic publications, we have a while mailing list of profs we can ask for advice :) I'd worry less about that, really.
22:15:58 * sdziallas is sorry, didn't mean to drop out, needed a short typing break.
22:16:00 <mchua> or... rather, "it's easy to get in touch with the right pepole to ask for that, profs are in the business of teaching others how to write good research papers for those sorts of publications"
22:16:03 <Jefro> mchua agreed
22:16:48 <Jefro> but I know print mags pay in the 25-35c/word range, which isn't bad. they are also less prestigious IMO and are very specifically aimed at developers who probably do little in the way of teaching
22:17:02 * Jefro thinks a mentoring article might go over well in the print mags
22:17:04 * sdziallas nods. That makes sense.
22:17:38 * sdziallas is thinking of next action items. Coming up with a concrete proposal and figuring out where... to submit that?
22:17:45 <Jefro> news organizations can be very prestigious (like lwn.net) but also may have very strict guidelines on content, and pay little (again, like lwn.net)
22:17:55 <sdziallas> Heh. :)
22:17:58 <Jefro> sdziallas sounds good - will get there in just a sec
22:18:33 <Jefro> linux.com pays slightly better and takes a much wider range of content, as they are a portal and not a news org. developerworks pays very well, but also demands a lot of research and very tight writing.
22:19:29 <Jefro> opensource.com pays nothing, but they have a very high reputation, so the prestige value there is very good. Also, the ROI might be higher there than than in most places, as I believe their readership is more distributed.
22:19:55 * sdziallas got his first opensource.com article through for SoaS 3 :)
22:20:03 <Jefro> that may exhaust my venue knowledge for now...
22:20:07 <Jefro> sdziallas cool :)
22:20:21 <Jefro> that brings up a good point - previous publication knowledge is golden when you are pitching an article
22:20:32 <Jefro> it really, really helps to be able to pitch to someone who knows your writing
22:20:57 <Jefro> most periodicals get hundreds of submissions per week, some get that many per day, so it is easy to get lost in the slush pile.
22:21:27 * sdziallas grins. That's good to know!
22:21:37 <sdziallas> #note previous articles = ++
22:22:10 <Jefro> this is actually quite similar to contract work - much more likely to get a job with someone you have already worked for, or with
22:22:38 <Jefro> should I put action items together in a list using the "action" hashtag?
22:22:53 <sdziallas> That would be awesome! :)
22:22:56 <Jefro> or does that tag require an assignee?
22:23:07 <Jefro> #action come up with content ideas
22:23:24 <Jefro> #action brainstorm & research possible venues
22:23:38 <Jefro> #action keep publication goals in mind
22:23:42 <sdziallas> Naw, that works like this. :) Thanks!
22:23:45 <Jefro> cool
22:23:50 <Jefro> ah, modern technology
22:24:45 * gregdek needs to get his behind in gear re: OSDC articles.
22:24:57 <Jefro> so, next is the pitch. if you were writing fiction, you would pitch a story *after* you had already written it, but for non-fiction you generally pitch first, as each venue has its own voice that you will need to match (or harmonize with)
22:26:34 <Jefro> pitches have general formats, ranging from a business letter style to a questionnaire, depending on what the venue wants.
22:26:48 <sdziallas> Okay...?
22:27:22 <Jefro> technically, this would be considered a "query" rather than a "pitch" as the content hasn't been written yet, so I'll use the word query instead
22:27:47 <Jefro> #action read the writer's guidelines for every potential venue
22:28:55 <Jefro> very often the writers guidelines are on a page called "write for us" or something similar, which you may have to dig to find
22:29:01 <Jefro> here is the one for linux pro magazine: http://www.linuxpromagazine.com/Contact2/Write-for-Us
22:29:18 <sdziallas> #link http://www.linuxpromagazine.com/Contact2/Write-for-Us
22:29:53 <Jefro> sdziallas, did you find one for linux.com? there may not be one, as they encourage all queries
22:29:56 <sdziallas> Yeah, the linux.com was kinda hidden too. :)
22:30:04 * sdziallas did, linked it above (I hope).
22:30:41 <Jefro> didn't see a link, but I did find it - there is a "submit an article" button on the top right, but I don't know what that is really
22:31:21 <Jefro> when I submit articles to them, I go through one of their editors, and the process is fairly informal because we know each other personally
22:31:33 <sdziallas> http://www.linux.com/tour
22:31:38 <sdziallas> Ah, okay. :)
22:31:55 <Jefro> here is the one specifically on articles & tutorials: http://www.linux.com/creating-articles
22:32:16 <sdziallas> Ah, cool!
22:32:25 <Jefro> interesting - that page does not mention payment at all
22:33:15 <Jefro> if a page doesn't mention payment, it is worth writing to the editor directly and asking how much they offer, AFTER you write the pitch and they express interest
22:33:38 <sdziallas> Okay. Yeah, that makes sense to me, too. :)
22:33:43 <Jefro> #link http://lwn.net/op/AuthorGuide.lwn
22:33:47 <Jefro> that is the one for lwn.net
22:33:49 <mchua> #note step 1: write the pitch, step 2: wait for editor to express interest, step 3: write to editor directly and ask how much they offer if the magazine's webpage doesn't mention payment.
22:33:59 <Jefro> mchua exactly
22:34:53 <Jefro> #action write a directed query and send to potential venus
22:35:33 <Jefro> by "directed" query, I mean craft the query exactly the way they want to read it. lwn.net just says "write to us and discuss it", so their procedure is less formal. for developerWorks, by contrast, I have a form I fill out
22:35:58 <Jefro> (looking up content, one sec)
22:36:29 <sdziallas> Thanks a ton, Jefro. :)
22:38:11 <Jefro> #info sample query contents with examples: Contact [Jeffrey Osier-Mixon, addr, email, etc] - Title [Open Source Hardware: How & Why It Works] - Topic Area [Open Source] - Brief Description [1-2 short paragraphs] - Target Audience [Embedded systems developers, open source advocates] - Proposed Outline [short desc. of each section]
22:38:53 <Jefro> note: in the brief description for that one, I also included two sentences of bio to remind them that I have written successful articles for them before
22:39:09 <Jefro> this is the sales/marketing portion of your writing career :)
22:39:21 <sdziallas> :)
22:40:11 <Jefro> The Brief Description section here is similar to what would end up in the text of a less formal query. I'll post the two paragraphs I used for that article:
22:40:12 <Jefro> Open source has been a very successful tactic in software, but how does it---indeed, how CAN it---apply to hardware? A number of hardware projects are testing these concepts, from the successful Arduino microcontroller to the up-and-coming BeagleBoard ARM-based single-board computer. This September, the first Open Hardware Summit will take place in New York to discuss licensing, availability, community, and many other cha
22:40:12 <Jefro> This 2000-word article will provide an overview of the concepts that apply to open hardware, including licensing, community issues, fabrication challenges, and more. The article will also provide a first-hand account of the Open Hardware Summit and outline the topics discussed there. Technical readers as well as managers will gain knowledge of this new trend in hardware development, along with pointers to help them determ
22:40:21 <Jefro> I am a veteran technical writer and community manager in the embedded Linux development space, as well as a freelance writer and long-time open source advocate. I have written four articles for developerWorks in the past year, including one on the open-source BeagleBoard which has garnered over 38,000 views.
22:41:14 <sdziallas> Jefro: whoa... this is... whoa.
22:41:28 <Jefro> that's one example for developerWorks, which is very developer-oriented
22:41:50 <Jefro> if I were writing that same article for, say, lwn.net, the focus might be different. In fact, I did write a similar article for lwn.net. :)
22:42:16 <Jefro> the pitch process was much more back and forth, as I had never written for a news org before (but I did know the editor, Jake Edge, from having met him at conferences)
22:42:23 * sdziallas nods.
22:42:47 <Jefro> what lwn.net needed was something much more tightly focused, literally only 4-6 paragraphs
22:43:03 <Jefro> and no matter what anyone tells you, writing shorter stuff is much harder than writing longer stuff
22:43:19 <sdziallas> Yes, I learned that lesson too! :)
22:43:43 <Jefro> not harder, I guess, but it takes more time to compress. it also usually makes for much more polished work.
22:44:28 <Jefro> knowing what the editor wants is critical in the process, as they are much more likely to respond positively for the next article if they didn't have to do much back and forth with this one
22:44:44 * sdziallas nods.
22:45:03 * sdziallas is sorta overwhelmed by awesome information and... nods. :)
22:45:48 <Jefro> sdziallas mea culpa :) I should have summarized this better before diving into so many details
22:46:02 <Jefro> the business of it is actually harder than writing the articles themselves
22:46:53 * sdziallas mhms, nods. Yeah... I think I get an idea of what you mean. :)
22:48:45 <Jefro> even that isn't hard, necessarily - it is best to think of it as the business activity that accompanies the writing activity.
22:49:20 <Jefro> there are other little things too, like sending a thank you note to the editor when you are accepted, when the article is complete, and when it is finally is published in public
22:49:38 <Jefro> and I'm not even going to get into things like invoicing or following up if someone doesn't pay :) we can cover those another time
22:49:41 <sdziallas> That sounds reasonable to me, yes. :)
22:50:33 <sdziallas> Jefro: I'm sorry, I gotta run. I've got another meeting. But... whoa, this is awesome. :)
22:50:57 <Jefro> sdziallas no worries - I'll be around to talk more later
22:51:02 <Jefro> later in the week, that is :)
22:51:11 <Jefro> mchua, any final q's or thoughts?
22:51:12 <sdziallas> Jefro: thanks a *ton* :)
22:51:17 <sdziallas> this is really appreciated
22:51:37 <mchua> Jefro: None, I think I'm good.
22:51:41 <mchua> somethat overwhelmed. But good.
22:51:46 * mchua ecohes the thanks
22:52:25 * sdziallas ends the meeting
22:52:28 <sdziallas> #endmeeting