19:01:32 <gregdek> #startmeeting community-working-group
19:01:32 <zodbot> Meeting started Wed Mar 16 19:01:32 2016 UTC. The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:32 <zodbot> The meeting name has been set to 'community-working-group'
19:01:39 <gregdek> #chair rbergeron
19:01:39 <zodbot> Current chairs: gregdek rbergeron
19:01:47 <rbergeron> YAY PARTYTIME
19:02:00 <gregdek> #info agenda, as always, at https://waffle.io/ansible/community
19:03:18 <rbergeron> :)
19:03:19 <rbergeron> okay!
19:04:14 <gregdek> #topic Proposal Process
19:04:16 <gregdek> https://github.com/ansible/community/issues/14
19:04:58 <rbergeron> hey! so: i haven't looked in a few days because... yay airplanes.
19:05:19 <rbergeron> that is the wrong issue.
19:05:20 <rbergeron> also.
19:05:31 <gregdek> #undo
19:05:31 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x32d00290>
19:05:33 <gregdek> Oops. :)
19:05:47 <gregdek> https://github.com/ansible/community/issues/23
19:06:28 <gregdek> So looks like jimi-c put this in process... why didn't this just get merged?
19:06:35 <rbergeron> No idea.
19:06:48 <rbergeron> I would just merge it, but i don't like to merge my own things because that seems uncool.
19:07:15 <rbergeron> gregdek: can you merge it, so i can move on? :)
19:07:21 <rbergeron> and move the things
19:07:24 <rbergeron> and we can proceed with this
19:08:00 <gregdek> Done.
19:08:03 <gregdek> What's the next step?
19:08:16 <svg> o/
19:08:20 <rbergeron> and maybe a thing to consider for ansible/proposals would be to have a bot check for new PRs and if the proposal has additional PRs from the author that they get automerged
19:08:34 <rbergeron> Well, i have to move this whole directory over to ansible/proposals
19:08:37 <rbergeron> without breaking anything
19:08:51 <rbergeron> or fork it, or something. *sweats*
19:09:07 <rbergeron> And then I guess bring it to a meeting.
19:09:26 <rbergeron> Or else re-circulate the proposal draft one more time.
19:09:30 <rbergeron> before going to a meeting.
19:09:35 <rbergeron> Since it's moved and we did some tweaks.
19:09:45 <rbergeron> That is probably the best course, I think. So:
19:10:02 <rbergeron> #action rbergeron to now move docs/proposals remains to ansible/proposals
19:10:23 <gregdek> I think you can just copypasta the whole thing into the new repo and commit it directly. That's one of the reasons it's a separate repo, after all.
19:10:23 <rbergeron> #action rbergeron to recirculate this draft in its current form to mailing list
19:10:36 <svg> sorry, hard time to follow, is that like "separate repo"?
19:10:40 <rbergeron> yeah, I guess so.
19:10:52 <rbergeron> @svg: yeah, it's a separate repo.
19:10:58 <svg> yay!
19:11:03 <rbergeron> Just so it's not "mixed up" with docs since that ships and all that. :)
19:11:27 * svg refrains himself to propose to move docs to separaret repo
19:11:40 <rbergeron> #action rbergeron to then take it to a public irc meeting for ... hugs
19:11:42 <rbergeron> approvals
19:11:48 <rbergeron> and I think that's it. @gregdek sound about right?
19:11:58 <rbergeron> man, when did i start using the twitter format in irc
19:11:58 <gregdek> svg: you could make that proposal using the new proposal proposal. :)
19:12:02 <rbergeron> so gross looking :)
19:12:08 <gregdek> rbergeron: wfm :)
19:12:14 <rbergeron> gregdek: excellente.
19:12:42 <gregdek> #topic New module process
19:12:53 <gregdek> https://github.com/ansible/community/issues/39
19:13:02 <gregdek> newtMcKerr: ping :)
19:13:02 <zodbot> gregdek: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
19:13:22 <gregdek> stfu zodbot
19:13:32 * gregdek glares at zodbot
19:13:55 <gregdek> The ping has copious context, you officious bot, you.
19:14:12 <svg> ping gregdek
19:14:20 <svg> (just doing trial and error)
19:14:47 <gregdek> zodbot apparently isn't interested in chastizing svg :)
19:14:57 <rbergeron> I guess the bot was looking for context on the same line
19:14:59 <svg> sounds legit
19:15:11 <rbergeron> when it should look for nearby likely context
19:15:12 <rbergeron> lol
19:15:15 * gregdek goes to ping newtMcKerr manually. Perhaps that's a poke.
19:15:38 * svg fondly remember C64 pokes
19:17:13 <rbergeron> uhhh
19:17:17 <rbergeron> err. huhhhhh.
19:17:23 <rbergeron> he was looking for a post office.
19:17:29 <gregdek> LOL
19:17:31 <rbergeron> maybe he's in a mailbox somewhere.
19:18:05 <gregdek> Ok, will come back to that. We're waiting on him to give us attendee(s) for the new module meeting.
19:18:27 <rbergeron> :)
19:18:55 <gregdek> Actually, I'm going to send him a quick note right now. One sec.
19:19:06 <rbergeron> kk
19:19:49 <gregdek> done.
19:20:02 <rbergeron> okay!
19:20:31 <rbergeron> what's next.
19:20:35 <rbergeron> me looks at the waffle
19:21:27 <rbergeron> there's a bunch of stuff in backlog that I'd like to poke at. :)
19:22:23 <rbergeron> or do you want to look at anything in Ready?
19:22:27 * rbergeron pokes at gregdek
19:23:32 <gregdek> Sorry.
19:23:40 * rbergeron waves the forgiveness wand
19:23:45 <gregdek> Move stuff from backlog to ready as you see fit, rbergeron
19:23:46 <rbergeron> hey dag- :)
19:24:00 <gregdek> And then let's go over ready
19:24:07 <rbergeron> gregdek: I moved https://github.com/ansible/community/issues/45 over -- that's the stuff re: labels and vagueness that I got pinged on yesterday.
19:24:38 <rbergeron> And I feel like maybe #36 could get moved over, but want to discuss it first
19:24:49 <rbergeron> but.
19:25:03 <rbergeron> Let's do ready (I did move over 45, I'll just move over 36 as well.)
19:25:08 <gregdek> ok!
19:25:22 <gregdek> #topic pr reviewer recruiting
19:26:22 <gregdek> https://github.com/ansible/community/issues/44
19:26:43 <gregdek> So I made this proposal and didn't get any feedback in the issue itself. Don't know if that means "awesome" or "whatevs" :)
19:26:56 <gregdek> (Or if we discussed it separately and I forgot)
19:27:12 <dag-> hi rbergeron !
19:27:23 <gregdek> I guess we should troll the minutes of our last meeting to find out :/
19:28:13 <svg> gregdek: sounds like that can't harm, so yay
19:28:22 <rbergeron> gregdek: so some of this was in last meeting.
19:28:24 <rbergeron> #link https://meetbot.fedoraproject.org/ansible-meeting/2016-03-11/community-working-group.2016-03-11-19.04.log.html
19:28:38 <rbergeron> #link https://meetbot.fedoraproject.org/ansible-meeting/2016-03-11/community-working-group.2016-03-11-19.04.html
19:28:44 <rbergeron> (second link is minutes)
19:29:08 <gregdek> OK. Looks like we agreed to try this in Extras boilerplate.
19:29:30 <gregdek> Which means I'll file it as an issue against Ansibullbot repo and close this one.
19:29:39 <gregdek> (Once I've done so.)
19:30:30 <rbergeron> okay, I've updated that issue.
19:30:35 <rbergeron> and assigned it to you. :)
19:30:39 <rbergeron> since you had the action. :)
19:31:10 <rbergeron> okay, next up?
19:31:38 <gregdek> Yep, I've moved it to in progress.
19:31:50 <gregdek> #topic Issue/PR template review
19:32:04 <gregdek> https://github.com/ansible/community/issues/36
19:32:17 <rbergeron> so: the description in this one is pretty sparse.
19:32:23 <gregdek> So the good thing is, we've got boilerplate! Hooray, and thanks Github!
19:32:30 <rbergeron> And we did review these a little bit yesterday.
19:32:35 <gregdek> Now... what should it look like, and how should it affect workflow?
19:32:41 <rbergeron> And i'm not feeling like theres 's anything bad here. So ...
19:32:41 <gregdek> And is this actually two different things?
19:32:42 <rbergeron> yeah.
19:32:55 <rbergeron> I feel like "we think this is okay for now!" ... so... what's the next steps or things to do?
19:33:01 <rbergeron> We need an issue bot bad.
19:33:13 <rbergeron> So maybe figuring out workflow is the first thing?
19:33:30 <rbergeron> And scope it out a bit and make a diagram.
19:33:52 <rbergeron> And then probably put that and some info about labels (per issue 45) in a more obvious visible place.
19:33:55 <rbergeron> :)
19:34:20 <gregdek> yes. this is actually that.
19:34:25 <rbergeron> And once we have a bot, we'd probably need to update our issue template to be VERY FIRM about stating "YOU MUST FOLLOW THIS OR YOU WILL GET REJECCCCCTED"
19:34:29 <gregdek> and that has needed to happen for a decade.
19:34:33 <rbergeron> :)
19:35:02 <gregdek> Fortunately, this is a simpler bot, and there's lots of precedence with bots all over github that do this.
19:35:16 <rbergeron> yeah.
19:35:26 <rbergeron> Well: and I think we also will need to do some sort of manual triage day
19:35:32 <rbergeron> with core / extras
19:35:38 <gregdek> Yep. But *only* once the process is clear.
19:35:44 <rbergeron> or ... something. To weed things out.
19:35:45 <rbergeron> Yeah.
19:36:15 <rbergeron> "Please refill this out. Sorry for noise."
19:36:28 <rbergeron> "but if you don't, we're going to close this in a month" or something like that?
19:36:42 <rbergeron> Well:
19:36:45 <rbergeron> I guess step one is clarify the process.
19:36:50 <gregdek> yep.
19:37:00 <rbergeron> So maybe I will hack on that tomorrow or this afternoon and we can play with a whiteboard and stuff.
19:37:07 <gregdek> sgtm.
19:37:14 <rbergeron> okay.
19:37:19 <gregdek> shall we rename this issue to reflect that?
19:37:35 <rbergeron> #action rbergeron to hack on workflow process for issue triage / future bot work.
19:37:55 <rbergeron> #action rbergeron to diagram Magical Things
19:38:34 <rbergeron> okay, i updated the issue with notes.
19:38:46 <rbergeron> #info rbergeron updated issue with notes re: the above
19:40:23 <gregdek> HAHAHAHA
19:40:27 <rbergeron> okay
19:40:33 <rbergeron> there was a jenga emergency here
19:40:38 <rbergeron> that freaked me out.
19:40:39 <gregdek> #info We just freaked out in the office because of Loud Jenga Disaster
19:40:40 <rbergeron> ALL FALL DOWN
19:41:06 <gregdek> #topic Github labels
19:41:07 <gregdek> https://github.com/ansible/community/issues/45
19:41:11 <gregdek> So we have a ton of labels.
19:41:17 <rbergeron> yes we do.
19:41:22 <gregdek> And I know these were all in a cool workflow graphic at some point.
19:41:36 <rbergeron> #info we have a ton of labels
19:41:43 <rbergeron> #info robyn has these in a workflow graphic somewhere
19:41:47 <rbergeron> (at least for core and extras)
19:41:53 <rbergeron> I think the things that we are missing are:
19:41:56 <rbergeron> * What do they meab
19:41:57 <rbergeron> mean
19:42:05 <rbergeron> * How do they get applied (and when and by whom)
19:42:18 <rbergeron> so: resmo has been doing some awesome new bot work
19:42:29 <rbergeron> and I know in the past sometimes random adds of labels would ... break workflow here and there
19:42:30 <resmo> hi
19:42:36 <rbergeron> resmo: you're amazing <3
19:42:49 <resmo> thanks! don't hear that often :)
19:43:07 <resmo> especially not from many women...
19:43:11 <rbergeron> Is that less of a thing that will happen now with improved bottiness?
19:43:18 <resmo> ;)
19:43:31 <rbergeron> resmo: just think of me as an appreciative community member who appreciates your efforts :)
19:43:49 <resmo> yeah, sure :)
19:44:14 <rbergeron> gregdek: otherwise I think we probably need at least basic information and maybe we need to be more vigilant about "please don't randomly apply labels, you might break bot-life"
19:44:35 <rbergeron> note: this issue was put in becasue I had some questions from shrews yesterday on irc and in person when i saw him
19:44:57 <rbergeron> before he and mordred abused my liver :)
19:45:09 <gregdek> Yep. Ideally, I'd like to get rid of all manual labeling entirely, and I'd like to make the bot fire on every PR change.
19:45:14 <gregdek> But not quite there yet. :)
19:45:21 <rbergeron> but it was just "am i supposed t apply labels? who does that? what do they mean?"
19:45:26 <rbergeron> And that's at least for core / extras.
19:45:41 <rbergeron> And maybe then we can also define it for ansible/ansible with the core team, once we have a good first swag at this.
19:46:03 <gregdek> Yep.
19:46:14 <gregdek> So.
19:46:29 <gregdek> 1. We need to look at our current graphic (wherever it is) and validate it, or fix it.
19:46:52 <gregdek> 2. We need to make sure that triagebot does what the workflow says it does.
19:47:09 <gregdek> 3. We need to make sure that committers are educated about the proper use of labels.
19:47:30 <gregdek> 4. We need to make sure that, when we change the bot, we also change the workflow, and vice versa.
19:47:30 <rbergeron> I feel like we added it as a link to some documentation somewhere?
19:47:45 <gregdek> Surely we did, but I can't find it for the life of me.
19:47:49 <gregdek> Was it in your repo?
19:49:09 <gregdek> I don't see it there anywhere. Gah.
19:49:23 <gregdek> It was like a graphing file of some kind... ¯\_(ツ)_/¯
19:49:33 <gregdek> We can start over if need be, but that would make me sad.
19:49:51 <gregdek> Oh!
19:49:57 <gregdek> Here it is -- where it should be, LOL
19:49:58 <gregdek> https://github.com/ansible/ansible-modules-extras/blob/devel/REVIEWERS.md
19:50:22 <gregdek> And this is outdated anyway.
19:50:40 <rbergeron> ohhh man.
19:50:43 <rbergeron> yeah, i was going to say.
19:50:43 <gregdek> SME stuff isn't being used.
19:50:51 <rbergeron> we should probably be re-reviewing that WHOLE THING.
19:50:52 <gregdek> Well, we should definitely fix this. :)
19:51:11 <rbergeron> One other thing that I feel like is getting missed in this process is
19:51:20 <rbergeron> When a new module finally gets in
19:51:31 <rbergeron> we are missing the loop to somehow get that person's name in as a maintainer
19:51:36 <rbergeron> into the maintainers file.
19:51:44 <rbergeron> github ID, whatever
19:52:00 <rbergeron> I've done lots of triage where it just breaks and cries because 'module doesn't seem to have an owner"
19:52:04 <gregdek> Yeah. But I'm ok saying "when Triage tool fails because maintainer isn't there, fix it." That is actually a perfectly reasonable process.
19:52:39 <rbergeron> Well, I would rather it be "when this thing gets merged"
19:52:41 <rbergeron> especially because:
19:52:48 <rbergeron> That's just for PRs --
19:53:14 <rbergeron> right now -- so even if it's a case of "shipit because it's from the module maintainer" ... fine
19:53:23 <rbergeron> but if we can't triage issues or direct traffic
19:53:33 <rbergeron> especially if that stuff is automated -- that kind of sucks
19:53:37 <rbergeron> as well
19:53:41 <rbergeron> I may be picky.
19:53:44 <rbergeron> I guess it is GEFN.
19:53:46 <rbergeron> :)
19:54:10 <rbergeron> a few weeks ago i did triage and there were all the new networking modules in there and i Had to stop and go through and add stuff like one zillion times.
19:54:33 <gregdek> If we have a weekly review process for new modules, we can make sure we do it at review time.
19:54:44 <rbergeron> yeah.
19:54:51 <rbergeron> That's a good call.
19:54:55 <gregdek> And if people commit new modules without doing it, we can yell at them.
19:55:05 <gregdek> (this is more an issue on the core modules side.)
19:55:07 <rbergeron> Or we can ask those folks to please submit a PR to the maintainer's file with their name
19:55:14 <rbergeron> when a new module gets a shipit.
19:55:20 <rbergeron> or gets shipped. :)
19:55:25 <gregdek> Yeah, but that takes extra time. We should really just do it for them.
19:55:26 <rbergeron> that prompt could probably be automated.
19:55:28 <rbergeron> okay.
19:55:30 <resmo> btw
19:55:34 <rbergeron> resmo: yes? :)
19:55:41 <resmo> for updating the maintainers files on new modules
19:56:12 <resmo> how about parsing the modules and get the authors from the modules itself and update the maintainers files accordantly
19:56:37 <resmo> so we could add some bot functionality to 2$
19:56:46 <resmo> refresh the maintainers list
19:57:05 <rbergeron> resmo: so i think the goal was to not have the author line in the module anymore, and just have a separate maintainer file
19:57:12 <gregdek> We could... but really, I wonder if the Author info should even be required.
19:57:15 <rbergeron> but, was a goal just for... clarity and etc.
19:57:17 <resmo> rbergeron: ok, missed that
19:57:19 <gregdek> But Author was weird anyway, because it morphed.
19:57:24 <gregdek> Now, actually, it might make sense.
19:57:25 <rbergeron> because "author" vs. "maintainer" are different things --
19:57:32 <gregdek> Author is always "initial author" and never changes.
19:57:41 <rbergeron> Author stuff is in the original PR detail anyway -- but who maintains it over time might change.
19:57:51 <gregdek> Maintainer is maintained elsewhere, and starts as "Author" by default but can then change as needed.
19:58:06 <rbergeron> resmo: sorry, I guess that wasn't clear because we didn't provide any clarity on it. :\ our bad.
19:58:20 <resmo> gregdek: right author vs maintainer
19:58:20 <rbergeron> our hurried band-aiding trying to get things moving I guess.
19:58:41 <gregdek> It was part of our first pass, and the first pass is always thrown away. :)
19:58:58 <gregdek> OK, so we have actions out of this?
19:59:13 <rbergeron> uhhhh
19:59:17 <rbergeron> I don't know that we do.
19:59:27 <rbergeron> because i can't remember what the original goal here was. :)
19:59:28 <rbergeron> ummm
19:59:36 <gregdek> Labels and process and stuff :)
19:59:42 <rbergeron> Okay. So:
20:00:28 <rbergeron> #action rbergeron to figure out some label definitions and re-review workflow
20:00:40 <rbergeron> #action rbergeron to figure out better place for that documentation of those things to go.
20:00:49 <gregdek> Should prolly change this issue to reflect that we're talking pr labels
20:01:05 <rbergeron> #action rbergeron to assign more stuff to greg more frequently
20:01:11 <rbergeron> :D
20:01:12 <rbergeron> #undo
20:01:12 <zodbot> Removing item from minutes: ACTION by rbergeron at 20:01:05 : rbergeron to assign more stuff to greg more frequently
20:01:37 <rbergeron> #info note: the above is really related to PR labels, and not issue labels, as that was a previous topic in meeting.
20:02:04 <rbergeron> #action rbergeron to maybe list out other things that may be affected / come to mind while going through this -- stuff relating to PR bot, etc.
20:02:49 <rbergeron> I think that's it.
20:02:56 <gregdek> I've already relabeled the issue.
20:03:02 <gregdek> Aaaand we're at our hour.
20:03:53 <gregdek> Thanks everybody :)
20:03:55 <gregdek> #endmeeting