16:00:17 <geppetto> #startmeeting fpc
16:00:17 <zodbot> Meeting started Thu Jul 7 16:00:17 2016 UTC. The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:17 <zodbot> The meeting name has been set to 'fpc'
16:00:17 <geppetto> #meetingname fpc
16:00:17 <geppetto> #topic Roll Call
16:00:17 <zodbot> The meeting name has been set to 'fpc'
16:00:55 <tibbs> Hey, folks.
16:01:08 <geppetto> hey
16:01:11 <geppetto> #chair tibbs
16:01:11 <zodbot> Current chairs: geppetto tibbs
16:02:13 <mbooth_> Hi
16:02:17 <tibbs> Im not supposed to be here, but we got in to Sandnessjoen about an hour ago.
16:02:46 <Rathann> hi
16:02:50 * limburgher is here
16:03:33 <geppetto> #chair mbooth_
16:03:33 <zodbot> Current chairs: geppetto mbooth_ tibbs
16:03:44 <geppetto> #chair Rathann
16:03:44 <zodbot> Current chairs: Rathann geppetto mbooth_ tibbs
16:03:48 <geppetto> #chair limburgher
16:03:48 <zodbot> Current chairs: Rathann geppetto limburgher mbooth_ tibbs
16:03:56 <geppetto> Cool, that's five
16:03:56 <mbooth_> tibbs: Aren't you supposed to be on vacation? :-p
16:04:09 <geppetto> No vacation from fpc ;)
16:04:40 <Rathann> which reminds me, I'm on vacation next week and I don't know if I'll be online
16:04:51 * bollocks_k is here
16:04:52 * geppetto nods
16:05:37 <geppetto> #topic Schedule
16:05:39 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/WO7T7VB2IU3XWMYWPCOROV6ZVQ7L2ZMB/
16:05:50 <geppetto> #topic #636 Various scriptlets no longer needed in F-24+
16:05:54 <geppetto> .fpc 636
16:05:55 <zodbot> geppetto: #636 (Various scriptlets no longer needed in F-24+) – fpc - https://fedorahosted.org/fpc/ticket/636
16:05:58 <Rathann> yay
16:06:08 <tibbs> I think this is the third ticket on this topic.
16:06:46 <geppetto> Yeh, do we want to just approve other "stuff moved from scriptlets to file triggers, delete these lines in policy" requests?
16:07:25 <Rathann> s/delete/mention in which Fedora releases they are still required/
16:07:30 <Rathann> but yes
16:07:35 <limburgher> MmmHmm.
16:07:59 <geppetto> ok
16:08:44 <geppetto> Proposal: When policy moves from scriptlets to file triggers, mark that policy as no longer relevant after N release
16:08:55 <limburgher> +1
16:09:09 <geppetto> +1
16:10:00 <Rathann> +1
16:10:10 <mbooth_> +1
16:10:32 <tibbs> +1
16:10:40 <bollocks_k> +1
16:10:46 <tibbs> But... does anyone actually have a list of all of these?
16:10:58 <geppetto> tibbs: No, we'll probably still need to get tickets
16:11:05 <geppetto> tibbs: We just don't need to vote on them
16:11:11 <geppetto> bollocks_k: Cute
16:11:26 <tibbs> Yesh, I think this is a "just do it" thing when it happens.
16:12:14 <tibbs> I am just not sure what's been converted at this point. But i can use what's in this ticket as a starting point.
16:12:39 * geppetto nods
16:12:47 <geppetto> #topic #637 approval for a 'docker-latest' package on fedora
16:12:51 <geppetto> .fpc 637
16:12:53 <zodbot> geppetto: #637 (approval for a 'docker-latest' package on fedora) – fpc - https://fedorahosted.org/fpc/ticket/637
16:13:22 <geppetto> This has now changed to a request for an older compat-docker package for openstack
16:13:47 <geppetto> I'm +1
16:14:06 <geppetto> And also +1 if they wanted to do a newer version, and have the old one be docker still
16:14:14 <geppetto> Just as long as it isn't called docker-latest :)
16:14:39 <Rathann> They don't need permission from FPC to call it compat-docker, it's written in the naming guidelines
16:15:02 <limburgher> +1
16:15:07 <geppetto> I thought people still needed approval for compat- packages?
16:15:13 <Rathann> actually I was wondering how rpm/dnf would handle things if compat-docker had Provides: docker = %{version} as well
16:15:33 <tibbs> +1
16:15:52 <tibbs> They don't need permission to make a package, but this is about a review process exemption.
16:15:59 <geppetto> I assume it would be fine, and pick the right one when you did yum install docker (like yum does) ... but that might be a bad assumption :-o
16:16:40 <Rathann> geppetto: https://fedoraproject.org/wiki/Packaging:Naming#Multiple_packages_with_the_same_base_name
16:17:28 <Rathann> they don't for compat, though the guidelines don't actually say anything about the compat- prefix (anymore?)
16:18:21 <geppetto> yeh, I saw that
16:18:35 <geppetto> was proably intentional ... so that yum list foo* shows you the older versions too
16:20:19 <geppetto> So this doesn't need a ticket anymore?
16:20:39 * geppetto tries to remember that compat doesn't need exceptions anymore
16:20:41 <tibbs> Well, they were asking for a review process excdeption.
16:20:50 <geppetto> Yeh, but they changed their mind about that
16:20:57 <geppetto> initially they wanted docker-latest
16:21:00 <tibbs> OK. can't keep track.
16:21:15 <geppetto> n/p
16:21:41 <geppetto> #action New plan follows https://fedoraproject.org/wiki/Packaging:Naming#Multiple_packages_with_the_same_base_name and thus. doesn't need an exception.
16:21:44 <tibbs> But I would consider making it possible to just make "versioned" packages without having to go through a review.
16:22:26 <geppetto> Yeh, that will probably have to happen sooner rather than later
16:22:28 <Rathann> looks like it's similar to the unison/unison240/unison227/unison213 case
16:23:17 <Rathann> and yes, I'm +1 to the idea of skipping review in this case (making a "older-versioned" package out of an existing one for backwards compatibility)
16:23:23 <geppetto> not really, those need to be compatible with themselves. docker 's probably is that a bunch of stuff uses it and can't move as fast
16:23:30 <geppetto> So more like old versions of glib
16:23:48 <Rathann> well, both reasons are good
16:23:53 <mbooth_> Yeah, makes sense. I missed that guideline when I commented on the ticket -- as long as "docker" is not the old version, I'm happy :-)
16:24:29 <geppetto> Proposal: Packages can skip reviews if they are just older versions of reviewed packages.
16:24:46 <geppetto> +1
16:24:49 <mbooth_> So "docker110" for docker 1.10 would be fine for me
16:25:02 <mbooth_> +1
16:25:03 <geppetto> yeh, or docker1.10 :)
16:25:12 <Rathann> +1
16:26:52 <geppetto> limburgher: tibbs vote?
16:26:55 <tibbs> +1
16:27:10 <tibbs> But... we really should solidify the naming.
16:27:35 <geppetto> the current policy heavily leans towards docker1.10
16:27:54 <tibbs> Might as well just make it a MUST.
16:28:15 <geppetto> I'm fine with that
16:28:37 <tibbs> And does it go without saying that these packages can't conflict?
16:28:43 <geppetto> We could just make it a "If you name it exactly like this you don't have to do a review"
16:29:21 <geppetto> tibbs: It doesn't, and we should probably specify that for the non-review case
16:29:27 <tibbs> That would work, but I think it would be clearer if we just said "name it like this" and be done with it.
16:29:50 <tibbs> Sadly we're about to have dinner.
16:29:53 <limburgher> +1
16:30:05 <geppetto> I'm mildly worried someone will say something old was named differently and doesn't want to rename
16:30:12 <geppetto> But I'm fine either way
16:30:19 <geppetto> Ok, that's 5
16:30:24 <limburgher> I think on the whole it shouldn't be that scary.
16:30:32 <geppetto> #action Packages can skip reviews if they are just older versions of reviewed packages. (+1:5, 0:0, -1:0)
16:31:07 <geppetto> Proposal: Make compat package naming a MUST
16:31:08 <geppetto> +1
16:31:52 <limburgher> +1
16:31:58 <mbooth_> +1
16:32:25 <Rathann> I just did a quick experiment and it seem the older version can specify Provides: name = %{version} to make upgrades seamless
16:33:02 <geppetto> without obsoletes?
16:33:05 <Rathann> i.e. if something has a strict version dependency on foo = 1.0, then foo1 will satisfy it when foo is upgraded to 2.0
16:33:13 <geppetto> Ahh, yeh
16:35:30 <Rathann> sorry, what is the exact proposal?
16:36:46 <geppetto> Proposal: Make compat package naming a MUST
16:37:34 <geppetto> I'm going to assume tibbs is having dinner and has a +1, given he suggested it
16:38:12 <limburgher> The audacity. . .
16:38:29 <Rathann> so let me get this straight, the proposal is to s/should/MUST/ in the first sentence of https://fedoraproject.org/wiki/Packaging:Naming#Multiple_packages_with_the_same_base_name ?
16:39:05 <Rathann> actually s/should/MUST/g
16:39:14 <limburgher> That's my understanding.
16:39:23 <Rathann> ok, +1 then
16:39:25 <geppetto> yeh
16:39:45 <geppetto> #action Make compat package naming a MUST (+1:5, 0:0, -1:0)
16:39:50 <geppetto> #topic Open Floor
16:40:05 <geppetto> Ok, anything else to discuss? Or early meeting this week?
16:40:14 <limburgher> Nothing here.
16:41:45 <geppetto> Ok, close the meeting in a minute and see you next week ... apart from Rathann, who'll be enjoying himself
16:41:49 <geppetto> :)
16:41:57 <Rathann> ;)
16:41:57 <geppetto> tibbs: And thanks for coming on your holiday!
16:43:03 <geppetto> #endmeeting