15:05:28 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:05:28 <zodbot> Meeting started Tue Apr 8 15:05:28 2014 UTC. The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:39 <danofsatx-work> ok, the net isn't split.
15:05:40 <Kevin_Kofler> #meetingname kde-sig
15:05:40 <zodbot> The meeting name has been set to 'kde-sig'
15:06:02 <danofsatx-work> I was concerned....freenode is having...'issues' today
15:06:23 <Kevin_Kofler> They're rebooting all the servers for that OpenSSL security fix.
15:06:52 <danofsatx-work> I know, I was just kicked off and it took ~10 minutes to reconnect
15:06:57 <Kevin_Kofler> #topic Role call
15:07:00 <rdieter> hola
15:07:03 <dvratil> hi
15:07:03 <ltinkl> hi
15:07:05 * Kevin_Kofler is present, who else?
15:07:08 <pino|work> hi
15:07:17 <danofsatx-work> aqui, here, present, whatever you call it
15:07:19 <rdieter> afk, back in ~10 min
15:07:28 <jgrulich> hi
15:08:21 <danofsatx-work> I was just informed that my presence may be required at a meeting in the conference room in a bit. Time is flexible, so no sure how long I'll be here.
15:08:21 <than> present
15:08:44 <tosky> hi
15:08:57 <Kevin_Kofler> #chair rdieter dvratil ltinkl pino|work jgrulich than tosky jreznik
15:08:57 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik ltinkl pino|work rdieter than tosky
15:09:45 <Kevin_Kofler> #info Kevin_Kofler, rdieter, dvratil, ltinkl, pino|work, danofsatx-work, jgrulich, than, tosky present, mbriza reported he'll be late.
15:09:50 <Kevin_Kofler> #topic Agenda
15:10:08 <Kevin_Kofler> Remaining system-config-* tools on the KDE Spin.
15:11:45 * jreznik is around
15:12:41 <Kevin_Kofler> #info jreznik also around.
15:13:25 <Kevin_Kofler> Is that all? I'd have expected more stuff…
15:13:49 <Kevin_Kofler> #topic Remaining system-config-* tools on the KDE Spin
15:13:57 <Kevin_Kofler> So let's start with this one.
15:14:54 <Kevin_Kofler> I have started an experiment: Try to make a pure KDE Fedora Remix. I called it "Kannolo" (yes, after the Sicilian sweet "cannolo", a "torta fedora" is also a Sicilian sweet).
15:15:03 <Kevin_Kofler> #link http://svn.calcforge.org/viewvc/kannolo/trunk/
15:15:10 <danofsatx-work> oh, that agenda call was a call for items? I misunderstood....
15:15:32 <Kevin_Kofler> danofsatx-work: Yes, that's the standard procedure in our meetings.
15:15:38 <Kevin_Kofler> If you have items to add, you can still propose them.
15:16:18 <Kevin_Kofler> So far Kannolo isn't going all that great, unfortunately; however there are some things I noticed that I think can benefit the official KDE Spin or Plasma Product or whatever.
15:17:18 <Kevin_Kofler> In particular, I noticed there are exactly 3 system-config-* tools left on the KDE Spin in current Rawhide (and I think at least F20 was the same already):
15:17:23 <Kevin_Kofler> * system-config-date
15:17:30 <Kevin_Kofler> * system-config-services
15:17:33 <Kevin_Kofler> * system-config-users
15:17:59 <Kevin_Kofler> None of these are required by (the current version of) Anaconda or initial-setup, so it's really our choice whether to ship them.
15:18:10 <Kevin_Kofler> And all 3 have KDE equivalents:
15:18:31 <Kevin_Kofler> * For system-config-date, we have kcm_clock in kde-workspace (and thus obviously already shipped).
15:19:11 <ltinkl> not sure about services, but the other 2 can go imo
15:19:15 <Kevin_Kofler> The only thing that is missing on the spin for it to be fully functional is ntpdate, which is less than 100 KiB uncompressed, so I guess ~a dozen KiB compressed, totally negligible compared to Firefox.
15:19:36 <Kevin_Kofler> Without ntpdate, it refuses to use NTP.
15:20:14 <Kevin_Kofler> * For system-config-users, there's kuser (formerly from kdeadmin, now a separate upstream tarball).
15:20:30 <Kevin_Kofler> IIRC, rdieter reported having had issues with KUser in the past, but as far as I can tell, it just works now.
15:21:01 <Kevin_Kofler> I did fix a bad default setting, the default minimum UID and GID were set to 500, I set the CMake setting to make it default to 1000.
15:21:10 <Kevin_Kofler> (It can be changed in the preferences.)
15:21:24 <mbriza> ok, i'm here, sorry
15:21:27 <Kevin_Kofler> Now ideally it should read the setting from login.defs.
15:21:30 <Kevin_Kofler> #chair mbriza
15:21:30 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich jreznik ltinkl mbriza pino|work rdieter than tosky
15:21:36 <Kevin_Kofler> #info mbriza present (late).
15:22:11 <Kevin_Kofler> mbriza: So we're discussing the remaining system-config-* tools on the KDE spin. -date is redundant with kcm_clock, -users could be replaced with kuser, I'm coming to -services.
15:22:29 <mbriza> Kevin_Kofler: thank you
15:23:07 <Kevin_Kofler> * For system-config-services, it doesn't even have full systemd support. There's something called kcm_systemd which should be a more powerful replacement.
15:23:51 <Kevin_Kofler> .bug 1085130
15:24:41 <rdieter> here, sorry for the delay
15:24:50 <Kevin_Kofler> #link https://bugzilla.redhat.com/show_bug.cgi?id=1085130
15:25:15 <Kevin_Kofler> That's the review request, I filed (picking up from where Mario Blättermann left it when he withdrew his).
15:25:51 <Kevin_Kofler> Now kcm_systemd is probably not bug-free yet, the most serious issue I'm seeing is that it can't be used from the live image.
15:26:26 <Kevin_Kofler> It says that I (i.e. liveuser) don't have permission to save the settings and doesn't offer me any way to auth as admin.
15:26:46 <Kevin_Kofler> But that could be worked around with a special policy for liveuser.
15:27:03 <Kevin_Kofler> I haven't yet done much testing otherwise because of that issue.
15:27:08 <danofsatx-work> yeah, that sounds easy enough (from a non-developer point of view)
15:27:28 <rdieter> Kevin_Kofler: let's get it reviewed, then we'll see
15:27:32 <Kevin_Kofler> Yeah, it's simple boilerplate in kde-settings or the live kickstart.
15:27:40 <Kevin_Kofler> rdieter: Well, I can't review it because I'm the submitter.
15:27:51 <rdieter> join the club (I can help take a look later)
15:28:15 <danofsatx-work> I can review it because I'm not a dev - I don't know what I'm looking at ;)
15:28:16 <Kevin_Kofler> So, I'm coming to the proposal, which has 3 parts:
15:28:27 <danofsatx-work> s/can/can't
15:28:34 <Kevin_Kofler> (a) remove system-config-date from the KDE spin, add ntpdate so that kcm_clock is fully functional
15:28:49 <Kevin_Kofler> (b) replace system-config-users with kuser on the KDE spin and
15:29:11 <Kevin_Kofler> (c) replace system-config-services with kcm_systemd on the KDE spin (once it's in Fedora, of course)
15:29:21 <Kevin_Kofler> My vote is obviously a+1, b+1, c+1.
15:29:35 <rdieter> a,b +1, c defer until we have a chance to test it
15:29:40 <danofsatx-work> +3
15:29:57 <rdieter> if you want to insist on a c vote now, then -1
15:29:59 <danofsatx-work> er, +1 to each
15:30:45 <danofsatx-work> I read c as a deferred vote to begin with - "once it's in Fedora, of course"
15:30:46 <Kevin_Kofler> OK, so let's evaluate kcm_systemd after it's been through review.
15:30:53 <Kevin_Kofler> danofsatx-work: Indeed.
15:30:54 <tosky> I agree with rdieter
15:31:13 <Kevin_Kofler> But the implication of voting for (c) now is that it is basically preapproved, which rdieter doesn't feel comfortable with.
15:31:42 <mbriza> why does kuser look so weird?
15:32:20 <tosky> mbriza: I guess it's almost the same code since ages
15:32:30 * dvratil agrees with rdieter
15:33:01 <mbriza> anyway, +1 everything
15:33:02 <Kevin_Kofler> So let's reevaluate kcm_systemd once it's in, and focus on the stuff that is in Fedora now, i.e. a and b.
15:33:29 <Kevin_Kofler> I don't think we can get a decision on c now, and I understand the reservations.
15:34:14 <Kevin_Kofler> So, does anybody NOT agree with parts (a) and (b) of the proposal?
15:34:35 * rdieter didn't see any dissent
15:34:54 * Kevin_Kofler neither, files it as agreed…
15:35:56 <Kevin_Kofler> #agreed remove system-config-date in favor of kcm_clock from kde-workspace (and add ntpdate for it to be happy), replace system-config-users with kuser, defer decision on kcm_systemd vs. system-config-services
15:37:53 <Kevin_Kofler> #topic Open discussion
15:37:58 <Kevin_Kofler> Everything else?
15:39:34 <danofsatx-work> I just read mattdm's email regarding wayland and gnome 3.12. Where's the KDE support on wayland?
15:40:48 <Kevin_Kofler> For 4.x it's mostly nonexistent, you're lucky if the apps work in X11 compatibility (XWayland).
15:41:05 <Kevin_Kofler> It's one of the big things being worked on in KF5 land.
15:41:19 <danofsatx-work> thanks, I wasn't aware of the status of it.
15:41:48 <rdieter> danofsatx-work: that's plasma.next land
15:42:03 <rdieter> (and kf5 too, as mentioned)
15:42:48 <Kevin_Kofler> I'd hope that most apps won't crash under XWayland in a GNOME session…
15:43:39 <tosky> unless someone patches the qwayland backend for Qt4, which is quite unlikely
15:44:07 <Kevin_Kofler> I think that'll actually make MORE apps crashy. :-(
15:44:29 <Kevin_Kofler> All the work on fixing X11 assumptions is being done only in the KF5 ports.
15:45:44 <Kevin_Kofler> Also, AIUI, in Qt 4, it'd have to be a compile-time choice, so a completely different Qt build for X11 and for Wayland.
15:45:50 <Kevin_Kofler> I don't think it'd be practical.
15:45:59 <Kevin_Kofler> This is really QPA and thus Qt 5 material.
15:48:22 <Kevin_Kofler> So, anything else or can I close the meeting?
15:48:53 <danofsatx-work> ummm.....
15:49:00 <danofsatx-work> i forget.
15:49:07 * danofsatx-work didn't take notes
15:52:35 <Kevin_Kofler> Closing meeting in 60 seconds.
15:53:27 <Kevin_Kofler> Closing meeting in 10 seconds.
15:53:35 <Kevin_Kofler> OK, thanks for coming everyone!
15:53:38 <Kevin_Kofler> #endmeeting