16:00:29 <mboddu> #startmeeting RELENG (2019-09-12)
16:00:29 <zodbot> Meeting started Wed Sep 11 16:00:29 2019 UTC.
16:00:29 <zodbot> This meeting is logged and archived in a public location.
16:00:29 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:29 <zodbot> The meeting name has been set to 'releng_(2019-09-12)'
16:00:29 <mboddu> #meetingname releng
16:00:29 <zodbot> The meeting name has been set to 'releng'
16:00:30 <mboddu> #chair nirik sharkcz pbrobinson pingou mboddu dustymabe ksinny jednorozec
16:00:30 <zodbot> Current chairs: dustymabe jednorozec ksinny mboddu nirik pbrobinson pingou sharkcz
16:00:30 <mboddu> #topic init process
16:00:49 * dustymabe waves
16:01:14 * sharkcz is here
16:01:55 <mboddu> Hello
16:02:25 <nirik> morning
16:03:43 <mboddu> Hello everyone
16:04:05 <mboddu> I will be running a shorter meeting today due to another meeting in 30 min
16:04:17 <mboddu> dustymabe: Do you have anything?
16:05:01 <dustymabe> mboddu: well there was the discussion on the ML about notifications from pagure
16:05:24 <dustymabe> don't know if we ran that to ground there or not
16:05:43 <dustymabe> mboddu: did you see it?
16:06:38 <mboddu> dustymabe: Nope, which one is that?
16:07:16 <dustymabe> https://lists.fedoraproject.org/archives/list/rel-eng@lists.fedoraproject.org/message/GEUUAU24S2BOHHDT3SCJ4RRPHFYDOGOT/
16:07:31 * nirik would be fine disabling pagure->mailing list... but I don't know if we came to many conclusions.
16:07:48 <dustymabe> mboddu: maybe we can let you read through it
16:08:01 <dustymabe> nirik: I think the conclusions I gleaned was:
16:08:20 <dustymabe> 1 - wait a few months and scm notifications should be better because we won't be using the pagure repo for that
16:08:34 <dustymabe> 2 - we may want to stop forwarding releng pagure repo to the releng list
16:08:45 * nirik nods.
16:09:35 <mboddu> dustymabe: So, unorphan will be handled by dist-git directly in the future release of pagure
16:10:04 <mboddu> Only other thing is unretirement, which are way less compared to unorphan requests
16:10:21 * nirik nods again
16:11:04 <mboddu> I am not sure if moving them would be any beneficial
16:11:43 <dustymabe> mboddu: right so if things weren't going to improve then I'd prefer to move them to another repo
16:11:59 <dustymabe> but since things are going to improve I'm willing to wait and see
16:12:14 <dustymabe> so for #1 we agree to wait and see
16:12:23 <dustymabe> nirik: want to argue for #2 ?
16:12:49 <nirik> I think it just results in 2 bad things and 1 good thing:
16:13:02 <nirik> bad: mailing list discussion is drowned out
16:13:23 <nirik> bad: most people end up getting 2 copies of everything.
16:13:36 <nirik> good: there's one place people could subscribe to (the list).
16:13:52 <nirik> but they could just subscribe in two places and get all the same stuff...
16:14:13 <dustymabe> I'm cool with whatever decision you all make
16:14:28 <mboddu> I prefer not to forward them, since people can follow the repo directly
16:14:33 <dustymabe> +1
16:14:52 <mboddu> s/follow/watch/
16:15:01 <nirik> yeah, thats my thought as well..
16:15:05 <dustymabe> if we choose to do that can we at least update a doc somewhere (or maybe the mailmain interface for releng list) to say that you should also follow the pagure repo ?
16:15:29 <nirik> we should send an email to the list describing that we are cutting off the copy...
16:15:37 <nirik> (people should find that at least for a while)
16:15:38 <mboddu> +1
16:16:10 <mboddu> nirik: Where is the forwarding setup?
16:16:34 <dustymabe> mboddu: I think it's a setting in pagure
16:16:41 <dustymabe> I can try to remove the forwarding if you like
16:16:56 <nirik> yeah, it's in pagure settings...
16:16:58 * mboddu checks
16:17:10 <nirik> who wants to send the email about it to the list? ;)
16:17:28 <mboddu> nirik: I can
16:17:38 <mboddu> I will also disable the forwarding
16:18:24 <nirik> cool. thanks mboddu!
16:18:37 <mboddu> #action mboddu will send an email to rel-eng@ list about not forwarding the releng repo stuff and ask people to watch the repo for email notifications and will disable the forwarding in the repo settings
16:19:23 <mboddu> Okay, moving on
16:19:40 <mboddu> #topic #8728 Add kalev to koji admins
16:19:45 <mboddu> #link https://pagure.io/releng/issue/8728
16:19:52 <mboddu> Any +1/-1's
16:20:35 <mboddu> Well, we wont be adding kalev as an admin, but we will give him some powers as we did with ignatenkobrain
16:20:37 <nirik> well, I'm fine with it... although kojira being slow is something we should fix rather than having lots of people regen repos
16:20:54 <mboddu> ack
16:22:04 <nirik> are those perms enough for those cases?
16:22:11 <mboddu> Sorry, it was an admin perm, not a hub policy
16:23:25 <mboddu> Yeah, we tried for few things and it worked, but we never updated it for regen-repo, if I remember correctly
16:23:37 * mboddu checks
16:23:47 <nirik> I'm not sure there's a seperate perm for that...
16:24:01 <dustymabe> regarding perms: https://github.com/coreos/fedora-coreos-tracker/blob/master/Fedora-Requests.md#existing-requests-for-fedora-releng
16:24:27 <nirik> yeah...
16:26:19 <mboddu> Yeah, that too
16:27:27 <nirik> so, what do we want to do here?
16:28:48 <mboddu> nirik: May be add kalev as admin for now and create a ticket for regen-repo policy as well(just like https://pagure.io/koji/issue/1637) ?
16:29:35 <nirik> well, I think it would need to be a new policy... the dist-repo one exists, just not in our instance due to schema problems.
16:29:38 <nirik> but sure.
16:29:47 <mboddu> Right
16:30:35 <mboddu> #action mboddu will add kalev as koji admin temporarily until we have a new policy for regen-repo permission, mboddu will file a koji ticket for it
16:30:45 * nirik will try and catch koji folks this week about the dist-repo thing... we need to get that sorted.
16:30:56 <mboddu> Yes
16:31:08 <kalev> thanks guys
16:31:13 <mboddu> Okay, thats it for today, sorry for the short meeting
16:31:29 <mboddu> Anything else before I end the meeting?
16:31:38 <dustymabe> nope
16:31:41 <nirik> #info rc1 is composing. :)
16:31:58 <mboddu> thanks nirik :)
16:32:10 <mboddu> Thanks everyone for joining
16:32:14 <mboddu> #endmeeting