02:02:27 <mchua> #startmeeting
02:02:27 <zodbot> Meeting started Thu Sep 9 02:02:27 2010 UTC. The chair is mchua. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:02:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
02:02:41 <quaid> random Arduino spotting: http://www.boston.com/lifestyle/articles/2010/04/06/chad_barrafords_digital_life_assistant_project_jarvis_is_indispensable/
02:02:43 * mchua wishes zodbot had a meeting timeout (#setlength 60, etc)
02:02:45 <quaid> also a cool post
02:02:47 <mchua> #chair quaid jadudm
02:02:47 <zodbot> Current chairs: jadudm mchua quaid
02:03:00 <mchua> #link http://mchua.fedorapeople.org/posse/notes/posse-curriculum.JPG
02:03:11 <mchua> #info That's the latest POSSE curriculum artifact.
02:03:30 <mchua> Right. So my intent here was to try and get a better... "academic source," for lack of better terminology, for the POSSE curriculum.
02:03:41 <jadudm> what does that mean?
02:03:47 <quaid> ok, let's talk about that
02:03:57 <mchua> I think we teach the right stuff in the right order, generally, but it's super haphazard, the design hasn't really been thought through, or the rationale behind it hasn't been clearly shared/expressed.
02:04:05 <mchua> At least by me. Chris and Dave did a much better job when they taught the first POSSE.
02:04:13 <quaid> I coined the term to describe the way that ACADemia goes about everything involved in teaching a student in a class.
02:04:29 <quaid> so FOSS uses 'open source' and ACAD uses 'academic source'
02:04:32 <jadudm> We might call that "course planning" and "teaching"
02:04:34 <quaid> that's as far as I defined it.
02:04:39 <quaid> right :)
02:04:45 <mchua> But that was "highly skilled and experienced people shipping their binary blob" and I, being a n00b in the teaching world, wasn't able to generalize it very well.
02:04:56 <jadudm> Well, it's still course planning and teaching.
02:04:59 <mchua> Yeah, "course planning" consisted of "Mel panics for a couple weeks."
02:05:02 <mchua> Not scaleable.
02:05:06 <mchua> Very non-raptor-proof.
02:05:12 <jadudm> However, the board looks good.
02:05:13 * mchua is a raptor-bus hazard
02:05:23 <quaid> loosely raptor proof, I argue
02:05:33 <jadudm> And, writing it out is actually a big step towards then being able to discuss it.
02:05:38 <mchua> Right. So I was trying to break this down into the units we already have - Open, Source, Development, & (Development II), Teaching.
02:05:41 * mchua nods
02:05:46 <quaid> in the sense that another skilled FOSS person could create a somewhat equivalent experience based on what you have written out there, if they studied fast.
02:05:52 <mchua> quaid: Yep yep, that's exactly the intent.
02:06:03 <mchua> quaid: well, skilled FOSS person with also teaching skillz.
02:06:03 <quaid> no, I mean, it's been that way, just to give credit.
02:06:11 <quaid> right, that rare-r combo
02:06:13 <mchua> For each module, I tried to make:
02:06:35 <mchua> (1) learning objectives (2) assessment mechanisms (3) some semblance of pedagogical outline
02:06:47 <jadudm> (good use of the word "pedagogical".)
02:06:49 <mchua> Now, I think I mostly got (1), though I'm not super happy with the "teaching" learning objectives, they were very arbitrary.
02:06:57 <jadudm> (we use it to sound professional and stuff.)
02:07:04 <mchua> jadudm: ooo, pro tip. thanks!
02:07:09 <jadudm> ;)
02:07:18 * quaid lolz
02:07:29 <mchua> (2) wasn't explicitly written on this board - I mostly listed out deliverables, with the hope that we could figure out what makes a "good" version of one of those deliverables... at some... point.
02:07:42 <mchua> Probably when the deliverables get spec'd out more.
02:07:58 <jadudm> You know, Reigeluth's text on instructional design would be a good resource for you.
02:08:03 <jadudm> I don't know why I didn't think of it sooner.
02:08:07 <jadudm> Let me see what I can dig up online.
02:08:09 <mchua> (3) is... very incomplete for all the modules, mostly I have a list of "topics that would be good to cover"
02:08:10 * quaid quietly steals $everything for textbook learning objectives ...
02:08:22 <mchua> and the occasional "yeah this would make a good reading group discussion" note, etc.
02:08:37 <mchua> quaid: Ooh, wait 'till you see the video.
02:08:46 <mchua> quaid: I compare the textbook to shared code libraries.
02:08:53 <mchua> quaid: Er. It... makes sense, really.
02:09:21 <quaid> sure thing
02:09:44 <mchua> (145 mb, so it's taking a while)
02:09:46 <mchua> (the video)
02:09:57 <quaid> oic
02:09:59 <jadudm> (I had 145 mb once.)
02:10:35 <quaid> ok, I'm using my power supply to keep my feet warm, it's time to move inside.
02:10:43 <jadudm> #link http://www.amazon.com/Instructional-Design-Theories-Models-Paradigm-Instructional/dp/0805828591
02:10:51 <jadudm> quaid: where do you live?
02:11:37 <mchua> Now that it's going on YouTube (112 min remaining, whee)
02:11:48 <mchua> things I know are weak-spots and next-steps in the POSSE whiteboard...
02:12:00 <mchua> Immediate next step is for me to type it on the wiki so it's more modifiable and then spam TOS.
02:12:07 <mchua> #action Mel transcribe whiteboard, spam TOS
02:12:12 <jadudm> #link http://www.alibris.com/booksearch?qwork=10054995&keyword=Instructional-Design+Theories+and+Models&matches=14&cm_sp=works*listing*buyused
02:12:28 <mchua> #note Reigeluth's text on instructional design - good book
02:12:36 <mchua> jadudm: ooo, thanks!
02:12:40 <jadudm> #note I started with volume 2.
02:12:49 <mchua> jadudm: I need to find where I put my copy of "understanding by design" and re-read it, too.
02:12:52 <quaid> jadudm: Santa Cruz - http://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=Riverside+Avenue+and+Broadway,+Santa+Cruz,+CA&sll=36.970856,-122.020992&sspn=0.012378,0.021222&ie=UTF8&hq=&hnear=Broadway+%26+Riverside+Ave,+Santa+Cruz,+California+95060
02:13:05 <jadudm> Ah. GMT-8 and warmer in general.
02:13:12 <quaid> in general, yes
02:13:22 <quaid> but not in the summer
02:13:35 <quaid> Monterey Bay == marine layer of fog
02:13:47 <jadudm> Wow.
02:13:57 <mchua> #action mchua turn this into a schedule for POSSE South Africa
02:13:59 * quaid queues Mark Twain quotes
02:14:08 <mchua> So much for immediate next actions. Er... weak points.
02:14:30 <jadudm> Is there still a goal of submitting a proposal for a workshop at SIGCSE?
02:14:35 <mchua> I'm pretty happy with learning objectives for days 1-3, like I said. I actually feel pretty good about days 1-3 in general, things just need fleshing out, but I think it's doable.
02:14:45 <mchua> jadudm: Yeeeeah, that's another immediate next action for me.
02:14:45 * mchua sighs.
02:14:54 <jadudm> Because you're dealing with more information on that whiteboard than can fit/go into a proposal.
02:15:04 <mchua> jadudm: Oh. Er.
02:15:21 * mchua has mostly been trying to get her brain-churn down enough to write well and fluently, found myself spewing utter junk this morning
02:15:49 <mchua> jadudm: I think of the SIGCSE workshop as something that would make people want to go to a POSSE, but now I have a better way of understanding what POSSE contains.
02:16:03 <mchua> So now that I know what it's advertising, the description, I hope, will be easier. And I can cherrypick a bit.
02:16:16 <mchua> ...from a wobbly new not-quite-ready-for-prime-time cherry tree, but... uh.
02:16:21 <mchua> Anyhoo.
02:16:41 <mchua> Day 4 has Too Much Stuff. Needs to be cut, needs to make sure people finish their projects on that day and wrap them up well whiel still absorbing extra info.
02:16:47 <mchua> s/whiel/while.
02:16:56 <jadudm> Well, we'll get the panel document squared away easily enough, I think. The workshop proposal... I don't think you should be thinking of it as a sales document for the 5-day workshop.
02:17:01 <jadudm> is the workshop about...
02:17:05 <jadudm> ... running your own POSSE?
02:17:12 <mchua> Day 5 is *totally* handwavy, mostly because I've just let the profs co-teaching POSSE totally run that day, since they know about teaching.
02:17:14 <jadudm> ... getting a "mini-POSSE" experience?
02:18:08 <mchua> jadudm: no, it's about incorporating FOSS into your existing curricula, and the POSSE connection is "if you need to learn about more tools, etc. and community norms to make the changes you're interested in, check out this workshop."
02:18:17 <mchua> at least that's what's in my mind atm, does that... fit?
02:18:22 <jadudm> Yes.
02:18:29 <mchua> I'm flying blind, never been to SIGCSE nor an academic conference before, nor a workshop at one.
02:18:46 <jadudm> Are Greg/Heidi involved/drafting/writing anything for the workshop proposal, or is that currently all on you?
02:19:10 <mchua> jadudm: all on me now, afaict.
02:19:24 <jadudm> quaid: are you still here, or have you succumbed to hypothermia?
02:20:24 <jadudm> Looks like we lost quaid.
02:20:49 <mchua> Might be taking him a while to relocate his cables.
02:21:00 <mchua> Either that, or the chickens finally attacked.
02:21:06 <jadudm> awesome.
02:21:15 <jadudm> so, I would consider one of the following three strategies:
02:21:23 <jadudm> 1. do nothing other that workshop proposal tomorrow and Friday.
02:21:31 <jadudm> 2. bail on workshop proposal.
02:21:40 <jadudm> but, (2) has alternatives/caveats
02:21:55 <jadudm> instead of (2) at SIGCSE, put a flier in every bag about a POSSE BOF.
02:22:16 <jadudm> Instead of doing a workshop within the structure of the conference, do an event in the ... less structured part of the conference.
02:22:23 <jadudm> Workshops run the day before SIGCSE.
02:22:29 <mchua> Would a workshop give us any more... um... people? street cred? awesomeness?
02:22:30 <jadudm> day before == fewer attendees
02:22:40 <mchua> Hrm.
02:22:41 <jadudm> BOF == more people around.
02:22:46 <jadudm> BOF + Food == lots more people around
02:22:54 <mchua> Oh, we can *so* do food.
02:22:55 <jadudm> Fliers in bag == message to every attendee
02:23:02 <mchua> What are the disadvantages of not having a workshop?
02:23:09 <jadudm> What is your goal?
02:23:11 <jadudm> Spreading the word?
02:23:14 <jadudm> Building community?
02:23:14 <mchua> I mean, are there really any, beyond "no can haz citation?"
02:23:22 * mchua thinks a moment
02:23:24 <jadudm> Workshops aren't amazing citation fodder.
02:23:33 <jadudm> workshop << paper
02:23:43 <jadudm> well.
02:23:45 <jadudm> workshop < paper
02:23:56 <mchua> Getting people interested in coming to POSSE who *aren't* already diehard FOSS fans.
02:24:17 <mchua> I'm... not super happy with that goal statement, but I'll start there for a bit.
02:24:26 <jadudm> my reason for suggesting (1) and (2) is because that's where you are at in terms of submission.
02:24:53 <mchua> jadudm: I could spend all my free time on (1) - and I would - but I'm not confident I could do it well.
02:25:08 <jadudm> And, sadly, I have meetings with students and interviews to do tomorrow and Friday.
02:25:13 <mchua> Because I lack so much of this context, I'm relying very heavily on folks like you, Heidi, Greg, etc. to fill in the expertise.
02:25:14 <jadudm> I'm booked rather solid for the next two days.
02:25:16 <mchua> And that... may not be feasible, or fair.
02:25:38 <jadudm> No, that's OK.
02:25:44 <jadudm> Feasible might be an issue.
02:25:57 <mchua> jadudm: Yeah, I've been amazed (and incredibly appreciative!) of how much you've been working o this the last few nights.
02:26:08 <mchua> I know you have a workload possibly even more deathful than mine. :)
02:26:12 <jadudm> However, I'm suggesting that the goal is probably to get more people in a room talking about POSSE/FOSS.
02:26:16 <jadudm> At least, at this tage.
02:26:18 <jadudm> stage.
02:26:20 * mchua nods.
02:26:32 <mchua> My only worry is "all buzz, no action."
02:26:33 <jadudm> gregdek: are you planning any presence at SIGCSE?
02:26:54 <gregdek> jadudm, I am not currently.
02:27:01 <jadudm> gregdek: OK.
02:27:08 <mchua> But that's something we can handle by making the informal presence a good one. So... I think that dropping and going for a BoF (how do we get flyers in every bag?) is the Right Thing.
02:27:54 <jadudm> Part of why I'm suggesting this, also, is because I'm concerned about running a workshop where we suggest we have expertise in integrating FOSS into existing curricula.
02:28:09 <jadudm> I'm still working things out.
02:28:37 <jadudm> I could not casually sit down and tell a colleague/operationalize what is involved in bringing 10 or 15 students into an open community.
02:29:02 <mchua> Oh man, neither could I.
02:29:08 <jadudm> What do you have to do when, and how, and how do you balance that with curricular requirements/certification/etc.
02:29:20 <mchua> I think we're just suggesting that we've... started trying it ourselves, not that we've actually grokked in fullness.
02:29:25 <jadudm> Which is good.
02:29:34 <jadudm> If we can get a panel, that's good.
02:29:43 <jadudm> And, we've talked about a paper. That's good.
02:30:03 <mchua> Ok, so we're at "panel" phase, not "workshop" phase - the latter implies you Know Things and can Teach Them To People?
02:30:06 <jadudm> And if we get the word out to 1500 people in a coherent way, and get 40-50 of them in a room because they're genuinely interested during a BOF session, that's also good.
02:30:14 <mchua> (which, uh, I guess in retrospect should be obvious, but...)
02:30:15 <jadudm> Dunno. I've never done a workshop. :)
02:30:48 <jadudm> Usually, though, they're hands-on in some way. There's been BlueJ/Greenfoot workshops, I know a colleague submitting one about Android programming, etc.
02:31:15 <jadudm> The direction for the proposal is good, but I'm concerned about the time left to make the proposal itself good.
02:31:24 <jadudm> I've spent a lot of time on 6 paragraphs so far.
02:32:03 * mchua nods
02:32:05 <jadudm> HOWEVER, all the work you've done this past day would feed *incredibly* well into the proposed paper that we had talked about/Greg started.
02:32:05 * mchua checks status
02:32:18 <mchua> jadudm: ...wait, really? I... have been tracking that less optimally.
02:32:25 <jadudm> We haven't done anything to it yet.
02:32:35 <jadudm> But, it would be a great chunk of the paper, I think.
02:32:37 <mchua> All right, cut workshop, go for flyer insert + BoF + paper + panel.
02:32:46 <mchua> jadudm: you mean the curriculum whiteboard scrawl?
02:32:50 <jadudm> Yep.
02:32:55 <mchua> Oh.
02:32:59 * mchua is glad this is useful
02:33:00 <jadudm> Because its the most coherent capture of POSSE we've had yet, I suspect.
02:33:02 <mchua> yay!
02:33:09 <mchua> ...wow, that means we need *way* more coherent captures.
02:33:23 <mchua> If this is the best we've got, then... we need... better things. But! Starting somewhere.
02:33:27 <jadudm> ... which is what we're working on again, after we move past SIGCSE sprinting.
02:33:32 <mchua> Right-o.
02:33:48 <mchua> It's the curriculum stuff I wanted to write up for you when we talked last... Tuesday.
02:34:01 <jadudm> So my point from the start wasn't "this isn't good," but "is there time before the 10th for a good workshop proposal?"
02:34:12 <mchua> #agreed no SIGCSE workshop, go for handout advertising BoF instead
02:34:15 * quaid is back from getting dinner for folks and now reads his buffer while scarfing his own
02:34:26 <mchua> #info also targeted for SIGCSE: panel, paper
02:34:32 <jadudm> oh.
02:34:34 <mchua> jadudm: is it problematic that the paper authors are also the panel?
02:34:38 <jadudm> no, the paper was targeted elsewhere.
02:34:41 <mchua> quaid: you're alive!
02:34:45 <mchua> quaid: the chickens did not get you!
02:34:47 <mchua> yay!
02:35:50 <jadudm> and, a SIGCSE paper would also be due... FRIDAY!
02:35:53 * jadudm does a jig
02:36:59 <mchua> #info Um, no SIGCSE paper, mchua is hallucinating
02:37:14 <mchua> #info actually targeted for SIGCSE: panel, BoF-announced-with-flyer-in-every-bag
02:37:17 <mchua> how does one get a flyer in every bag?
02:37:42 <mchua> And this means that I'm just going to (1) send the whiteboard photo to TOS now, and (2) crank on my panel position statement, again.
02:37:47 <mchua> (thank you, Matt, for your infinite patience.)
02:38:53 <jadudm> mchua: gladly, no worries, etc.
02:39:01 <jadudm> sounds like a plan.
02:39:13 <jadudm> as to fliers: I don't know, but we certainly have weeks, if not months, to figure that out.
02:39:17 * mchua is ready to just sprint on that, has nothing further
02:39:18 * mchua nods
02:39:20 <jadudm> #action Matt find out how to get fliers in bag.
02:39:27 <mchua> Rockin'.
02:39:28 <jadudm> #action Mel pester Matt about fliers if I forget.
02:39:41 <mchua> I'll send these minutes to the TOS list when we #endmeeting, too.
02:40:04 <mchua> Aaand tomorrow I fly to Columbus, OH.
02:40:06 <jadudm> Before bailing 100% on the workshop proposal, it might be nice to touch base with Heidi, Greg and see if they were invested in it.
02:40:08 <jadudm> Oh.
02:40:09 <jadudm> Wow.
02:40:10 <mchua> Ahh, life. :)
02:40:20 <jadudm> Yeah, there wasn't time to finish the workshop proposal even if you wanted to.
02:40:36 <jadudm> LinuxCon.
02:40:39 <jadudm> I forgot.
02:40:44 <jadudm> For me, it will have to be next year.
02:40:53 <jadudm> But, I'll try and work it out so I can take a vanload of students or something.
02:40:58 <mchua> jadudm: gotcha - yeah, I was going to send a note to TOS saying "think I'm gonna have to bail on workshop proposal, here is alt.betterness jadudm proposed, others more than welcome to pick up, though, thoughts?"
02:41:20 <mchua> jadudm: Ohio LinuxFest, actually - and they do an incredible job of running a very nice, safe, diverse conference.
02:41:29 <mchua> Hey, ctyler - we were just discussing SIGCSE and the POSSE curriculum.
02:41:30 <jadudm> that's what I meant.
02:41:32 <mchua> Which... you should...
02:41:40 <mchua> ctyler: http://mchua.fedorapeople.org/posse/notes
02:41:50 <ctyler> mchua: yes, I was following just before I rebooted my server :-)
02:41:56 <mchua> ahh!
02:41:59 <mchua> okay.
02:42:15 <mchua> jadudm: Vanload of students next year == sounds awesome.
02:42:30 <jadudm> mchua: Yeah, I'm getting certified to drive campus vans later this month.
02:43:45 <mchua> AWESOME
02:46:18 <jadudm> mchua: I'm crashing out.
02:46:27 <jadudm> I was up early, and it's been a full day.
02:47:16 <mchua> jadudm: Thanks, Matt. I think I"m set. I'll send this to the TOS list and crack on that position statement of mine.
02:47:24 <mchua> If I don't finish it before I pass out myself, I'll do it tomorrow morning again.
02:47:34 <mchua> jadudm: have a good night!
02:47:41 <jadudm> mchua: you too. good work
02:50:31 <mchua> #endmeeting