13:03:36 <ryanlerch> #startmeeting Workstation WG
13:03:36 <zodbot> Meeting started Mon Apr 23 13:03:36 2018 UTC. The chair is ryanlerch. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:03:36 <zodbot> The meeting name has been set to 'workstation_wg'
13:03:51 <mclasen> .hello mclasen
13:03:52 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:03:58 <ryanlerch> #meetingname workstation
13:03:58 <zodbot> The meeting name has been set to 'workstation'
13:04:01 <kalev> .hello kalev
13:04:01 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
13:04:05 <cschalle> .hello cschalle
13:04:06 <ryanlerch> #topic rollcall
13:04:08 <zodbot> cschalle: Sorry, but you don't exist
13:04:13 <ryanlerch> .hello ryanlerch
13:04:14 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:04:15 <juhp> .hello petersen
13:04:17 <zodbot> juhp: petersen 'Jens Petersen' <petersen@redhat.com>
13:04:25 <mcatanzaro> .hello catanzaro
13:04:26 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
13:04:36 <ryanlerch> #chair kalev juhp cschalle cschalle mcatanzaro
13:04:36 <zodbot> Current chairs: cschalle juhp kalev mcatanzaro ryanlerch
13:04:49 <stickster> .hello pfrields
13:04:50 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:04:59 <ryanlerch> #chair mclasen stickster
13:04:59 <zodbot> Current chairs: cschalle juhp kalev mcatanzaro mclasen ryanlerch stickster
13:05:46 * mclasen marked a few tickets with our new 'meeting' tag
13:06:03 <ryanlerch> okies, i think that is almost everyone
13:06:13 <ryanlerch> mclasen: yeah, there are 4 currently in there
13:06:46 <ryanlerch> #topic #49 -- add commandline container tools
13:07:02 <ryanlerch> #info https://pagure.io/fedora-workstation/issue/49
13:07:20 <ryanlerch> #info #49 Add commandline container tools
13:07:48 <ryanlerch> mclasen: this is one of yours i believe...
13:08:02 <mclasen> originally a request by colin
13:08:10 <stickster> This seems like a good call and a no-brainer to me. +1.
13:08:10 <mclasen> but I support it
13:08:37 <mclasen> the request is to add the commandline container setup and build tools into the workstation
13:09:00 <mclasen> it is essential for atomic workstation - you need to be able to set up containers so you can install more tools in them
13:09:06 <ryanlerch> aiming for f29? i assume no time to squeeze this into f28?
13:09:11 <mclasen> so the tools to set up the containers need to be part of the image
13:09:31 <mclasen> currently atomic ws adds these manually, but we should just include them in the workstation proper, I think
13:09:52 <ryanlerch> this is a +1 from me too
13:09:54 <mclasen> since supporting container-based developer workflows seems very much on target
13:10:05 <mclasen> +1 from me
13:10:08 <stickster> We're on freeze, not sure whether that means comps is out of bounds for F28, but I would assume people will look at that request cross-eyed
13:10:49 <juhp> how about deps btw?
13:10:51 <mclasen> i am ok with doing this for f29. as I said, FAW includes these tools now
13:10:56 <cschalle> +1 for me too. Do we have any way to add stuff to a system beyond initial install?
13:11:00 <juhp> I would assume f29
13:11:03 <kalev> I think it's a good idea to keep the Atomic Workstation and Workstation package set in sync
13:11:10 <juhp> +1
13:11:28 <kalev> so if we don't end up adding those to Workstation, I think they should be taken out of Atomic Workstation as well
13:11:43 <mclasen> cschalle: dnf install works fine. we can't magically make things appear on an already installed system, if thats what you mean
13:11:46 <stickster> kalev: adding to F29 or F28?
13:11:51 <mclasen> unless we artificially add some deps somewhere
13:11:54 <kalev> stickster: F29
13:12:12 <stickster> kalev: yeah, agreed, but I think adding them to non-Atomic WSis a winning proposal thus far
13:12:23 * kalev nods.
13:12:39 <cschalle> mclasen, yeah, it is just that depending on fresh installs to get stuff onto peoples system feels like a losing proposition after we improved upgrades so much. Maybe we could advertise these tools through GNOMe Software in some way?
13:12:48 <stickster> juhp: Not sure what your question was about deps
13:12:50 <kalev> +1 from me too. I don't know all of the tools, and I think flatpak-builder is maybe a bit too much to add to the default install, but otherwise seems like a good idea
13:13:06 <juhp> How much space will it take?
13:13:17 <juhp> kalev: +1
13:13:19 <mclasen> kalev: is flatpak-builder heavy ? I can't imagine
13:13:36 <mclasen> its written in C, it doesn't pull in half the world of python
13:14:04 <ryanlerch> we have 6 +1s so far here
13:14:31 <ryanlerch> mclasen: so the proposal is to add the list there, plus flatpak-builder and origin clients
13:14:34 <kalev> mclasen: it has hard requires on a bunch of build utils
13:14:42 <mcatanzaro> "How much space will it take" <-- my question too
13:14:55 <kalev> like git, for example -- the original proposal seems to avoid full git and explicitly lists git-core only
13:15:09 <stickster> juhp: mcatanzaro: Is there a "too much space" limit for you?
13:15:19 <mclasen> given that we aim for f29, should we defer a final decision until we have an answer to "what does it weigh" ?
13:15:23 <juhp> Nope just checking
13:15:51 <stickster> juhp: OK, we don't need to block on that but maybe spin up a F28 Live and check via dnf install
13:17:12 <stickster> Sounds like the proposal passes though
13:17:19 <juhp> Yeah I was starting to try
13:17:45 <ryanlerch> so agreed, or wait until we know how much space?
13:18:46 <stickster> I don't see a need to wait unless there's some need to stay below a certain limit
13:18:58 <stickster> I doubt we're looking at many 100s of MB of deps
13:19:03 <kalev> maybe wait on how much space? and I'm still a bit unsure about build utils like flatpak-builder. container management stuff makes a lot of sense to me though
13:19:11 <mclasen> one point is - those tools are on faw today
13:19:26 <mcatanzaro> I'm interested in space on the live image... I agree it's probably not much, +1 from me
13:19:50 <mcatanzaro> In the unlikely event it makes a noticeable impact in live image size, we might take a look at that later on
13:19:50 <juhp> I think flatpak pulls in quote a lot
13:19:59 <juhp> flatpak-builder sorry
13:20:02 <mclasen> kalev: I'm viewing flatpak-builder as a container management tool for my build containers, but ok
13:20:02 <mcatanzaro> Oh
13:20:06 <juhp> ugh quite a lot
13:20:33 <juhp> maven etc
13:20:36 <mclasen> so, lets defer flatpak-builder and origin-clients until we know their impact, and just vote on the rest ?
13:20:42 <mcatanzaro> Um
13:20:50 <mcatanzaro> Yeah, -1 to flatpak-builder
13:20:58 <mcatanzaro> It will have to split out some dependencies into Suggests, I suppose
13:21:29 <mcatanzaro> juhp: I have flatpak-builder installed on F27, but not maven...?
13:21:48 * stickster thinks we should definitely go through a ton of deps investigation in the meeting :-)
13:21:58 <cschalle> :)
13:22:01 <juhp> okay a bunch of Java deps - we should probably check more carefully :)
13:22:12 <juhp> stickster: lol yeah
13:22:21 <juhp> mclasen: +1
13:22:23 * stickster is +1 on deferring flatpak-builder/origin-clients while waving the rest in
13:22:32 <kalev> +1 to that plan
13:22:36 <ryanlerch> +1
13:22:42 <mclasen> +1
13:23:07 <stickster> #proposed #action mclasen juhp mcatanzaro report deps/size info into ticket for flatpak-builder/origin-clients so we can treat separately
13:23:24 <mclasen> sure, will do
13:23:30 <stickster> #action mclasen juhp mcatanzaro report deps/size info into ticket for flatpak-builder/origin-clients so we can treat separately
13:24:18 <ryanlerch> #agreed to adding commandline container tools listed in #49, other than flatpack-builder and origin-clients
13:24:47 <ryanlerch> n to the next one?
13:24:50 <stickster> #meetingname workstation
13:24:50 <zodbot> The meeting name has been set to 'workstation'
13:24:56 <mclasen> yes, please
13:25:10 * stickster just making sure logs end up in same place as others
13:25:17 <ryanlerch> #topic ticket #50 add linux-firmware
13:25:35 <ryanlerch> #info add linux-firmware https://pagure.io/fedora-workstation/issue/50
13:25:49 <mclasen> I filed this because somebody complained that linux-firmware is not included in FAW
13:26:20 <kalev> +1 from me, makes sense to include as much as hardware support as possible
13:26:36 <cschalle_> hmm, I never installed it manually so it must be pulled in somehow?
13:26:46 <mclasen> I just don't know how it ended up on my system. I think kalev suspected some obsoletes
13:26:57 <mcatanzaro> I'm confused how this is not installed already
13:27:19 <mclasen> it is possible that the rpm-ostree compose drops it for some reason
13:27:33 <stickster> Huh, that is confusing
13:27:40 <mclasen> would be worth checking if it is on the default workstation install
13:28:06 <mcatanzaro> I'm checking now, I have a fairly fresh VM
13:28:30 <stickster> it's on the default Live.
13:28:37 <stickster> (based on 28 Beta 1.3)
13:28:48 <kalev> ah, then it's probably something that Recommends it
13:29:17 <kalev> there's an issue where the Workstation install tree doesn't include any Recommends, but the live media does
13:29:31 <mclasen> and yet, not in https://pagure.io/workstation-ostree-config/blob/master/f/fedora-workstation-base-pkgs.json
13:29:39 <kalev> the ostree composes are done off the Workstation install tree (that doens't have any recommends) and thus they don't end up in ostree images
13:29:49 <mclasen> this is the faw package list that gets created from comps, programmatically
13:30:18 <stickster> ah interesting
13:30:21 <kalev> yes, but on live installs, any Recommends are added on top of that, but on rpm-ostree they are not
13:30:23 <mclasen> we never really got a good answer what this Workstation install tree is good for, or did we ?
13:30:26 <ryanlerch> what are the possible solutions? explicitly require it?
13:30:30 <mcatanzaro> kalev: Does that mean you won't get it if you install using the normal Workstation netinstall?
13:30:31 <mclasen> why not use everything ?
13:30:47 <kalev> yeah, I think it should just get switched to everything
13:30:55 <kalev> mclasen: I don't know.
13:30:57 <kalev> err
13:31:01 <kalev> that was to mcatanzaro :)
13:31:30 <kalev> https://bugzilla.redhat.com/show_bug.cgi?id=1569242 talks about the Recommends issue in workstation install tree
13:32:24 <kalev> https://pagure.io/pungi-fedora/pull-request/499 is a ticket to switch atomic to everything tree, looks like it was closed as wontfix or so
13:32:27 * mclasen is not looking forward to years of debugging mysterious 'package missing' issues due to this
13:32:42 <stickster> mclasen++
13:32:42 <zodbot> stickster: Karma for mclasen changed to 5 (for the f27 release cycle): https://badges.fedoraproject.org/tags/cookie/any
13:32:43 <juhp> ...
13:32:49 <mclasen> but this is how it will end up :-(
13:33:12 <ryanlerch> so how should we proceed on this one?
13:33:18 <juhp> We could add it to comps for now?
13:33:25 <mclasen> yes
13:33:38 <mclasen> if the compose process is broken for soft deps, we need to use comps
13:33:46 <mclasen> it sucks, but such is life
13:33:46 <juhp> okay
13:33:48 <mcatanzaro> bandaid over the real problem, but OK-
13:33:55 <mcatanzaro> I'd add it in such a way that it's easy to remove later
13:34:03 <mclasen> the real problem will take ages to get any motion on
13:34:10 <mcatanzaro> E.g. a new comps group "workstation-workaround-for-broken-compose"
13:34:43 <stickster> Should we reopen that #499 PR on pungi-fedora?
13:34:45 <mcatanzaro> (...I thought releng was fairly responsive to serious issues like this?)
13:34:51 <juhp> Well if it should be installed, it should not harm to have it in comps :)
13:35:02 * stickster is disappointed that there seems to be no rationale coming back in that ticket from rel-eng
13:35:20 <stickster> edicts without reasoning are always suspect to me
13:35:22 <kalev> yeah, I think it should be in comps, and not in some kind of "workaround-for-broken-compose" group but just added
13:35:29 <kalev> it makes sense to explicitly list it anyway
13:35:37 <stickster> kalev++ ... that would work fine.
13:35:40 <zodbot> stickster: Karma for kalev changed to 7 (for the f27 release cycle): https://badges.fedoraproject.org/tags/cookie/any
13:35:40 <ryanlerch> so vote on adding linux-firmware to comps for workstation as a workaround?
13:35:52 <stickster> +1 to add linux-firmware to comps
13:35:54 <juhp> +1
13:35:56 <kalev> +1
13:35:57 <ryanlerch> +1
13:36:01 <mcatanzaro> OK yeah, +1, this one is harmless to have in comps because it will always be desired
13:36:19 <mcatanzaro> I think this is going to be a problem again pretty soon though, and we're not going to want to keep doing this...
13:36:24 * stickster amused that comps was supposed to get less and less used, and yet we may be forced to use it for other things
13:36:37 <mclasen> +1
13:36:39 <juhp> mcatanzaro: true
13:37:44 <ryanlerch> #agreed add linux-firmware to comps for workstation
13:38:11 <ryanlerch> who is able to get this one done?
13:38:32 <mclasen> kalev, can you ?
13:38:57 <kalev> sure, happy to
13:39:21 <mclasen> thanks
13:39:25 <ryanlerch> #action kalev to add linux-firmware to comps
13:39:51 <kalev> that's also for F29, right?
13:40:32 <kalev> if it's F28 then it needs paperwork to get comps changes through the freeze
13:40:58 <juhp> Sounds to me like f28 is desirable?
13:41:20 <stickster> Yeah, in this case it would be
13:41:33 * stickster sees this more as a bug
13:41:43 <juhp> yes
13:41:47 <stickster> well, actually I guess that's irrelevant, there *is* a bug filed :-D
13:42:07 <kalev> we need a bug on bugzilla though and have it go through the freeze exception process
13:42:43 <kalev> I can file that too and there's a blocker review meeting coming up later today where it hopefully gets approved
13:42:52 <stickster> oh wait, was looking at wrong bug
13:43:14 <stickster> #proposed #action stickster file a bug and assign to kalev, and post as freeze request
13:43:18 <stickster> ^ ?
13:43:31 <ryanlerch> +1
13:43:45 <kalev> sure
13:43:49 <stickster> #action stickster file a bug and assign to kalev, and post as freeze request
13:44:29 <ryanlerch> #topic Fedora 28 Workstation Talking Points #51
13:44:36 <juhp> stickster++
13:44:36 <zodbot> juhp: Karma for pfrields changed to 18 (for the f27 release cycle): https://badges.fedoraproject.org/tags/cookie/any
13:44:44 <ryanlerch> #info https://pagure.io/fedora-workstation/issue/51
13:44:49 <mclasen> I looked them over, they seemed reasonable to me
13:44:56 <mclasen> not sure there's much to add
13:45:06 <mclasen> just put it on the agenda in case somebody else wants to review
13:45:17 <ryanlerch> mclasen: the main things i probably needed to be checked were the powermanagement stuff
13:45:32 <ryanlerch> i got those points form the feature page, and wasnt sure how up to date they were
13:46:14 <kalev> third party repo install is missing there
13:46:23 <ryanlerch> mclasen: yeah, happy fo people to review and edit those (or comment in the ticket with suggestions)
13:46:34 <kalev> we're now including an easy way to install Google Chrome, Steam, NVIDIA drivers and PyCharm directly from gnome-software
13:46:54 <mclasen> good point
13:47:09 <ryanlerch> kalev: is there a feature page for that one i can use to write the note?
13:47:10 <mclasen> but we'll probably get dinged for promoting non-freedom
13:47:47 <kalev> ryanlerch: no, I don't think we have one, sadly :(
13:48:13 <kalev> ryanlerch: there's a https://pagure.io/Fedora-Council/tickets/issue/121 , https://fedoraproject.org/wiki/Workstation/Third_Party_Software_Repositories , and a youtube video I'll find in a sec
13:48:23 <kalev> ryanlerch: https://www.youtube.com/watch?v=IF2FEeOdmFE
13:48:46 <ryanlerch> kalev: thanks! are you able to throw those into the ticket for me, and i will write it up tomorrow
13:48:54 <kalev> sure
13:49:23 <ryanlerch> #action ryanlerch to add item about thrid party repos into the f28 talking points
13:50:00 <ryanlerch> okies, on to the final ticket?
13:50:07 <stickster> ryanlerch: be sure to include a note that these are only used if the user agrees they want to
13:50:11 * mclasen has an item for open floor too
13:50:14 <stickster> to head off the naysayers
13:50:26 <ryanlerch> stickster: ack, thanks!
13:50:47 <ryanlerch> #topic Need an end-user docs / wiki page for Third Party Repositories
13:50:51 <stickster> ...although everyone seems to complain about free cake anyways, it's the way of the world
13:51:00 <ryanlerch> #info https://pagure.io/fedora-workstation/issue/41
13:51:48 <kalev> so I wrote up a quick page for that at https://fedoraproject.org/wiki/Workstation/Third_Party_Software_Repositories and gnome-software points to that now
13:52:01 <mclasen> I added this to maybe elicit some review of the suggested text
13:52:09 <mclasen> no need to do it in the meeting, though
13:52:21 <kalev> and Ankur has some additions to that now
13:52:25 * kalev nods.
13:53:08 <kalev> https://fedoraproject.org/wiki/User:Ankursinha/Third_Party_Software_Repositories is Ankur's suggestions
13:53:16 * stickster might take a scalpel to some of the text, but mainly minor readability things
13:54:18 <ryanlerch> okies, so no action required really on this one?
13:54:25 <stickster> I have to bounce in a minute to get set up for another meeting. I'll try to work on this text during the next hour.
13:54:37 <stickster> #action stickster do some editorial love on https://fedoraproject.org/wiki/User:Ankursinha/Third_Party_Software_Repositories
13:54:49 <stickster> o/
13:54:51 <ryanlerch> #topic open floor
13:54:59 <ryanlerch> mclasen: you have 5 mins!
13:55:02 <ryanlerch> :D
13:55:03 <mclasen> I have one informational item
13:55:38 <mclasen> as some of you may be aware, we've been looking for a new 'home' for the atomic workstation, since there's some changes coming to project atomic
13:56:10 <mclasen> and independently, we've been looking to ramp up mindshare for atomic workstation in general, since it is on the verge of 'generally useful'
13:57:08 <mclasen> last weeks faw sig spent time looking for a codename for that project - we didn't find one in the meeting, but we've since completed an exhaustive search and settled on 'Silverblue' or 'Team Silverblue'
13:58:19 <mclasen> working on a website/logo etc for that atm
13:58:40 <ryanlerch> silverblue?
13:58:54 <mclasen> yeah
14:00:33 <mclasen> you can find some early material on github, teamsilverblue
14:00:51 <ryanlerch> mclasen: thanks, will chekc it out
14:01:20 <mclasen> jimmac is working on a nice logo for it
14:02:16 <ryanlerch> nice!
14:03:00 <ryanlerch> mclasen: anything more to add?
14:03:10 <ryanlerch> anyone else?
14:03:42 <ryanlerch> 5
14:03:45 <ryanlerch> 4
14:03:51 <ryanlerch> 3
14:03:56 <ryanlerch> 2
14:03:58 <ryanlerch> 1
14:03:59 <mclasen> nothing more for now
14:04:03 <ryanlerch> #endmeeting