17:56:45 <gundalow> #startmeeting AnsibleFest Austin: Contributors Summit - AWX
17:56:45 <zodbot> Meeting started Mon Oct  1 17:56:45 2018 UTC.
17:56:45 <zodbot> This meeting is logged and archived in a public location.
17:56:45 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:56:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:56:45 <zodbot> The meeting name has been set to 'ansiblefest_austin:_contributors_summit_-_awx'
17:56:49 <gundalow> #chair bcoca cybette_
17:56:49 <zodbot> Current chairs: bcoca cybette_ gundalow
17:56:53 <gundalow> there you go
17:57:57 <matburt> thanks folks
17:58:20 <cybette_> thanks!
17:59:27 <AlanCoding> I'm dialed into that meeting link shared earlier in this conversation
18:00:04 <matburt> #info testing info!
18:02:06 <notting> we are currently working on fixing some display issues in the room
18:07:11 <cybette_> sorry for the delay
18:07:59 <matburt> I think we're almost ready
18:13:40 <cybette_> #info Bluejeans link: https://redhat.bluejeans.com/7025862841/
18:19:12 <notting> #info etherpad link https://etherpad.openstack.org/p/ansible-summit-october-2018-awx
18:25:41 <shanemcd> would be helpful if people could type their name into the etherpad document (top right icon) so we can correlate ideas with people.
18:29:15 <dmsimard> #info "Zuul v3 For Gating": https://www.youtube.com/watch?v=6177329H4Tg
18:29:42 <dmsimard> #info "Zuul Testing the Future": https://www.youtube.com/watch?v=KXh0sh3ETkQ
18:30:10 <notting> #info runner links - https://pypi.org/project/ansible-runner/ , https://github.com/ansible/ansible-runner/
18:33:05 <benthomasson> https://github.com/ansible/ansible-jupyter-kernel
18:33:28 <shanemcd> #info ansible-jupyter-kernel https://github.com/ansible/ansible-jupyter-kernel
18:40:23 <Pilou> ++ better upgrades :)
18:41:37 <notting> is the proposal mentioned suitable for what you need?
18:42:39 <Pilou> question: variables precedence (using same as Ansible)
18:43:40 <notting> more detail, plz?
18:44:00 <Pilou> should not AWX use the same variable precedence as Ansible ?
18:44:34 <Pilou> https://github.com/ansible/awx/issues/1280#issuecomment-391687216
18:47:47 <Pilou> Are AWX weekly community meetings planned (like the Ansible Core ones) ?
18:48:22 <AlanCoding> @Pilou I'm still not 100% on this, but my interpretation was that you were probably, in some way, using the same SCM directories for the import as for the playbook run
18:50:03 <AlanCoding> also, referencing "bypass ansible-inventory processing", it's not really viable for us to completely bypass the step where the inventory is imported into the database, just because we rely on this for setting properties on hosts as/after playbook runs happen
18:50:51 <AlanCoding> some people do things like invoke ansible-playbook as a shell command inside of their playbook, passing a different inventory, and that should be okay
18:51:27 <matburt> #action matt to set up monthly community meetings
18:52:17 <Pilou> Cache of group/vars all variables (https://github.com/ansible/awx/issues/1997) is unexpected when there is only one inventory source
18:52:28 <Pilou> :)
18:53:03 <cybette_> #info you'll get an angry spud sticker for first merged PR :)
18:53:12 <AlanCoding> aaah, I see
18:53:55 <AlanCoding> actually, 1997 is something that I personally think would be better to resolve
18:54:03 * bcoca wants angry spud t-shirt
18:54:49 <AlanCoding> group vars should be overwritten, but the all group is an exception, all group vars don't get overwritten
18:55:32 <notting> thanks all for coming! we're here if you ahve more questions
18:57:17 <cybette_> thanks all!
18:57:21 <cybette_> #endmeeting