00:03:09 <Kylie_> #startmeeting Ansible Azure Working Group
00:03:09 <zodbot> Meeting started Thu Mar 15 00:03:09 2018 UTC.  The chair is Kylie_. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:03:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:03:09 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:03:22 <jborean93> 10am for me
00:04:14 <yuwei> you also dont have daylight savings time?
00:04:17 <Kylie_> I have 2 topics. 1 is about bot broen. The other is PR. Any other topic, feel free raise it here.
00:04:20 <jborean93> Not in Brisbane
00:04:23 <Kylie_> #chair jborean93
00:04:23 <zodbot> Current chairs: Kylie_ jborean93
00:04:32 <jborean93> GMT+10 all year round for me
00:04:52 <yuwei> all year +8 for us
00:04:58 <Kylie_> Good time zone working with us:)
00:05:09 <Kylie_> #topic bot broken
00:05:33 <Kylie_> Jordan, Yuwei was added as one maintainer but it seems her "shipit" does not work.
00:05:43 <jborean93> Do you have an example PR?
00:05:48 <Kylie_> Below are examples for community modules.
00:05:49 <Kylie_> https://github.com/ansible/ansible/pull/35156
00:05:49 <Kylie_> https://github.com/ansible/ansible/pull/36109
00:05:49 <Kylie_> https://github.com/ansible/ansible/pull/34980
00:05:49 <Kylie_> I do see Yuwzho in https://github.com/ansible/ansible/blob/devel/.github/BOTMETA.yml but it seems her message “shipit” does not trigger approval for support:community pull requests
00:06:05 <yuwei> Yes,the inventory things
00:07:54 <jborean93> ok, not sure if the inventory scripts are seen as community modules, they be under "core" which is why the shipits don't matter too much
00:08:21 <Kylie_> For https://github.com/ansible/ansible/pull/34980, you could see a note from bot that "Zim approved ..." when Zim said "shipit". But no any response from bot when Yuwei said "shipit".
00:08:26 <yuwei> The tag is support:community
00:09:14 <jborean93> hmm I see, I would need to look into it and potentially raise a bug, just waiting to see the reply to one of the `bot_status` commands for one
00:09:42 <Kylie_> Please. Thank you.
00:10:42 <Kylie_> #topic PR
00:12:07 <Kylie_> https://github.com/ansible/ansible/pull/36766
00:12:23 <Kylie_> https://github.com/ansible/ansible/pull/36768
00:13:04 <Kylie_> Above 2, we got confirmation from the issue submitter that they work fine.
00:13:22 <zikalino> https://github.com/ansible/ansible/pull/36824
00:13:23 <Kylie_> Can you please review them again? Zim did update based on your comments.
00:13:31 <jborean93> I can see Zim has added the tests as well, I've added myself to the review and will hopefully get to them soon
00:13:36 <zikalino> regarding this one i will have to add some changes
00:13:53 <jborean93> sorry I've been focusing on some outside libraries and that's been taking a lot of time for me
00:14:49 <Kylie_> So you and Matt are fully on Azure. Right?
00:14:54 <jborean93> If they have been tested by a customer it would be great if that feedback could be put on the PR either from them (if they have Github) or just a message saying it was testing
00:15:11 <zikalino> ok, i will ask them
00:15:27 <jborean93> Not fully, we both work on other things, I mostly work on the Windows side. Matt works on a wide range of stuff and with 2.5 he is the RM which takes a lot of time
00:16:38 <Kylie_> I see. more resources or bandwidth are needed here:)
00:16:57 <jborean93> In regards to the inventory PRs, looks like no shipits are being added https://github.com/ansible/ansible/pull/35156#issuecomment-373217469. Will need to follow it up
00:17:23 <zikalino> yes, there are lots of prs contributed by people even a year ago, and now forgotten...
00:18:13 <jborean93> usually the shipits are cleared if a new commit is added but for that one I referenced both Zim's and Yuwzho's shipits aren't registered even those they are listed as a maintainer
00:20:31 <Kylie_> Yes. There are many good PRs from community. We should review them and approve them if good to move forward. As maintainers, Zim and Yuwei would like to help here but seems not work :(. Really need your help to see how to resolve it. Thank you.
00:21:09 <zikalino> for example this one: https://github.com/ansible/ansible/pull/22728
00:21:14 <jborean93> yep, I've sent a message to the guy who does the bot work but timezones are a pain
00:21:47 <zikalino> submitted already a year ago, and now it's actually needed by one of the customers
00:23:01 <jborean93> A lot of the PRs that are submitted usually don't proceed if there isn't a community demand or a driving force behind it. We can only do so much ourselves but with your help  we can try and clear the backlog
00:25:21 <zikalino> one question, do you think it would be ok to downgrade existing modules from "certified" to "community" ?
00:25:53 <Kylie_> Yes, Jordan, please help push bot issue. Then Zim and Yuwei could help. Otherwise, we still have to manually write down what we reviewed but not work and ping your and Matt again which is big overhead for you guys and not efficient.
00:26:18 <Kylie_> Zim, we discussed this offline:)
00:26:47 <jborean93> I'll try my best from our side
00:27:31 <Kylie_> Thank you.
00:27:55 <Kylie_> Any other PR or topic? @zikalino, @Yuwei?
00:28:13 <jborean93> For the 2.5 release I have an update
00:28:36 <jborean93> A few bugs were found and the decision was made to create an rc3 release which pushes back the final release by a week
00:28:55 <jborean93> So rc3 is expected Thursday/Friday this week and the final is now end of next week
00:29:39 <Kylie_> O, ok. Thank you for update.
00:30:47 <Kylie_> We are working with Red Hat on blogs to talk about new modules of Azure in 2.5. The target date was 3/15. Then let me talk with all to see when is the best time to post the blog. Thank you.
00:31:02 <Kylie_> Any other topic?
00:31:14 <jborean93> Not from me
00:31:31 <jborean93> Once I work through this SPNEGO stuff I've got locally I'll get back to reviewing the PRs
00:32:13 <Kylie_> #action @jborean93, review PR https://github.com/ansible/ansible/pull/36766
00:32:13 <Kylie_> https://github.com/ansible/ansible/pull/36768
00:32:28 <yuwei> We cannot close some issue
00:32:30 <yuwei> https://github.com/ansible/ansible/issues/30142
00:32:51 <jborean93> just closed it
00:32:54 <zikalino> and https://github.com/ansible/ansible/pull/36826
00:33:39 <zikalino> and https://github.com/ansible/ansible/pull/36824 but i will ping you when it's updated as i mentioned today
00:33:40 <jborean93> The MSI PR is good, only thing would be the better error handling on 403 errors when getting the subscription_id
00:33:44 <Kylie_> Jordan, for these 2, could you please prioritize them first since they are confirmed by the customer ( I will add the comment and @the submitter)? The customer also would like the bug fix cherry pick by 2.5.
00:33:45 <yuwei> https://github.com/ansible/ansible/issues/29586
00:34:11 <yuwei> This also need to close
00:34:25 <jborean93> done
00:34:42 <jborean93> I've added those PRs to my Github review list, trying to take advantage of that now as it gives me a list of PRs
00:35:42 <Kylie_> Nice. Poor Yuwei - bot does not get your point:(
00:35:46 <Kylie_> Thank you Jordan.
00:35:58 <jborean93> no worries
00:36:04 <yuwei> https://github.com/ansible/ansible/issues/21825 https://github.com/ansible/ansible/issues/29317
00:36:25 <yuwei> these two,I think no more from my side
00:37:22 <jborean93> closed, not sure if you are aware, if you put `Fixes: link to issue` in the PR, when that PR is merged it will close the issue. Only really works when you create the PR yourself after the issue is created though
00:38:28 <yuwei> How about others create the PR
00:38:40 <Kylie_> Good learning. I think Zim and Yuwei could do it for their PRs. For PRs contributed by others, could their comments trigger that?
00:38:45 <yuwei> I will add fixes later for all the PR
00:38:57 <jborean93> I don't believe so, I think it is only for the initial PR message
00:39:07 <jborean93> the rules seem to vary and I never really looked into it more
00:40:55 <Kylie_> Ok. Then it is better Yuwei's comment could trigger bot close those issues which have corresponding PRs. Otherwise, again, she has to write them done and ping you every time.
00:41:32 <jborean93> yea, it would be a try it out and see how it goes
00:41:58 <Kylie_> BTW, I noticed mattclay deleted some "bot_broken" comment. What is his role?
00:43:25 <jborean93> He works on the testing side of Ansible
00:44:13 <Kylie_> Does he also take care of bot?
00:44:13 <mattclay> Kylie_: Did you have questions about the bot_broken comments?
00:45:30 <Kylie_> Hi Matt
00:45:40 <zikalino> i actually have one question
00:45:41 * mattclay waves
00:46:03 <Kylie_> https://github.com/ansible/ansible/pull/36109
00:46:04 <zikalino> when test on particular module is classified as unstable and disabled?
00:46:11 <zikalino> is there any automatic rule?
00:47:09 <Kylie_> @mattclay, for example https://github.com/ansible/ansible/pull/36109. It is support:community, then maintainers should have right to approve it as we understand. But not trigger any action of bot. So Yuwei added bot_broken in comment.
00:48:22 <Kylie_> I noticed you removed that comment. What is the process?
00:49:16 <Kylie_> Matt, are you still here?
00:49:37 <mattclay> I periodically look for PRs which are labeled bot_broken to see if the label can be removed.
00:50:12 <mattclay> The most common case I see is when someone wants a PR to be merged and they think the bot isn't processing their shipit comments.
00:50:26 <Kylie_> Yes, that is the case.
00:50:29 <Kylie_> I do see Yuwzho in https://github.com/ansible/ansible/blob/devel/.github/BOTMETA.yml but it seems her message “shipit” does not trigger approval for support:community pull requests.
00:50:51 <Kylie_> Then bot's processing on a maintainer's comment should be expected. Right?
00:50:59 <mattclay> Sometimes the bot misses comments, and simply adding additional comments or changing anything on the PR will cause the bot to re-evaluate the PR.
00:51:47 <mattclay> However, if the bot_broken label is applied the bot will completely ignore the PR -- which is basically the opposite of what is desired (having the bot merge the PR).
00:52:20 <jborean93> did not know that fact, that could be why the shipits are missed
00:52:25 <Kylie_> O~~ That is definitely not what we want. We want bot owner check these issues as references.
00:52:26 <mattclay> The label cannot be removed without also removing the comment (or the bot will re-apply it).
00:52:55 <mattclay> The best course of action when it appears the bot is ignoring a PR is to first comment on the PR (bot_status is good for this).
00:53:35 <mattclay> When the bot responds you'll know it has looked at the PR and will be able to see what the bot is waiting for.
00:54:09 <mattclay> If at that time it looks like the bot isn't operating as intended, I recommend reaching out on #ansible-devel to see if someone can look to see why the bot may be misbehaving.
00:54:51 <mattclay> You can also reach out on #ansible-devel if after putting in a bot_status comment you don't see a response from the bot. Depending on how busy things are, it could be an hour or more before the bot is able to respond.
00:55:10 <Kylie_> Understand. For this case,
00:55:16 <Kylie_> https://www.irccloud.com/pastebin/UokO7CAc/
00:55:38 <mattclay> AFAIK I'm the only person who regularly checks for bot_broken. It is mainly intended to stop the bot from working on a PR when it is exhibiting bad behavior, such as repeatedly commenting on a PR when it should not be.
00:55:56 <Kylie_> yuwzho and zikalino are listed as maintainers. They commented "shipit". But the status is still "waiting_on: maintainer".
00:57:14 <Kylie_> Good learning. Thank you Matt. We are bothered by bot responses for weeks. Will reach #ansible-devel to raise them.
00:57:50 <Kylie_> Thank you all for today meeting. If no other open, I will end the meeting.
00:57:56 <mattclay> In this case it looks like the shipit comments were added after the latest commit.
00:57:58 <jborean93> thanks Matt for the info
00:58:14 <mattclay> The bot requires that the shipit comments be applied after the latest commit, even if they were previously given for earlier commits.
00:58:42 <mattclay> zikalino: Did you have another question? You said: when test on particular module is classified as unstable and disabled?
00:59:37 <Kylie_> You mean Yuwei commented "shipit" 8 days ago but added the comment for PR link 3 days ago. Right? Yuwei, please have a try - reply your "ship it" and check "bot status".
01:00:26 <mattclay> Kylie_: I see the shipit comments from 8 days ago and 2 days ago, but the latest CI run was from 1 day ago.
01:01:17 <mattclay> Since the latest passing CI run was 1 day ago that implies that the latest commit is either newer than the shipit comments, or previous CI runs failed and it had to be restarted, which would have occurred after the shipit comments were made.
01:04:38 <Kylie_> As for CI, you mean the CI against referred PR?
01:05:21 <mattclay> Yes, Shippable, our CI system. It will run when the PR is opened and when new commits are pushed.
01:05:45 <mattclay> I looked at the latest Shippable run for the PR you linked to see if it was before or after the shipit comments.
01:07:54 <Kylie_> Got it. @Yuwei, let us see the status of these PRs and try them out again today. Thank you Matt.
01:08:31 <Kylie_> @zikalino, are you still online for your question?
01:09:13 <Kylie_> Ok, then Zim, you may contact Matt offline for your question. Sorry for missing it before.
01:09:16 <Kylie_> #endmeeting