00:03:15 <nitzmahone> #startmeeting Ansible Azure Working Group
00:03:15 <zodbot> Meeting started Thu Apr 26 00:03:15 2018 UTC.  The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:03:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:03:15 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:03:32 <nitzmahone> #chair Kylie_ jborean93 mattclay
00:03:32 <zodbot> Current chairs: Kylie_ jborean93 mattclay nitzmahone
00:04:22 <nitzmahone> Sounds like the Github access issues have been resolved...
00:04:25 <Kylie_> Nice. Thank you.
00:04:45 <Kylie_> Nod. Catherine and Zim verified it. Thank you Matt.
00:05:08 <nitzmahone> While we were in Redmond last week, I told Yuwei I'd figure out what's up with https://github.com/ansible/ansible/pull/35823
00:05:56 <nitzmahone> Turns out it was just some more changes were needed- the sanity failures were actually legit. Hoping to finish that this week and get it merged
00:06:11 <nitzmahone> But will probably wait to bring back into 2.5 for 2.5.3
00:06:42 <Kylie_> Ok. Yuwei just joined.
00:06:57 <yuwei> sorry for the late
00:07:10 <Kylie_> @Yuwei, Matt just talked about https://github.com/ansible/ansible/pull/35823
00:07:12 <yuwei> poor network
00:07:34 <yuwei> yes
00:07:38 <Kylie_> Understand.
00:07:43 <Kylie_> https://www.irccloud.com/pastebin/RWea6X9K/
00:08:08 <nitzmahone> I think the only other thing we wanted to discuss was the number of disabled tests due to instability (mostly seem to be related to module issues). Matt C has a list of those going at https://github.com/ansible/ansible/projects/22
00:09:30 <nitzmahone> Most of the instability seen by tests will also be seen by end users
00:10:28 <Kylie_> Got the list. Zim is working on it but he is not here today. Let me discuss the list with him today and send out the update in GitHub.
00:10:46 <nitzmahone> Seems like several of the modules need to do some other kind of sanity check on the resource to see if it's ready to use before returning. There also appear to be common issues around deletion, but I suspect those issues are usually related (eg, the resource isn't fully created yet and is thus not in a state to be delete-able)
00:11:02 <nitzmahone> OK cool
00:11:07 <nitzmahone> That's all from our saide
00:11:08 <nitzmahone> side
00:11:44 <nitzmahone> I assume everyone made it back to Shanghai in one piece? ;)
00:12:40 <Kylie_> They did and delivered an internal sharing yesterday.
00:13:16 <Kylie_> I have one PR https://github.com/ansible/ansible/pull/38643 which resolved the issue - create VM without NSG which requested by customers.
00:13:39 <Kylie_> @Yuwei, Is it ready_for_review?
00:14:25 <yuwei> yes
00:14:49 <yuwei> i should have added the comment
00:14:55 <nitzmahone> OK, I'll take a look
00:15:25 <Kylie_> Thank you. And Yuwei, any other PR pending on review? I know ADFS one is under discussion.
00:16:32 <yuwei> https://github.com/ansible/ansible/pull/38077#issuecomment-384472754
00:16:49 <yuwei> the load balancer sku
00:18:10 <nitzmahone> OK, added myself as reviewer there too
00:18:24 <Kylie_> #action nitzmahone, review  https://github.com/ansible/ansible/pull/38643  and https://github.com/ansible/ansible/pull/38077#issuecomment-384472754.
00:18:28 <Kylie_> Thank you.
00:19:08 <nitzmahone> OK- anything else for today?
00:19:40 <Kylie_> I think that's all for today.
00:19:42 <Kylie_> And as I heard from Zim/Yuwei/Catherine, you guys had a very good day in Redmond. Look forward to next F2F meeting, including Matt C and Jordan. Thank you.
00:19:57 <nitzmahone> Sounds good- thanks all!
00:20:00 <Kylie_> #endmeeting