00:03:55 <Kylie_> #startmeeting Ansible_azure_working_group
00:03:55 <zodbot> Meeting started Thu May 10 00:03:55 2018 UTC.
00:03:55 <zodbot> This meeting is logged and archived in a public location.
00:03:55 <zodbot> The chair is Kylie_. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:03:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:03:55 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:04:03 <Kylie_> #topic plan for 2.6
00:04:18 <Kylie_> Jordan, we have below plan for 2.6.
00:04:54 <Kylie_> New modules:
00:04:54 <Kylie_> -	Azure VM facts (committed by external contributor)
00:04:54 <Kylie_> -	Rest API
00:04:54 <Kylie_> -	Application Gateway
00:04:54 <Kylie_> -	AKS
00:04:54 <Kylie_> -	App Service
00:04:54 <Kylie_> -	Azure storage facts (committed by external contributor https://github.com/ansible/ansible/pull/37333)
00:05:10 <Kylie_> #chair jborean93
00:05:10 <zodbot> Current chairs: Kylie_ jborean93
00:05:21 <zikalino> Azure VM and VMSS facts
00:06:01 <zikalino> can we start with this? then?
00:06:06 <Kylie_> Bug fixes:
00:06:06 <Kylie_> -	VMSS stability
00:06:06 <Kylie_> -	ADAL
00:06:06 <Kylie_> -	UA for inventory
00:06:06 <Kylie_> -	MSI
00:06:06 <Kylie_> -	SDK version
00:06:06 <Kylie_> -	Bug fixes for networking/LB
00:06:07 <Kylie_> -	Bug fixes for inventory
00:06:07 <Kylie_> -	https://github.com/ansible/ansible/projects/22
00:06:15 <Kylie_> Yes. Zim. Please.
00:06:34 <Kylie_> I will leave time to Zim, Yuwei and Catherine to discuss opens for items in 2.6 plan.
00:06:40 <zikalino> yes, so already discussed with jborean93
00:07:19 <zikalino> i made changes to format option of vmss facts. currently format can have two values "raw"  and "curated"
00:07:23 <jborean93> I haven't seen the facts one in depth but I know the VM one is being held up because there are no tests and we want the curated return values first
00:08:00 <jborean93> zikalino: vmss facts is an existing module right?
00:08:23 <zikalino> yes, i asked Gustavo if i could help, but he said he wants to do it himself
00:08:29 <zikalino> yes, it's an existing module
00:09:02 <zikalino> i just added "curated" and test for curated, so if you could review it as soon as possible, it would be great
00:09:24 <jborean93> ok, can you send through a link, I'll do that once I'm finished with what I'm working on now
00:09:35 <zikalino> i still have a few minor issues there to fix.... but i hope it will be ready to merge tomorrow morning
00:09:36 <jborean93> if it is an existing we can't change the default but that's ok for now
00:09:44 <jborean93> for the vm facts we want to make sure we have the default as curated
00:10:30 <zikalino> https://github.com/ansible/ansible/pull/39722
00:10:52 <jborean93> thanks
00:10:59 <zikalino> i will tell gustavo that we want to release early next week and ask him if he can finish by the end of the week
00:11:17 <yungezz> so next rest api?
00:11:54 <zikalino> yes, here: https://github.com/ansible/ansible/pull/39274
00:12:16 <zikalino> i added idempotence option already and tests for indepotence
00:12:41 <zikalino> and it would be good if nitzmahone_ could find some time to review....
00:12:59 <jborean93> yea I know he wanted to have a look through that
00:13:12 <zikalino> oh... but back to vmss facts... could we agree on the format option names?
00:13:30 <yungezz> isn't it curated vs raw?
00:13:32 <jborean93> I'm happy with raw/curated
00:13:40 <zikalino> i think we all here (on msft side)agreed on raw/curated
00:14:13 <jborean93> raw being the raw API results and curated being the more user friendly results
00:14:41 <Kylie_> #action Jborean93 review https://github.com/ansible/ansible/pull/39722
00:14:46 <zikalino> more specifically -> curated will fit main module input
00:15:02 <jborean93> I thought that was going to be a third input?
00:15:10 <jborean93> Honestly I don't know how that is going to really work though
00:15:24 <jborean93> because you can't do `azure_rm_virtualmachine: '{{variable_dict}}'`
00:15:43 <zikalino> it works for vmss
00:15:46 <jborean93> you could hack around with yaml anchors but that defeats the point
00:16:08 <jborean93> really? I thought we explicitly don't allow that for security reasons
00:16:26 <Kylie_> #action @nitzmahone review https://github.com/ansible/ansible/pull/39274
00:17:35 <zikalino> ok, let's just stay with raw/curated for now :-)  i think it works well for vmss. i will prepare a document about facts
00:17:57 <zikalino> and discuss more when nitzmahone_ is available
00:17:57 <yungezz> agree
00:17:59 <jborean93> e.g. this does work but is set to be removed in a future version https://www.irccloud.com/pastebin/HcyoHQ2p/
00:18:12 <zikalino> i am happy with current agreement
00:19:35 <yungezz> next is application gateway, aks and appservice , those are new modules
00:19:49 <yungezz> i'll send out app service pr today
00:19:50 <yuwei> aks https://github.com/ansible/ansible/issues/36677
00:20:05 <yuwei> contributed by other people
00:20:54 <yuwei> sorry wrong link
00:20:55 <Kylie_> Application gateway, Zim, do you have PR?
00:20:59 <zikalino> app gateway will be ready by the end of tomorrow / end of weekend depending on my time
00:21:18 <zikalino> i can create pr even today, but it will be WIP
00:21:20 <jborean93> yuwei: is there a PR for that ask issue?
00:21:28 <jborean93> s/ask/aks/
00:22:13 <yungezz> i think there's some customer asking for aks, @Kylie_ ?
00:22:53 <yuwei> https://github.com/ansible/ansible/pull/35888
00:23:05 <yuwei> jborean93
00:23:15 <jborean93> ok thanks
00:23:28 <yuwei> this is held up for a long time
00:23:56 <Kylie_> Yes for AKS module.
00:24:10 <Kylie_> And BUILD will announce more news about AKS.
00:25:24 <Kylie_> #action @jborean93, review https://github.com/ansible/ansible/pull/35888. Very important.
00:25:45 <jborean93> I'll do vmss facts and that one today
00:26:19 <Kylie_> Another one - https://github.com/ansible/ansible/pull/37333. It seems you assigned it to yourself. Please also help take a look. It could be after AKS. Thank you.
00:27:47 <Kylie_> As for bug fixes, Yuwei, you have urgent ones for UA and MSI. Right?
00:27:57 <yuwei> yes
00:28:05 <jborean93> are they simple PRs?
00:28:20 <yuwei> https://github.com/ansible/ansible/pull/39785
00:28:36 <jborean93> I know that's subjective but if they are smaller fixes and have been reviewed by more than 1 person you should be able to merge yourself
00:28:48 <yuwei> same with azure rm common
00:28:55 <yungezz> adfs fixing is ready also, https://github.com/ansible/ansible/pull/37909, we talked this last week, matt was aware of the fixing
00:29:03 <yuwei> for inventory
00:31:02 <zikalino> ok, then i think i can take care of these and merge. is it ok?
00:31:20 <Kylie_> Yes. Catherine and Zim could review azure_rm_common related fix if it is simple and we have much confidence in it.
00:31:30 <yungezz> ok
00:31:41 <zikalino> i added it to my list now
00:32:21 <jborean93> as long as multiple people merge simple bugfixes are fine
00:32:53 <Kylie_> As for https://github.com/ansible/ansible/pull/39785, it is for inventory to add UA and MSI. @yungezz and @zikalino could you please see whether you could take care of it. I see changes are for one file azure_rm.py.
00:33:45 <zikalino> ok
00:34:05 <jborean93> how are you going with the test stability fixes
00:34:23 <Kylie_> Jordan,  https://github.com/ansible/ansible/pull/37909 still need your review. Catherine address Matt's comments.
00:35:05 <zikalino> not as well as i would like to.... most of the problems are some random internal issues on azure side
00:36:28 <jborean93> I believe Matt is doing the ADFS stuff, he understands that a lot more than I do
00:36:43 <jborean93> zikalino: so what's the proposed solution going forward?
00:38:52 <zikalino> i will put more effort into this at some point next week when all the planned modules are merged. i think i should be able to reenable some tests already next week.
00:40:00 <zikalino> about some issues i am trying to chase appropriate teams internally (responsible for particular service)
00:40:57 <jborean93> ok sounds good
00:42:19 <yuwei> aha I have a backport of
00:42:25 <yuwei> a bugfix
00:42:40 <yuwei> https://github.com/ansible/ansible/pull/39266
00:43:37 <jborean93> yuwei: can you add the changelog fragments in the backport PR
00:43:53 <yuwei> ok i ll add it
00:44:04 <jborean93> do you know the format?
00:44:11 <jborean93> once that's in, I'll merge it
00:44:54 <yuwei> I can find it in other pr
00:45:09 <jborean93> ok, let me know if you need help
00:45:39 <yuwei> or it is better you send me a link
00:45:45 <yuwei> thx
00:45:50 <jborean93> here is one https://github.com/ansible/ansible/blob/stable-2.5/changelogs/fragments/39818-loop_control_task_vars.yaml
00:46:02 <jborean93> basically create a file in `changelogs/fragments`/<something>.yaml`
00:46:38 <jborean93> https://www.irccloud.com/pastebin/It5yGzPM/
00:46:50 <yuwei> thx
00:46:53 <jborean93> you can have multiple entries if there ar emultiple fixes
00:47:25 <Kylie_> Nice. Any other open
00:47:26 <yuwei> And i have 2 feature request
00:47:26 <Kylie_> ?
00:47:32 <Kylie_> Go ahead.
00:47:40 <yuwei> https://github.com/ansible/ansible/pull/37627
00:48:19 <yuwei> This is addressed the agreement we arrived last week
00:48:32 <yuwei> Refer resources in other e.g.
00:48:34 <yuwei> Rg
00:49:01 <yuwei> https://github.com/ansible/ansible/pull/38643
00:49:24 <yuwei> This is support loadblancer in mic
00:49:24 <yuwei> Nic
00:50:03 <jborean93> just briefly looking at it, it would be nice to see an example of the dict format to show users how to do it
00:51:22 <Kylie_> Those are new features because they added parameters for existing modules. Right?
00:51:30 <jborean93> yep
00:51:39 <yuwei> Okay I will move some test to example
00:51:52 <jborean93> it would be up to Matt whether it could be considered a bugfix but usually they are considered features
00:52:21 <jborean93> but because the whole option name was changed (with an alias) I would be surprised if it could be backported
00:53:56 <Kylie_> Since 2.6 is upcoming, no worry for backported. But would like to see what Catherine and Zim could approve.
00:54:03 <Kylie_> New modules, definitely need your approval.
00:54:29 <yuwei> Change the name and add alias is suggested by Matt
00:54:42 <jborean93> yep, I agree with the what was done :)
00:54:51 <Kylie_> Small bug fixes, Catherine and Zim could review and approve if ok.
00:55:45 <Kylie_> Bug fixes involving in new parameter, how to handle those PRs in future?
00:55:47 <Kylie_> Any one which got comment from Jordan/Matt or any other core committer, still need to get their approval.
00:55:56 <jborean93> yep small bug fixes are fine with me
00:56:16 <jborean93> honestly it depends on how large the change, new modules we definitely want to look at it
00:56:24 <jborean93> bug fixes should be fine with you to review/merge
00:57:09 <jborean93> I'll probably err and get a review from us on features that add new parameters
00:58:00 <jborean93> we can always revert the changes if something bad get's through, just not after a release so might be better to get a review the closer we get to a freeze/release or backporting
00:58:47 <Kylie_> Understand. Let us move forward with current process and discuss it if needed in the future. - new module, need approval from Jordan/Matt; fixes adding new parameters, need approval from Jordan/Matt; small bug fixes - Catherine/Zim could make the call.
00:59:00 <jborean93> sounds good to me :)
00:59:22 <Kylie_> #action @Yuwei, update #37627, #38643 and #39266 ASAP and ask for review to move forward.
00:59:47 <yuwei> Yes
01:00:04 <Kylie_> Any other open? Yuwei, Zim and Catherine
01:00:36 <yuwei> No
01:01:02 <jborean93> for me I'm about to start reviewing 39722, 35888, 37333
01:01:04 <yuwei> Zim's network stop working
01:01:18 <jborean93> 39266 is waiting for the fragment but that's pretty simple
01:03:37 <Kylie_> Yes. Thank you. And we will ping you when the contributor updated https://github.com/ansible/ansible/pull/38279 for VM facts.
01:03:46 <jborean93> sounds good
01:03:48 <Kylie_> Then that's all. Thank you Jordan.
01:03:59 <jborean93> have a good day all
01:04:08 <Kylie_> You too.
01:04:10 <Kylie_> #endmeeting