23:59:30 <nitzmahone> #startmeeting Ansible Azure Working Group
23:59:30 <zodbot> Meeting started Wed Jun  6 23:59:30 2018 UTC.
23:59:30 <zodbot> This meeting is logged and archived in a public location.
23:59:30 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:59:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:59:30 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:00:00 <nitzmahone> #chair zikalino jborean93 yungezz yuwei
00:00:00 <zodbot> Current chairs: jborean93 nitzmahone yungezz yuwei zikalino
00:00:08 <nitzmahone> Hey all
00:00:13 <yungezz> hello!
00:00:14 <jborean93> hey
00:00:18 <yuwei> hi
00:01:05 <yungezz> hello Matt and Jordan, hello Yuwei, we can start from PR
00:01:07 <nitzmahone> I don't have a lot for today- if you didn't notice, I hard-pinned all the azure-mgmt deps in devel and 2.6
00:01:17 <nitzmahone> @yungezz sounds good
00:01:43 <zikalino82> i just have some integration testing issues
00:01:49 <yungezz> firstly, azure webapp module, https://github.com/ansible/ansible/pull/40005, last week meeting, Jordan comments to combine frameoworks argument one
00:01:50 <zikalino82> firstly https://github.com/ansible/ansible/pull/41053
00:02:04 <yungezz> I updated it
00:02:29 <yungezz> and the seprate app service plan module is ready also https://github.com/ansible/ansible/pull/40906
00:03:45 <nitzmahone> OK cool, will take a look
00:03:58 <nitzmahone> #action nitzmahone to review 40005/40906
00:04:13 <nitzmahone> Already at a glance the module UI looks *much* improved :)
00:05:07 <yungezz> thanks Matt. pls add comments in the pr, so i could update it. so 2.7 release date still not determined yet, right?
00:05:58 <yungezz> I have another one, to add azure service principal object id lookup plugin https://github.com/ansible/ansible/pull/40932
00:05:58 <nitzmahone> Probably late September
00:06:12 <yungezz> which original was added for key vault scenario
00:06:19 <yungezz> got it, thanks for the info
00:06:38 <nitzmahone> So freeze would probably be late August, but we're still hashing out the dates
00:07:42 <nitzmahone> Also a few feature things that *might* make things like the keyvault lookup simpler ("cloud as connection plugin") - so you could define a cloud config in inventory and it would be implicit (instead of having to pass lots of auth junk to lookup plugins/modules)
00:07:52 <yungezz> ok, we want to release webapp, appgateway and maybe some other new modules like sql managed instance in 2.7
00:08:10 <nitzmahone> Yep, that seems like a good plan
00:08:10 <yungezz> good idea, can i do it in seperate pr?
00:08:52 <zikalino82> well, sql managed instance will be probably still in limited preview in september...
00:09:11 <nitzmahone> Yeah- we can either review/merge as you have it now, then revisit (hopefully before 2.7 freeze) if those things make it in, otherwise we can deprecate or add cloud inventory features later once done
00:10:00 <jborean93> interesting the cloud plugin sounds cool
00:10:01 <nitzmahone> I'm happy to have the plugin anyway- nice to have a use case that I can test out the cloud-from-inventory changes against.
00:10:13 <nitzmahone> We've needed it for a long time
00:10:56 <yungezz> ok. I can do it after lookup plugin merged -> keyvault test passed, then keyvault bug merged -> cloud-from-inventory
00:11:29 <nitzmahone> @zikalino82 Now that we're hard-pinning all dependencies, I'm *less* worried about shipping things that have pre-release dependencies
00:11:32 <yungezz> currntly keyvalut keys/secrets has bugs cannot work at all. bug fxing pending test pass
00:11:43 <nitzmahone> 👍
00:12:19 <nitzmahone> @zikalino82 (since we know the deps won't change from under us within a release, so long as they don't kill the pre-release API versions too soon)
00:12:27 <nitzmahone> I had a nice chat with Azure Stack folks
00:12:54 <yungezz> oh, @nitzmahone, is there any plan on Azure Stack?
00:12:57 <nitzmahone> Apparently there's already a couple of public-ish Azure Stack instances that are being used by Red Hat for testing stuff, so they're going to try and get us access to that
00:13:15 <nitzmahone> I have it tentatively on the 2.7 roadmap
00:13:22 <yungezz> cool! because we have some custtomer using ansible with Azure Stack also
00:13:31 <nitzmahone> But will depend on us having permanent access to Azure Stack instances to test on from CI
00:13:46 <nitzmahone> Yeah, I really want to make sure we can work with it too, so long as we can test it
00:14:43 <nitzmahone> I'll let you know once the CI access is worked out- from that point I can run the test suite against it, see what's broken, and we can prioritize/design how it should work here
00:15:00 <yungezz> great!
00:15:20 <nitzmahone> They said it should be pretty soon- we last talked on Friday last week
00:16:05 <nitzmahone> #topic https://github.com/ansible/ansible/pull/41053
00:16:47 <zikalino82> ok, this one is pretty simple, just upgraded everything to the latest version (regarding mysql and postgersql)
00:16:58 <nitzmahone> @zikalino82 wondering if the pinned older versions of some of the intermediate deps may cause us problems
00:16:58 <zikalino82> i have another one (still wip)
00:17:54 <nitzmahone> If we're going to bump other deps to get tests working on 2.6, we need to do it soon; I got the current set in just in time for 2.6.0RC1
00:18:09 <zikalino82> well, maybe i shoudl retest manually to make sure
00:18:13 <nitzmahone> We don't want them to change after 2.6.0 final unless *absolutely* necessary
00:18:33 <nitzmahone> There's a merge conflict right now on #41053 (from the pinning I did)
00:18:42 <zikalino82> oh, ok, i will check this
00:19:18 <zikalino82> so i have another one, trying to handle limit of public ips (currently 60)
00:19:21 <zikalino82> https://github.com/ansible/ansible/pull/41184
00:20:03 <nitzmahone> I "sort of" fixed one of the problems with the new azure-mgmt-common stuff (it doesn't allow profile and api_version together), but we'll have to fix it "right" in 2.7 to support Azure Stack/profiles now that they're in the SDK
00:20:16 <zikalino82> i will still improve / add a few things in that pr, but i wonder if this is right direction. in that pr i am basically using unique names for public ips and deleting them
00:20:36 <zikalino82> oh, i have pr for this issue too :-)
00:21:53 <nitzmahone> That should definitely help- I think some tests were leaving IPs laying around. They of course get cleaned up when the RG gets destroyed, but multiple test runs in close proximity can easily hit the limit
00:22:11 <nitzmahone> (because the RG is destroyed lazily)
00:22:44 <nitzmahone> Another things that might help is to use `block:`/`rescue:` (basically Ansible try/catch) to try and clean up the IPs on a failure as well
00:23:08 <zikalino82> yeah, i just wonder how many tests can run at once?
00:24:13 <nitzmahone> Effectively maybe 2-3 PRs worth, but the problem comes if a bunch of them run in a row- the RG isn't deleted for 30m (or more, can't remember), so if the test "leaks" them, the IPs will hang around for awhile even though they're no longer being used
00:24:30 <zikalino82> ok, so that should help
00:24:48 <zikalino82> i am just trying to clean up all the fixed names of resources...
00:25:00 <nitzmahone> Yep, and adding block/rescue will help in case the test blows up (so the cleanup will still try to run)
00:25:04 <zikalino82> possibly some other unexpected failures will disappear
00:25:10 <nitzmahone> noice
00:25:32 <nitzmahone> Did you see the one I filed about the resource module? Maybe a cheaper/simpler resource than storage account would be good to test
00:25:57 <nitzmahone> (either that or we have to figure out what to poll to know it's safe to mutate the storage account)
00:25:57 <zikalino82> yes, i saw it. i will replace the test today with something simpler
00:26:21 <zikalino82> i just used storage account, as i assumed it was simple enough for test....
00:26:51 <nitzmahone> #action nitzmahone to review #41184/41053 (test stability fixes) once zikalino fixes merge conflict
00:27:10 <yuwei> https://github.com/ansible/ansible/pull/41073 I have cherry picked some commit from devel branch to 2.6
00:29:49 <zikalino82> yes, i think we can't merge this one, it requires special permissions
00:30:32 <yuwei> we are not able to merge this
00:31:24 <jborean93> during the rc/release period the stable branches get locked, the RM can merge them in
00:31:44 <nitzmahone> Can you add the devel PRs and/or issue #s that were fixed? Usually we do `git cherry-pick -x (sha)` to include the original devel SHA (so we know the fix has actually landed in devel)
00:32:38 <yuwei> ok I'll do that
00:32:45 <nitzmahone> (just edit the original PR text to include the original PR/issue #s)
00:32:59 <nitzmahone> Ideally you'd also include a changelog fragment
00:34:11 <yuwei> yes
00:34:36 <nitzmahone> But only for user-visible changes (you can include all the bugfixes in one changelog fragment with multiple values for `bugfixes:`)
00:35:19 <nitzmahone> eg we don't care about the metadata tweaks and stuff, but if it's fixing a bug a user might have hit in 2.6.0rc1, it'd be good if the 2.6.0rc2 changelog told them what was fixed
00:36:25 <nitzmahone> If you can get those things done within the next couple days, we should have no trouble getting those fixed merged for rc2
00:36:30 <nitzmahone> *fixes
00:36:45 <yuwei> so i cannot merge the fix unstable test pr?
00:37:22 <nitzmahone> for 2.6 only the release manager can merge backport fixes right now (Matt Clay)
00:37:36 <yuwei> okay thank you
00:38:01 <nitzmahone> He's regularly looking for things targeting the stable-2.6 branch though, so as soon as you get those things in there, he'll usually merge it pretty quick
00:38:14 <nitzmahone> Just to be clear though: all the relevant fixes *are* already in devel, right?
00:38:40 <nitzmahone> (that's why we like the `cherry-pick -x` from devel so we know the relevant devel SHAs
00:39:15 <nitzmahone> Because I see a lot of local commits to that PR- just want to make sure we don't end up with regressions from things that were fixed only in 2.6 and not devel
00:39:49 <yuwei> i see
00:40:15 <nitzmahone> Anything else for today?
00:40:21 <zikalino82> just one more thing
00:40:48 <zikalino82> nitzmahone do you know if the registration for ansiblefest is already open? (i mean for speeches)
00:40:59 <nitzmahone> Yes- the CFP opened last week
00:41:14 <nitzmahone> https://www.ansible.com/ansiblefest#speakers
00:42:19 <zikalino82> ok, cool! so still time till the end of june, thanks! :-)
00:42:24 <nitzmahone> Yep.
00:42:35 * nitzmahone has to run- until next week!
00:42:52 <nitzmahone> #endmeeting