00:00:29 <nitzmahone> #startmeeting Ansible Azure Working Group
00:00:29 <zodbot> Meeting started Thu Oct 11 00:00:29 2018 UTC.
00:00:29 <zodbot> This meeting is logged and archived in a public location.
00:00:29 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:29 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:00:37 <nitzmahone> Good $time_in_your_region!
00:00:47 <yungezz> :)
00:00:50 <yuwei> hh
00:00:57 <yuwei> hello
00:01:16 <Kylie_> Hi all
00:01:24 <nitzmahone> #chair yungezz yuwei Kylie_ zikalino82
00:01:24 <zodbot> Current chairs: Kylie_ nitzmahone yungezz yuwei zikalino82
00:01:26 <Kylie_> Who is online?
00:01:30 <nitzmahone> --^
00:01:36 <jborean93> hey
00:01:42 <zikalino82> hello :-)
00:01:44 <Kylie_> Great.
00:01:44 <nitzmahone> #chair jborean93
00:01:44 <zodbot> Current chairs: Kylie_ jborean93 nitzmahone yungezz yuwei zikalino82
00:02:03 <zodbot> Kylie_: Error: Can't start another meeting, one is in progress.
00:02:05 <nitzmahone> Seems like everybody made it back home?
00:02:12 * nitzmahone already started the meeting
00:02:15 <yungezz> Yes
00:02:39 <zikalino82> X)
00:02:42 <Kylie_> Yes:) It was a great experience to attend my first AnsibleFest.
00:02:45 <zikalino82> still dizzy
00:03:28 <nitzmahone> Was great to see yungezz and zikalino again, and great to meet Kylie in person!
00:03:29 <Kylie_> We did a survey during the event.
00:03:29 <yungezz> Kylie_: do you have agenda? I have one question
00:03:42 <Kylie_> From the survey, many people are using both Jenkins + Ansible.
00:04:08 <zikalino82> btw, did we have question about windows?
00:04:10 <Kylie_> We also would like to learn more about the app deployment functionality of Ansible.
00:04:34 <Kylie_> No, we don't have question about Windows in the survey. From Booth, we got questions about winRM.
00:04:51 <Kylie_> Catherine, you go ahead for your topic.
00:05:25 <yungezz> I would like to learn ansible deployments function also :)
00:05:55 <nitzmahone> Best way to learn is by doing ;) Find a stack you want to deploy and start automating it
00:06:13 <yungezz> I tried ftp to web app
00:06:37 <yungezz> It’s not so straightforward
00:07:07 <nitzmahone> As in pushing code via FTP with Ansible?
00:07:27 <yungezz> War file to azure web app
00:08:10 <nitzmahone> FTP is a very difficult protocol to do things over idempotently
00:09:05 <jborean93> also quite insecure
00:10:08 <yungezz> What’s most frequently used deployment method in ansible
00:10:08 <yungezz> Yes
00:10:09 <yungezz> I just want to give it a try to see if I can do e2e webapp flow by ansible
00:10:55 <jborean93> not sure on the most frequence but previously I stored my app artifacts in a repository and downloaded it using get_url/win_get_url
00:11:06 <jborean93> but it depended on the app and if there were other things aorund it
00:11:13 <nitzmahone> Depends on the target environment; usually people try to do via git checkout/push or http download if you're directly automating the target environment
00:11:51 <nitzmahone> Azure Web App is kind of a special case since IIRC you can't directly manipulate the hosting env (but I don't remember what all the deployment options are for that, either)
00:11:52 <yungezz> Ok, That makes more sense
00:13:52 <nitzmahone> What else for today?
00:14:07 <yungezz> I have question on inventory
00:14:12 <nitzmahone> sure
00:14:54 <yungezz> We have old and new inventory now, when adding new feature such as availablility set, will support both
00:15:16 <yungezz> And there’s some bug need fixing in old
00:15:17 <jborean93> yes that reminds me, what to do with the old feature/issue PRs for the old inventory script
00:15:28 <yungezz> Yes
00:16:02 <yungezz> We need long term plan on how to obsolete old one
00:16:54 <nitzmahone> The old script always been a "contrib" level thing, so I'd definitely suggest stopping adding new features, and probably only fixing bugs that are critical and easy to test
00:17:40 <yungezz> How about users who used old already?
00:18:07 <jborean93> they can keep their forked version if they want
00:18:08 <nitzmahone> The way they're using it, they have to copy it anyway
00:18:16 <jborean93> but we should really be pushing people to the new inventory plugin
00:18:18 <yungezz> We can update doc accordingly
00:18:29 <nitzmahone> We don't need to take it away, but probably put in a warning or pointer to the inventory plugin instead
00:18:42 <nitzmahone> You should be able to do everything plus a lot more with the plugin, and it's WAAAAY faster
00:18:52 <jborean93> it's not like the scripts are updated with Ansible versions so if they want to continue using the old slower script then they can
00:19:15 <nitzmahone> (though the error handling in inventory plugins generally is not great, it's currently difficult to diagnose issues, but it often was with the script too)
00:20:21 <nitzmahone> I still have to finish cleaning up the unit/integration tests for it too, but once they're there, if we need to add new features, we just have to add stub content to the test infra to emulate them
00:21:56 <yungezz> Sorry I dropped off due to bad network
00:22:13 <nitzmahone> What was the last response you saw?
00:22:24 <yungezz> Cleanup tests
00:22:27 <nitzmahone> OK
00:22:40 <nitzmahone> (you didn't miss anything then)
00:22:47 <yungezz> You mean inventory test?
00:22:54 <nitzmahone> yes
00:23:07 <yungezz> Great
00:23:56 <zikalino82> https://github.com/ansible/ansible/pull/45077
00:24:05 <yungezz> There’s test for the new inventory? Since old has no test
00:24:15 <zikalino82> just two prs :-)
00:24:53 <nitzmahone> I have tests for it, but I have to finish generalizing before I commit
00:25:01 <Kylie_> I think the idea of putting in a warning or pointer to the inventory plugin instead is good. Matt or Catherine, how about submit a PR for it?
00:25:18 <yungezz> Got it
00:25:27 <nitzmahone> I don't think we have a standard way of adding a warning to the old script, but maybe just in the text of the header/docs
00:25:28 <yungezz> Ok
00:25:53 <nitzmahone> Could also try writing directly to stderr, but not sure if that gets collected or displayed by the new wrapper system around it
00:26:11 <nitzmahone> (if it doesn't, it probably should)
00:26:54 <yungezz> Will try it, at least update doc to get awareness
00:27:01 <nitzmahone> Zim, was there another PR also? I'll take those and do final review
00:27:11 <nitzmahone> #action nitzmahone to review $45077
00:27:25 <nitzmahone> 45074, right?
00:27:44 <nitzmahone> #action nitzmahone to review 45074
00:28:35 <zikalino82> yes
00:28:39 <zikalino82> both
00:28:47 <nitzmahone> got it
00:29:20 <zikalino82> i guess there's not that much in there, they are pretty small :-)
00:30:41 <nitzmahone> #action yungezz to add "no longer maintained" + pointer to inventory plugin to azure_rm.py script
00:30:51 <nitzmahone> Yeah, those should be quick to finish up
00:31:07 <Kylie_> 👍
00:31:08 <nitzmahone> Anything else for today?
00:31:14 <yungezz> No from me
00:31:15 <jborean93> I'm good
00:31:35 <nitzmahone> Are we generally agreed that we don't want to spend a lot of time on Azure Stack right now?
00:31:45 <Kylie_> As for app deployment, we documented how to deploy simple application with Ansible to Azure VMSS. But I don't understand what's the benefit of automating app deployment with Ansible comparing with Jenkins.  I heard use cases of deploying windows update with Ansible. Anyway, will learn and try more. BTW, I noticed this one https://docs.ansible.com/ansible/2.3/jboss_module.html
00:31:45 <Kylie_> . Interesting, you could direclty push war file to Jboss.
00:33:01 <Kylie_> As for Azure stack, so far yes as priority 2 unless we receive requests from big customers. The priority is driven by customer request. Make sense?
00:33:10 <yungezz> Kylie_: azure stack
00:33:10 <nitzmahone> Yep, totally
00:33:45 <Kylie_> We are on the same page. Thank you.
00:33:52 <yungezz> Thanks all
00:34:02 <nitzmahone> OK then- til next week!
00:34:13 <Kylie_> No more topic from me. We are defining our plan according to the survey and will communicate with you about the plan in next week meeting. THanks.
00:34:22 <nitzmahone> Sounds good... Until next week!
00:34:26 <nitzmahone> #endmeeting