23:59:21 <nitzmahone> #startmeeting Ansible Azure Working Group
23:59:21 <zodbot> Meeting started Wed Oct 17 23:59:21 2018 UTC.
23:59:21 <zodbot> This meeting is logged and archived in a public location.
23:59:21 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:59:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:59:21 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
23:59:31 <nitzmahone> #chair yungezz Kylie_
23:59:31 <zodbot> Current chairs: Kylie_ nitzmahone yungezz
00:00:17 <yungezz> I don’t have special topic today but some prs
00:00:26 <nitzmahone> Jordan's on a plane, so won't be joining today
00:00:39 <nitzmahone> I have a couple things we should talk about as well
00:00:48 <nitzmahone> #chair zikalino82
00:00:48 <zodbot> Current chairs: Kylie_ nitzmahone yungezz zikalino82
00:00:57 <yungezz> Sure
00:01:15 <Kylie_> Matt, let us start from you topics
00:01:44 <nitzmahone> First is just a reminder to include a changelog fragment on feature/bugfix PRs (so they'll automatically be available on bugfix backports as well)
00:02:16 <yungezz> Yes
00:02:18 <zikalino82> yes, so that's quite new thing right? i noticed related doc appeared around a month ago
00:02:23 <nitzmahone> No need to do it for new modules/plugins as we generate those lists, but anytime a new feature is added to an existing thing or a bugfix is done, it should have a changelog fragment added
00:02:48 <nitzmahone> It's actually been around since 2.5, but we'll probably start cracking down on it more soon
00:03:27 <zikalino82> shouldn't this somehow be taken from pr summary?
00:03:30 <nitzmahone> So just something to keep an eye on as you're reviewing each others' work
00:03:49 <yungezz> Ok
00:03:53 <nitzmahone> Not necessarily; we've tried a few different ways to automatically create them, but they usually cause more problems than they solve
00:04:01 <zikalino82> ok
00:04:40 <nitzmahone> This is just for users to see at a glance what's new/fixed in a given release, so short and bugfixes should usually point to the fix PR
00:04:41 <Kylie_> I remember Catherine raised this before. If we don’t add change log, our fixes cannot be captured by release notes of 2.6.x.
00:04:52 <yungezz> Yes
00:04:55 <nitzmahone> Exactly- they're generated off the changelog fragments
00:05:14 <nitzmahone> (used to be a manual doc, but was problematic for backports and other things)
00:05:25 <nitzmahone> That's all on that...
00:05:37 <nitzmahone> mattclay was also seeing some weird failures in CI
00:06:08 <nitzmahone> It looks like some API results are returning something that's not like we expect- not a CloudError, but doesn't have "id" field, for instance
00:06:36 <nitzmahone> So we see KeyError: 'id' and there's no useful exception detail
00:06:43 <yungezz> Any idea what resource or module?
00:07:01 <nitzmahone> Here's one he sent me: https://app.shippable.com/github/ansible/ansible/runs/88950/77/tests
00:07:28 <nitzmahone> it was webapp and appserviceplan in this case, but I think he said we've seen it elsewhere
00:07:52 <nitzmahone> Not sure if it's a module bug or weird REST API failure case or what
00:08:08 <yungezz> I will look at it
00:08:29 <nitzmahone> So maybe more defensive code needed around things like `response['id']` to handle if it's not there without a KeyError (and hopefully to show us what we got back)
00:08:36 <yungezz> #action yungezz look at test failure
00:09:05 <nitzmahone> Last thing from me was around addition of `requests[security]` to Azure requirements
00:10:59 <nitzmahone> I can't remember if that was required by Azure itself or we needed it for some reason
00:11:30 <nitzmahone> I guess I'll talk that over with Matt offline; it was apparently causing some Tower users grief
00:11:37 <nitzmahone> So that's all from me
00:11:46 <nitzmahone> #chair yuwei
00:11:46 <zodbot> Current chairs: Kylie_ nitzmahone yungezz yuwei zikalino82
00:11:48 <nitzmahone> Howdy
00:12:01 <yuwei> hi
00:12:33 <nitzmahone> yungezz: you had some PRs you wanted us to look over?
00:12:51 <nitzmahone> (I merged Zim's 2 this week)
00:12:54 <yungezz> For the security, you will go back to us later?
00:13:14 <nitzmahone> Yeah, I hadn't looked at the blame beforehand, just came up yesterday
00:13:18 <zikalino82> thanks a lot!
00:13:28 <nitzmahone> I'll bring it back next week once Matt and I have discussed
00:13:39 <yungezz> Ok
00:13:44 <yungezz> https://github.com/ansible/ansible/issues/46796
00:13:46 <zikalino82> i will have a few smaller modules to merge, i will send in a separate e-mail
00:14:00 <zikalino82> still working on them
00:14:02 <nitzmahone> k
00:14:12 <yungezz> https://github.com/ansible/ansible/pull/46939
00:15:31 <nitzmahone> #action nitzmahone to review 46796, 46939
00:15:46 <yungezz> https://github.com/ansible/ansible/pull/47045
00:16:00 <nitzmahone> yungezz: anything controversial to discuss on those now, or should I just review offline?
00:16:26 <yungezz> That’s all from me
00:16:41 <yungezz> They’re simple modules, pls review them offline
00:16:42 <nitzmahone> #action nitzmahone to review 47045
00:16:57 <nitzmahone> will do
00:17:10 <yungezz> Thanks a lot!
00:17:20 <nitzmahone> No worries!
00:17:24 <nitzmahone> Anything else for today
00:17:25 <nitzmahone> ?
00:17:45 <yungezz> Kylie_: do you have anything?
00:17:55 <Kylie_> Zim and Catherine, do you want to discuss VM here?
00:19:17 <yungezz> Yes, vm module is really big now, and we got some feedback, such as async sub resource creation to reduce duration
00:20:02 <Kylie_> We have some initial thought to update existing VM module. In general what’s suggested approach? 1) creat a new one and retire old one; 2) update existing one and retire some old features?
00:20:26 <zikalino82> yeah, here's my list:
00:20:33 <zikalino82> Uploaded file: https://uploads.kiwiirc.com/files/782f41568a8e4355f49462e5f5ff7ec2/pasted.txt
00:20:59 <nitzmahone> Unless the UI is totally unworkable, changing implementation is usually preferrred
00:21:11 <yungezz> For 2) retire features, how about existing users
00:21:18 <nitzmahone> Sometimes it's just so awful that you need to start over, but naming is problematic (for one thing)
00:21:38 <zikalino82> 2) that will go through standard retiring cycle
00:21:48 <nitzmahone> Deprecation warning period + removal after 4 releases is our usual policy
00:21:55 <yungezz> Ok
00:22:07 <Kylie_> Thank you
00:22:18 <zikalino82> and i think we shoudl start with the features that will actually improve current implementation
00:22:29 <zikalino82> for instance proper cleanup, proper idempotency, etc...
00:22:43 <nitzmahone> I don't know if it's made it your way yet, but I came up with a list of things that should be fixed in existing stuff for Azure "certified modules"
00:22:53 <nitzmahone> Yeah, +1 to all that
00:23:17 <nitzmahone> Async subresource creation should be do-able in existing impl as well without much hassle
00:23:25 <yungezz> Yes
00:23:25 <zikalino82> where's that list?
00:24:14 <zikalino82> maybe we should create issues on github....
00:24:23 <nitzmahone> I sent to our cloud PM to make sure partner folks have no objections, so either it'll come back around through Microsoft somewhere, or I can convert to wiki or share here and discuss once our end agrees with what I proposed
00:24:42 <nitzmahone> It's just a starting point
00:25:07 <yungezz> Thanks it will be great to have a wiki to start discussion
00:25:09 <zikalino82> or shoudl we add it to the module guidelines?
00:25:15 <yungezz> Yes
00:25:26 <nitzmahone> This is more of specifics on a bunch of modules
00:25:34 <zikalino82> ah, ok
00:25:49 <yungezz> Adding to coding guidelines after improvement done sounds better
00:25:54 <nitzmahone> So we might want to work backwards from that to update module guidelines, but I think you've already covered a number of the items there (so hopefully new stuff won't have the same issues)
00:26:11 <Kylie_> Who is cloud PM? Dylan?
00:26:16 <nitzmahone> Richard Henshall
00:26:53 <Kylie_> Got. I thought he is engineering manager.
00:27:06 <nitzmahone> They're on the same team, and responsibilities may be shuffled soon...
00:27:17 <nitzmahone> James Tanner is the eng manager
00:28:25 <nitzmahone> Anyway, I'll hopefully have enough internal agreement on that to bring it next week, just wanted to let everyone know it was in the works
00:28:37 <Kylie_> Well received
00:28:48 <yungezz> Ok
00:28:51 <nitzmahone> Anything else for today?
00:28:59 <zikalino82> not from me
00:29:00 <Kylie_> No.
00:29:08 <Kylie_> On time:)
00:29:09 <yungezz> No from me
00:29:10 <nitzmahone> Short meetings are good!
00:29:17 <yungezz> :)
00:29:18 <nitzmahone> Til next week, then- thanks all!
00:29:21 <nitzmahone> #endmeeting