00:02:52 <jborean93> #startmeeting Ansible Azure Working Group
00:02:52 <zodbot> Meeting started Thu Nov  1 00:02:52 2018 UTC.
00:02:52 <zodbot> This meeting is logged and archived in a public location.
00:02:52 <zodbot> The chair is jborean93. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:02:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:02:52 <zodbot> The meeting name has been set to 'ansible_azure_working_group'
00:03:13 <jborean93> #chair yungezz yuwei zikalino82 Kylie_ nitzmahone
00:03:13 <zodbot> Current chairs: Kylie_ jborean93 nitzmahone yungezz yuwei zikalino82
00:03:48 <Kylie_> Any other topic before discussing certified?
00:03:59 <yungezz> No from me
00:04:08 <yungezz> Oh, maybe one
00:05:00 <yungezz> I tried new inventory in plugin, met some error, seems someone else met it also, he also contributed a or
00:05:02 <jborean93> I'm good
00:05:19 <yungezz> Will find that pr out for Matt review
00:05:56 <zikalino82> mattclay are you here today?
00:06:26 <mattclay> zikalino82: I am.
00:06:49 <zikalino82> i need you to add hdinsight :-)  https://github.com/ansible/ansible/pull/47602
00:07:17 <zikalino82> Error Code: MissingSubscriptionRegistration\n\tMessage: The subscription is not registered to use namespace 'Microsoft.HDInsight'
00:08:30 <mattclay> zikalino82: It's registering now. I'll restart the tests once it's registered.
00:08:46 <zikalino82> ok, thank you :-)
00:10:04 <yungezz> Kylie_: I think you can start certified topic
00:10:07 <Kylie_> Is Matt Davis online?
00:10:21 <nitzmahone> yes
00:10:49 <Kylie_> I received a excel from Richard and saw notes like below one.
00:10:55 <Kylie_> add lowercase aliases for choices options for consistency, case insensitive idempotency comparison
00:10:55 <Kylie_> add support for az and prefix?
00:10:55 <Kylie_> add iptag support?
00:11:23 <Kylie_> I guess you mean once those things (documented in the notes) are fixed, those ones can be "certified" ones from technical quality side. Right?
00:12:01 <nitzmahone> Yeah, I was proposing those as things to be fixed for consistency to be certified
00:12:34 <Kylie_> I see. Should we submit issues to follow them up?
00:12:48 <nitzmahone> Sure, or just PRs, either way
00:13:07 <yungezz> What does it mean “add support for az and prefix”, “add iptag support”?
00:13:10 <nitzmahone> Dunno if we want to move that to the wiki or something, or ?
00:13:20 <nitzmahone> Availability Zone and IPTags
00:13:28 <zikalino82> yeah, that's a kind of mysterious
00:13:35 <nitzmahone> (they're features on the underlying REST api not currently supported by that module
00:14:10 <yungezz> Ok, will check
00:14:58 <Kylie_> :) We could go through notes to ensure all on the same page. Before that,  we still don't understand what "certified" means? What additional effort is needed for those ones? Test?
00:15:00 <nitzmahone> Have heard a couple requests for the AZ part
00:15:20 <Kylie_> requests for the list?
00:15:53 <nitzmahone> Those notes about "merging facts and module tests" to ensure that changes/settings made by the main module actually occurred on the resource (vs many tests now just check "changed = true" and call it good)
00:16:09 <nitzmahone> I just mean I've heard a couple of user requests for AZ support
00:16:25 <nitzmahone> (availability zone)
00:16:28 <zikalino82> i think we have merged most of the facts tests already
00:16:40 <zikalino82> i think there may be still some remaining
00:16:44 <nitzmahone> Yeah, just the ones I'd called out in the list
00:16:57 <nitzmahone> A lot of the newer stuff looks much better there
00:17:33 <zikalino82> btw, regarding idempotency, i am just doing new, more generic approach, just to standarize it.
00:17:45 <zikalino82> i will give you a pr later
00:17:47 <yungezz> I have some question with Kylie_ , what does certified mean?
00:17:55 <nitzmahone> The "certified" stuff is mostly business-side around "who answers the support call first", and which modules we/you feel comfortable putting any kind of support SLA on.
00:19:13 <Kylie_> We also received some questions about Ansible from our support team.
00:19:15 <nitzmahone> Practically speaking, the way new stuff is being written with better tests, it shouldn't really change anything going forward.
00:19:27 <nitzmahone> (from the engineering perspective anyway)
00:19:48 <nitzmahone> It's mostly a business-side thing about being able to sell a support offering that covers some of the Azure modules
00:20:46 <nitzmahone> So I chose a minimal set based on stability/longevity and "what a customer would probably expect" for minimal support. But once those others have "soaked" for awhile, probably they can all be added reasonably to the lsit.
00:21:27 <Kylie_> Do you mean if we have a certified module list and ansible customers meet any question against any of that list, Red Hat support team and Microsoft support team should have a process to answer the calls and some level of SLA. Is my understanding right?
00:24:42 <nitzmahone> That's what they're trying to build, yes
00:25:05 <nitzmahone> (completely different team, I don't know a lot of the details other than they asked for "what's a good candidate set of modules we could include")
00:25:58 <Kylie_> From engineering perspective, enhance the tests for ones in the list first. In long-term, need to ensure the quality for each module from code, test case and tests and then add more customers expect into the list.
00:26:12 <yungezz> Ack
00:26:42 <Kylie_> Support team is also a completely different team here.
00:26:58 <nitzmahone> Yep
00:27:19 <nitzmahone> And it's the partnership teams that are driving this whole thing from both sides
00:27:34 <nitzmahone> I've tried to keep the scope as small as possible to start
00:28:41 <Kylie_> Understand from engineering perspective. As for what a customer expect to us, rm_deployment is a top one.
00:29:47 <Kylie_> How about the stability/longevity for rm_deployment?
00:30:17 <nitzmahone> My biggest beef with that one is the return value is a mess
00:30:55 <nitzmahone> It's been awhile since I looked at it, but if we can make the return value more generic, no reason not to include it
00:31:44 <yungezz> Talking about support customer, Can we not add rm_deployment to the list for now? Because it’s sending template , have a feeling that most issues will be template issue or service issue
00:32:10 <yungezz> If there’s failure
00:32:19 <Kylie_> Let me add this action item here because whatever the topic of "certified" module is, we want to enhance this for customers.
00:32:52 <Kylie_> #action, Catherine, see how to make the return value more generic for rm_deployment
00:32:55 <nitzmahone> Yeah, if you think it's an important one, let's add it to the list, but we probably want to look at it very carefully for usability issues and the return value
00:33:55 <zikalino82> deployment has a major flaw which is passing numeric values also....
00:34:04 <nitzmahone> ah yes, I recall that as well
00:34:07 <zikalino82> but that's ansible problem, not module problem
00:34:25 <zikalino82> recently somebody reopened that, seems to be partially fixed.....
00:37:14 <Kylie_> @yungezz, I got a way to look at details under compute, storage and networking. Let us run query to understand more. Then we could discuss with Matt which ones are top ones.
00:37:32 <yungezz> Ok
00:39:14 <Kylie_> Matt, I think it is valuable to understand which ones are top ones and among them which ones are stable ones (as what you did). We do want to improve the quality. I will separate this with "certified" module process which is unclear for me now.
00:40:05 <Kylie_> Zim, Catherine, do you want to discuss those notes today? Or let us review internally and bring what you don't understand to Matt next week. How about that? Thanks.
00:40:19 <yungezz> Next week
00:40:45 <nitzmahone> Sounds good
00:41:11 <nitzmahone> Mostly just wanted to start a discussion on this; it's something we'll all need to agree on together
00:41:47 <nitzmahone> (which ones make the certified list)
00:41:48 <zikalino82> well, yes, next week, i haven't seen them yet
00:42:28 <nitzmahone> Google document sharing is annoying on corporate accounts, so I can't just blanket share to anyone with the link :(
00:43:22 <Kylie_> I got one hard copy from Richard. We will start from there.
00:43:37 <yungezz> zikalino82: you are in the thread Kylie_ started, you ever added some modules there
00:44:03 <zikalino82> yes, but i was too busy to review later
00:44:58 <Kylie_> Thank you Matt and all. Let us start engineering discussion based on usage and quality.
00:45:05 <Kylie_> Any other topic today?
00:45:17 <yungezz> I am ok
00:45:24 <nitzmahone> Nothing here. (been distracted with IBM fun and all)
00:46:02 <Kylie_> Any news you guys could share to us?
00:46:09 <zikalino82> just one module to review :-)
00:46:13 <nitzmahone> We basically don't know anything
00:46:38 <nitzmahone> They're saying "we'll leave you alone", but nobody knows what that looks like yet
00:46:38 <zikalino82> https://github.com/ansible/ansible/pull/47181
00:47:09 <zikalino82> to being left alone is not always a good thing ;-)
00:47:39 <Kylie_> I already got some asks about any change for our close collaboration on Ansible.
00:48:05 <Kylie_> From newsletter, IBM will continue the partnership with Microsoft Azure.
00:48:46 <nitzmahone> #action nitzmahone added 47181 to review queue
00:49:12 <nitzmahone> The deal isn't even closing until well into next year, but even after that, I don't anticipate any changes
00:50:31 <Kylie_> 🤝
00:50:39 <yungezz> Thanks all
00:50:57 <yungezz> Bye
00:51:02 <nitzmahone> Til next week!
00:51:04 <nitzmahone> #endmeeting