22:07:34 <gregdek> #startmeeting ansible news
22:07:34 <zodbot> Meeting started Wed Sep  6 22:07:34 2017 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:07:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
22:07:34 <zodbot> The meeting name has been set to 'ansible_news'
22:07:46 <gregdek> #chair stickster rbergeron
22:07:46 <zodbot> Current chairs: gregdek rbergeron stickster
22:07:49 <gregdek> Order!
22:07:51 <stickster> \o/
22:07:57 <gregdek> I have QUESTIONS!
22:07:59 <stickster> Let us begin.
22:08:02 <gregdek> 1. Who do we get news from?
22:08:08 <gregdek> 2. How do we disseminate it?
22:08:16 <gregdek> 3. How do we not kill everyone in the process?
22:08:24 <gregdek> I yield to stickster of Fedora Magazine et al.
22:08:46 <stickster> News comes from two places IMHO. Internally from the project, and externally from your friends/potential contributors who want to tell the world great things about Ansible.
22:08:57 <stickster> i.e. people who build things, and people who build your brand.
22:09:05 <gregdek> Ooh, I like that
22:09:07 <stickster> (sometimes the same)
22:09:31 <stickster> I have a theory that there are also two kinds of news you want to disseminate
22:09:48 <gregdek> and those are?
22:09:53 <stickster> One is things you want the contributor base (or core contributors) to know
22:09:58 <rbergeron> well, theoretically, they are... :)
22:10:13 <stickster> Another is a less bounded set of things you'd like your users (the public) to know or be aware of
22:10:40 <stickster> So you should know the audience you're trying to reach for any specific kind of news
22:11:01 <stickster> In Fedora we set up the Fedora Magazine (hereinafter f-mag) to reach mainly the second audience.
22:11:28 <stickster> We have many channels for the first kind of news, and most of that stuff isn't stuff that our users really give a crap about
22:11:31 <gregdek> Is there a newsletter equivalent of f-mag? How do you let people know there's a new f-mag edition/article/etc.?
22:11:55 <stickster> f-mag is a continuously publishing (wordpress-style) blog of stuff, as opposed to timed newsletter
22:12:01 <rbergeron> with their like 85 thousand twitter followers :)
22:12:07 <gregdek> wut
22:12:10 <stickster> we publish as often as we like, but we try never to go below 3 things per week
22:12:17 <gregdek> Oh you mean @fedora has 85k followers?
22:12:23 <stickster> yes
22:12:29 <gregdek> I guess that's a big part is tweeting to them about particular articles?
22:12:43 <gregdek> Which obviously works well with individual articles and maybe not so well with a newsletter
22:12:44 <stickster> we rely on twitter/facebook/reddit/g+ to spread the message of "here's a new article on f-mag"
22:12:50 <stickster> we post there via @fedora
22:13:04 <gregdek> 3 things per week.
22:13:26 <gregdek> How many people do you have working on f-mag from an editorial perspective, and how much of their time is dedicated?
22:13:30 <stickster> yes, and that can be challenging at times. ;-) with (I'm guessing here) an order of magnitude bigger community you might not be as hard pressed.
22:13:47 <stickster> We have 3 people working part time on editorial for f-mag -- jflory7, ryanlerch, and myself
22:13:52 <gregdek> Well, you've still got an editorial function, right? I'd imagine that's a large part of the bottleneck
22:14:22 <gregdek> Do you schedule content, say, x weeks out, or is it always a struggle to pull in the content every week?
22:14:24 <stickster> editorial isn't a terrible bottleneck for 3 articles per week. if you wanted to do more, then you'd want at least proportionally more editoris.
22:14:29 <stickster> *editors.
22:14:39 <gregdek> MAXIMUS EDITORIS
22:15:00 <stickster> we schedule content usually the week before. and it can be a struggle depending on the pipeline of contributors.
22:15:45 <stickster> here's where we have started to make a dent -- starter article ideas -- something any lightly-skilled contributor could pick up and run with. It has a well defined scope so they don't have to write too much, and we give them a number of words to shoot for.
22:15:58 <stickster> it only needs to be 300-500 words total, which is not very long.
22:16:16 <gregdek> So you basically pitch ideas you'd like to see written?
22:16:26 <stickster> yes, but we also invite other ideas.
22:16:26 <gregdek> Just brainstorm a long list and then start handing them out/
22:16:29 <stickster> yes.
22:16:31 <gregdek> k
22:16:40 <stickster> some other ideas that have worked well:
22:16:52 <gregdek> #action generate a list of starter ideas
22:17:13 <stickster> 1. "listicle" type pieces showing 3-4 things in a set topic (like shell extensions for doing <X> thing)
22:17:36 <stickster> 2. interviews with contributors and users talking about what they do, how they use Fedora, and how they got involved in the community (if applicable)
22:17:51 <stickster> (those can follow a simple template and even be self-submitted)
22:18:27 <stickster> 3. announcements of big news (like Beta and GA releases)
22:18:45 <stickster> 4. announcements of smaller big news (like releases of important or popular software now in the current version)
22:18:46 <gregdek> may i presume that the listicles deliver most of the hits?
22:19:07 <stickster> they do quite well but they're not the bread and butter at this point
22:20:20 <stickster> biggest hits are stuff concerning big upstream releases (like newest GNOME in Fedora Beta release); stuff like alternate window managers (appeal to tweakers); and yes, listicles
22:20:34 <gregdek> lol tweakers
22:20:46 <stickster> something that's helped a *lot* lately is listicles that point to other f-mag articles ;-) -- you'd need to be going for a while before you can lean on that, though.
22:20:56 <gregdek> ohhhh, right. inception.
22:20:58 <stickster> anyway, the bottom line is...
22:21:08 <stickster> content is king
22:21:21 <stickster> we used search results for 'fedora how do i' to help us seed article ideas
22:21:32 <stickster> that went a long way to escalating the f-mag as a source of info
22:21:42 <stickster> we also try to keep in mind shelf life
22:21:47 <gregdek> #action use 'ansible how do i' as search term to build article idea list
22:22:05 <stickster> did we cover enough of the content stuff?
22:22:09 <gregdek> Do people write articles about Fedora for not-f-mag that you then reprint?
22:22:14 * stickster is hoping someone out there is listening other than gregdek
22:22:19 <stickster> <chirp chirp>
22:22:22 <rbergeron> "how do i fix my issues with all other projecs with ansible" ;)
22:22:23 <gregdek> :)
22:22:25 <rbergeron> i am listening :)
22:22:29 <stickster> lol
22:22:39 <gregdek> The marketing team will be listening by proxy later.
22:22:48 <stickster> gregdek: not-f-mag?  Oh, you mean the other news outlet?
22:22:48 <gregdek> When they're not putting on an Ansiblefest :)
22:22:51 <stickster> lol
22:22:56 <gregdek> No, I mean any other outlet.
22:22:59 <rbergeron> well, the marketing folks are half-moving also
22:23:06 <rbergeron> so i have no idea how that is going to work long term
22:23:16 <gregdek> Like, does someone write about Fedora for their own blog, say, and then you go get permission to reprint in f-news?
22:23:20 <gregdek> Is that a thing that happens ever?
22:23:21 <stickster> Ah, yes -- sometimes we do "clickbait" articles to point to something important or interesting appearing elsewhere
22:23:28 <rbergeron> gregdek: that is def a thing for the fedora peeps aiui
22:24:34 <stickster> Occasionally we'll ask an author to submit their article to us for reprint, yes -- although often we'll run it through editorial to make it more readable, because writing skillz.
22:24:35 <gregdek> Yeah, that's some brilliant content ideas.
22:24:43 <gregdek> So what about infrastructure?
22:24:46 <gregdek> Can we talk about that a bit?
22:24:50 <stickster> sure.
22:24:55 <stickster> #topic infrastructure
22:24:56 <gregdek> #topic infrastructure
22:24:59 <gregdek> GAH
22:25:03 <stickster> lulz
22:25:15 <gregdek> can we just steal yours?
22:25:20 <stickster> We use self-hosted Wordpress on our Openstack cloud
22:25:30 <gregdek> "your" openstack cloud -- fedora?
22:25:35 <stickster> it's maintained as "best effort," meaning it's not going to wake someone up if it goes down
22:25:40 <gregdek> yup
22:25:58 <stickster> But having said that, it hasn't worked out badly at all
22:26:14 <stickster> And yes, we could provide you an instance in our cloud, and do whatever !$)%& DNS dance is needed to point to it :-)
22:26:21 <gregdek> ok.
22:26:29 <stickster> We have *GASP* AN ANSIBLE PLAYBOOK FOR IT
22:26:31 <gregdek> i have absolutely no compunction in saying "yes pls thx"
22:26:34 <gregdek> INORITE
22:26:36 <gregdek> so easy!
22:26:48 <gregdek> #action get ansiblenews domain
22:27:06 <gregdek> (we'll actually have to discuss domain with mktg)
22:27:09 <stickster> We use a combinaion of plug-ins for it that are pretty well vetted like Yoast SEO, a publishing workflow, etc.
22:27:15 <gregdek> #action discuss ansiblenews domain with ansible mktg
22:27:20 <gregdek> Man.
22:27:25 <gregdek> That's a whole new world.
22:27:29 <gregdek> How well does that stuff work?
22:27:35 <stickster> It's fortunately easy to explain and to use
22:27:42 <gregdek> I mean, clearly you're doing a lot of business.
22:28:43 <stickster> We tune content to make sure that it scores well enough in search engines
22:29:10 <stickster> And also we look at the readability scores as editors -- and have used it to help train writers
22:29:22 <gregdek> ...?
22:29:23 <stickster> things like avoiding passive voice, long sentences and jargon, etc.
22:29:56 <stickster> it's all very easy to read in the editing window itself -- so it's not arcane or hard to deal with
22:30:05 <stickster> (yay for good plugins)
22:30:10 <gregdek> Wow. New world.
22:30:43 * stickster takes a moment to show gregdek the dashboard on the back end
22:32:06 <gregdek> maaaaan
22:32:48 <stickster> OK, so that was hopefully helpful
22:33:06 <gregdek> Yes.
22:33:07 * stickster points to Yoast SEO plugin for those who want to see the features in all their glory
22:33:21 <rbergeron> Yoast?
22:33:22 <stickster> Anyway, we also use a custom theme that Ryan Lerch did for the f-mag.
22:33:32 <rbergeron> ohhh
22:33:35 <rbergeron> SEO not CEO
22:33:37 <rbergeron> sorry.
22:33:37 <stickster> Yoast SEO is just the name of the plugin. Named after its creator
22:33:40 <rbergeron> i read that incorrectly :)
22:33:43 <stickster> hee hee
22:33:45 <gregdek> We'll need to talk about what's required to actually stand up our own -- like,  we need someone who has f-infra access, I guess?
22:33:55 <stickster> Ryan also said he'd be willing to design you a theme too ;-)
22:34:05 <stickster> Also we have a couple custom plugins, like one that allows us to have co-authors
22:35:08 <gregdek> yes pls again :)
22:36:02 <stickster> One thing you might want to think about at some point is whether you "graduate"  out of our cloud, but that's a subject for another day
22:36:09 <stickster> let's get the hits first ;-)
22:36:12 <stickster> anyhoo
22:36:19 <gregdek> Yeah, when would that happen?
22:36:24 <gregdek> You get a ton of hits yes?
22:36:32 <stickster> I don't know, when you're getting 100K hits a day?
22:36:50 <stickster> for comparison... f-mag is aiming at 3,000,000 hits for the 2017 calendar year
22:36:55 <gregdek> Ohhhhh
22:36:56 <stickster> and we're almost on target
22:37:12 <stickster> Ansible would likely have a higher hit rate once people know an A-Mag is there
22:37:22 <gregdek> Well, I'm saying that I don't know how much traffic we can actually expect. Despite our coolness, Fedora has 2x our twitter followers.
22:37:37 <stickster> Yeah but the technology I imagine has a great deal higher user count
22:37:51 <stickster> So... who knows? Same? order of magnitude higher? *shruggie*
22:37:59 <gregdek> Do you have any idea about how close you are to "too much traffics"?
22:38:03 <stickster> Not close.
22:39:56 <gregdek> Then I think we'd be fine for a while tbh
22:39:59 <stickster> On the order of 10K hits a day is not a big deal, that's what we're doing now. We use a Varnish cache in front of the wordpress instance so that it can keep up with traffic easily.
22:40:23 <gregdek> varrrrrnish
22:40:27 <stickster> again, this is something we can just provide with our current playbooks.
22:40:31 <stickster> *snaps fingers* done.
22:41:02 * stickster unilaterally changes topic
22:41:12 <stickster> #topic Establishing ground rules
22:41:19 <gregdek> OH WAIT
22:41:21 <stickster> soooooo
22:41:22 <gregdek> no never mind
22:42:04 <stickster> this isn't about content per se but more about setting expectations with the community about what you will or won't do in the voice of a Magazine
22:42:12 <gregdek> ahhhhhh.
22:42:28 <stickster> We had to have some discussions about this, and some of them were ad-hoc as we went, and that wasn't ideal (although ultimately we got to where we wanted tob e)
22:43:16 <stickster> I would *definitely* encourage thinking about how much an outlet like this represents your project. Like, is it official, or not? Does it speak for Ansible as a project?
22:43:29 <stickster> oops, redundant, thanks single line editing
22:43:43 <stickster> For instance, are there topics that are verboten?
22:44:16 <gregdek> Would be better to tell them before the article comes in, instead of "oh right, yeah, you can't really talk about that"
22:44:18 <stickster> In f-mag we avoid anything that's illicit in large areas (like patent encumbered things even if they're FOSS... YAY CODECS I'M LOOKING AT YOU)
22:44:22 <stickster> Yes
22:44:24 <gregdek> yup
22:45:06 <stickster> But we *do* cover stuff that's legal for folks even if it's not FOSS... e.g. Chrome, which we know that like 50% of Fedora users install ;-)
22:45:15 <gregdek> Yeah.
22:45:23 <stickster> At the same time we prioritize FOSS stuff... so we ask authors to do stuff with KVM, not Virtualbo
22:45:27 <stickster> *virtualbox
22:45:38 <gregdek> I suspect we'd be pretty encouraging of various not-strictly-Ansible topics.
22:45:41 <stickster> sure
22:45:49 <stickster> it's all about setting up those expectations at the outset
22:46:08 <stickster> we keep this guidance enshrined in pages on the f-mag
22:46:11 <gregdek> And tbh we'd probably have lots of ubuntu / other vaguely rh-hostile topics, since that's where large chunks of our base are
22:46:20 <gregdek> but ¯\_(ツ)_/¯
22:46:58 <stickster> for example, would you want screenshots to be done on any particular platform? or not?
22:47:06 <gregdek> right
22:47:32 <stickster> would you want processes that only work on a specific distro? cover all equally? or do a sample? (like "do this on deb/ubu, do this on rhel/centos/fedora")
22:47:35 <stickster> etc.
22:48:42 * stickster can provide links to all our pages -- there are only 3 or 4 of them.
22:49:29 <stickster> Also, defining where you want to stake out article content vs. docs -- where do you not want to tread
22:50:04 <stickster> #action figure out any ground rules for must/must-not in a magazine
22:50:44 <stickster> so gregdek, this is a lot about how we do external facing stuff... we haven't really talked about the internal side
22:51:31 <stickster> we use a community blog site (but still a wordpress instance) for that
22:54:29 <gregdek> Why would this not be just a straight newsletter?
22:54:31 <stickster> Do you guys know whether you would like to do something different for community (inward-facing) news?
22:54:35 <stickster> well, it could be
22:54:47 <gregdek> And "internal" == "internal community" and not "internal company"?
22:54:52 <stickster> #topic Newsletter
22:55:27 <stickster> yeah, 'internal community' is how I think of this
22:55:59 <stickster> I mean, you could echo that internally in some way for sure -- but the point is to reach your contributor base *wherever* they are, and not mix that up with the stuff you want to distribute to the user base (or public)
22:56:24 <stickster> so it's an open publication, not internal to RH
22:56:29 <gregdek> Yup, got it
22:56:36 <gregdek> Just a much more limited distribution
22:56:42 <gregdek> Not by design, I guess
22:56:45 <gregdek> What's its url?
22:56:58 <stickster> We use https://communityblog.fedoraproject.org for this
22:57:18 <gregdek> ahhhh, ok
22:57:20 * gregdek looks
22:57:53 <gregdek> kjandova is a beast :)
22:57:58 <stickster> This was started for a specific reason... because ryanlerch and I got tired of seeing FESCo election quesionnaires splattered all over public RSS feeds going to people who didn't give a crap about them
22:58:19 <stickster> the best way to lose audience is to push stuff at them they don't care about
22:59:01 * gregdek nods
22:59:09 <stickster> by curating content more carefully we basically relaunched the magazine... it used to get hundreds of hits a week, now it gets many tens of thousands ;-
22:59:12 <stickster> ;-)
22:59:12 <gregdek> so a separate mechanism for  "inside baseball" discussions.
22:59:19 <stickster> exactly
22:59:23 <gregdek> when did this relaunch start?
22:59:32 <stickster> My metaphor: "Empire" magazine vs. "Variety"
22:59:45 <stickster> back in... 2013? 2014?
22:59:50 <stickster> 2014 I think.
23:02:48 <stickster> <short discussion of old Fedora News site in meatspace>
23:04:19 <stickster> We started talking about editors too
23:04:25 <gregdek> Yes, editors
23:04:33 <stickster> The issue with editors is finding people with good writing skills
23:04:56 <stickster> and the ability to make text better. The unfortunately part is it may lock out some ESL friends and contributors
23:05:12 <stickster> nice ^ see, my editing skills are awesome
23:05:18 <gregdek> :)
23:05:30 <gregdek> Oh! Any translations of these articles?
23:05:38 <stickster> AH! Good question
23:05:46 <stickster> So... this is notoriously HARD in wordpress
23:06:11 <stickster> It's absolute crap for doing translation, other than people making their own separate articles and translating by hand
23:06:49 <stickster> We basically leave that up to the community, so someone could launch something like MojeFedora.cz
23:06:59 <gregdek> Has anyone taken you up on any of that?
23:07:11 <gregdek> Oh, right.
23:07:44 <gregdek> That seems like... a lot of English.
23:08:05 <stickster> Yeah, they don't as much translate everything as key things, and/or print their own local community news or things people care about in CZ
23:08:19 <stickster> The translation infrastructure bits for FOSS are just not well rigged up for a PHP app like Wordpress
23:08:27 <stickster> and that's a level of effort we have no cycles to undertake
23:08:48 <stickster> There is a consolation in that en_US is the lingua franca of Fedora
23:09:18 <stickster> we occasionally get questions whether it's OK to translate material, and we tell community members the license allows it, no problem
23:09:54 <stickster> but that we don't really want to split the magazine into many subdomains or have repeated articles in different languages, that means custom plugin work we'd have to do for RSS splitting, etc.
23:10:12 <gregdek> Yeah, that's kind of the thing.
23:10:15 <gregdek> #topic g11n
23:10:17 <stickster> hm, I didn't re-#topic, sorry
23:10:18 <stickster> nice
23:10:20 <stickster> now we're done
23:10:23 <gregdek> I LEARNED A THING
23:10:27 <stickster> I WANT TO TALK ABOUT ZIS NO MORE
23:11:40 <gregdek> I mean, here's the thing: a lot of people don't trust tech articles in their own language -- docs especially -- because of the suspicion that the content is out of date by the time it's published.
23:11:51 <stickster> Right.
23:11:52 <gregdek> But ¯\_(ツ)_/¯
23:12:06 <gregdek> We can at least license it appropriately to make g11n a possibility.
23:13:30 <stickster> Yes -- we do a CC-BY-SA if I recall correctly
23:13:57 <stickster> I imagine you will want to pick an appropes license that makes sense for Ansible community, but chances are it would be something like that, I'm guessing
23:17:54 <stickster> Hmm
23:18:01 * stickster wracks brain for other topics
23:18:44 <stickster> gregdek: rbergeron: I think this is most of what I know. I have some additional notes I can provide that I sketched up in a doc somewhere... happy to share or put on a list, nothing that can't be public
23:18:57 <stickster> let me know if you want me to dump them somewhere
23:19:05 <gregdek> This has been fantastic, dude. thank you.
23:19:38 <gregdek> If you have a URL, can you just drop it in here?
23:19:55 <stickster> gregdek: It's a google doc atm
23:20:03 <gregdek> ah.
23:20:09 <gregdek> you can email me the link, that's fine
23:20:21 <stickster> so I'll see if I can post it somewhere that makes more sense... maybe a gist
23:21:37 <stickster> gregdek: https://gist.github.com/stickster/5f75091153e0390eb6146b5f9d01476c
23:21:43 <stickster> yay \o/
23:21:48 <gregdek> perfect!
23:22:48 <stickster> Well I guess we're done here, then :-)
23:23:18 <gregdek> yep.
23:23:20 <stickster> oh, one more note
23:23:31 <stickster> we maintain presence in #fedora-magazine and are *always* available to consult
23:23:31 <gregdek> "Oh, one more thing..." thx stevejobs
23:23:36 <gregdek> oh yay!
23:23:39 * gregdek joins
23:24:43 <stickster> I think *now* I'm done
23:24:47 <gregdek> OK!
23:24:59 <gregdek> And since no other lurkers have been present, I'll go ahead and close.
23:25:01 <gregdek> #endmeeting