16:59:41 <gregdek> #startmeeting cwg
16:59:41 <zodbot> Meeting started Wed Sep 20 16:59:41 2017 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:59:41 <zodbot> The meeting name has been set to 'cwg'
17:00:05 <gregdek> ping chouseknecht rbergeron
17:00:16 <gregdek> #chair rbergeron chouseknecht
17:00:16 <zodbot> Current chairs: chouseknecht gregdek rbergeron
17:00:29 <gregdek> Will get started in two
17:00:36 <gregdek> Or soonish, anyway :)
17:03:03 <rbergeron> hi!
17:03:10 <rbergeron> sorry, i was nursing my head
17:03:44 <gregdek> What happened?
17:05:54 <rbergeron> i went to a very loud concert last night
17:06:03 <rbergeron> :)
17:06:04 <gregdek> Oh, right! How was it, besides loud?
17:06:38 <rbergeron> it was lovely!
17:06:45 <rbergeron> would go again. A+++
17:06:56 * gundalow waves
17:07:01 <gregdek> :)
17:07:16 <gregdek> OK, so two big topics, and then we can basically have a big chunk of time back:
17:07:23 <gregdek> 1. Ambassadors WG, and 2. News WG.
17:07:29 <gregdek> On which shall we start?
17:08:06 <rbergeron> ooh. ambassadors?
17:08:22 <gregdek> ok!
17:08:26 <gregdek> #topic Ambassadors
17:08:43 <gregdek> Basically, nothing yet, which is why I want the meeting time back, LOL
17:09:04 <gregdek> But! The decks are clear, so I fully expect to have the working group itself set up later today and some content moved over.
17:09:18 <gregdek> #info Ambassadors WG will be stood up this week
17:09:33 <gregdek> #info First invites to Speaker Bureau will go out this week
17:09:47 <rbergeron> yasssssss
17:09:51 <gregdek> And I think we'd kind of settled on a mailing list, yes?
17:10:05 <gregdek> This is one of those things where there are a *lot* of members.
17:10:09 <rbergeron> I think that would be great, yes.
17:10:16 <gregdek> Like, 100+ meetup organizers alone.
17:10:18 <gregdek> OK.
17:10:25 <gregdek> #info mailing list will be set up this week
17:10:44 <gregdek> I think we may already have a google group that's unloved, but I'll double check. If so, we will rejuvenate it.
17:11:17 <gregdek> Nope, doesn't look like it
17:11:21 <gundalow> What's "Speaker Bureau"?
17:12:06 <gregdek> List of people who are able and willing to give talks remotely (or rarely, in person)
17:12:28 <gregdek> For instance, bcoca used to give his Tips and Tricks talk remotely quite a lot
17:12:47 <gregdek> So that's the high level update.
17:12:48 <rbergeron> I do wonder if bureau is the best / most easily understood word here but i lack a substitute :)
17:13:03 <gregdek> Yeah, we can always rename it if we come up with something better
17:13:17 <gregdek> collection? cadre? gang? cabal?
17:13:24 <gregdek> squad?
17:14:31 <gregdek> Anyway.
17:14:34 <gregdek> Any Qs?
17:14:39 <gregdek> Comments?
17:14:40 <rbergeron> well. the thesaurus offers terrible alternatives for bureau
17:14:48 <gundalow> Sounds like a useful thing
17:14:56 <rbergeron> agency, authority, board, commission, committee, department, division, office
17:15:00 <rbergeron> "branch of an organization"
17:15:45 <plm31> If possible, I would like to discuss a PR for a new module that I opened some time back and it was suggested I discuss it here, https://github.com/ansible/ansible/pull/26071
17:16:11 <gregdek> Hi plm31 -- the best place for that is the Core team meeting. Are you familiar with it?
17:16:20 * gregdek looks to make sure...
17:16:24 <plm31> No, I was told to attend this one
17:16:42 <gregdek> Oh, ahhhhhh.
17:16:45 <gregdek> This is for adoption!
17:16:49 <plm31> I am looking to provide community support for some modules
17:16:54 <gregdek> Right!
17:16:55 <plm31> that I have written
17:17:12 <plm31> this was the first one to try and get it accepted, then I would do the rest
17:17:17 <gregdek> So the problem appears to be that you never got a second shipit, correct?
17:17:36 <plm31> Well it went to approval by communit members
17:17:47 <plm31> but I am willing to be the support on it
17:18:01 <gregdek> Yup. https://github.com/ansible/ansible/pull/26071#issuecomment-311238901
17:18:07 <gregdek> OK, so.
17:18:13 <plm31> I am not entirely sure how to "join" the community here
17:18:17 <gregdek> #topic New module maintainer status
17:18:37 <gregdek> plm31: unfortunately, the new module path still isn't an easy one, and the bot doesn't give you a lot of feedback.
17:19:14 <gregdek> plm31: is this the only module you're looking to get merged, or are there others?
17:19:42 <plm31> This is the first one, I have not raise PRs for the others as I wanted to get used to the process first
17:19:49 <plm31> the others are for TeamCity
17:20:09 <plm31> and I have a couple more for GitHub Enterprise
17:21:06 <gregdek> OK.
17:21:43 <chouseknecht> So I think the bot is saying, on his PR, that everything checks out.
17:22:02 <chouseknecht> I say we hit the merge button
17:22:28 <plm31> The version introduced won't match now though
17:22:47 <plm31> Happy to update that, as long as it will go stright through
17:22:48 <gregdek> Let's grab thaumos.
17:23:44 <rbergeron> it's an abadger1999! :)
17:23:47 <gregdek> :)
17:24:00 <gregdek> And soon to be a thaumos as well
17:24:10 * thaumos waves
17:24:17 <gregdek> Hey thaumos :)
17:24:22 <thaumos> hola
17:24:32 <gregdek> OK, plm31 has joined us at thaumos urging to discuss a PR:
17:24:32 <thaumos> whats crackalackin
17:24:43 <gregdek> https://github.com/ansible/ansible/pull/26071
17:25:06 <gregdek> So my question to the two of you is, "what is the current correct process for getting net new modules merged?"
17:25:15 <gregdek> (the two of you being abadger1999 and thaumos)
17:25:42 <thaumos> attend the community meeting tues/thurs, have some people do reviews, then it will utimately get merged
17:25:53 <gregdek> thaumos: that would be the *core* meeting, yes?
17:25:57 <thaumos> correct
17:26:07 <gregdek> ok, this is the community working group meeting. :)
17:26:11 <gregdek> So there's confusion point #1.
17:26:25 <gregdek> plm31: apologies for sending you to the wrong meeting.
17:26:37 <plm31> The module will be community supported... Why is that coire meeting?
17:26:48 <gregdek> It's a nomenclature issue, clearly.
17:27:01 <abadger1999> Yep, that's the way.  We hope that a like-minded community member would step up.  But when none does, taking it to the core meeting is the way to draw attention and get someone to commit to reviewing
17:27:11 <gregdek> OK.
17:27:23 <thaumos> yep + its a core meeting discussion because the core team is presently a gate for merging new modules into the project
17:27:41 <gregdek> #action add to community documentation the process for merging new modules: attend core team meeting, with link
17:27:46 <plm31> So if I am wanting to do this with more modules after this one, it is the core meeting I need to go to for them too?
17:28:17 <thaumos> for new modules yes
17:28:21 <gregdek> Yes. Unless you can find someone already in the community who can review your modules and give a thumbs-up (which admittedly is not a clear process at present).
17:28:45 <thaumos> once merged if you have a second person to speak to them, it requires two shipits in the pr to auto merge
17:28:50 <plm31> ok, well considering it has been open so long and there was a request to the community, that is unlikely
17:29:25 <gregdek> plm31: yep. Which is why the core meeting is the fallback.
17:29:47 <plm31> ok, I will try my luck there, thanks
17:30:10 <gregdek> Once your modules are in, they should be easier to maintain; merges go faster for modules that already exist.
17:30:16 <gregdek> plm31: thanks, and sorry for the runaround :/
17:30:22 <gregdek> abadger1999 thaumos thanks folks.
17:30:51 <abadger1999> de nada
17:30:51 <rbergeron> plm31: yes, sorry :\ but -- this was also useful in seeing how people perceive the naming of these meetings and what they imply
17:31:22 * gregdek wonders if we should call the core meeting the "module meeting", heh
17:31:33 <rbergeron> or maybe just the "devel" meeting
17:31:38 <gregdek> Yeah, maybe
17:31:59 <gregdek> #idea propose renaming the "core" meeting to "devel" meeting
17:32:18 <gregdek> OK. Moving on:
17:32:23 <gregdek> #topic News WG
17:32:30 <gregdek> rbergeron: anything to report?
17:32:41 <rbergeron> Core just has this multi-meaning thing going on -- because we used to have core and extras, but now we also call the folks with commit bits the core team
17:33:07 <rbergeron> um, well, i can report that i'm now not in a plane and can do things? :)
17:33:14 <gregdek> w00t!
17:33:21 <gregdek> Upcoming goals?
17:33:40 <rbergeron> we haven't visited this for a while but i seem to recollect that where we were last this was discussed was "we'll ask the marketing folks about getting a mailing list after we get done with ansiblefest"
17:34:17 <rbergeron> does that seem accurate?
17:34:28 <gregdek> Yep.
17:34:40 <gregdek> Also need to sort out content and first issue target date. Paul had some good content ideas.
17:34:56 <gregdek> I don't recall who was going to ping marketing, you or me...
17:35:01 <gregdek> But I can just do that.
17:35:03 <rbergeron> I think it was you.
17:35:20 <gregdek> OK.
17:35:22 <rbergeron> we could look in the issue :)
17:35:27 <gregdek> Oh, right!
17:35:43 <rbergeron> https://github.com/ansible/community/issues/211
17:35:50 <gregdek> grr, too many issues on this topic
17:36:32 <gregdek> ok.
17:36:43 <gregdek> let's just talk it through. the issues are too muddy.
17:36:52 <gregdek> (issues meaning the github tickets)
17:37:24 <gregdek> If I ask for a mailing list...
17:37:30 <gregdek> ...the next question will be "who's on it?"
17:37:41 <gregdek> And that answer, to start, will be "nobody" unless we seed it somehow.
17:37:41 <rbergeron> So, we need:
17:37:59 <rbergeron> well, i won't start what we need.
17:38:08 <rbergeron> Yes, this part takes time.
17:39:05 <rbergeron> (it's also why I prefer to start with a "user" newsletter and not a developer/contributor newsletter -- we'll be able to let all the user readers know about a contributor newsletter which might encourage them to contribute or be interested in the idea, vs. ... building a contributor newsletter which may not grab user attention.)
17:39:24 <gregdek> Yep, stickster reinforced this message at fest.
17:39:38 <gregdek> #agreed newsletter will be user-focused, not developer-focused
17:39:42 <rbergeron> so -- social media, our existing mailing lists (ansible-announce, etc.) are good places to say to sign up. (mailing lists == once, once only, not repetitive spam.)
17:39:56 <rbergeron> developer-focused can def. happen at some point, but.
17:40:23 <rbergeron> We did plenty of "sign up on a tablet, maybe win a $thing" at lots of conferences.
17:40:27 <gregdek> Should we consider sending the first one to basically everybody on all lists and say "for subsequent newsletters subscribe here"?
17:40:57 <rbergeron> devopsdays, etc.
17:41:18 <rbergeron> I think that's reasonable, yes.
17:41:38 <gregdek> ok.
17:42:00 <rbergeron> I think even doing that once every... 6 months isn't a terrible idea.
17:42:18 <rbergeron> actually, scratch that --
17:42:19 <gregdek> and remind me again why this is a company mailing list and not just a google group? I know there was a reason, I just don't remember what it was.
17:42:20 <rbergeron> i think once is fine.
17:42:53 <gregdek> (Being that google group messages are archived, and until we actually have a website for this, I don't think company mailing list mails are...)
17:43:08 <rbergeron> because otherwise we invite the possibility of every newsletter on earth getting sent to the list. :)
17:43:28 <rbergeron> so: we do'nt need a mailing list per se.
17:43:51 <rbergeron> I mean, in essence it sort of is since you say "sign me up" --
17:44:41 <rbergeron> but things like that don't let us really know (at least, easily) about stuff like
17:44:54 <rbergeron> "a bunch of people unsubscribed" (which tells us we suck)
17:45:09 <gregdek> Right. Stats.
17:45:13 <rbergeron> or "here's the link they used to subscribe" (which can tell us where better sources are for getting people to sign up)
17:45:35 <rbergeron> mailchimp's page shows a lot of the neat things we might want to think about.
17:45:36 <gregdek> And I think we'd agreed that we were going to double-publish the content... somehow.
17:45:51 <rbergeron> right. So -- we def. agreed on a flat-text mail if nothing else --
17:46:05 <rbergeron> but some platforms can let people opt in to html vs. text --
17:46:19 <gregdek> Would we just take the whole newsletter and publish it as a blog post?
17:46:32 <rbergeron> lh and i used to send the newsletter and then also do a blog post.
17:46:48 <rbergeron> And make sure some of the cool tweets or videos or slide decks were embedded --
17:46:50 <gundalow> Blog post of content sounds good. And we already have that tech setup
17:46:54 <rbergeron> which makes it look like a pretty / visual blog post.
17:47:04 <gundalow> Also can tweak formatting
17:47:32 <gregdek> ok!
17:47:36 <gregdek> I understand.
17:48:09 <gregdek> I'm going to make the request to marketing right after this meeting.
17:48:09 <rbergeron> https://www.elastic.co/blog/newsletter-and-hangouts
17:48:16 <gregdek> And then we'll have a list.
17:48:30 <gregdek> When will we have our first newsletter? :)
17:48:35 <gregdek> And what will we call it?
17:48:42 <gregdek> "Ansible Community News" or some such?
17:48:52 <rbergeron> And then we had a signup page -- https://www.elastic.co/community/newsletter
17:49:31 <rbergeron> (though i'd leave out company name, quite possibly, but experience level or "user, contributor, advocate" checkboxes might be nice
17:49:45 <rbergeron> gregdek: we waxed on about this in a previous meeting quite a bit :)
17:49:53 <gregdek> Yeah.
17:50:04 <gregdek> I'm remembering. Sorry!
17:50:05 <rbergeron> "community newsletter" ... well, this gets back into semantics :)
17:50:09 <gregdek> Problem with me being the bottleneck.
17:50:27 <rbergeron> community newsletter almost sounds like "for contributors"
17:50:42 <gregdek> right. so what, then?
17:50:47 <rbergeron> a tagline saying "by the Ansible community, for everyone"
17:50:55 <rbergeron> is +++ though
17:50:56 <rbergeron> umm
17:51:03 * rbergeron looks in issue where all the ideas were
17:51:17 <gundalow> Ansible Users Newsletter
17:51:28 <gregdek> We completely punted on the name.
17:51:30 <gregdek> :)
17:51:36 <gundalow> oh, did I miss that, sorry
17:51:36 <rbergeron> The moosletter
17:51:38 <rbergeron> the bullpen
17:51:39 <rbergeron> the bullhorn
17:51:43 <gundalow> moosletter +1
17:52:27 <gregdek> i like bullhorn :)
17:52:31 <rbergeron> I'm not sure moos translates well to all potential readers. But maybe it does. Not sure if the moos/news thing really comes through to non-native / non-punny speakers
17:53:04 <rbergeron> Bullhorn is decent because it conveys... things
17:53:55 <rbergeron> and is a translatable word tht makes sense even outside of the bull pun
17:54:10 <rbergeron> bullhorn
17:54:12 <rbergeron> n     (US)   (=loudhailer)   porte-voix    m inv  , mégaphone    m
17:54:19 <gregdek> Yep.
17:54:22 <gregdek> That's why I like it.
17:54:32 <rbergeron> el megáfono
17:55:09 <rbergeron> Pay no attention to the cowboy with the bullhorn.
17:55:09 <rbergeron> Не обращайте внимания на ковбоя с рупором.
17:55:41 <gregdek> lolwut
17:55:42 <gregdek> ok!
17:56:02 <gregdek> "rooporom".
17:56:09 <gregdek> anyway.
17:56:11 <rbergeron> Though it'd be neat to figure out how to work Ansible into that line, but .. yeah
17:56:20 <rbergeron> okay. so you can go ping poeple and i'll think about the other things
17:56:22 <gregdek> I'll request the mailing list from marketing, and we'll move forward.
17:56:33 <gregdek> What date can we commit to, and then what frequency?
17:56:49 <gregdek> Or are we ready for that yet?
17:58:11 <rbergeron> umm --
17:58:30 <rbergeron> i think every two weeks for now. I mean, there's enough content for every week, easily, but .. I think every two weeks is decent.
17:58:33 <rbergeron> esp as we figure out process.
17:58:57 <rbergeron> For a date --
17:59:18 <rbergeron> I mean, it depends on if we want to do anything drumming up excitement / getting people to sign up first, or not.
17:59:40 <gregdek> OK, we can talk about that later.
17:59:57 <gregdek> OK, request email is basically ready to go, and we'll go from there.
18:00:01 <gregdek> #topic Open Floor
18:00:03 <gregdek> Anything else?
18:00:03 <rbergeron> If we didn't, I think next week would be reasonable. But i think maybe 2-3 weeks and making sure we have some solid plans for signing people up and making sure we're organized and ready for people to submit things for future issues and so forth is useful
18:00:08 <rbergeron> one thing:
18:00:18 <rbergeron> I got pinged on this yesterday --
18:00:20 <rbergeron> https://github.com/ansible/community/issues/246
18:00:28 * gundalow -> food
18:00:29 <rbergeron> (via twitter, so i asked him to file an issue)
18:00:37 <rbergeron> (and he did! yay, thanks joshsimmons)
18:01:13 <rbergeron> i'm gonna ping our bay area friends and see if they're interested in attending / tabling --
18:01:33 <gregdek> I'm a little worried that we're going to get overrun by these.  I said yes to one in Ohio, floated them $500, and now I've seen five of them in a month.
18:01:34 <rbergeron> if not, i would elect that we opt to do an in-kind, "sorry we can't be there but hope the money can help get a good human there"
18:01:45 <rbergeron> these == python things?
18:01:47 <rbergeron> or ... ?
18:01:50 <gregdek> Yeah, Python specifically.
18:02:54 <rbergeron> well -- i mean between this and every other open source community, yeah.
18:02:58 <gregdek> We can do $500 sponsorships without really even asking anyone, so I'm fine with that, but they don't really get us much.
18:03:02 <rbergeron> is this like a new thing in python land?
18:03:06 <gregdek> I wonder.
18:03:13 <gregdek> Seems like a lot of them popping up.
18:03:29 <rbergeron> yeah, i mean -- i said we do, but not always, but also -- i feel like north bay will be ... lots of bay area humans, probably a larger event.
18:03:44 * rbergeron will look into it
18:04:14 <gregdek> ok. :)
18:04:20 <rbergeron> i think the answer is largely twofold though
18:04:40 <rbergeron> 1: i think i'm okay with pinging our ppl who live nearby and seeing if they want to attend / do anything, etc. and figuring out what we want to do.
18:05:01 <rbergeron> 2: more broadly -- we should probably just think about ... how to handle all of these types of things going forward.
18:05:25 <rbergeron> at least: how far in advance we need to know (ie: do we set aside some amount of money every quarter for "being good citizens" or whatever)
18:05:33 <rbergeron> etc.
18:05:36 <rbergeron> food for thought.
18:05:40 <rbergeron> brain all done though for moment.
18:06:46 <rbergeron> gregdek: ready to wrap it up? :)
18:06:51 <gregdek> I think si.
18:07:01 <gregdek> I think so, si. :)
18:07:01 <rbergeron> I think oui.
18:07:10 <gregdek> OK then!
18:07:13 <gregdek> #endmeeting