#ansible-community: AnsibleFest Austin: Contributors Summit - Contributor Experience

Meeting started by gundalow at 20:12:18 UTC (full logs).

Meeting summary

    1. https://etherpad.openstack.org/p/ansible-community-experience (gundalow, 20:12:29)
    2. https://github.com/orgs/ansible/projects/2 (gundalow, 20:19:10)
    3. New Contributors https://github.com/ansible/community/issues/353 (gundalow, 20:20:38)
    4. Identify common issues, feed those into Bot, CI etc (gundalow, 20:28:22)
    5. Speak to the people (gundalow, 20:28:27)
    6. Add the human touch - Personally great people (gundalow, 20:29:43)
    7. Docs team are meeting weekly to review docs PRs. They are also aiming to give a human response and a) request feedback b) close c) fix d) fix+merge (gundalow, 20:31:39)
    8. Bot is good for rapid turn around, not for the human touch (gundalow, 20:31:56)
    9. ACTION: gundalow to follow up with David@cisco about why merging didn't work (gundalow, 20:33:51)
    10. take advantage of GitHub's notifications of CONTRIBUTOR.md linking for new_contributors (gundalow, 20:35:05)
    11. Add very basic workflow (with links to other docs) into `CONTRIBUTOR.md` so people will be notified via GitHub UI (gundalow, 20:36:32)
    12. AGREED: adding a changelog shouldn't block automerge (gundalow, 20:41:19)
    13. PRs that affect lib/ bin/ contrib/ (but not bin/ansible-test lib/ansible/release.py) MUST have changelog fragment for stable-x.y PRs (gundalow, 20:48:38)
    14. https://github.com/ansible/ansible/blob/stable-2.7/changelogs/CHANGELOG-v2.7.rst#new-modules-2 (felixfontein, 21:00:11)
    15. Agree (via dev_guide) when we need `fragments` (gundalow, 21:02:49)
    16. Question: How do we increase testing (gundalow, 21:04:51)
    17. Question: How do we increase people looking at/testing PRs (gundalow, 21:05:04)
    18. "Topic of the week" - How to get people together for one purpose (gundalow, 21:09:57)
    19. reducing back-and-forth needs to be done (gundalow, 21:15:29)
    20. What other working groups do we need - Look at PRs per directory. (gundalow, 21:16:15)
    21. Use GitHub issues to notify maintainers to see if they would be interested in setting up a Working Group (gundalow, 21:19:37)
    22. review maintainers guide (gundalow, 21:21:17)
    23. The Fedora Project has/had similar problems with reviewing new packages. There are three former Fedora Project Leaders here, at ansiblefest that you could pick the brains of: Matt Miller, robyn, and gregdek (abadger1999, 21:21:17)
    24. org level github project to make visible the Contributor Experience action items https://github.com/orgs/ansible/projects/2 (abadger1999, 21:25:11)
    25. The Fedora Project has/had similar problems with reviewing new packages. There are three former Fedora Project Leaders here, at ansiblefest that you could pick the brains of: Matt Miller, robyn, and gregdek (abadger1999, 21:25:47)
    26. org level github project to make visible the Contributor Experience action items https://github.com/orgs/ansible/projects/2 (abadger1999, 21:25:58)
    27. How did "Active Community Members" find out/get involved. How can we encuragethat (gundalow, 21:26:32)
    28. how do we define "active" in the above (gundalow, 21:27:58)
    29. Post-Contributors Blog post should also make it clear that we aren't just talking about Python programmers - Link to acozine's talk (gundalow, 21:29:18)
    30. Post-Contributors Blog post - Also detail what type of participation we are looking for (gundalow, 21:29:54)
    31. Create issue" WG - todo list" 1) Docs 2) PRs without needs_info/needs_revision 3) Needs test (gundalow, 21:35:32)
    32. Badges: Mozilla & Fedora - Ask Matthew Miller if they've helped or not. What are the real rewards (recognition, merge rights, etc) (gundalow, 21:40:14)
    33. Lessons learnt from Network Documentation t-shirt game - Multiple example PRs on same file resulted in continual merge conflicts. Had a few people that tried to "game" the system (just copy-paste). Next time: Would timebound it from the start. Add initial limits for responses from PR authors. More general ensure every module EXAMPLE has a `- name: ` set (gundalow, 21:45:45)
    34. Look at https://openbadges.org/ and https://badges.fedoraproject.org/ (gundalow, 21:49:02)
    35. Badges/points for doing X each week. Number of weeks X was done. Number of continuous weeks where X was don e (gundalow, 21:52:40)
    36. what are the rewards (gundalow, 21:53:38)
    37. https://www.redhat.com/archives/fedora-devel-list/2004-May/msg00104.html (abadger1999, 21:55:10)


Meeting ended at 21:56:43 UTC (full logs).

Action items

  1. gundalow to follow up with David@cisco about why merging didn't work


Action items, by person

  1. gundalow
    1. gundalow to follow up with David@cisco about why merging didn't work


People present (lines said)

  1. gundalow (46)
  2. felixfontein (37)
  3. misc (27)
  4. bcoca (19)
  5. abadger1999 (19)
  6. zodbot (7)
  7. acozine (1)
  8. jlk (1)
  9. mattclay (0)


Generated by MeetBot 0.1.4.