#ansible-community: Ansible Contributor Experience Working Group

Meeting started by gundalow at 19:00:08 UTC (full logs).

Meeting summary

    1. Agenda: https://github.com/ansible/community/issues/390 (gundalow, 19:00:17)
    2. We define "contributor" as someone that does or should interact with PRs (gundalow, 19:00:26)
    3. As discussed in Contributor Summit in Austin, we'd setup this new group, which I'm working on full time. We are (initially) focusing on PRs, though we are happy to fix other stuff as we go along. It's also expected that some of this work will also improve issues and general community stuff. (gundalow, 19:06:30)

  1. Where to start (gundalow, 19:06:58)
    1. There is loads to do, and just about anything is "in scope", though based on discussing in Austin we will focus on making things clearer for people, then work on adding more contributors/maintainers/. Part of this group is about "oiling the machine", parts is actually about sitting down and reviewing PRs (gundalow, 19:08:37)

  2. Improving Docs: /community and /dev_guide (gundalow, 19:09:17)
    1. Plan for restructure of /community/ and /dev_guide/ https://docs.google.com/document/d/1nMevQ0W7MZgJA1tJrJbNHIhTiHYHYUlO3IHXBs_usGE/edit?ts=5be2cd87 (gundalow, 19:10:10)
    2. this would be replacement for docs.ansible.com/ansible/devel/community/ (gundalow, 19:13:42)
    3. https://github.com/jctanner/molecule/blob/MAZER_COLLECTIONS_ANSIBLE_TEST/molecule/command/init/module.py is a prototype of what i wanted to do with proposal 49 (jtanner, 19:20:39)
    4. ACTION: acozine gundalow to think about changelog for docs, test infrastructure, coding standards (gundalow, 19:26:55)
    5. AGREED: Writing/reviewing code is only one way to be a contributor (gundalow, 19:35:09)
    6. How can we make it clear that if "all" someone does is review PRs that's great (and in someways better than contributing new_modules) (gundalow, 19:42:55)
    7. Can we do some diamond diagram to show this? (gundalow, 19:43:25)
    8. ACTION: create issue for tracking ideas on how to motivate reviewers. credit people in changelog, points/badges/stars - watch out for people gaming the system (gundalow, 19:44:40)

  3. Improving Docs: How to Review and test a PR (gundalow, 19:46:39)
    1. https://docs.google.com/document/d/1nMevQ0W7MZgJA1tJrJbNHIhTiHYHYUlO3IHXBs_usGE/edit?ts=5be2cd87#heading=h.kzxzqyez5fp5 (gundalow, 19:46:51)
    2. See the `[Docs] How to review & test a PR #399` section (gundalow, 19:47:01)
    3. During Contributors Summit in Austin we identified that we don't have any clear guidelines on how to do local testing of a PR (gundalow, 19:49:06)
    4. ACTION: gundalow needs to document his bigger picture plan (contributor workflow, why we are starting with docs before adding people. Why we improve the SIGs before adding people) (gundalow, 19:55:35)

  4. the high level plan (gundalow, 20:15:37)
    1. ACTION: gundalow to do walkthough and document how to test a PR (gundalow, 20:26:00)


Meeting ended at 20:26:09 UTC (full logs).

Action items

  1. acozine gundalow to think about changelog for docs, test infrastructure, coding standards
  2. create issue for tracking ideas on how to motivate reviewers. credit people in changelog, points/badges/stars - watch out for people gaming the system
  3. gundalow needs to document his bigger picture plan (contributor workflow, why we are starting with docs before adding people. Why we improve the SIGs before adding people)
  4. gundalow to do walkthough and document how to test a PR


Action items, by person

  1. acozine
    1. acozine gundalow to think about changelog for docs, test infrastructure, coding standards
  2. gundalow
    1. acozine gundalow to think about changelog for docs, test infrastructure, coding standards
    2. gundalow needs to document his bigger picture plan (contributor workflow, why we are starting with docs before adding people. Why we improve the SIGs before adding people)
    3. gundalow to do walkthough and document how to test a PR


People present (lines said)

  1. gundalow (131)
  2. misc (43)
  3. acozine (30)
  4. felixfontein (28)
  5. decentral1se (25)
  6. jtanner (18)
  7. caphrim007 (14)
  8. zodbot (10)
  9. sdoran (5)
  10. dsoper2 (5)
  11. agaffney (1)
  12. akshay196 (1)
  13. bizonk (0)


Generated by MeetBot 0.1.4.