19:00:44 <gundalow> #startmeeting Ansible Contributor Experience Working Group
19:00:44 <zodbot> Meeting started Thu Nov 15 19:00:44 2018 UTC.
19:00:44 <zodbot> This meeting is logged and archived in a public location.
19:00:44 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:44 <zodbot> The meeting name has been set to 'ansible_contributor_experience_working_group'
19:00:59 <gundalow> #chair shaps felixfontein dmsimard
19:00:59 <zodbot> Current chairs: dmsimard felixfontein gundalow shaps
19:01:14 * acozine waves
19:01:23 <felixfontein> hi everyone!
19:02:40 <gundalow> #chair acozine felixfontein samccann
19:02:40 <zodbot> Current chairs: acozine dmsimard felixfontein gundalow samccann shaps
19:03:29 <felixfontein> hi samccann and apple4ever!
19:03:40 <apple4ever> Hello!
19:03:41 <gundalow> Welcome everybody to the Ansible Contributor Experience Working Group
19:03:53 <samccann> helloooo
19:03:53 <shaps> Hi :)
19:03:53 <gundalow> apple4ever: Hi, you here for Contirbutor Experience, welcome!
19:05:23 <gundalow> #info agenda https://github.com/ansible/community/issues/390
19:05:47 <gundalow> #info Please subscribe to agenda, after each meeting I'll put a summary in
19:06:09 <gundalow> If anyone has anything, please add it to the agenda
19:06:19 <gundalow> #topic Improving Docs: /community and /dev_guide
19:06:31 <gundalow> #info aka Helping new contributors figure out how to navigate our processes
19:06:31 <apple4ever> I'm a new contributor so hopefully I can help inform the process
19:07:59 <gundalow> apple4ever: Thank you for making the time to join us. View of new contributors are very important, in fact more important that the others (soz everybody else)
19:08:22 <gundalow> So I guess that brings us nicely onto https://github.com/ansible/ansible/pull/48734
19:09:38 <gundalow> In particular https://github.com/gundalow/ansible/blob/community-dev_guide-reorg/docs/docsite/rst/community/index.rst which will be the replacement for https://docs.ansible.com/ansible/latest/community/
19:10:16 <acozine> gundalow: what kind of feedback/discussion do you want in this meeting? I see a typo in the PR - should I save that for comments on the PR itself, or do you want that sort of stuff here?
19:10:46 <gundalow> acozine: good question, things like that, just comment on the PR.
19:11:20 <gundalow> I've not been through and build the docs yet, though I thought it was worth while pushing up what I have for discussion today
19:11:56 <gundalow> #info As per previous meeting, this PR is about making it easier for new contributors to understand the process and highlight existing documentation
19:12:40 <gundalow> Everybody does https://github.com/gundalow/ansible/blob/community-dev_guide-reorg/docs/docsite/rst/community/index.rst look roughly right?
19:12:51 <apple4ever> Looking pretty good to me
19:13:04 <felixfontein> much better than the old version!
19:13:10 <felixfontein> and yes, it does :)
19:13:20 <apple4ever> Is there a reason to split Developing from Working With Pull Requests?
19:13:22 <gundalow> apple4ever: I'm not sure how much you used the docs when you started, or if you'd were already familiar with how GitHub etc works
19:13:31 <apple4ever> I was familar with GitHUb
19:13:45 <shaps> looks good to me
19:14:14 <apple4ever> But it was hard how to figure out just to fix a bug. A lot of docs point back to "Developing a module" which had some helpful things but much which wasn't relevant
19:14:25 <gundalow> I think in the previous meeting we went through a few names of some ofthe sections, and I changed it at least two times during that PR
19:14:43 <samccann> I miss the 'how can I help' link.  I'd like to see something that points a new contributor to 'quickfix' issues or PRs they can jump right in on
19:15:39 <gundalow> samccann: ah, good point
19:16:00 <gundalow> #info existing "How can I help" page https://docs.ansible.com/ansible/devel/community/how_can_I_help.html
19:16:26 <gundalow> personally I bounce between "I like this page"/"I really don't like this page"
19:16:46 <acozine> apple4ever: thanks for sharing your experience - what information on fixing a bug were you looking for? Was it more about branching, or testing, or how to open a PR, or something else?
19:16:52 <gundalow> would love to know what y'all think about it
19:17:24 <apple4ever> Setting up the dev environment, branching, and testing. I'm sure submitting a PR would be helpful too, but I already knew how to do that
19:17:55 <apple4ever> The first was the most difficult to find
19:18:20 <shaps> also, github now gives you a link to open a PR directly when you push to your fork
19:18:34 <apple4ever> Yes! that is really nice. Stole that from Gitlab ha
19:18:37 <misc> shaps: on the CLI only, no ?
19:18:50 <acozine> apple4ever: awesome, thanks - would this page have helped you? https://docs.ansible.com/ansible/devel/dev_guide/index.html
19:18:57 <gundalow> apple4ever: dev_guide/index links to https://docs.ansible.com/ansible/latest/dev_guide/developing_modules_general.html#environment-setup
19:19:08 <felixfontein> misc: yes on the CLI
19:19:30 <gundalow> `I want to set up my Python development environment.` I'm not sure if that contains what you want, or should be linked form else where
19:19:33 <gundalow> #chair misc
19:19:33 <zodbot> Current chairs: acozine dmsimard felixfontein gundalow misc samccann shaps
19:19:33 <shaps> misc, yep CLI ( is there a non-cli-github? )
19:19:36 <gundalow> welcome
19:19:48 <samccann> gundalow: perhaps the first part of 'Understanding Ansible's Development Process' can be called 'How can I help?" And then move the 'understanding' title to just before the development process link?
19:20:00 <felixfontein> shaps: I think there is, I have seen people using something like that for Windows, but I don't really know it
19:20:19 <acozine> felixfontein: misc: there's a prompt on the GUI for GitHub too - a banner with your last-pushed branch and a button for "compare and open a PR"
19:20:31 <apple4ever> acozine gundalow yes that is the steps I took. It was a little confusing because it was under "developing a module". I thought "well that's not what I want to do"
19:20:35 <misc> shaps: I guess people might use IDE to interact with git
19:20:37 <shaps> gundalow, I think the 'How I can help' can stay if it's given some love
19:20:54 <misc> and if we are speaking of newcomers, that's maybe something to keep in mind
19:20:54 <gundalow> apple4ever: oh, that's a very good point
19:21:10 <acozine> apple4ever: ah! I hadn't thought of it that way
19:21:51 <shaps> misc, that's possible, although the message comes from git (maybe), so you should be able to see it from an IDE as well
19:22:30 <gundalow> apple4ever: if we put I want to :ref:`set up my Python development environment <environment_setup>`. under https://github.com/ansible/ansible/pull/48734/files#diff-e792758adc61c4cc6bd4eff51d5c80ecR44 ?
19:23:00 <apple4ever> Yes I think that would make more sense
19:23:34 <apple4ever> A next step after that would be two different types of things: fixing bugs/add feautres in existing modules, or developing a new module
19:23:55 <gundalow> OK, want to make sure we aren't missing this,
19:24:17 <gundalow> 1) link to how_can_I_help and refactor that page
19:24:37 <gundalow> 2) Do we need to link to some GitHub guides for branch/forking?
19:25:18 <gundalow> 3) samccann's comment: perhaps the first part of 'Understanding Ansible's Development Process' can be called 'How can I help?" And then move the 'understanding' title to just before the development process link?
19:25:48 <gundalow> so, going to do the easy stuff first
19:25:52 <gundalow> (3)
19:26:24 <felixfontein> +
19:27:24 <gundalow> and make `Understanding Ansible's release cycle:` a top level heading?
19:27:37 <shaps> gundalow, for 2, yes github guides on branch/fork look good for entry level I think
19:27:43 <shaps> -> https://help.github.com/articles/fork-a-repo/#
19:29:15 <samccann> gundalow: for (3) yes, that's what I was thinking
19:29:37 <gundalow> #action gundalow https://docs.ansible.com/ansible/latest/community/development_process.html refactor should include https://help.github.com/articles/fork-a-repo/# etc
19:29:39 <shaps> Why make the 'release cycle' a top level heading?
19:29:41 <felixfontein> I wish they would make an easy to use UI for Step 3. I think that would help *a lot* of people
19:29:59 <samccann> from there, we compare the new 'how can I help' section with the old one (#1) above, and decide if anything else needs to be added to the new 'how can I help'.
19:30:03 <gundalow> I'll do ^ action in a separate PR, that's a lot of work needed on that page
19:30:45 <shaps> felixfontein, I just have a script to sync the forks
19:31:05 <gundalow> samccann: Not all of `Understanding Ansible's release cycle:` are things that contributors do, some things are info (everything apart from how do I request a bugfix gets backported
19:31:05 <shaps> but yeah, agree step 3 is a pain if you don't know what's happening
19:31:40 <gundalow> oh shaps ^
19:32:08 <shaps> then, yeah, I guess that could be top level, and momve the backport under the how an I help?
19:32:09 <felixfontein> shaps: something for rebasing in general would be nice. that's really hard for people which don't really now git...
19:32:55 <shaps> felixfontein, yep
19:32:55 <apple4ever> Rebasing can be very confusing
19:34:08 <gundalow> OK, so to step back a bit. This PR is about making the existing content easy to find. After this we can work on a) How to review a PR b) simplified PR process (which is where the GitHub links go)
19:34:40 <shaps> +1
19:35:01 <samccann> gundalow: so maybe the 'understanding Ansible's Release cycle' gets moved to 'Further learning' or 'Developers' section - some place for more advanced contributors to find it
19:35:53 <gundalow> maybe, though I've like more people to understand the importance of staying current
19:35:57 <gundalow> ie using latest releases
19:37:01 <gundalow> s/Understanding Ansible's development process/How can I help/
19:37:32 <gundalow> Move ` Understanding Ansible's release cycle:` under "Further info"
19:37:51 <gundalow> maybe that?
19:38:55 <samccann> +1
19:39:28 <shaps> +1
19:40:45 <gundalow> cool, thanks, made notes
19:42:05 <acozine> I published gundalow's branch to our test site
19:42:08 <acozine> http://docs.testing.ansible.com/ansible/latest/community/index.html
19:42:25 <gundalow> acozine: Ace, thank you
19:42:49 <acozine> vs. current published version for comparison purposes: https://docs.ansible.com/ansible/devel/community/index.html
19:43:03 <gundalow> Q: Does any of https://docs.ansible.com/ansible/devel/community/how_can_I_help.html highlighting on `community/index.html`?
19:44:42 <acozine> Maybe a link for "I'm not sure how to contribute, can you give me some ideas?"
19:44:49 <acozine> that's pretty much what that page is
19:45:06 <samccann> or "easy ways you can contribute"
19:45:06 <acozine> a laundry list of ways to contribute, with links to more detailed info elsewhere
19:45:26 <acozine> samccann: ++ nice phrase
19:45:31 <samccann> would be nice, down the road, if we could tie that into PRs/issues with an easyfix label too
19:46:53 <acozine> oh, good idea
19:46:59 <misc> IIRC, Fedora has a website that direct people on how they can contribute by asking question, maybe a idea to borrow ?
19:47:03 <gundalow> I like "easy ways you can contribute", I'll put that at the top as well
19:47:29 <samccann> misc: yeah that's were my vague memory was pulling ideas from :-)
19:48:39 <gundalow> I have another meeting in 12 minutes
19:48:52 <acozine> ultimately I'd like to unify the "voice" and point-of-view of the page, but this is a really good start
19:49:08 <acozine> gundalow: you are Meeting Man
19:49:12 <misc> ( https://whatcanidoforfedora.org/en#designexclamation )
19:49:36 <gundalow> Would anyone be interested in fleshing out the "How to review & test a PR" document: https://docs.google.com/document/d/1nMevQ0W7MZgJA1tJrJbNHIhTiHYHYUlO3IHXBs_usGE/edit?ts=5be2cd87#heading=h.kzxzqyez5fp5
19:49:40 <misc> I kinda wonder if asking what people want to get by contributing would change the dynamic
19:50:17 <samccann> misc: fancy page! but yes, I like that focus - do I want to code, write, help w. community etc.
19:50:45 <gundalow> misc: interesting, eventually I'd love for a high level page (with nice pictures) on I want to do x
19:50:48 <acozine> misc: motivation is a fascinating topic - I don't really understand what most people are looking for
19:51:19 <acozine> the folks I've asked have mostly said, "bragging rights from a merged PR" but I don't know how widespread that motivation is
19:53:22 <gundalow> OK
19:53:26 <gundalow> #topic Open Floor
19:53:29 <gundalow> Anything else?
19:54:00 <gundalow> Anyone got anything they are/would like to work on that will help the effort?
19:54:03 <gundalow> #chair
19:54:03 <zodbot> Current chairs: acozine dmsimard felixfontein gundalow misc samccann shaps
19:54:51 <shaps> gundalow, I'll be looking at the bot, not sure how much that helps the general effort :D
19:55:22 <gundalow> shaps: making people aware of this & Working Group meetings is a good thing (tm)
19:55:42 <shaps> hehe
19:55:48 <shaps> spammybot :D
19:56:02 <misc> acozine: myself, that's either "do my job", or "keep my skills fresh", which is "bragging about PR but on a CV" :p
19:56:34 <shaps> ^ +1 to that
19:56:44 <misc> but highlighting what people do get by contributing likely help them seeing as beneficial for them and maybe push them to continue (but I do not have any empirical data on that)
19:57:41 <acozine> yup - I'd really like to get a survey going . . . but not this week
19:58:53 <gundalow> Building up Working Groups is very much within the remit of this team (and on the list)
19:59:17 <gundalow> One thing I'd like to do, and not sure if it would be in here, or elsewhere, is to do some new_contributor PR review
19:59:20 <acozine> many keyboards make light work . . . and also good code and docs
19:59:28 <gundalow> Yes!
20:00:28 <felixfontein> yeah, some new_contributor PR review wouldn't hurt
20:01:06 <felixfontein> that would help the new contributors, and we might learn something with what they have trouble :)
20:01:14 <shaps> got to go now, see y'all
20:01:19 <acozine> bye shaps
20:01:34 <acozine> gundalow: are we done for this week?
20:01:39 <gundalow> Yup
20:01:44 <gundalow> Thanks y'all
20:01:48 <gundalow> Really useful as always
20:01:53 <gundalow> Comments on the PR welcome
20:01:56 <gundalow> #endmeeting