19:00:18 <gundalow> #startmeeting Ansible Contributor Experience Working Group
19:00:18 <zodbot> Meeting started Thu Jan 10 19:00:18 2019 UTC.
19:00:18 <zodbot> This meeting is logged and archived in a public location.
19:00:18 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:18 <zodbot> The meeting name has been set to 'ansible_contributor_experience_working_group'
19:00:25 * gundalow waves
19:00:28 <gundalow> Who's around?
19:00:35 <ChrisShort> here
19:01:00 <gundalow> #chair ChrisShort
19:01:00 <zodbot> Current chairs: ChrisShort gundalow
19:03:40 <gundalow> dag: felixfontein shaps spredzy Xaroth You around?
19:03:42 <agaffney> here...sort of
19:03:56 <gundalow> agaffney: hey :)
19:04:15 * gundalow talks and will put stuff in the logs
19:04:26 <gundalow> Hope everybody had a good Christmas
19:04:53 <gundalow> #info Agenda https://github.com/ansible/community/issues/390#issuecomment-453070703
19:05:05 <gundalow> #topic Webinar: How to Make Your Mark: Ansible Community Contributions
19:05:21 <gundalow> #info Webinar info & sign up page https://www.ansible.com/resources/webinars-training/ansible-community-contributions
19:06:43 <gundalow> #info acozine and myself will be doing a presentation at the end of the month on Contributing to Ansible. Aim of this is to encourage new contributors and direct people to give useful contributions. Detail the various ways to contribute, and that you don't need to be a Python export
19:07:02 <gundalow> How to attract new contributors
19:07:03 <gundalow> Showing community Progress
19:07:03 <gundalow> What do people need to know/motivate to get them contributing
19:07:03 <gundalow> Big PR review days
19:07:03 <gundalow> What other topics should we cover?
19:08:28 <Xaroth> I may be around in a bit
19:09:45 <ChrisShort> I don't have any additional suggestions. I can help review content as needed too.
19:09:55 <gundalow> ChrisShort: Most kind thank you
19:10:06 <gundalow> I need to start drafting
19:11:22 <gundalow> #info Will also give this as a cutdown 10 minute version at London's Ansible Automates a few days before
19:12:45 <gundalow> What is the Ansible Community
19:12:45 <gundalow> What do we do
19:12:45 <gundalow> What have we done
19:12:45 <gundalow> What is Core's responsibility, what isn't
19:12:45 <gundalow> How the Ansible Community works - talk about scale
19:12:46 <gundalow> Adding +1 doesn't help, test PRs, give feedback
19:12:46 <gundalow> Gives us the confidence to merge
19:12:47 <gundalow> Horizontal community, not vertical
19:13:03 <kenp> For "How to attract new contributors", what got us involved was a talk by John McDonough from Cisco, he does a "making an Ansible module" at every Cisco show and also at SXSW this year doing the same talk..
19:13:43 <gundalow> kenp: oh I saw his presentation at Austin, I'll take a look at his presentation, thanks for the suggestion
19:14:02 <gundalow> #action gundalow Look at John McDonough (Cisco) presentation from Austin
19:14:59 <gundalow> It's my first day back, I'll start a draft outline online so people can see and contribute
19:15:07 <gundalow> #chair agaffney Xaroth kenp
19:15:07 <zodbot> Current chairs: ChrisShort Xaroth agaffney gundalow kenp
19:16:55 <gundalow> #action gundalow put presentation outline somewhere public
19:17:05 <gundalow> #info If you have ideas let me know
19:17:13 <gundalow> #topic New Working Groups
19:17:36 <gundalow> #info New AIX Working Group: https://github.com/ansible/community/issues/421
19:17:50 <gundalow> #info New Solaris Working Group: https://github.com/ansible/community/issues/422
19:18:17 <gundalow> misc: Were you just interested in POWER/RHEL, or POWER/AIX as well? ^
19:19:35 <gundalow> I'm not liking https://docs.ansible.com/ansible/devel/community/communication.html#working-groups (even though I created it), I wonder if having a new page
19:19:35 <gundalow> * Describe the purpose of Working Groups
19:19:35 <gundalow> * Better links and details of what they are doing
19:19:35 <gundalow> * Link to docs on how to create a working group
19:19:37 <gundalow> Would be good
19:20:05 <gundalow> Anyone got anythign else?
19:20:40 <gundalow> Guess people are busy getting back into $day_jobs after having time off. I hope the notes above are useful for people reading scroll back. Feel free to continue the discussion here
19:20:46 <ChrisShort> Just that you're the best Gundalow I know
19:20:58 <gundalow> ChrisShort: and worst :
19:21:00 <gundalow> :P
19:21:12 <gundalow> #topic GitHub improvements
19:21:21 <ChrisShort> False: I only know the good you. Happy 2019!
19:21:26 <shaps> Hey, sorry yes I'm kind of around now
19:21:31 <gundalow> #info GitHub: General, Ansibullbot & Scaling issues https://github.com/ansible/community/issues/357
19:22:21 <gundalow> #info I've made contact with one of the Program Managers at GitHub and going to go through https://github.com/ansible/community/issues/357 with them. So any ideas of what may make our GitHub lives easier please add to #357 (or discuss in #ansible-community)
19:23:37 <gundalow> shaps: All good, anything from you?
19:23:50 <gundalow> shaps: Thank you for all your help with the London Meetup this week
19:25:38 <gundalow> Will #endmeeting shortly if there isn't anything else
19:26:24 <kenp> one sec....
19:26:53 <kenp> For a module want to do, we want to upload a firmware image to our box to update it via https. I did not see a way from the existing Anasible built in open_url and wanted to use the request module, is that frowned upon and cause for rejestion ?
19:27:03 <kenp> sorry, if its the wrong place to bring this up.
19:28:39 <gundalow> kenp: Best to ask that in #ansible-devel
19:28:51 <kenp> no worries, thanks
19:29:10 <gundalow> There maybe occasions where it is right to use `request`, or maybe we can update Ansible to support what you need
19:29:26 <kenp> will ask there, thanks for the direction.
19:29:50 <gundalow> nps
19:29:57 <gundalow> Anyone got anything else?
19:32:54 <gundalow> Thanks y'all
19:32:58 <gundalow> #endmeeting