18:59:57 <gundalow> #startmeeting Ansible Contributor Experience Working Group
18:59:57 <zodbot> Meeting started Thu Jan 17 18:59:57 2019 UTC.
18:59:57 <zodbot> This meeting is logged and archived in a public location.
18:59:57 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:59:57 <zodbot> The meeting name has been set to 'ansible_contributor_experience_working_group'
19:00:07 <gundalow> bah, 1 minute early :(
19:00:21 * gundalow waves
19:00:26 <gundalow> Xaroth: Hi :)
19:00:34 <gundalow> Who else is joining today?
19:02:23 <alongchamps> I'm new so I'm here to get a feel for things, but mostly lurking
19:02:41 <Xaroth> Hi :)
19:03:25 <gundalow> alongchamps: Welcome. Thank you for joining. Please do shout out at any point, this is all very informal, and more importantly this is *your* meeting and chance to raise ideas/challanges etc
19:03:59 <gundalow> #chair Xaroth alongchamps
19:03:59 <zodbot> Current chairs: Xaroth alongchamps gundalow
19:04:18 <gundalow> #info Agenda https://github.com/ansible/community/issues/390 (feel free to add things)
19:04:21 <alongchamps> all right, sounds good
19:04:32 <gundalow> I have two topics 1) Molecule 2) Webinar
19:04:52 <gundalow> alongchamps: How about yourself? What brings you here what are you hoping to get out of this?
19:05:10 <gundalow> Xaroth: welcome back, what would you like to discuss today?
19:05:22 <Xaroth> I never left? :P
19:05:34 <gundalow> haha
19:05:37 <alongchamps> I'm mostly just getting a feel for community and processes. I'm a VMware admin by day and possibly looking at using ansible to config manage our VMware spaces which may also include new modules that don't exist quite yet
19:06:03 <gundalow> alongchamps: oh, are you aware of #ansible-vmware
19:06:07 <alongchamps> yup
19:06:27 <gundalow> Cool, just didn't see you in there. They have regular meetings as well
19:06:43 <alongchamps> I just added it to my channel list :)
19:07:18 <gundalow> Xaroth: Anything you'd like to talk about today?
19:07:37 <gundalow> (Want to make sure we cover any of your stuff before I do the other bits)
19:07:50 <Xaroth> Not particularly, browsing through the agenda points of previous weeks
19:08:38 <gundalow> alongchamps: FYI we have a number of different Working Groups https://docs.ansible.com/ansible/devel/community/communication.html#working-groups
19:09:13 <alongchamps> thanks for sending that along, I have seen that page
19:09:14 <gundalow> #action gundalow update /communication.html to include AIX, Solaris and Molecule
19:09:31 <gundalow> #topic Molecule Working Group
19:09:39 <gundalow> #info Happy to announce that we now have a Molecule Working Group
19:09:49 <Xaroth> Woo
19:10:09 <gundalow> #info Molecule Agenda (and meeting link) https://github.com/ansible/community/issues/427 <- hit subscribe
19:10:19 <gundalow> #info Molecule is 1900UTC on Wednesdays
19:10:38 <gundalow> #undo
19:10:38 <zodbot> Removing item from minutes: INFO by gundalow at 19:10:19 : Molecule is 1900UTC on Wednesdays
19:10:50 <gundalow> #info Molecule meeting is 1900UTC on Wednesdays in #ansible-molecule
19:11:05 <gundalow> (so that's the same time as this meeting, just the day before)
19:11:31 <gundalow> #info If you are thinking What's Molecule- see https://molecule.readthedocs.io/en/latest/
19:11:41 <gundalow> #info Molecule is designed to aid in the development and testing of Ansible roles. Molecule provides support for testing with multiple instances, operating systems and distributions, virtualization providers, test frameworks and testing scenarios. Molecule is opinionated in order to encourage an approach that results in consistently developed roles that are well-written, easily understood and maintained.
19:12:01 <Xaroth> I should give that a whirl
19:12:42 <alongchamps> I'm going to take a look at that later myself for module testing
19:13:26 <gundalow> Really energetic community. The user-guide part of the docs need some work, though that's all doable
19:13:43 <gundalow> Xaroth: alongchamps Have you both heard of Molecule before/
19:14:03 <alongchamps> I haven't; I'm only a few weeks in to using ansible at all personally
19:14:07 <Xaroth> I have, before it merged with the ansible repos
19:14:40 <Xaroth> Never really gave it much thought, not much space in terms of time available to investigate
19:15:45 <gundalow> alongchamps: oh, very exciting. Feedback from people like yourself is *really* important to us so we ensure that it's easy for people to get started. There are loads of things that could be clearer, though unfortunately for people that have "been around a while", like myself we just don't see it anymore.
19:15:56 <gundalow> Xaroth: often the way :)
19:16:00 <alongchamps> I definitely know that feeling!
19:16:13 <gundalow> s/often/almost always/
19:17:16 <gundalow> Any other questions on Molecule?
19:17:17 <alongchamps> so can molecule be instructed to test combination A with combination B with combination C etc? Because if so, I think I just found a good way to spend an afternoon
19:17:22 <alongchamps> (reading docs on it now)
19:17:44 <Xaroth> gundalow: yeah, though I'm working on rebuilding my home lab/nas by making it fully ansible managed, hopefully allows me to experiment a bit with things like molecule
19:18:07 <gundalow> alongchamps: good question. I'm not that familiar with all the user-cases, hop in #ansible-molecule they will be able to help
19:18:18 <Xaroth> Though I might need to stop trying to make ansible do things it's not designed for first :P
19:19:11 <gundalow> Most tools can be used and abused
19:19:31 <gundalow> #info Join #ansible-molecule to find out more!
19:19:39 <gundalow> #topic Community Webinar
19:20:04 * gundalow spies bizonk JohnLieske and thedoubl3j
19:20:18 <thedoubl3j> :wave:
19:20:59 <gundalow> #info on Wed, Jan 30, 2019 9:30AM EST we will be hosting `How to Make Your Mark: Ansible Community Contributions` online webinar
19:21:10 <gundalow> #info signup via https://www.ansible.com/resources/webinars-training/ansible-community-contributions
19:21:13 <Xaroth> Cool
19:21:37 <gundalow> Would be interested to know what you think should be covered
19:22:51 <Xaroth> The lifetime of a or/issue, but I'm sure that's already on your list
19:23:59 <gundalow> oh, I've not actually got that specifically, i do have about labels, and maintainers. Though a little time line would be great
19:26:02 * JohnLieske waves to gundalow
19:27:05 <gundalow> #chair bizonk JohnLieske thedoubl3j
19:27:05 <zodbot> Current chairs: JohnLieske Xaroth alongchamps bizonk gundalow thedoubl3j
19:27:31 <gundalow> Xaroth: thanks, added to my notes
19:27:44 <gundalow> I've got a draft outline here https://docs.google.com/document/d/194Khkr7bABzKYWAjFtYwzJ7IS9dtrEjrxeBcuT-n5C4/edit?ts=5c3864c9# (mostly in note form)
19:29:55 <gundalow> Which I'll be working on over the next week
19:30:57 <gundalow> Cool, that's all I had
19:31:03 <gundalow> apart from one important announcement
19:31:10 <gundalow> #topic AnsibleFest 2019
19:31:16 <gundalow> I'm excited to announce that AnsibleFest Atlanta will be held September 24-26, 2019 https://www.ansible.com/ansiblefest will be updated as further details are announced.
19:31:29 <thedoubl3j> woot woot!
19:31:48 <JohnLieske> aww yiss
19:35:16 <gundalow> #info AnsibleFest Atlanta will be held September 24-26, 2019 https://www.ansible.com/ansiblefest
19:35:21 <gundalow> Anyone got anything else?
19:38:02 <gundalow> #chair
19:38:02 <zodbot> Current chairs: JohnLieske Xaroth alongchamps bizonk gundalow thedoubl3j
19:41:35 <thedoubl3j> nothing else from me. I like the idea for the webinar. hopefully see a couple of you all at fest if you are there!
19:41:52 <gundalow> :)
19:41:55 <gundalow> Cool,will close
19:42:08 <gundalow> Thanks for taking the time to join!
19:42:10 <gundalow> #endmeeting