#ansible-community: Ansible PR Review Day
Meeting started by gundalow at 10:00:30 UTC
(full logs).
Meeting summary
-
- So we've been crunching the numbers, if we can
close/merge just an extra 25 PRs/week then we will level out the
backlog. Anything over that and the PR backlog will start to
drop (gundalow,
10:02:31)
- label/needs_repo (gundalow, 10:03:25)
- https://github.com/ansible/ansible/labels/needs_repo
The source repo (branch) has been deleted. This means that any
changes can't be made. Often this indicates that the other isn't
around. Idea here is to close (gundalow,
10:04:09)
- https://github.com/ansible/ansible/pull/59872
New Windows module to chanage CDROM drive letter and unmount virt.
cdroms (gundalow,
10:04:47)
- ACTION: see if 59872
can be closed (gundalow,
10:08:25)
- https://github.com/ansible/ansible/pull/58170
VMware: vsphere_copy IndexError: tuple index out of range (gundalow,
10:08:50)
- https://github.com/ansible/ansible/pull/24111
feels abandoned to me. (mrproper,
10:10:29)
- ACTION: close
58170 (gundalow,
10:12:14)
- https://github.com/ansible/ansible/pull/24111
New module: Add Uptrends module. (monitoring/uptrends) (gundalow,
10:12:40)
- ACTION: close
24111 (gundalow,
10:14:05)
- https://github.com/ansible/ansible/pull/57042
make env setup faster (gundalow,
10:14:29)
- https://github.com/ansible/ansible/pull/12090
has an author who shows up once a year. But there’s been no movement
in a full year again. How do you feel about this situation (mrproper,
10:15:03)
- ACTION: close
57042 (gundalow,
10:16:39)
- https://github.com/ansible/ansible/pull/12090
Update cobbler.py inventory script to more fully leverage Cobbler
management fields (gundalow,
10:16:59)
- ACTION: BOTMETA add
maintainer for inventory/cobbler - Update 12090 (gundalow,
10:19:32)
- https://github.com/ansible/ansible/pull/56953
Update win_domain_group_membership.ps1 (gundalow,
10:21:12)
- ACTION: close 56953
(It's less of an issue in 2.8) (gundalow,
10:22:24)
- https://github.com/ansible/ansible/pull/55436
PR try 3 (gundalow,
10:22:40)
- ACTION: check with
Security Team, most likely close 55436 P (gundalow,
10:25:10)
- https://github.com/ansible/ansible/pull/54912
Create django_models.py (gundalow,
10:25:32)
- ACTION: ask others
about 54912, most likely close it (gundalow,
10:28:35)
- https://github.com/ansible/ansible/pull/54167
Return MAC address from Supermicro and HP systems (gundalow,
10:30:18)
- https://github.com/ansible/ansible/pull/53796
New module: Kibana saved object (gundalow,
10:32:50)
- https://github.com/ansible/ansible/pull/51668
Added OS families (gundalow,
10:34:52)
- https://github.com/ansible/ansible/pull/51371
flatpak: Open subprocess in text stream mode (gundalow,
10:36:13)
- https://github.com/ansible/ansible/pull/50454
Issue #41447 - support AWS Aurora S3 privileges in mysql_user module
(gundalow,
10:39:01)
- https://github.com/ansible/ansible/pull/47980
scap facts module (gundalow,
10:43:01)
- https://github.com/ansible/ansible/pull/44981
VMware: Add error checking for networking (gundalow,
10:46:10)
- https://github.com/ansible/ansible/pull/42106
Update lambda.py (gundalow,
10:49:27)
- https://github.com/ansible/ansible/pull/41653
add master_ssl_verify_identity to mysql_replication (gundalow,
10:51:04)
- https://github.com/ansible/ansible/pull/40411
Add support for GitHub Enterprise for github_deploy_key (gundalow,
10:54:37)
- https://github.com/ansible/ansible/pull/40003
Update cron.py (gundalow,
11:00:35)
- https://github.com/ansible/ansible/pull/36096
Same bugfix as #30121 (gundalow,
11:04:23)
- https://github.com/ansible/ansible/pull/32930
Windows Facts: add WinSystemLocale (gundalow,
11:07:40)
- https://github.com/ansible/ansible/pull/32571
Add aci_bd_dhcp_label.py (gundalow,
11:11:07)
- https://github.com/ansible/ansible/pull/32549
refactored gen_candidate_chars out to common; hashi_vault generating
passwords (gundalow,
11:11:25)
- https://github.com/ansible/ansible/pull/32158
iptables: chain creation and deletion (gundalow,
11:13:57)
- https://github.com/ansible/ansible/pull/30653
Changed 'plugins/json_query.py' to use jebabin's solution to issue
#27299 (gundalow,
11:17:55)
- https://github.com/ansible/ansible/pull/28474
Add sql_log_bin option to mysql_db module (gundalow,
11:20:17)
- https://github.com/ansible/ansible/pull/27431
closed. I found a new PR that doing the same thing (gundalow,
12:26:49)
- needs_repo has been reviewed. We've
closed/merged 25 (gundalow,
13:00:38)
- owner_pr & small_patch (gundalow, 13:01:13)
- https://github.com/ansible/ansible/issues?utf8=%E2%9C%93&q=is%3Aopen+label%3Asmall_patch+label%3Aowner_pr+-label%3Abackport
(gundalow,
13:01:24)
- https://github.com/ansible/ansible/pull/58816
bitbucket_access_key: Fix Python 2.7 compat (gundalow,
13:05:42)
- https://github.com/ansible/ansible/pull/58089
win_package - Test to solve quotes issues (gundalow,
13:06:20)
- https://github.com/ansible/ansible/pull/55253
jenkins_plugin: Read update file as UTF-8 (fixes #55250) (gundalow,
13:11:44)
- https://github.com/ansible/ansible/pull/52017
elb_application_lb: Fix required_together statement -
access_logs_s3_prefix is not requir… (gundalow,
13:12:57)
- https://github.com/ansible/ansible/pull/39175
Support new mongodb versions in check_compat function (gundalow,
13:14:40)
- https://github.com/ansible/ansible/pull/32912
Fix missing pass of IPXe params to API client call, fixes #32910
(gundalow,
13:21:19)
- small_patch NOT owner_pr (gundalow, 13:22:37)
- https://github.com/ansible/ansible/issues?utf8=%E2%9C%93&q=is%3Aopen+label%3Asmall_patch+-label%3Aowner_pr+-label%3Abackport+
(gundalow,
13:22:43)
- https://github.com/ansible/ansible/pull/61686
Fix examples for bigip_file_copy (gundalow,
14:37:12)
- https://github.com/ansible/ansible/pull/61668
github_deploy_key: Clarity on mutual exclusion of Username and Token
(gundalow,
14:39:55)
- https://github.com/ansible/ansible/pull/61668/files
looks good though I'm not going to bother backporting it (gundalow,
14:41:07)
- https://github.com/ansible/ansible/pull/61660
YAML parser - set source file position for vault encrypted strings
(gundalow,
14:43:42)
- https://github.com/ansible/ansible/pull/61657
Remove unnecessary information about amount of actions in the meta
module (gundalow,
14:45:52)
- https://github.com/ansible/ansible/pull/61656
Update unit tests requirements/units.txt path (gundalow,
14:47:52)
- https://github.com/ansible/ansible/pull/61655
Fix creation of DigitalOcean droplets using digital_ocean_droplet
module (gundalow,
14:49:40)
- https://github.com/ansible/ansible/pull/61561
resmo Thank you for all you've done and continue to do! (merged with
sadness) (gundalow,
14:56:23)
- https://github.com/ansible/ansible/pull/61556
net_user documentation typo configured_password (gundalow,
14:57:13)
- https://github.com/ansible/ansible/pull/61552
docs: Update apt_key.py add requirements of gpg (gundalow,
15:00:33)
- https://github.com/ansible/ansible/pull/61493
Fix bug preventing wait_condition from being respected when using
apply (gundalow,
15:04:06)
- ACTION: merge
61493 (gundalow,
15:04:18)
- https://github.com/ansible/ansible/pull/61430
Add mount_point option to approle login (gundalow,
15:05:16)
- https://github.com/ansible/ansible/pull/61651/files
merged (with `pr_day` label added) (samccann,
15:05:32)
- https://github.com/ansible/ansible/pull/61667/commits/1fa6f99f044256fc1c52104a55388843f3a13dc5#diff-f304419db157dd40f7accc8a752da63bR979
(resmo,
15:18:13)
- https://github.com/ansible/ansible/pull/61667/files#diff-d4f6bc58692a5a4858ccfeae3b7c458eL88
(acozine,
15:19:52)
- https://docs.ansible.com/ansible/2.6/dev_guide/developing_modules_documenting.html#formatting-functions
(gundalow,
15:29:20)
- https://github.com/ansible/ansible/pull/61060
Add caution about handlers & import to Pitfalls (docs) (gundalow,
15:34:46)
- https://github.com/ansible/ansible/pull/18583
been asked for rebas 2017, 2018. I think I'll close (gundalow,
16:09:01)
- https://github.com/ansible/ansible/pull/22765
closing (gundalow,
16:12:17)
- https://github.com/ansible/ansible/pull/60112#pullrequestreview-271678361
(acozine,
16:14:11)
- https://github.com/ansible/ansible/pull/30467
adding the `ansiblefest` label, need testing though I think should
be good (gundalow,
16:16:28)
- https://github.com/ansible/ansible/pull/39557/files
looks sensible, I've retriggered CI (gundalow,
16:24:16)
- https://github.com/ansible/ansible/pull/59144/files
(acozine,
16:29:28)
- https://github.com/ansible/ansible/pull/59144
(acozine,
18:40:40)
- https://github.com/ansible/ansible/pull/60881/files
(acozine,
19:13:25)
- 51 PRs closed/merged. I'm sure a few more will
click through in the next day or so. Great work everybody
(gundalow,
19:55:00)
Meeting ended at 19:55:06 UTC
(full logs).
Action items
- see if 59872 can be closed
- close 58170
- close 24111
- close 57042
- BOTMETA add maintainer for inventory/cobbler - Update 12090
- close 56953 (It's less of an issue in 2.8)
- check with Security Team, most likely close 55436 P
- ask others about 54912, most likely close it
- merge 61493
People present (lines said)
- gundalow (230)
- acozine (147)
- samccann (45)
- felixfontein (29)
- shaps (28)
- mrproper (15)
- agaffney (13)
- resmo (11)
- tremble (7)
- zodbot (6)
- Xaroth (6)
- dmsimard (4)
- bcoca (4)
- halberom (2)
- gwmngilfen (1)
Generated by MeetBot 0.1.4.