10:57:51 <gundalow> #startmeeting Ansible Contributors Summit
10:57:52 <zodbot> Meeting started Mon Jul  6 10:57:51 2020 UTC.
10:57:52 <zodbot> This meeting is logged and archived in a public location.
10:57:52 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:57:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
10:57:52 <zodbot> The meeting name has been set to 'ansible_contributors_summit'
10:58:35 <gundalow> #chair abadger1999 gregdek jimi|ansible phips rbergeron cybette felixfontein andersson007_ shaps
10:58:35 <zodbot> Current chairs: abadger1999 andersson007_ cybette felixfontein gregdek gundalow jimi|ansible phips rbergeron shaps
10:58:51 <gregdek> mmmornin
10:58:53 <gundalow> #info Agenda https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
10:59:02 <cybette> morning!
10:59:11 <jimi|ansible> o/
10:59:18 <jimi|ansible>10:59:32 <andersson007_> morning
10:59:38 <felixfontein> good day! :)
11:00:07 <felixfontein> is there already something to see or hear?
11:00:16 <misc> hi
11:00:48 <shertel> Hi
11:01:13 <misc> felixfontein: gundalow is on screen
11:01:23 <misc> and Carol
11:01:25 <abadger1999> Hello
11:01:43 <felixfontein> misc: in that case, there is, and it isn't working for me yet
11:02:48 <gundalow> felixfontein: https://bluejeans.com/617182211
11:03:18 <gregdek> There is an absurdly loud wren on my porch.
11:03:41 <felixfontein> gundalow: that's what I'm trying
11:03:50 <misc> you seems connected
11:03:56 <felixfontein> now I can see you!
11:03:57 <misc> did the popup about camera appeared ?
11:03:59 <gundalow> felixfontein: no one is speaking at the moment, though you should see video
11:04:23 <felixfontein> misc: I don't have a webcam anyway :)
11:04:30 <sshnaidm|ruck> so there is a time for bringing a coffee :)
11:04:41 <gundalow> sshnaidm|ruck: sure
11:05:01 <shaps> Morning all
11:05:16 <misc> ansible -i localhost, -c local -m coffee -a "state=present"
11:05:32 <gundalow> #chair misc shertel sshnaidm|ruck jimi|ansible
11:05:32 <zodbot> Current chairs: abadger1999 andersson007_ cybette felixfontein gregdek gundalow jimi|ansible misc phips rbergeron shaps shertel sshnaidm|ruck
11:06:20 <shaps> Yeah, I need caffeine too
11:07:09 <gregdek> Hello everyone!
11:07:10 <resmo> o/
11:07:14 * gregdek waves
11:07:18 <persysted> Hi all
11:08:18 <felixfontein> shaps: you just got up? :D
11:08:24 <cybette> #info Etherpad https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
11:08:38 <cybette> oops sorry for the repeat
11:08:46 <shaps> No that happened about 6h ago
11:08:53 <felixfontein> #topic Etherpad https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
11:08:56 <shaps> felixfontein: ^
11:08:58 <felixfontein> let's put it in the topic :)
11:09:04 <felixfontein> shaps: hehe, same here
11:10:24 <gundalow> #info Now doing Introductions: Who are you (real name & IRC/GitHub). What are you hoping to get from today
11:10:49 <gundalow> #info Ansible Code of Conduct https://docs.ansible.com/ansible/latest/community/code_of_conduct.html
11:11:05 <gundalow> #chair adev persysted resmo
11:11:05 <zodbot> Current chairs: abadger1999 adev andersson007_ cybette felixfontein gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo shaps shertel sshnaidm|ruck
11:11:33 <gundalow> adev: appreciate you getting up crazy early to join us
11:11:49 <jimi|ansible> adev: I'm central so not far off from you :)
11:11:55 <adev> happy to be hear, thanks :)
11:13:04 <shaps> I’ll join audio in a bit
11:13:35 <gregdek> A note: if you write things, we're always happy to share them on the Bullhorn :)
11:18:21 <gregdek> Here's the outline for the next one:
11:18:23 <gregdek> https://drive.google.com/drive/folders/1NDIQlx9olAYSTBfzwquhrFK9bKqP0YSG
11:19:35 <gundalow> #chair geerlingguy
11:19:35 <zodbot> Current chairs: abadger1999 adev andersson007_ cybette felixfontein geerlingguy gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo shaps shertel sshnaidm|ruck
11:19:54 * jimi|ansible needs more coffee in the ansible mug
11:19:58 * geerlingguy falls out of chair :D
11:22:55 <gundalow> #chair berkhan Im0_
11:22:55 <zodbot> Current chairs: Im0_ abadger1999 adev andersson007_ berkhan cybette felixfontein geerlingguy gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo shaps shertel sshnaidm|ruck
11:22:58 <gundalow> Welcome :)
11:23:02 <Im0_> G'day
11:23:10 <gundalow> Im0_: Good to see you again!
11:23:20 <berkhan> Good {morning,afternoon,evening}
11:23:31 <Im0_> Thanks gundalow... great to see a good time for Australia :) Thanks
11:24:05 <jimi|ansible> bonjour misc :)
11:24:44 <gundalow> #chair Pilou
11:24:44 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ berkhan cybette felixfontein geerlingguy gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo shaps shertel sshnaidm|ruck
11:29:39 <baptistemm> Hi there also
11:29:46 <gundalow> #chair tcraxs
11:29:46 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ berkhan cybette felixfontein geerlingguy gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo shaps shertel sshnaidm|ruck tcraxs
11:30:15 <gregdek> cybette: a request for swag for our next contributor summit: actual Angry Spuds https://www.anonymouspotato.com/
11:30:35 <cybette> gregdek: noted!
11:30:39 <gundalow> Yes, everybody. Please do feel free to ask question at anypoint. One of the advantages of IRC is that questions can be asked at anypoint
11:31:08 <gundalow> #action cybette actual Angry Spuds https://www.anonymouspotato.com/
11:32:45 <gundalow> #topic Recap of what we are doing and why
11:37:14 <geerlingguy> lol it looks like they just glue a photo onto a potato and stick it in the mail. /me was half hoping it was some sort of laser etching
11:37:40 <jimi|ansible> potato ink jet printer
11:37:53 <gregdek> We won't know until we give it a shot!
11:38:17 <gregdek> (and lol that cybette took it as an actual action)
11:38:32 <gregdek> (not mad about it tho)
11:39:04 <gundalow> #info Some info on Collections https://github.com/ansible-collections/overview/blob/master/README.rst
11:39:25 <gundalow> jimi|ansible: would you be able to talk about ansible-base shortly?
11:39:38 <gundalow> abadger1999: would you be able to talk about the new `ansible` package after jimi?
11:39:49 <jimi|ansible> gundalow: yes
11:39:52 <abadger1999> Yep
11:40:29 <berkhan> What is going to happen to modules like Xen? Are they going to stay in the General repository?
11:41:32 <sshnaidm|ruck> Is package name of https://github.com/ansible/ansible will be "ansible-base" and not "ansible"?
11:41:43 <gregdek> sshnaidm|ruck: that is correct.
11:42:01 <gregdek> We recognize the mismatch between repo name and package name, but we can't change everything at once. :)
11:42:13 <jimi|ansible> sshnaidm|ruck: both will exist, but you will be able to continue doing `pip install ansible` though with no changes
11:42:14 <sshnaidm|ruck> and no other repo which package name would be "ansible"?
11:42:44 <felixfontein> sshnaidm|ruck: there's no real "content" in the (new) ansible package that's not living somewhere else already
11:42:49 <jimi|ansible> if you did `pip install ansible-base` you would get the core engine only with no modules/plugins other than what we include with the core engine
11:43:09 <felixfontein> sshnaidm|ruck: the ansible package will be built by antisbull-build: https://github.com/ansible-community/antsibull
11:43:36 <sshnaidm|ruck> felixfontein, oh, nice, didn't see it before
11:43:44 <felixfontein> sshnaidm|ruck: the collections are each in their own repo, ansible-base is a dependency of ansible, and the remaining few files that are added are either contained in the antsibull repo, or are generated by scripts in it
11:43:55 <sshnaidm|ruck> jimi|ansible, I just mean "names" conflict, it makes us a little pain :)
11:44:14 <gundalow> #topic ansible-base
11:44:31 <gundalow> #info jimi|ansible is now give an overview of `ansible-base`
11:45:02 <berkhan> Will Ansible have built-in and default testing method? I'm very sad that Ansible doesn't have a set of testing methods that works like Kitchen CI.
11:45:14 <gundalow> #info `pip install ansible` will continue to give you a working Ansible setup (Core Engine plus modules). `ansible` depends on the new `ansible-base` package
11:45:59 <geerlingguy> berkhan: There is ansible-test, though its goals are slightly different than Kitchen CI. There's also molecule, which is (IMO) a little closer to Kitchen.
11:46:04 <abadger1999> jimi|ansible: How many/what type of modules are staying in ansible-base?
11:46:18 <berkhan> Yeah, thanks
11:46:50 <geerlingguy> jimi|ansible: is there any criteria for including any _new_ modules in core at some point? Or is the list that's in core pretty much set in stone now?
11:46:58 <gundalow> #info use-cases and criteria for modules being kept in `ansible-base` https://github.com/ansible-collections/overview/blob/master/README.rst#q-what-exactly-is-ansible-base-for-and-what-does-it-contain
11:47:26 <berkhan> We are using Molecule 3.0 and not good at edge-cases we have. We had to move one step back and use Kitchen CI
11:48:10 <geerlingguy> jimi|ansible: also, can a collection override a core plugin?
11:48:45 <geerlingguy> (could be useful for patching something in core (e.g. if waiting for a PR to land))
11:48:56 <berkhan> I'm also curious, will Molecule stay outside of main Ansible development?
11:49:07 <sshnaidm|ruck> zbr, ^
11:49:08 <felixfontein> if you use FQCN in playbooks/roles, I think it is hard to override it
11:49:52 <felixfontein> FQCN = ansible.builtin.xxx for buitlin modules/plugins
11:52:26 <sshnaidm|ruck> to clear up - if I have "copy" module in my collection and use "collections" keyword in playbook, what will run in "copy" task?
11:52:46 <baptistemm> I have a question / feedback later about how triage bugs/pr is hard. github interface is not really easy to use and it's not possible to move issue / pr to collections repositories
11:52:51 <zbr> berkhan: not sure what you mean but comparing molecule (testing tool) with a CI system does not make a lot of sense to me
11:53:29 <felixfontein> sshnaidm|ruck: depends on what you specify in `collections` :) if your collection comes before before ansible.builtin (or that one doesn't come in the list), the copy module from your collection should be used
11:53:56 <sshnaidm|ruck> felixfontein, that's scaring
11:53:58 <geerlingguy> baptistemm: that's a good topic of conversation. I think gundalow has been working on some sort of 'issue/pr move' thing that may be run on ansible/ansible soon
11:54:18 <felixfontein> sshnaidm|ruck: that's why using FQCNs has advantages ;)
11:54:29 <berkhan> Kitchen (https://kitchen.ci) is a tool which is used in Chef to test recipes. Molecule is doing the same thing but for Ansible and Ansible roles/collections. Thanks for the heads up zbr
11:54:49 * geerlingguy mmm someone mentions coffee
11:54:59 <baptistemm> ☕☕
11:55:23 * geerlingguy oh copy. First time I heard "coffee" and now you can tell where my mind is.
11:56:09 <geerlingguy> I think in the end, using FQCN explicitly will the the safest default going forward.
11:56:30 <geerlingguy> thought for later: autocomplete for editors somehow?
11:57:12 <geerlingguy> e.g. I type in `copy`, and my editor gives suggestions for `ansible.builtin.copy` and `my.collection.copy` (whatever's in the current scope). Might be a bit complicated to try to figure that out though.
11:57:18 <sshnaidm|ruck> felixfontein, but using fqcn for core modules is kinda weird
11:57:22 <felixfontein> is the `builtin` namespace in galaxy reserved? or can someone try to register it?
11:57:40 <geerlingguy> felixfontein: I remember we reserved `local`... looking up `builtin`
11:57:41 <felixfontein> sshnaidm|ruck: true. you could simply not use the `collections` keyword, then you're also on the safe side
11:58:01 <felixfontein> geerlingguy: who is "we"? :)
11:58:05 <sshnaidm|ruck> geerlingguy, yeah, I meant collection that makes coffee, but has also malware copy module :D
11:58:33 <sshnaidm|ruck> felixfontein, yeah, seems like it's more safe
11:58:37 <geerlingguy> felixfontein: heh... I think gundalow and I are owners of `local`. Builtin is not reserved, do you want me to open an issue requesting that?
11:58:38 <felixfontein> sshnaidm|ruck: (except of course modules in library/, that can still overwrite)
11:58:58 <resmo> is there already a target date for 2.10?
11:59:08 <resmo> will there be a freeze for colleciotns in ACD?
11:59:12 <felixfontein> geerlingguy: I think it's a good idea, so it's reserved by the core team (or the ansible organization or whomever)
11:59:31 <felixfontein> resmo: I think abadger1999 has a very tentative date for 2.10.0
11:59:49 <sshnaidm|ruck> +1 to reserve builtins
11:59:53 <gundalow> #topic new `ansible` package
12:00:27 <geerlingguy> felixfontein: https://github.com/ansible/galaxy/issues/2432 reservation for 'builtin'
12:02:08 <jimi|ansible> I remember discussing that back in the day but yeah I guess it was never done
12:02:10 <gundalow> #info You can test this today `pip uninstall ansible  --user && pip install ansible==2.10.0a2 --user`
12:02:19 <felixfontein> geerlingguy: thanks!
12:02:37 <gundalow> #action gundalow claim `builtin` https://github.com/ansible/galaxy/issues/2432
12:03:30 <geerlingguy> For ansible / ACD - will any new content be put into it in the future (e.g. 2.11, 3.0, etc.) or is it more or less locked and all new content will go into collections?
12:04:34 <abadger1999> geerlingguy: Good question, I'll answer that next.
12:05:51 <persysted> -1
12:05:52 <resmo> -1
12:05:54 <gregdek> -1
12:06:08 <baptistemm> +1
12:06:21 <geerlingguy> +1 https://github.com/geerlingguy/ansible-content-testing — been using that to test lots of the things I do regularly
12:06:24 <baptistemm> reported the pip installation bug
12:06:25 <rbergeron> now there are two :)
12:06:26 <baptistemm> :)
12:06:34 <gundalow> #Info we are really interested in if this new package "just works" for you.
12:07:00 <baptistemm> I got a problem with an openstack module that I reported to the developers
12:07:04 <resmo> NO WAY! ;)
12:07:17 <baptistemm> it will eat your machine
12:07:34 <sshnaidm|ruck> baptistemm, what is that?
12:08:48 * baptistemm hopes he did not forget to report
12:08:55 <rbergeron> Do we have a specific list of things that we should actually test for? :) aside from "does it break my existing universe"?
12:09:00 <geerlingguy> most crazy bug gets an angry spud spud
12:09:02 <gregdek> I think that's it!
12:09:07 <resmo> speaking of filter, fcqn for filters in community.general must be prefix with FQCN, there is no "routing", is there?
12:09:14 <gregdek> "Does it break all my old things when I run it"
12:09:21 <geerlingguy> rbergeron: I think the best test is uninstall 2.9.x, install 2.10 alpha, run playbook and see if it works
12:09:30 <gregdek> ^^^
12:09:33 <geerlingguy> (ideally not on a production environment first :D)
12:09:36 <felixfontein> resmo: I *think* there is routing for them too
12:09:40 <rbergeron> Or a list of "make sure x, y, and z work"
12:09:50 <felixfontein> resmo: but there's no shortcut like the `collections:` keyword
12:09:59 <rbergeron> Does it install properly, does it ... whatever. dance, party, etc
12:10:19 <felixfontein> abadger1999: when do you want to release a2 btw?
12:10:26 <abadger1999> felixfontein: a2 is out
12:10:33 <geerlingguy> rbergeron: I also confirmed cowsay is still working (since we're talking about important functionality like dance parties)
12:10:37 <felixfontein> abadger1999: ah, great!
12:10:59 <felixfontein> abadger1999: completely missed that :D
12:11:09 <rbergeron> I think that the task of "just test it with your stuff preferably not in production and does it work" might be cool for more experienced users, but some folks may actually want guidance or a set of "please try the following 5 things" with a bit of guidance
12:11:10 <gundalow> geerlingguy: :D
12:11:28 <rbergeron> ARE YOU A PROVEN COLLECTIONER
12:12:22 <geerlingguy> rbergeron: Sounds like a good topic for an Ansible blog post maybe — Ansible (ACD) 2.10 is coming, here's what we're testing and here's how you can install it...? (Or maybe just something in collections overview repo)
12:12:25 <felixfontein> I've tried some playbooks with devel (since routing PR got merged), so far I didn't found big problems (the only one I found got fixed already)
12:12:27 <abadger1999> felixfontein: I didn't announce it because I was doing all the things this weekend ;-)  But I did manage to get it posted on pypi.
12:12:34 <resmo> redhat collectioner certification ;)
12:12:46 <gundalow> Collections in the Ansible 2.10 package: https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd.in
12:13:00 * geerlingguy goes to see if domain acd.in is registered
12:13:14 <baptistemm> sshnaidm|ruck: sorry I forgot
12:14:02 <gundalow> #topic Collections in Ansible
12:14:07 <gundalow> #info Collections in the Ansible 2.10 package: https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd.in
12:14:09 <rbergeron> #idea from geerlingguy -- blog post on ansible 2.10 is coming, here's what we're testing and how you can install / help / etc.
12:14:31 <gundalow> #info Community collections: https://github.com/ansible-collections/
12:14:40 * rbergeron recollects that meetbot supports hashtag idea ;)
12:15:18 <gundalow> #info Community Collections on Galaxy https://galaxy.ansible.com/community
12:16:05 <baptistemm> sshnaidm|ruck: actually this is https://storyboard.openstack.org/#!/story/2007895
12:18:57 <berkhan> Will Xen related modules be moved from `ansible-collections/community.general` to a separate module and publish it under `ansible-collecitons/community.xen`?
12:19:35 <felixfontein> berkhan: probably depends on whether someone wants to maintain them there
12:19:55 <gregdek> +1 to quick break
12:20:01 <geerlingguy> Back in 15
12:20:12 <felixfontein> berkhan: everything that has no active maintainers, or no maintainers interested in a dedicated collections, will stay in community.general (sometimes called the "dumping ground" :) )
12:20:14 <geerlingguy> 7:35 US Central ;)
12:20:15 <misc> yes, a quick break to go back to DC being on fire
12:20:23 <jimi|ansible> yay for my being awake putting us ahead of schedule!
12:20:46 <geerlingguy> jimi|ansible++ the hero we deserve
12:20:56 <sshnaidm|ruck> baptistemm, ack, will look into
12:21:05 <sshnaidm|ruck> baptistemm, did you use the latest version from git?
12:21:29 <adev> has webchat.freenode.net stopped working for anyone else?
12:21:58 <felixfontein> misc: /19
12:21:58 <baptistemm> sshnaidm|ruck: no I use ansible-2.10.0a1
12:22:02 <felixfontein> oops sorry
12:22:08 <Im0_> What's the naming convention regarding ansible collections such as community.xen ?  Is it just one level deep?
12:22:10 <sshnaidm|ruck> baptistemm, I mean openstack modules
12:22:42 <baptistemm> sshnaidm|ruck: the ones provided inside this version https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd-2.10.0a1.deps
12:22:52 <baptistemm> openstack.cloud: 1.0.1
12:23:12 <baptistemm> If I understand correctly how ansible is built now
12:23:35 <cybette> adev: try reloading?
12:23:48 <felixfontein> Im0_: just one level, there's namespace and collection name separated by dot, nothing more
12:24:36 <sshnaidm|ruck> baptistemm, hmm.. are you sure it's 1.0.1? Please check
12:24:45 <misc> so to answer adev , yep, error 500 on my side (but they left before)
12:25:10 <jimi|ansible> geerlingguy / felixfontein I thought to reserve a namespace all we'd need to do is register that username on galaxy?
12:25:36 <jimi|ansible> I'm sure the galaxy devs could also do some hard-coding to make sure it's never allowed but that would be the easiest way?
12:25:37 <Im0_> felixfontein: so first in first served for clashing acronyms (can';t think of an example though)
12:25:37 <felixfontein> jimi|ansible: I haven't really understood yet how explicitly reserving a namespace is different from registering a user
12:25:57 <jimi|ansible> well you can make whatever namespace you want you just can't push it to galaxy :)
12:27:29 <sshnaidm|ruck> baptistemm, I'm afraid it's 1.0.0
12:29:34 <berkhan> Forgot to mention that but can we prefix Ansible play name? I have a solution where I write `name:` as `(template: CentOS/RHEL) enable sites`, so I know that that line will do something with template module on a CentOS/RHEL machine.
12:30:28 <felixfontein> Im0_: well, that will happen sooner or later... and first come first serve... I guess :)
12:30:40 <berkhan> Here is a sample snippet https://github.com/BerkhanBerkdemir/ansible-role-lighttpd/blob/master/tasks/main.yaml
12:31:20 <berkhan> I also would like to hear some thoughts on this _design_ decision I made.
12:33:23 <geerlingguy> felixfontein: registering a user doesn't create a namespace for that user anymore... I don't think?
12:33:34 <geerlingguy> I think all namespaces have to be created explicitly via an issue on the GH repo
12:34:09 <felixfontein> geerlingguy: good question. that solution sounds good to me :) I already wondered under which conditions you can get a namespace by registering a user (when earlier this year I noticed I already had one)
12:34:28 <geerlingguy> Older accounts were 'grandfathered' in since that's how it used to work
12:35:45 * shaps -> food
12:36:11 <felixfontein> geerlingguy: makes sense
12:36:56 * geerlingguy you need to take the blue pill to make the matrix accept you
12:38:58 * gwmngilfen waves
12:39:46 <gundalow> https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd.in
12:43:58 <gundalow> QUESTION: What should the criteria be to allow collections into the future ansible-2.11 package?
12:45:42 <geerlingguy> I know there are some criteria for collections that are "certified" or supported by Red Hat. Maybe a subset of that for a baseline?
12:46:18 <geerlingguy> (e.g. passes sanity tests with ansible-test, has complete documentation, etc.)
12:46:31 <baptistemm> +1
12:46:54 <sshnaidm|ruck> how do we know what are versions of collections are added to ansible 2.10 now?
12:47:00 <felixfontein> I wonder how long it will take until ACD will be 1 GB in size and contains almost everything that's on galaxy ;)
12:47:15 <felixfontein> sshnaidm|ruck: essentially the latest
12:47:17 <gregdek> #info Fedora proven packager policy for reference: https://docs.fedoraproject.org/en-US/fesco/Provenpackager_policy/
12:47:26 <gregdek> #info reminder that there is no ACD, only Ansible :)
12:47:27 <sshnaidm|ruck> felixfontein, how do I check it
12:47:30 <felixfontein> sshnaidm|ruck: until a point, form then on we stick to semver (2.11 will then have the latest again)
12:48:06 <geerlingguy> gregdek: I guess to that point, is there "Ansible" and "Ansible Base"? Or is the ansible you get installed with `pip install ansible` something else?
12:48:16 <resmo> since there is a way to install collections as a user, is it really the goal to expand acd? or wouldn't it make sense to engage users to use galaxy.ansible.com to install whatever they need?
12:48:30 <geerlingguy> (And of course "Ansible Automation Platform" which is kind of the umbrella of supported stuff
12:48:30 <felixfontein> gregdek: sorry, ACD is just a useful term to make clear we're not talking about ansible 2.9 or earlier ;)
12:48:38 <gregdek> :)
12:49:43 <gundalow> POLL: Should ansible-2.11 be allowed to massively expanded in terms of numbers of colections +1/-1 (feel free to add thoughts after your vote)
12:50:06 <abadger1999> The versions of ansible collections in 2.10.0a2: https://github.com/ansible-community/ansible-build-data/blob/main/2.10/acd-2.10.0a2.deps
12:50:34 <geerlingguy> +1 with condition: maybe not 'massively', but 'strategically' (e.g. don't just toss everything inside, but have a good process and guidelines)
12:50:40 <sshnaidm|ruck> abadger1999, thanks
12:51:03 <felixfontein> -1 I don't like massive! strategically is ok, but massive? please no :)
12:51:09 <berkhan> +1 agree with Geerling
12:51:43 <madonius> +1 though massive might be the wrong point
12:51:57 <abadger1999> +0
12:52:43 <TKersten> Agree with felixfontein and geerlingguy: Growth OK, but just growing for the sake of it -1.
12:53:17 <gregdek> Rather than a simple +1/-1, I think we need to use the 2.11 timeframe to clarify our policy for adding new content.
12:53:22 <geerlingguy> Is it possible for content to be *removed* in an Ansible 3.0
12:53:26 <adev> -1 for massive as well
12:53:28 <gregdek> I think it needs to be one of the key deliverables for that timeframe.
12:53:37 <geerlingguy> e.g. network collections or general stuff that has not been maintained for years and is pretty much broken
12:53:38 * baptistemm is afk
12:53:50 <sshnaidm|ruck> why to add to ansible instead of requirements.yml? to increase the visibility?
12:53:56 <gregdek> If the policy is good enough to allow "massive amounts of content" then fine. I suspect it won't be. :)
12:54:04 <abadger1999> sshnaidm|ruck: When we hit b1, I'll be making sure that updates to the collection version are backwards  compatible (according to semver) or explicitly requested by the collection owners (probably with a statement from them about backwards compatibility)
12:54:17 <geerlingguy> sshnaidm|ruck: I think mostly convenience and keeping the community Ansible experience "batteries included"
12:54:18 <felixfontein> geerlingguy: good question. inside collections, there's a deprecation phase. but deprecating collections in ACD doesn't really exist yet
12:55:07 <sshnaidm|ruck> abadger1999, sorry, backwards compatible with what?
12:55:57 <resmo> (how does a maintained collectoin look like?)
12:56:00 <felixfontein> sshnaidm|ruck: previous versions of the collection included in 2.10.x
12:56:21 <geerlingguy> resmo: Maybe "any of the maintainers have done anything with it in the past year" :D
12:56:26 <abadger1999> sshnaidm|ruck: With itself.... say community.network-1.0.0 is in ansible-2.10.0b1..... I would update it to community.network-1.2.2 but I would not update it to community-network-2.0.0 for 2.10.x
12:58:05 <rbergeron> "this is up for adoption!"
12:58:31 <resmo> gregdek: speaking of "forking" of unmaintained collections, that is not easy atm
12:58:32 <felixfontein> adopt this one, get another 5 for free!
12:58:57 <sshnaidm|ruck> abadger1999, so ansible 2.10 will have an older version of collection?
12:59:15 <resmo> everything that is not in gh/ansible-collection repositories
13:00:58 <felixfontein> resmo: I guess it more depends on the galaxy namespace than on the github namespace... if it is in the `community` galaxy namespace, but the repo is somewhere else, we could create a new one somewhere else
13:02:04 <gundalow> #topic Community Stats
13:02:48 <abadger1999> sshnaidm|ruck: Depending on the release schedule of the collection, yes.
13:02:49 <gundalow> #info Now over to gwmngilfen who's giving some details of how we use data and statistics to make informed decisions on Community health
13:02:56 <resmo> felixfontein: absolutely, I meant, everything not under redhat "control" must be hard forked, and there is no smooth process to do it
13:03:21 <abadger1999> sshnaidm|ruck: if the collection only releases backwards compatible versions, then the ansible package will keep up.
13:03:23 <gwmngilfen> wow, chromium
13:03:26 <felixfontein> resmo: true
13:03:28 <gwmngilfen> i said "crash" and it did
13:03:31 <geerlingguy> gwmngilfen: lol
13:03:37 <resmo> linux
13:03:55 <felixfontein> use firefox :D
13:04:02 <gwmngilfen> omg
13:04:08 <gwmngilfen> yeah, i will
13:04:08 <misc> gwmngilfen++
13:04:08 <zodbot> misc: Karma for gsutcliffe changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:04:15 <abadger1999> sshnaidm|ruck: But if the collection reduces backwards incompatible versions quickly, then the ansible package will be shipping older versions.
13:04:47 <sshnaidm|ruck> abadger1999, ack, just trying to think how the collection can be not backwards compatible with itself
13:05:05 <resmo> let's give him some time
13:06:16 <madonius> gwmngilfen: I hat similar behaviour with chrome and screensharing in M$-Meet the other day…
13:06:23 <gundalow> QUESTION: If this is your first Contributor Summit, how did you hear about it?
13:07:05 <felixfontein> sshnaidm|ruck: features can be removed, behavior of features changed, plugins/modules removed
13:07:45 <rosowiecki> gundalow I saw a mention about Summit in issue about main branch renaming
13:08:21 <sshnaidm|ruck> felixfontein, yeah, but you install a specific collection version that fully works. I'm not sure I understand the case with backward incompatibility
13:08:50 <felixfontein> sshnaidm|ruck: sometimes you want to upgrade to get bugfixes and/or new features. and newer versions might break something else.
13:12:02 <berkhan> Thanks for having us in this summit. See you on GitHub 👋️
13:12:31 <gundalow> berkhan: Thank you for your time
13:13:47 <gundalow> #info You can see the growth (in terms of unique contributors) to the collection repos at https://stats.eng.ansible.com/apps/collections/contributors/
13:16:39 <geerlingguy> gwmngilfen: so what you're saying is our backlog can be tracked like COVID and our Rt is currently above 1 :D
13:20:32 <felixfontein> geerlingguy: it's not that bad, the growth is not (yet) exponential :)
13:21:12 <felixfontein> community.network is currently somewhat worse than community.general (though also a lot less active)
13:21:26 <geerlingguy> 2.10 isn't out yet :D — we'll see what happens then! (Also we haven't moved issues/PRs from ansible/ansible yet)
13:22:43 <felixfontein> gundalow: we really need the bot for community.network too
13:23:28 <gundalow> Currently bot only runs on community.general
13:23:58 <shertel> gundalow: are there plans to extend it to other collections?
13:23:59 <gundalow> felixfontein: yup, I tried though got a load of backtraces. I can should probs focus on that this week
13:24:08 <gundalow> shertel: yup, whichever you want
13:27:53 <samccann> hello all!
13:28:31 <cybette> samccann: hi!
13:33:52 <geerlingguy> aww st. louis has fallen off to 2 in past year :(
13:36:54 <jimi|ansible> :'(
13:40:37 <gundalow> #chair samccann
13:40:37 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ berkhan cybette felixfontein geerlingguy gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
13:40:40 <gundalow> samccann: Morning :)
13:42:13 <baptistemm> #chair baptistemm
13:43:39 <gundalow> #chair baptistemm
13:43:39 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm berkhan cybette felixfontein geerlingguy gregdek gundalow jimi|ansible misc persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
13:45:13 <gundalow> #topic Meetups
13:45:15 <gwmngilfen> some graphs from my RStudio session:
13:45:19 * gwmngilfen uploaded an image: image.png (72KB) < https://matrix.org/_matrix/media/r0/download/matrix.org/KeCGJeyCUSDutaCKhlhAQVFo >
13:45:29 <gwmngilfen> (does that work in IRC? I use Matrix)
13:45:39 <shaps> gwmngilfen: yep
13:45:43 <gwmngilfen> thats the community.general backlog by day instead of by week
13:45:44 <gundalow> #info cybette (who looks after Ansible Meetups, events and outreach) gives an update on meetups
13:45:56 <gwmngilfen> which shows the levelling off more clearly
13:45:59 <gundalow> POLL: Who's attended an Ansible Meetup +1/-1
13:46:00 <gundalow> +1
13:46:04 * jimi|ansible -> brb, puppy bio-break
13:46:08 <felixfontein> +1
13:46:10 <sshnaidm|ruck> I don't have meetups in my area, just joining virtually in all I understand their language :D
13:46:12 <shaps> +1
13:46:32 <dmsimard> I attend and organize meetups ;)
13:46:37 <geerlingguy> +
13:46:39 <TKersten> These are the stats of the Ansible Benelux Meetup group https://github.com/tonk/ansible-benelux-meetup/blob/master/meetup_attendencee.pdf
13:46:41 <geerlingguy> +1
13:46:48 <gwmngilfen> @gund
13:46:52 <gwmngilfen> fail :/
13:46:55 <gwmngilfen> gundalow:
13:47:05 <gwmngilfen> does this count? because then we all have to answer +! :P
13:48:45 * gwmngilfen uploaded an image: image.png (54KB) < https://matrix.org/_matrix/media/r0/download/matrix.org/lkJoQjzdrlyouNBnrBcMdWYN >
13:48:54 <gwmngilfen> backlog for 62 collections, again we see the levelling off
13:49:08 <gwmngilfen> i'll stop interrupting Carol Chen now
13:51:58 <geerlingguy> Virtual meetup fatigue++ is real
13:52:14 <gundalow> QUESTION: How do we avoid "Virtual meetup fatigue"
13:52:58 <TKersten> That will be a hard one to solve, as a lot of people have a lot of virtual meetings right now.
13:53:14 <misc> I guess we could organize smaller group to participate to meetup
13:53:15 <gundalow> QUESTION: How can we make virtual meetups more fun. Can we replicate/replace the beer/pizza/swag element?
13:53:21 * gwmngilfen has been remote for 8 years, what is a non-virtual meeting again? :P
13:53:24 <misc> like, get with 1 or 2 friends for a virt meetup
13:53:42 <misc> (that's what Pilou and I did for the previous remote summit)
13:53:52 <gundalow> gwmngilfen: no pizza or beer (or BYOB)
13:53:54 <misc> and what folks do for CCC
13:54:13 <gundalow> CCC?
13:54:38 <misc> chaos computer congress
13:54:53 <resmo> misc: c3? undecided AFAIK
13:54:54 <gwmngilfen> i thought it was communication
13:54:55 * jimi|ansible back
13:54:57 <misc> since the event is full on a regular basis, people just organize remote watching and hacking from their hackerspace
13:55:03 <gwmngilfen> https://en.wikipedia.org/wiki/Chaos_Communication_Congress ?
13:55:09 <jimi|ansible> back just in time for break
13:55:10 <misc> which do permit to see people
13:55:17 <geerlingguy> break++
13:55:18 <misc> (that's the setup from previous years)
13:55:22 <sshnaidm|ruck> gundalow, maybe live discussions will make little bit more fun
13:55:57 <misc> gwmngilfen: indeed :)
13:56:04 <misc> (that's why I say CCC :p)
13:56:09 <gwmngilfen> C3
13:56:14 <sshnaidm|ruck> gundalow, short "elevator pitches" from participants maybe, so people will feel more involved
13:56:17 <misc> resmo: yeah, I do not know how they are going to do this year
13:56:18 <gwmngilfen> 33% less typing than CCC :P
13:58:59 <resmo> misc: have you been at c3 last year?
14:00:22 <misc> resmo: last year, nope
14:00:28 <misc> I think I went 2 years ago
14:00:52 <misc> last one was 36C3
14:01:10 <misc> mhh no, last year I got the oucher was 36C3
14:01:20 <misc> but I didn't go and passed it to someone, I think
14:02:01 <misc> (I would be bad in a horror movie, because I do not know what I did last winter, so no hope of knowing what I did last summer...)
14:12:27 <shaps> can't get my mic to work on bluejeans today :(
14:13:58 <gregdek> aw shoot
14:14:03 <gundalow> shaps: 1) Need to give browser permission 2) need to set the microphone in BlueJeans (cog)
14:14:25 <shaps> gundalow: yeah done that, no luck
14:14:36 <gundalow> shaps: otherwise you can click the down button next to the microphone and dial in via phone
14:19:40 <shaps> I'll try with a reboot see if makes things better, will switch to phone if not
14:19:43 <felixfontein> hi docs team! :)
14:19:58 <shaps> cybette: will be back in 10
14:20:41 * geerlingguy afk
14:22:07 <rbergeron> #link https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
14:22:38 <rbergeron> #topic Unconference Planning
14:23:01 <rbergeron> #link https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
14:23:14 <rbergeron> #info scroll down to Unconference section
14:23:32 <rbergeron> #info gregdek elaborated on "how this works"
14:23:48 <rbergeron> #info gregdek pitched session on "the bullhorn"
14:25:15 <rbergeron> #info carol pitches "virtual conferences" -- even though we can't meet in person, we should keep things going so we can stay connected, and what can we do virtually to make that happen?
14:26:47 <felixfontein> I hope that not everything will happen in parallel
14:27:05 <rbergeron> #info Testing -- noobdy volunteering?
14:27:32 <rbergeron> #undo
14:27:32 <zodbot> Removing item from minutes: INFO by rbergeron at 14:27:05 : Testing -- noobdy volunteering?
14:27:46 <rbergeron> #info multiple volunteers for Testing!
14:28:17 <felixfontein> k8s!
14:28:21 <rbergeron> #info Gundalow pitches "how to keep community collections moving"
14:29:08 <rbergeron> felix: throw it in the etherpad :)
14:29:32 <felixfontein> rbergeron: I meant as an example of active small collections :)
14:29:50 * geerlingguy afk again, back in a minute
14:31:27 <felixfontein> maybe not all ;) but definitely more than one
14:32:25 <gundalow> #action gundalow to fix Bot so links aren't to master
14:33:37 <felixfontein> `plugins` is a very generic term
14:35:10 * geerlingguy back
14:35:22 <geerlingguy> waitwhat???
14:35:26 <felixfontein> lol
14:35:37 <felixfontein> geerlingguy: congratulations, you got your session ;) :p
14:35:43 <samccann> heh
14:36:19 <gundalow> Line 83 https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
14:36:25 <geerlingguy> I'd rather not :)
14:36:53 * geerlingguy just went off to grab a donut hole and comes back to voluntoldedness!
14:37:47 <rbergeron> #info rbergeron possibly leading session on improving the proposal process assuming it is later in the day
14:37:59 <rbergeron> #info alicia pitching D&I session
14:39:11 <rbergeron> #info alicia pitching docs in the new world; what do people want, what strategies should we be adopting, what help do community members need, all topics around documentation
14:41:53 <felixfontein> I guess this needs input from some people from Ansible
14:42:02 <felixfontein> or the galaxy team
14:42:50 * madonius is off for now, maybe I will join later
14:42:53 <madonius> CU
14:43:01 <cybette> see you madonius
14:44:02 <felixfontein> madonius: bye!
14:44:50 <resmo> what si service now?
14:44:56 <gwmngilfen> NotReallyAnAction Carol to figure out shipping pizza to everyone
14:45:06 <geerlingguy> It's more quick than Service Later
14:45:08 <cybette> :D
14:45:20 <rosowiecki> I'm jus googling ServiceNow actually, never heard of it :D
14:45:27 <cybette> service soon(tm)
14:45:49 <gwmngilfen> service maybe
14:46:37 <felixfontein> `service: state=absent` ;)
14:46:43 <sshnaidm|ruck> how is service now related to ansible though?
14:46:49 <gwmngilfen> thats just wishful thinking
14:48:29 <geerlingguy> found the person still using 2.8!
14:48:31 <rosowiecki> General questions: how many of you people still use 2.7?
14:49:28 <abadger1999> sshnaidm|ruck: What are you looking from plugin development?
14:49:43 <felixfontein> free pizza?
14:49:49 <felixfontein> (not yet on the list)
14:50:06 <sshnaidm|ruck> abadger1999, improving docs so i don't need to reverse engineer :) licensing issues, best practices
14:50:32 <sshnaidm|ruck> abadger1999, although it's too general imho
14:50:37 <abadger1999> <nod>
14:50:38 <abadger1999> Yeah.
14:50:46 <felixfontein> rosowiecki: I'm using 2.9 and devel mostly
14:51:11 <abadger1999> I think we'll talk about some of those in the thing that gundalow is going to lead as a hackfest.
14:51:12 <rbergeron> #info robyn gave up on typing all the pitches
14:52:22 <gundalow> DING DING DING Please vote on what session's you'd like to join Line 76-87 https://etherpad.opendev.org/p/virtual-ansible-contributor-summit-july-2020
14:54:29 * felixfontein has to stop writing himself with `(when time permits)` to more topics...
14:55:45 <gundalow> :D
15:04:16 <sshnaidm|ruck> if this will be a parallel, it will be a tough choice
15:04:42 <gwmngilfen> yeah
15:04:56 <gwmngilfen> especially as i'm tangential to many areas :)
15:06:36 <geerlingguy> etherpad is so colorful now!
15:06:41 <geerlingguy> Also locked up and had to refresh
15:11:18 <felixfontein> we ALWAYS need more time :P
15:11:28 <gundalow> :D
15:12:52 <gundalow> #topic Community Collections contributor workflow
15:12:52 <maxamillion> o/
15:12:54 <gregdek> Always need to timebox :)
15:12:59 <maxamillion> sorry I'm super late to the party :)
15:13:02 <gregdek> hey maxamillion :)
15:15:41 <gundalow> QUESTION: What helps/hurts the Collections
15:16:04 <abadger1999> #info kubernetes experinces: 5-6 people driving it
15:16:14 <acozine> where are we taking notes on these sessions? here? in the Etherpad?
15:16:26 <gundalow> acozine: in here
15:16:29 <abadger1999> #info kubernetes experiences:  focused on kubernetes so testing is easier
15:16:33 <acozine> gundalow: thanks
15:17:30 <abadger1999> #info vision: geerlinguy would like to see large collections like community.general break up in the  future
15:17:38 <gundalow> #info community.kubernetes testing (Sanity, Integration, Molecule) https://github.com/ansible-collections/community.kubernetes/blob/master/.github/workflows/ci.yml
15:18:26 <geerlingguy> gwmngilfen: if you could build some sort of heat map of users to modules, maybe that could help see "oh xyz is often making changes to these 5 modules... maybe those are good for breaking out"
15:18:43 <gwmngilfen> hmm
15:18:55 <gwmngilfen> heat map of activity is already on my todo
15:19:05 <abadger1999> #info gwmngilfen offering his expertise to help collect and anaylze data about contributions, bugs, and general health
15:19:13 <gwmngilfen> something like the bubbleplot from Dec, but with another colour index
15:19:29 <gwmngilfen> however I'm wary of calling out specific users, not everyone likes the spotlight
15:19:47 <gwmngilfen> but activity is important, yes
15:19:55 <samccann> We also have stats we can dig out on the docs side (not on who but how many visitors go to these 5 modules etc). So we could attempt to fetch the most popular modules within community.general for example
15:20:06 <gwmngilfen> #action gwmngilfen to look into activity heatmaps
15:20:21 <samccann> though my suggestion can't distinguish between users and contributors
15:20:22 <sshnaidm|ruck> I saw coverage module for molecule somewhere.. lemme find
15:20:32 <gundalow> #action investigate if we can get Molecule code coverage into codecov.io
15:20:38 <gwmngilfen> samccann: i was definitely going to bring up docs stats when we get to that session ;)
15:20:58 <gwmngilfen> (although I have to go in ~1 hr so we'll see)
15:21:03 <geerlingguy> sshnaidm|ruck: ooh that'd be nice
15:21:30 <gundalow> #info Example Code coverage https://codecov.io/gh/ansible-collections/community.zabbix/tree/master/ansible_collections/community/zabbix/plugins
15:22:35 <gundalow> #info These issues and PRs will be closed with a note to say "Move to the `collection:XXX` repo" https://github.com/ansible/ansible/labels/needs_collection_redirect
15:22:48 <sshnaidm|ruck> geerlingguy, seen this one, but didn't try yet https://github.com/leominov/ansible-coverage-callback
15:22:59 <abadger1999> #info geerlinguy excited to see the separation of core and collections when the collection-related issues in ansible/ansible are closed
15:24:01 <abadger1999> #info each issue and PR will be closed with a message to look at the PR labels to decide where to move to.
15:24:19 <abadger1999> #info a script exists to move prs but not issues.
15:25:57 <felixfontein> about the schedule: shouldn't there be a "lunch" break somewhere?
15:26:05 <gundalow> felixfontein: who's lunchtime
15:26:08 <felixfontein> (would be dinner for me :D )
15:26:15 <samccann> docs team isn't usually online til closer to 10am ET fwiw
15:26:26 <samccann> (for a docs portion of the hackathon days).
15:27:01 <felixfontein> what's 10am ET in UTC?
15:27:04 <samccann> kewl thanks!
15:27:10 <felixfontein> (or when is the docs meeting in ET?)
15:27:14 <abadger1999> cybette: ^ See felixfontein 's scheduling question.
15:27:15 <samccann> (it's 30 min befour our usual docs meeting)
15:27:20 <felixfontein> ah
15:27:23 <gundalow> #action cybette to create docs hackathon session for 10am UTC Tue (Issues and PR move)
15:27:26 <acozine> felixfontein: it's now 11:30 Eastern
15:27:40 <felixfontein> samccann: acozine: thanks! :)
15:28:10 <cybette> felixfontein: 10am ET so 14:00 UTC
15:28:54 <abadger1999> #info about 8 networking collection.  All managed by the same team
15:29:13 <abadger1999> #info networking team talks to each other every day
15:30:45 <abadger1999> #info networking team testing: Has a large matrix of devices and python versions.  Easier to manage than when it was in ansible/ansible
15:32:35 <gundalow> #info Example of Grafana's CI running against a matrix of Grafana_version, Python_version, ansible_version: https://github.com/ansible-collections/community.zabbix/blob/master/.github/workflows/plugins.yml#L57-L114
15:33:08 <geerlingguy> (I wish we could do that for multiple OpenShift versions but there's no way to install v4 or later in CI)
15:33:12 <Qalthos> #link https://github.com/ansible-collections/ansible.netcommon/pull/75 Example of tests running on PRs in network collections
15:33:17 <sshnaidm|mtg> let's all move to Zuul
15:33:26 <gundalow> QUESTION: sshnaidm+gundalow+geerlingguy+persysted+felixfontein+gwmngilfen+acozine+abadger+anshulbehl+andersson007_+resmo+adev+rbergeron+stan_g+maxamillion+relrod What did you want to get from this session?
15:33:47 <geerlingguy> gundalow: main thing I want is closing/redirecting questions
15:34:01 <gwmngilfen> more stats idaes, so geerlingguy++ for the heatmap thoughts
15:34:12 <acozine> I'd like to hear where contributors would expect to find docs on redirecting issues
15:34:13 <gwmngilfen> * more stats ideas, so geerlingguy++ for the heatmap thoughts
15:34:17 <acozine> in the community guide?
15:34:19 <acozine> developer guide?
15:34:20 <acozine> both?
15:34:29 <abadger1999> #info networking team is closing and redirecting issues manually.
15:34:56 <felixfontein> gundalow: seeing what people expect
15:35:02 <felixfontein> acozine: I think it should be in dev guide
15:35:09 <abadger1999> #info taking a set of issues tagged with collection_redirect every week and closing in the ansible/ansible repo and reopening in the network collection repos.
15:35:10 <gundalow> #info Network Team are manually closing & redirecting issues and PRs. The team is working through this list https://github.com/ansible/ansible/issues?q=is%3Aopen+label%3Aneeds_collection_redirect++label%3Anetworking
15:35:19 <samccann> I'm interested in how someone wanting to contribute does that now, or really - how do we make it easy for them to find which collection has foo module now so they know - how to find the relevant collection, how to understand any unique contributor guidelines/requirements, how to get the pr merged etc
15:35:23 <abadger1999> #info about one hour per week
15:35:31 <felixfontein> does network team also wants to look into community.network?
15:35:37 <abadger1999> #undo
15:35:37 <zodbot> Removing item from minutes: INFO by abadger1999 at 15:35:23 : about one hour per week
15:36:00 <abadger1999> #info networking team handles the issue moving in a one hour meeting every week.
15:36:21 <sshnaidm|mtg> gundalow, can we give more permissions to close issues? For example for closing openstack/podman issues I need to call for ansible core each time?
15:37:16 <gundalow> sshnaidm|mtg: if you are a maintainer (accoring to BOTMETA) then you can do `close_me`
15:37:16 <maxamillion> gundalow: I was interested in the community opinion on this just for general education and to understand desired processes/practices because the collections I focus on are low on community contributors these days and are mostly focal points for bug reports by users compared to active contributors, so I lack perspective on the greater community outlook on the topic
15:37:18 <felixfontein> are you on the maintainer list (in botmeta) for modules these issues are about? then you should be able to do `close_me`
15:37:22 <felixfontein> sshnaidm|mtg: ^
15:37:46 <persysted> I just started looking at migrated some modules to a dedicated last week, so at this point I was mostly just interested in listening in.. ..that said I hear a lot of folks using molecule for testing collections, and wondered what the direction of ansible-test will be going forward, and whether the integration testing will look to cover some of the reasons why folks are still using molecule for module testing today?
15:37:57 <sshnaidm|mtg> felixfontein, I don't think I am
15:38:08 <sshnaidm|mtg> there is a "team" maintainer maybe
15:38:16 <persysted> *at migrating some modules to a dedicated collection
15:38:21 <felixfontein> sshnaidm|mtg: you could get added to the list, then you should be able to use close_me
15:39:29 <samccann> #info at 10amET tomorrow's doc hackathon will work on the wording of this PR close statement to generalize for closing/moving the big batch of stuff still on ansible/ansible - https://github.com/ansible/ansible/issues/70374
15:40:26 <geerlingguy> gundalow and gwmngilfen — though with that, is it mostly people cleaning up random things that needed fixing from the core extraction?
15:40:40 <geerlingguy> or is it also people working on bugfixes and improvements to modules now?
15:41:57 <gundalow> #info Example of human closing and redirecting new issues & PR https://github.com/ansible/ansible/issues/70374#issuecomment-651362731
15:41:58 <samccann> persysted: if that testing info doesn't get covered in this session, please bring it up again during the test session later today
15:43:17 <abadger1999> #info for a large colection like community.general... Can we do something like: PR gets opened.  No one looks at it for (a week).  Ask if the PR submitter would like to become a new maintainer.
15:43:44 <felixfontein> that might be a bit scary for people just creating simple bugfixes
15:47:58 <gundalow> #action For issue/pr relocation need to make it clear that "If this *is* still relevant, please recreate in the new place
15:49:13 <geerlingguy> (As someone who's started using a stale bot to close old issues, you do get some pushback initially no matter what, but people get used to it.
15:49:45 <geerlingguy> IMO better to close an old issue where nobody's touching it for 'x' amount of time than to let it sit forever. Closed issues can still be searched for reference.
15:50:10 <geerlingguy> no the other acozine :D
15:50:12 <gundalow> #topic Diversity and Inclusion
15:50:23 * geerlingguy afk for quick bio break
15:52:56 <gundalow> QUESTION: How did you join the Ansible Community?
15:54:34 <acozine> We'd like to expand the Ansible Community and especially encourage many different types of people to participate. So how do we recruit new people?
15:54:48 <acozine> For current participants, how did you get started?
15:55:02 * geerlingguy back
15:55:05 <acozine> Were you already coding before you made your first contribution?
15:55:48 <misc> mhh, 1) I tried ansible, found a bug, I was a python coder, decided to help by submitting a bug report, rinse repeat
15:55:54 <felixfontein> I got involved because I wanted to fix a few bugs, and add a feature I was missing. I have been coding before.
15:55:55 <resmo> (so long ago, I can't remember in detail, but I guess I needed that functionality and teached myself to do it by looking at code
15:56:18 <acozine> #info experience for first-time contributors is important in bringing in diverse contributors
15:56:59 <gregdek> This is useful: https://docs.google.com/presentation/d/13UxBGj2lI66SLjl6sp4NE3DH2ndT0k5QM0pPyyzZXuY/edit#slide=id.g3240500814_4_74
15:57:05 <acozine> so misc felixfontein resmo you were all Ansible users before you became contributors
15:57:13 <misc> yeah
15:57:46 <samccann> #info D&I slidedeck from mozilla - https://docs.google.com/presentation/d/13UxBGj2lI66SLjl6sp4NE3DH2ndT0k5QM0pPyyzZXuY/edit#slide=id.g3240500814_4_74
15:58:02 <gundalow> #info Older Mozilla research https://docs.google.com/presentation/d/1hsJLv1ieSqtXBzd5YZusY-mB8e1VJzaeOmh8Q4VeMio/edit#slide=id.g43d857af8_0177
15:58:12 <geerlingguy> Outside of Ansible, my first open source contribution was to Drupal, and I hopped on IRC and encountered a very helpful person who was willing to help with my issue for like 30 minutes
15:58:14 <gundalow> #info Mozilla: Contributors who received code reviews within 48 hours on their first bug have an exceptionally high rate of returning and contributing.
15:58:15 <misc> (but not a big user, I was just automating a few stuff while working in RH IT)
15:58:28 <resmo> acozine: yes
15:58:30 <gundalow> #info Mozilla: Contributors who wait longer than 7 days for code review on their first bug have virtually zero percent likelihood of returning.
15:58:35 <misc> (and I was doing packaging and all kind of contribution before)
15:58:38 <geerlingguy> (And I was an Ansible user before contributing as well.)
15:58:40 <gundalow> #info: Showing a contributor the next bug they can work on dramatically improves the odds of contributing.
15:59:23 <jillr> #info  https://opensourcesurvey.org/2017/#insights
15:59:55 <gregdek> Ah, the Monday morning lawn mowing. I'll be back, moving to a quiet place.
16:00:03 <geerlingguy> One quick data point—for the online materials for which I have analytics having to do with Ansible and/or sysadmin/ops things, the demographics I see are something like 99% male, 1% female (according to Google Analytics)
16:00:05 <gundalow> #chair jillr
16:00:05 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm berkhan cybette felixfontein geerlingguy gregdek gundalow jillr jimi|ansible misc persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
16:00:26 <gundalow> geerlingguy: so that's YouTube and your website?
16:00:35 <misc> geerlingguy: yeah, kinda mirror the hackathon demographics :/
16:00:38 <geerlingguy> and book pages
16:00:45 <gwmngilfen> so i was building a basic model for labelling community.general issues as "good starter issue" or similar, a while back
16:00:54 <gwmngilfen> it was... sketchy :)
16:01:43 <geerlingguy> It's crazy because in other web communities (webdev, frontend programming) I'm in it's at least 10-20% female, usually more.
16:01:55 <sshnaidm|mtg> for not scaring people it's better to keep review process well defined and...encouraging
16:03:06 <sshnaidm|mtg> I found some reviews to be very frustrating and discouraging tbh, can easily push people away from contributing
16:03:23 <gwmngilfen> +1
16:03:40 <gundalow> #info for PR review I personally like https://sage.thesharps.us/2014/09/01/the-gentle-art-of-patch-review/
16:04:08 <acozine> geerlingguy: the DevOps world generally is more diverse than Ansible, too
16:04:24 <acozine> sshnaidm|mtg: ah, that's good feedback
16:05:17 <gwmngilfen> language matters hugely in reviews. I can't speak for Ansible, but other communities I've been a part of definitely had people who meant well, but were too terse in their replies :)
16:05:27 <gundalow> #info if you think people aren't using the best (welcoming) language in Ansible (IRC, GitHub, etc, etc) please feel free to ping me directly and I'll happily educate
16:05:44 <gundalow> #info #ansible-diversity exists now, all are welcome
16:05:54 <geerlingguy> gwmngilfen: it seems to me that a lot of times those situations are also due to language barriers, not necessarily people who are terse by nature
16:06:13 <gwmngilfen> agreed. although in some cases it's definitely nature :)
16:06:30 * baptistemm is back
16:06:32 <sshnaidm|mtg> it's not even language, but some review anti-patterns
16:06:48 <misc> gwmngilfen: well, not all cultures are as the same level of warmness
16:06:57 <jillr> geerlingguy: to expand on your point, in the US, Dept of Labor stats say 27% of technical staff are women (they dont track diverse genders).  with only 4% in F/OSS, we need to examine that.
16:07:38 <misc> (like, I do dunk on germans a bit cause I am french, but there is a few videos on youtube on the topic)
16:07:42 <baptistemm> sshnaidm|mtg: +1
16:08:32 <baptistemm> we should not forget there is real people who took the time to 1) report a problem 2) wrote a patch
16:09:09 <felixfontein> gregdek: github is showing that ('First Contributor') I think
16:09:16 <geerlingguy> "First-time contributor" tag is on PRs when they put up the first one
16:09:25 <baptistemm> yep this is written on github
16:09:33 <felixfontein> ah first-time, not first :)
16:09:45 <misc> well, but if someone do contribute 2 patchs, only 1 is tagged, no ?
16:09:53 <acozine> sshnaidm|mtg: when you get a chance, please say more about the anti-patterns
16:10:32 <sshnaidm|mtg> acozine, sorry, can't talk with voice right now
16:10:53 <felixfontein> sshnaidm|mtg: you could write them here :)
16:10:56 <misc> interpretive dance !
16:10:59 <acozine> sshnaidm|mtg: on IRC is fine, later is fine too
16:11:04 <acozine> just don't want to lose that feedback
16:11:34 <sshnaidm|mtg> acozine, but worth to have agreed review guidelines like I saw of google somewhere, or like in openstack: https://docs.openstack.org/project-team-guide/review-the-openstack-way.html
16:11:40 <acozine> misc: I think we should have a Dance Party break
16:11:41 <sshnaidm|mtg> at least for start
16:11:48 <felixfontein> misc: I think both are tagged, until the first is merged, then no one is tagged (at least for the github `first-time contributor` label)
16:11:48 <gwmngilfen> #action gwmngilfen produce some stats on first-time contributors, cc gregdek, gundalow
16:12:16 <gregdek> yespls :)
16:12:27 <acozine> #info consider incorporating review guidelines like https://docs.openstack.org/project-team-guide/review-the-openstack-way.html
16:13:04 <misc> I kinda feel that you are either doing a 1st PR or you are a hardened veteran to be weird, like, I would add a bit more categories or some scale
16:13:13 <sshnaidm|mtg> acozine, just from top of my head, reviewer should review the whole patch at once, picking one specific issue each day, waiting until it's fixed, picking next one - all this will blow mind of contributor after a week :)
16:13:25 <misc> cause having 1 1st good experience, but 2 not great after :/
16:13:30 <gwmngilfen> misc: thats fair. I'll have a think. expect a blog post :)
16:13:59 <baptistemm> so the solution is to greet 1st or any contribution the same way
16:14:03 <baptistemm> :)
16:14:13 <gwmngilfen> #action gwmngilfen stratify contributors along more than first/not-first contributor status
16:14:32 <sshnaidm|mtg> acozine, style issues should be done by linters in python, no style comments should be done, especially when there is no any specific style and it changes from module to module
16:14:32 <abadger1999> misc: +1.... I think that progress vs non-progress is really important.
16:15:06 <abadger1999> In several ways... (1) I discovered a bug.  I fixed the bug.  The bug fix gets fixed <= task driven progress
16:15:37 <acozine> #action acozine to expand https://docs.ansible.com/ansible/latest/community/how_can_I_help.html#review-and-submit-pull-requests
16:15:55 <abadger1999> () I learned about the code base. (2) I had my fixes merged (3) I was able to merge fixes (4) I helped other people get their fixes merged <= personal development driven progress
16:16:52 <sshnaidm|mtg> next anti-pattern, "your way" is not "only the way", for contributor to change its patch there is need for a more established reason than "I just like if different"
16:17:11 <andersson007_> my expirience: i wasn't a professional coder before ansible. Now i'm a commiter, thanks:) I'd been an ansible user for some time when i found that there was no module for stuff i needed. I made a pr with the module which was merged quickly. I started contributing actively, completed other's interesting PRs, solved issues, helped other folks, made new modules, etc. A bit more than in a year i got commit.
16:17:11 <andersson007_> Thanks guys from core and community for your support:)
16:17:14 <misc> I also wonder if that's worth having "exit interview", or just contacting people X days after their last PR to know if something happend
16:17:23 <misc> andersson007_: wow, nice
16:17:57 <andersson007_> misc: thanks:)
16:18:14 <geerlingguy> I think one thing that is difficult to cope with in a global community is sometimes the US-centric conditions placed on language usage
16:18:21 <misc> yeah
16:19:15 <sshnaidm|mtg> +1
16:19:19 <samccann> so in docs, we have perhaps a bit more flexibility to accept/merge PRs that aren't perfect, but are good enough, and we can go back in and make some extra changes if necessary.  Can/does this happen at all on the code side? where a senior person can either make suggested edits to fix things, or even use the PR as a teaching/coaching option for a new contributor to get it to the point of being mergeable?
16:19:29 <gregdek> How are we handling this? https://github.com/ansible-collections/community.general/pulls?q=is%3Apr+is%3Aopen+label%3Anew_contributor
16:19:58 <misc> samccann: I think people can submit PR on PR
16:20:08 <geerlingguy> jillr: eek! The last four jobs I had I was on teams where the worst split was something like 60-40
16:20:26 <gwmngilfen> iirc by default maintainers can add commits to any PR
16:20:31 <samccann> misc: yeah that's what we do in docs land. I'm wondering if that also happens in  the coding PRs
16:20:45 <misc> I personnally do not do it that often
16:20:47 <felixfontein> gwmngilfen: if the PR creator didn't uncheck that checkbox
16:20:48 <geerlingguy> samccann: good point—I often do that (merge incomplete PR then fix) for my own repos, as I know that as a beginner just "simple" things like rebasing were very stressful
16:20:50 <gwmngilfen> we used to do that quite a bit in Foreman - we'd offer to fix up style or minor typos on merge
16:20:50 <misc> (but I am lazy)
16:20:56 <gwmngilfen> felixfontein: indeed
16:20:57 <samccann> geerlingguy: time to recruit them into the ansible community!!
16:21:17 <jillr> geerlingguy: it is often better in corporate IT in the US at least, where there are better policies and enforcement protecting folks from some of the things that are sadly common elsewhere in the industry
16:21:19 * resmo is afk
16:21:24 <cybette> I also try to show my face in video conf calls, not that I want everyone to see me, but (hopefully) it helps others to see some "different" faces. I know it helps me.
16:21:36 <jillr> cybette++
16:21:42 <gwmngilfen> cybette++
16:21:42 <samccann> cybette++
16:21:52 <abadger1999> gwmngilfen: also doesn't help when people aren't committers (for instance, community.general where we have ansibullbot to gate commits)
16:21:55 <gwmngilfen> and yes, ban "just", "simply" and "should" :)
16:22:02 <geerlingguy> cybette: I like to have video on for any smaller gatherings mostly because no matter who you are, it makes everyone way more likely to humanize the others
16:22:13 <felixfontein> geerlingguy: samccann: I do that for modules/plugins I work on (because I can fix it later), but I don't like to do that for modules/plugins I don't really know much about
16:22:28 <acozine> in docs we get a lot of contributions straight from github, that's a signal that the person either isn't experienced with git or is in a big hurry, we try to pay extra attention to those
16:22:32 <felixfontein> geerlingguy: samccann: which happens a lot when reviewing PRs in community.general :)
16:22:33 <gwmngilfen> abadger1999: ah yes, i'd forgotten about the bot/shipit stle of running the repo
16:22:47 <gwmngilfen> *style
16:22:55 <cybette> geerlingguy: yep, it does make you feel more connected
16:23:06 <jillr> the Ansible project does not qualify for https://www.outreachy.org/, but it's a great program if you have a chance to participate/mentor someone
16:23:14 <gwmngilfen> i like having my video on for that reason, even if I'm not helping the diversity balance :)
16:23:34 <cybette> Gwmngilfen: it helps in the connectedness!
16:23:34 <gwmngilfen> sadly, I have to go cook dinner
16:23:36 * misc is a mentor for this period for Fedora
16:23:47 <jillr> misc that's awesome!
16:23:52 <cybette> Gwmngilfen: thanks for being here o/
16:24:02 <samccann> misc++  maybe you can help us understand how that works and how we can launch something like that in ansible land
16:24:02 <misc> acozine: but isn't the github editor "good enough" for a quick modification of doc ?
16:24:08 <gwmngilfen> it's been fun! feel free to tag me for related stuff, irc is on my phone :)
16:24:20 <misc> samccann: I got volunteered by a coworker :p
16:24:21 <acozine> misc: yes, it's a great way to fix the docs
16:24:59 <acozine> I just meant that it's one way we identify PRs that need a bit of extra welcome
16:25:13 <jillr> samccann: openstack participates, I can fill you in
16:25:20 <samccann> kewl
16:25:44 <andersson007_> imo, a lack of reviewers (specialists) is one of the most painful issues. very often felixfontein and me can't provide deep reviews for community.general prs because we don't work with that stuff. But we could merge more confidently if there are CI tests for such modules. So the second issue is bad ci coverage of some stuff. Just thoughts:)
16:26:40 <gundalow> #action jillr to create GitHub issue for D&I
16:26:45 <geerlingguy> andersson007_: yeah lack of CI coverage always makes me 50x more nervous merging anything
16:26:52 <bcoca> andersson007_: that hsa been endemic problem with ansible modules/plugins since we broke 200
16:27:01 <gundalow> #action jillr to add D&I into next issue of The Bullhorn
16:27:04 <abadger1999> That was my worry... It feels like growing the pool of maintainers/committers is important to scale that.
16:27:08 <felixfontein> andersson007_: indeed! also I feel bad if I can just write "please add a changelog fragment", give some general guideline, but ni the end cannot merge because I cannot judge the part of the change that requires domain knowledge - and none of the maintainers (if these exist after all) write anything
16:27:13 <bcoca> and ci helps, but cannot ensure correctness w/o proper expertise
16:27:14 <geerlingguy> bcoca: maybe long term goal is to have no collection with more than 200 modules then?
16:27:27 <geerlingguy> I know my brain asplode around 100
16:27:28 <bcoca> geerlingguy: that was my short term goal
16:27:36 <abadger1999> andersson007_: That's why I'm in favor of giving people maintainership a whole lot quicker than core did.
16:27:40 <geerlingguy> bcoca is very ambitious
16:27:41 <gundalow> In an ideal world community.general would not exist. Though that requires maintainers for every collection
16:27:45 <felixfontein> abadger1999: that's indeed once of the big problems IMO
16:28:13 <andersson007_> felixfontein: yeah, i understand what you're saying 100%:)
16:29:17 <felixfontein> andersson007_: I sometimes wonder whether we should just merge changes (at least bugfixes) if nobody with domain knowledge commented after some time
16:29:27 <abadger1999> geerlingguy, gwmngilfen: One thing I'd be interested in figuring out is whether the ratio of active maintainers to review vs number of modules  or the raw number of modules in a repo is more indicative of success,
16:29:32 <jillr> #info https://github.com/ansible/community/wiki/Diversity
16:29:50 <jillr> I'll fill that in more later today
16:29:54 <bcoca> felixfontein: depends on focus, moviing as fast as possible or stability and quality
16:30:00 <abadger1999> My gut says that both are helpful but the ratio of maintainers is the more important of the two.
16:30:12 <bcoca> felixfontein: ti will be a per collection decision
16:30:19 <misc> well, ansible as a project is kinda easy to get in, IMHO
16:30:27 <andersson007_> there's one more downside of having a big number of collections: we can easily forget that they exist:)
16:30:27 <misc> (on the module side)
16:30:32 <felixfontein> bcoca: for modules which have no maintainers, stability means they're dead and will stay dead
16:30:40 <felixfontein> s/maintainers/active maintainers/
16:30:46 <misc> pinning for the fjord
16:30:48 <gundalow> #topic Documentation in the new world order
16:30:49 <bcoca> felixfontein: most likely, but also they are dead for a reason
16:30:53 <abadger1999> felixfontein: I think that's probably a good idea.  (or making the person a maintainer so that if there are bugs in their code, there's a better chance they'll work to fix it)
16:30:59 <gundalow> #chair jillr bcoca maxamillion
16:30:59 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm bcoca berkhan cybette felixfontein geerlingguy gregdek gundalow jillr jimi|ansible maxamillion misc persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
16:30:59 <gwmngilfen> abadger1999 good question. Drop me a note :)
16:31:14 <bcoca> a) they are perfect, no changes needed b) not enough people will use them nor are interest in them to even attract 1 maintainer
16:31:17 <geerlingguy> abadger1999: I think number of modules is important because at some point you can't run full CI on [daily|weekly] basis or have it all return relevant test data for every PR
16:31:17 <felixfontein> bcoca: but when people want to improve, but there's nobody to judge their changes, stability prevents new potential maintainers
16:31:28 <bcoca> felixfontein: as i said, it is a choice
16:31:39 <andersson007_> felixfontein: about merging bugfixes, i thought of that as well but if something breakes down i'll feel responsible for that:)
16:31:42 <bcoca> not easy one to make and global/blanket statements rarely work
16:31:47 <geerlingguy> usually those jobs would take hours for 500+ modules (at minimum) so you end up running subsets of tests, and bugs sneak in in places you wouldn't expect over time
16:31:52 <felixfontein> bcoca: <nod>
16:32:17 <andersson007_> felixfontein: to take part in breaking somebody's pipelines doesn't feel good:)
16:32:30 <bcoca> felixfontein: not trying to say one way or the other, it is always about the context, its really hard to have a fast rule for these things, sometimes the right option is the least bad option
16:32:35 <felixfontein> andersson007_: that's why I don't do it (yet) either :) or only if I think I understand the fix well enough that it shouldn't be too bad
16:32:47 <gundalow> I'd be happy if we ever hit the problem of having soooo many tests for community.general that they take hours to run
16:33:05 <bcoca> andersson007_: but you also cannot stifle code for 2 people to keep pipelines w/o change while 10000 need the change
16:33:10 <felixfontein> gundalow: they already need quite some time when all of them run :)
16:33:13 <misc> let us just test on every Fedora version :p
16:33:15 <andersson007_> felixfontein: but i agree, people do a lot of work fixing bugs on the other hand
16:33:16 <felixfontein> and they are still faaaar from complete
16:33:26 <persysted> out of interest, what will be the next opportunity to move modules out of community.general after this Friday?
16:33:36 <gundalow> #action gundalow to speak to gregdek about throwing more $$$ at Shippable
16:33:41 <felixfontein> gundalow: ^
16:33:54 <bcoca> felixfontein: my advice, weigh in the scope of changes, the commitment of 'changer' and the likelyhood of breakage + the ability of user community to come back with a fix
16:33:54 <felixfontein> persysted: good question. I don't know. I hope gundalow knows ;)
16:34:30 <abadger1999> geerlingguy: Also, after a certain number of modules with diverse interests, you get people clamouring for a bot to manage permissions rather than giving people direct commit.
16:34:32 <andersson007_> felixfontein: other people are surpriced by our "high expectations" about changelogs:)
16:34:34 <bcoca> felixfontein: +- your own ability to deal with the issue if biological waste encounters the bladed air moving aparratus
16:34:37 <gundalow> persysted: yes, though not till after 2.10 has shipped. The reason is there is enough moving around already. Is their a particular area you are interested in?
16:35:09 <abadger1999> geerlingguy: But.... I still think that the number of reviewers with power to merge things might be more important.
16:35:29 <felixfontein> andersson007_: true. and I understand that it is annoying to follow such precise rules. but I don't want to write fragments for everyone :)
16:35:55 <felixfontein> bcoca: for modules I don't use? well, I don't care if they break :P
16:36:34 <felixfontein> persysted: for the modules you are currently moving out, did you already start with setting up the collection repo?
16:36:36 <persysted> gundalow: I'll make the deadline for the proxysql modules, I'd potentially be able to look at the mysql and/or potentially the digitalocean modules after that but moving those before Friday wouldn't be something I could do :)
16:37:04 <sshnaidm|mtg> maxamillion, o/ so maybe you know whom to ping about https://bugs.launchpad.net/tripleo/+bug/1885728 :D
16:37:07 <geerlingguy> persysted: can I send you some github sponsorship dollars to move the digitalocean modules out by Friday?
16:37:23 <persysted> felixfontein: gundalow setup the collection repo, I've just been writing the scaffold, and adding some the integration tests, etc
16:37:26 <bcoca> felixfontein: until enough people are pissed and say  your project sucks because of a tiny part of a community 'effort' ...
16:37:29 <felixfontein> persysted: for the mysql modules you should talk to the working group first
16:37:50 <felixfontein> persysted: if you need help with something, please ask
16:38:22 <felixfontein> geerlingguy: why do you want them moved out? (out of curiosity) and who wants to look after them?
16:38:29 <maxamillion> sshnaidm|mtg: oh my ... is the playbook that causes that available publicly anywhere?
16:38:42 <gundalow> persysted: ah, yes, Please shout out if you need any help with any of this
16:38:43 <geerlingguy> felixfontein: anything that's not in one massive collection means it'll be easier for me to fork and contribute back for itty bitty fixes
16:38:56 <maxamillion> sshnaidm|mtg: also, is that a CI job? ... that's concerning
16:39:17 <sshnaidm|mtg> maxamillion, yeah, it's in openstack and I think it was different playbooks
16:39:26 <sshnaidm|mtg> maxamillion, not easily reproducible though
16:39:27 <persysted> felixfontein: the info you and the rest of the folks provided other day was useful, no further questions since.. ..in terms of workflow should I copy the first pr here?
16:39:49 <sshnaidm|mtg> maxamillion, let's not distract people here, maybe better to talk on different channel
16:39:53 <maxamillion> sshnaidm|mtg: interesting
16:39:54 <felixfontein> persysted: feel free to do so (though maybe not today, it will get lost in all the summit talk :D )
16:39:57 <maxamillion> sshnaidm|mtg: yeah +1
16:40:41 <acozine> docs links:
16:40:42 <acozine> https://docs.ansible.com/ansible/devel/dev_guide/developing_collections.html#
16:40:45 <felixfontein> geerlingguy: I can do the move, but I only want to do it if someone promises to look after the resulting collections, because I won't :)
16:40:55 <acozine> https://docs.ansible.com/ansible/devel/community/contributing_maintained_collections.html#contributing-maintained-collections
16:41:04 <acozine> https://docs.ansible.com/ansible/devel/user_guide/collections_using.html
16:41:22 <andersson007_> felixfontein: yep, i meant that pr where a contributor denied to finish the pr because of changelog:D
16:41:25 <geerlingguy> felixfontein: I'd at least minimally help with reviews (as I use a few of the DO modules personally)
16:41:49 <persysted> geerlingguy: alas Friday is just too close a deadline for me due to the day job ( at DigitalOcean :D )
16:42:15 <felixfontein> persysted: would you look after the modules as well?
16:42:36 <geerlingguy> felixfontein: it sounds like if you moved them out then persysted and I would be willing to be maintainers...
16:42:49 <felixfontein> there are some (active?) maintainers for these modules, no idea what they think about it
16:42:55 <acozine> Questions about docs:
16:43:16 <felixfontein> gundalow: what do you think about community.digital_ocean?
16:43:21 <acozine> 1. Have you used any of the collections-focused docs?
16:43:29 <acozine> 2. If you have, what did you think?
16:43:43 <acozine> 3. What's missing (other than module docs, we're working on that . . . )
16:43:47 <gundalow> felixfontein: as long as we have some people, then I think it would be ace
16:43:51 <gregdek> A: no, not yet
16:43:55 <rosowiecki> 1. yes
16:44:19 <persysted> felixfontein: it's a nit pick, but fwiw digitalocean is all one word, so probably community.digitalocean would work best
16:44:21 <acozine> 4. In light of our discussion earlier, are there ways we can improve the docs about Contributing to make the project more welcoming?
16:44:38 <felixfontein> persysted: fine for me, just the current modules have an underscore in it :)
16:44:45 <geerlingguy> felixfontein: yeah community.digitalocean++ (sorry for the noise :)
16:44:57 <rosowiecki> 2. It was at the early stage of 2.10, they were not very helpful, but I hope they improved.
16:47:17 <geerlingguy> rosowiecki: huge improvements in the past month... there were a lot of things in there that were confusing to me at first but were fixed recently
16:48:27 <felixfontein> a (not completely up to date) example of how the generated collection docs look like: https://toshio.fedorapeople.org/ansible/docsite/collections/
16:48:54 <abadger1999> This is what hte new pages for the collections will look like: https://toshio.fedorapeople.org/ansible/docsite/collections/
16:49:42 <abadger1999> heh, sorry felix for duplicating your link :-)
16:50:16 <felixfontein> abadger1999: no problem, I guess we were looking it up in parallel ;)
16:50:31 <samccann> #info example of how the generated collections docs look - https://toshio.fedorapeople.org/ansible/docsite/collections/
16:50:39 <sshnaidm|mtg> as a maintainer for a collection, what should I do special to keep my collection docs readable in Ansible docs? Are there guidelines somewhere?
16:51:01 <sshnaidm|mtg> should I generate docs and keep them in the repo?
16:52:17 <bcoca> if using the common CI you should get plugins validated already,  you can use ansible-doc  for 'runtime docs test' as for 'published docs' .. that i'll leave up to docs team
16:52:49 <baptistemm> I think doc is a huge topic, for instance the left columns aggregrate lots of differents topics, and I think we should better separate our targets: ansible users, ansible developpers but not contributing (working for a compamy) , ansible contributors
16:52:54 <cybette> #info Docs working group https://github.com/ansible/community/wiki/Docs
16:53:29 <baptistemm> reference and appendices also have a lot of top level entries
16:53:30 <bcoca> also you have Galaxy/AH docs, they display modules and README.md right now, but might do more in future
16:53:36 <felixfontein> abadger1999: I think we need a `--strict` option for antsibull-docs, which stops and prints errors instead of building error pages
16:54:02 <baptistemm> I mean doc by the website doc.ansible.com
16:54:43 <samccann> felixfontein abadger1999 can you add some infos here when you are done talking so we can capture the links, options etc in the meeting notes?
16:55:10 <felixfontein> abadger1999: `current-collection` would probably be more useful for CI (to not die on errors in collections your collection depends on)
16:55:27 <samccann> baptistemm: agreed for sure!  That's something we hope to address in the future -making the docs work for particular readers (contributors, users, etc)
16:55:56 <acozine> baptistemm: great idea, we have been moving toward a user-focused organization instead of a product-focused organization
16:56:12 <cybette> Antsibull repo: https://github.com/ansible-community/antsibull
16:56:43 <abadger1999> felixfontein: How about if it outputs all the errors to a log or similar?
16:57:00 <acozine> #info https://github.com/ansible-community/antsibull is where the docs pipeline lives
16:57:41 <abadger1999> (We could change the default logging cfg to print all error-level logs to stderr, for instance, and then call log.error() when we output an error pages.
16:57:53 * geerlingguy afk
16:58:58 <felixfontein> abadger1999: that should work as well
17:02:02 <samccann> were there other things y'all wanted to discuss on docs?
17:02:33 <baptistemm> actually I'm really confused by the too many sectionss on the left part
17:02:51 <baptistemm> there should be only a limited set of top entries
17:03:00 <sshnaidm|mtg> btw, I hope ansible-test sanity tests keep my docs valid, right?
17:03:04 <baptistemm> I know it's peripherical
17:03:08 <acozine> baptistemm: ah, okay, thnks
17:03:27 <samccann> is it the reference that starts getting confusing?
17:03:41 * geerlingguy break time!
17:03:42 <baptistemm> https://puppet.com/docs/puppet/latest/puppet_index.html
17:03:49 <samccann> https://docs.ansible.com/ansible/devel/index.html
17:03:55 <samccann> (for comparisons)
17:03:55 <baptistemm> puppet doc is a good inspiration
17:04:41 <gregdek> Link for the Bullhorn: https://docs.google.com/document/d/1CS8Y6CpBriwyNfL5nwnQ03pQ6bJiAtLJnyqaINnE4x8/edit
17:04:48 <gregdek> (Outline for issue #6)
17:04:55 <samccann> ah. so for example in ansible, we have a somewhat similar set of high level sections if you read the teal text
17:05:01 <gregdek> #info Link for Bullhorn Outline issue #6: https://docs.google.com/document/d/1CS8Y6CpBriwyNfL5nwnQ03pQ6bJiAtLJnyqaINnE4x8/edit
17:05:38 <samccann> installation, using, contributing, extending (which is confusing to me now that I look at it), scenarios, networking, galaxy, and appendix
17:06:34 <gundalow> #topic The Bullhorn: The Ansible Community newsletter
17:06:39 <samccann> but that contributing vs extending might be the split that was mentioned earlier - between people who want to contribute but not write code, and those who want to develop code (extending)
17:06:43 <gundalow> #chair
17:06:44 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm bcoca berkhan cybette felixfontein geerlingguy gregdek gundalow jillr jimi|ansible maxamillion misc persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
17:06:59 <abadger1999> felixfontein:  https://github.com/ansible-community/antsibull/issues/124
17:07:07 <acozine> #info Docs Working Group info: https://github.com/ansible/community/wiki/Docs
17:07:59 <abadger1999> sshnaidm|mtg: That's going to need some work.  We probably have to write a new sanity test.
17:09:17 <abadger1999> sshnaidm|mtg: I think right now the move to collections has silently broken the test which checks whether the plugins will successfully build into website docs.
17:10:04 <felixfontein> abadger1999: sshnaidm|mtg: the docs build test is only run in ansible/ansible, if it is still run at all
17:10:05 <abadger1999> (as in... those tests only check whether the ansible-base plugins build, not the plugins in the collection being tested)
17:10:45 * felixfontein will prepare some food now (and listen a bit in the background)
17:10:50 <sshnaidm|mtg> felixfontein, abadger1999 I see, I think I've got docs issues from ansible-test and fixed them, maybe it was more yaml linting or kind of
17:11:22 <geerlingguy> +1
17:11:25 <Pilou> +1
17:11:27 <gundalow> #info gregdek is now talking about the Ansible Bullhorn
17:11:31 <abadger1999> sshnaidm|mtg: yeah... there are three docs related tests in sanity.  two work but are incomplete and the third doesn't work.
17:11:34 <sshnaidm|mtg> o/
17:11:44 <gundalow> QUESTION: Who already knew about `The Bullhorn` +1/-1
17:11:54 <acozine> -1, I'm sorry to say
17:11:59 <gundalow> +1
17:12:06 <acozine> glad to hear about it now!
17:12:15 <sshnaidm|mtg> +1 like it
17:12:20 <resmo> +1
17:12:56 <samccann> +1
17:13:43 <cybette> #action cybette to subscribe ansible-devel to The Bullhorn
17:14:05 <felixfontein> +1
17:14:19 <abadger1999> (ansible-doc [will it parse], a validate-modules check which tests if the module DOCUMENTATION conforms to a schema [but this is imperfect because it normalizes data... but normalization should be done in the production parser, not in the tests], and  a test build of the website)
17:14:46 <gundalow> QUESTION: Is it useful
17:14:54 <gundalow> QUESTION: What can we do to make it better?
17:15:02 <gundalow> QUESTION: Anyone interested in helping out
17:15:08 <sshnaidm|mtg> yes, it's useful
17:15:33 <samccann> +1 for useful  (and for extending the distribution so more folks know about it/read it)
17:15:51 <anshulbehl> afk
17:15:55 <geerlingguy> make it better - more cowsay
17:15:58 <sshnaidm|mtg> what help is required though?
17:16:03 <gundalow> gregdek: ^
17:16:54 <gundalow> #info We want more content on Ansible Working Groups
17:17:19 <rbergeron> Having a list of specific types of appropriate content and the actual Mission of The Bullhorn, listed in a specific place, would be useful.
17:17:26 <samccann> +1 on working group sections
17:17:30 <jimi|ansible> just realized my browser had sound quit working
17:17:33 <Pilou> useful: yes
17:17:38 <sshnaidm|mtg> gregdek, can it get PRs?
17:17:39 <gundalow> #action gregdek add "New Collections" list community.proxysql, community.digitalocean
17:17:46 <rbergeron> Is the Bullhorn an actual Working Group on its own
17:17:47 <gundalow> sshnaidm|mtg: It's a Google Doc
17:17:47 <rbergeron> ?
17:18:06 <sshnaidm|mtg> ack
17:18:46 <samccann> rbergeron: not sure it needs its own working group unless we create an ansible-outreach WG and tie it into that?
17:19:21 <rbergeron> Would PRs actually limit the potential of aspiring contributors who aren't necessarily PR-knowledgeable?
17:19:26 <cybette> there is an outreach WG: https://github.com/ansible/community/wiki/Outreach
17:19:41 <rbergeron> i believe we have an ansible-outreacy wg and this was one of the original goals. Like, 4 years ago.
17:19:43 <samccann> hah.. TIL   thanks cybette!
17:20:18 <gundalow> gregdek: Have you had (m)any people email you with content?
17:20:26 <rbergeron> I think "guidelines for the bullhorn" should be on a page that requires PRs, though.
17:20:41 <rbergeron> ...was it voluntary content? :)
17:20:52 <rbergeron> or was it "YOU BETTER SEND THIS BECAUSE I BOUGHT YOU A BEER"
17:21:00 <sshnaidm|mtg> repo and PRs can be more visible than google doc "somewhere"
17:21:23 <gundalow> QUESTION: What updates would people like to see from from Collections?
17:22:16 <rbergeron> yes
17:22:19 <sshnaidm|mtg> +1
17:22:36 <gundalow> +1
17:22:47 <Pilou> yep
17:22:47 <cybette> +1 (with contributions via email still acceptable)
17:22:52 <gregdek> #action gregdek will move outline of Bullhorn #6 to ansible/community repo issue (and post that link in the next Bullhorn!)
17:23:25 <gundalow> QUESTION: Where else could we promote The Bullhorn?
17:23:37 <sshnaidm|mtg> What updates would people like to see from from Collections? - those that applies for all collections, like for example removing "ansible_metadate" etc
17:24:07 <baptistemm> acozine: samccann: small doc fix https://github.com/ansible/ansible/pull/70480 :)
17:24:07 <rbergeron> get jim whitehurst to pimp it out
17:24:11 <sshnaidm|mtg> post it on reddit :)
17:24:13 <samccann> lol
17:24:21 <samccann> +1 for reddit (and jimw :-)
17:24:27 <baptistemm> +1 on reddit
17:24:30 <rbergeron> TWITCH
17:24:33 <gundalow> I normally post it on Reddit, though missed the last two
17:24:35 <rbergeron> hmm.
17:24:56 <baptistemm> +1 late on "who know bullhorn"
17:24:59 <gundalow> picture of JimW in Ansible Swag talking about The Bullhorn?
17:25:25 <samccann> woot
17:25:41 <rbergeron> #idea where to promote The Bullhorn? Templated slide decks for virtual meetups; reddit; twitter (@ansible + individuals); linkedin; etc.
17:26:21 <sshnaidm|mtg> medium devops communities, like "faun"
17:26:43 <gundalow> #action gregdek Slide template for Virtual Meetupss
17:26:48 <gundalow> #undo
17:26:48 <zodbot> Removing item from minutes: ACTION by gundalow at 17:26:43 : gregdek Slide template for Virtual Meetupss
17:26:50 <gundalow> #action gregdek Slide template for Virtual Meetups
17:26:55 <rbergeron> Someone just needs to photoshop a bullhorn into this picture
17:26:59 <rbergeron> https://twitter.com/AnsiBull/status/654991717725138944
17:28:01 <rbergeron> yes.
17:28:08 <rbergeron> it's jim@ibm.com
17:28:10 <rbergeron> not hard
17:28:10 <rbergeron> :)
17:28:13 <rbergeron> LOL
17:28:36 <gundalow> #action rbergeron to ask Jim to promote The Bullhorn
17:29:14 <gundalow> #info Where do people discuss Ansible https://github.com/ansible/community/issues/525
17:29:34 <sshnaidm|mtg> in telegram channels
17:29:49 <cybette> sshnaidm|mtg: which channels?
17:29:51 <baptistemm> gundalow: at geerlinguy live video :)
17:30:03 <cybette> gitter: https://gitter.im/ansible/ansible
17:30:50 <gundalow> #info List of Ansible notification modules https://docs.ansible.com/ansible/2.9/modules/list_of_notification_modules.html
17:30:50 <cybette> matrix:  #ansible:matrix.org
17:31:24 <gundalow> sshnaidm|mtg: Are their Ansible Telegram Channels?
17:31:49 <sshnaidm|mtg> gundalow, general devops, like https://t.me/DevOps_Experts_Forum
17:32:01 <sshnaidm|mtg> gundalow, I know mostly russian ones :(
17:32:22 <baptistemm> dev.to seems to be a general platform for developers
17:32:28 <baptistemm> so a good target
17:32:32 <sshnaidm|mtg> +1 ^
17:32:49 <gundalow> Thanks, added to https://github.com/ansible/community/issues/525
17:35:36 <baptistemm> ansibull should be also the channel to enboard potential contributors
17:36:02 <baptistemm> organise regurlar time limited action for small patch / easy fix PR
17:36:21 <gundalow> #action gregdek to see if there are AWX, ansible-lint, Molecule updates to include in Bullhorn
17:36:28 <gundalow> (thanks boss!)
17:36:35 <samccann> heh
17:37:07 <rbergeron> baptistemm: that's exactly right :)
17:37:12 <Pilou> and maybe a short description about new project: eg ansible-runner-service ?
17:37:13 <gundalow> I'm glad we have The Bullhorn
17:37:14 <rbergeron> small simple first steps
17:37:24 <baptistemm> bullhorn is great
17:37:46 <rbergeron> @pilou yes, that should also be a thing.
17:37:52 <gundalow> baptistemm: How would you see this new channel working?
17:38:22 <baptistemm> s/ansibull/bullhorn.
17:38:29 <baptistemm> call Mr typo
17:39:01 <samccann> ah so a section in the bullhorn dedicated to 'stuff new people might want to help on' ?
17:40:23 <gundalow> baptistemm: So is this similar to "Office Hours" that some groups do? say 2x1 hour slots where people can drop in and ask questions and get help? A dedicated channel, so stuff doesn't get lost in the noise of (say) #ansible-devel
17:40:36 <baptistemm> "be involved in Ansible"
17:40:45 <baptistemm> gundalow: yes
17:40:58 <baptistemm> after I don't know if IRC is still a thing for younsters
17:41:02 <baptistemm> :)
17:41:11 <samccann> LOL
17:41:19 <misc> snapchat office hours ?
17:41:33 <baptistemm> slack / telegram is perhaps a better medium
17:41:51 <gundalow> So on that note, I'm wondering if http://gitter.im/ would be good, since you can auth with GitHub. And we automagically get channel per repo
17:42:10 <misc> baptistemm: discord, just brand ansible as a MMORPG
17:42:53 <misc> (I still think that doing bugfixing on twitch would work, if I wasn't so paranoid on being recorded)
17:43:20 <baptistemm> misc: redhat is doing a lot of streaqming stuff thesess day on openshift
17:43:24 <gundalow> MMOPRG: Massively Multiplayer Online Pull Request Game
17:43:32 <jillr> irc can be friendly to new people, we could have a doc that guides folks to webclients or things like irccloud wherever we link to our channels
17:43:46 <misc> baptistemm: yep, cause we can't travel :)
17:43:54 <felixfontein> misc: I could imagine it works... I heard of people making youtube videos of them coding, and people watching that
17:44:10 <misc> "twitch does ansible bugfixing"
17:44:23 <baptistemm> felixfontein: some people are doing live straming on youtuibe each wednesday
17:44:26 <baptistemm> hum hum
17:45:28 <misc> each time we tried that with Pilou , we had no trouble finding bugs that looked easy enough, but ... plot twist, the code was slightly not as good as we hoped :)
17:45:54 <misc> or..... we can make bug fixing tournaments !
17:46:05 <baptistemm> +1
17:46:58 <misc> (even better if that's fake bugfixing tournament, like WWF)
17:47:08 <felixfontein> lol
17:47:14 <baptistemm> trowing PRs
17:47:27 <baptistemm> throwing PRs
17:47:53 * baptistemm sends #70480 on misc's head
17:48:32 * misc is ejected out of the chan and come back looking angry
17:50:36 <gundalow> #topic Testing Ansible content
17:52:06 <cyberpear> blue jeans link?
17:52:18 <gundalow> cyberpear: https://bluejeans.com/617182211
17:52:40 <samccann> talking on BJ about ansible-test vs molecule
17:52:49 <cyberpear> thx
17:52:52 <samccann> k8 collection is using molecule
17:52:58 <gundalow> #info CI where `community.kubernetes` use Molecule https://github.com/ansible-collections/community.kubernetes/blob/master/.github/workflows/ci.yml#L67-L99
17:53:27 <felixfontein> hi doggie!
17:53:34 <baptistemm> wouaf
17:54:04 <geerlingguy> 🐕
17:54:07 <baptistemm> :D
17:54:17 <cybette> puppies!
17:54:31 <felixfontein> can you ask the dog whether they prefer ansible-test or molecule? I think they wanted to say something :D
17:54:44 <gundalow> they wanted to join DaWG
17:55:11 <gundalow> PLEASE do use `ansible-test sanity` for all collections
17:55:26 <felixfontein> I can only second that!
17:55:30 <gundalow> #chair pabelanger
17:55:30 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm bcoca berkhan cybette felixfontein geerlingguy gregdek gundalow jillr jimi|ansible maxamillion misc pabelanger persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
17:55:56 <geerlingguy> FYI if I search "ansible-test documentation" on Google... there's nothing :(
17:56:17 <samccann> ooch
17:56:32 <geerlingguy> There is a tiny bit of info (but no context, no "getting started" type of ground level info) on https://docs.ansible.com/ansible/latest/dev_guide/testing.html
17:57:02 <geerlingguy> https://docs.ansible.com/ansible/latest/dev_guide/testing_running_locally.html#testing-running-locally doesn't say anything about what it's for, how to use it, etc.
17:57:18 <gundalow> #action Google `ansible-test documentation` needs improving
17:57:40 <geerlingguy> gundalow: also action 'is there any "getting started with ansible-test" documentation?
17:57:50 <gundalow> #action not "Getting started with ansible-test"  in https://docs.ansible.com/ansible/latest/dev_guide/testing.html
17:58:05 <gundalow> #undo
17:58:05 <zodbot> Removing item from minutes: ACTION by gundalow at 17:57:50 : not "Getting started with ansible-test"  in https://docs.ansible.com/ansible/latest/dev_guide/testing.html
17:58:14 <gundalow> #action We need some "Getting started with ansible-test"  docs in https://docs.ansible.com/ansible/latest/dev_guide/testing.html
17:58:51 <samccann> #info molecule or more complex CI is good for big items like k8 where you have to set up some complexity to test it.
17:58:56 <gundalow> #action Need to document where `ansible-test integration` vs `molecule` (Requiring external infra) is needed
17:59:00 <samccann> #info network collections using zuul
17:59:23 <samccann> #info but ansible-test is the baseline that has to pass in general to be sure 'all the things' like docs etc work
17:59:54 <gundalow> #action need to document that ansible-test is for modules & plugins. not for Roles
17:59:54 <samccann> #info molecule also has strong roles support.
18:00:08 <sshnaidm|mtg> I think molecule uses ansible-lint and yamllint for roles
18:00:28 <gundalow> #action Maybe write a table of tool vs things they can test.
18:00:44 <samccann> ping anshulbehl sshnaidm pilou felixfontein resmo adev stan_g - we are talking tests of collections now
18:00:47 <sshnaidm|mtg> I see ansible-test and ansible-lint converge in some point..
18:01:20 <anshulbehl> I also feel ansible-test can be intelligent enough when running on collection to check what content is inside the collection and then run specific sanity tests accordingly
18:02:29 <samccann> #action - consider adding some tidbits re molecule/test inside the collection template in github itself
18:02:40 <geerlingguy> It was August (not November) but I wrote up my two experiences here: https://www.jeffgeerling.com/blog/2019/how-add-integration-tests-ansible-collection-molecule vs https://www.jeffgeerling.com/blog/2019/how-add-integration-tests-ansible-collection-ansible-test
18:03:01 <gundalow> #action docs: GitHub Actions are good for testing against multiple versions of application (API) under test (Grafana, Zabbix). Shippable is good where you want to test against multiple Operating systems
18:03:14 <gundalow> mattclay: We are talking about testing https://bluejeans.com/617182211
18:04:11 <samccann> #info some info from geerlingguy on molecule vs ansible-test - https://www.jeffgeerling.com/blog/2019/how-add-integration-tests-ansible-collection-molecule and https://www.jeffgeerling.com/blog/2019/how-add-integration-tests-ansible-collection-ansible-test
18:04:40 <gundalow> #action Can Molecule generate codecoverage to feed into codecov.io
18:05:43 <samccann> anything else people want to talk re ansible-test vs molecule?
18:06:00 <anshulbehl> ansible-test sanity --docker will run sanity tests inside a container, agreed that its not dev friendly as molecule*
18:07:44 <samccann> #info github Actions - from the user perspective, is easy to use/pickup. K8 collection is using it.
18:08:02 <resmo> .oO(gh action is easy to use, he says...and me fighting with it since 3 hours...)
18:08:08 <samccann> #info podman also using github actions
18:08:16 <samccann> woopsie :-)
18:08:46 <sshnaidm|mtg> hate github actions
18:08:57 <gundalow> resmo: shout out in #ansible-devel if you need help with GHA, I've done a lot of hacking (swearing) at them recently
18:09:01 <baptistemm> someone to close https://github.com/ansible/community/issues/537 which should not be here
18:09:46 <jillr> the AWS collections have their release jobs in zuul, but testing is all still shippable
18:09:52 <gundalow> One nice thing with GitHub Actions rather than Shippable is you can add the errors directly to the line causing them, WIP example: https://github.com/gundalow/GHA_testing/pull/1/files#diff-e81322d356781dacf8c7b91c21b5cf95R13
18:09:52 <resmo> gundalow: it is probably just me, I did a lot with gitlab ci and somehow I can not wrap my head around it.
18:10:33 <sshnaidm|mtg> gundalow, can you even use shippable when collection is not on ansible.collection namespace?
18:10:46 <sshnaidm|mtg> gundalow, just curios
18:11:26 <gundalow> sshnaidm|mtg: yes, Shippable is free for public repos
18:12:01 <geerlingguy> ??
18:12:15 <resmo> sound feaky ;)
18:12:24 <resmo> s/feaky/freaky
18:13:41 <anshulbehl> for dev workflows -> ansible-test vs molecule , for CI -> zuul vs shippable vs GH actions?
18:14:24 <sshnaidm|mtg> anshulbehl, well, zuul is for specific repos I think, <- pabelanger ?
18:14:29 <gundalow> sshnaidm|mtg: Though if you want Shippable to test against AWS, Macstadium etc then we have to enable it
18:14:36 <samccann> #info ansible-test, molecule, ansible-lint are tests, zuul, travis, shippable are CIs to run those tests
18:15:06 <gundalow> #info What to run: ansible-test, ansible-lint, molecule, etc
18:15:31 <gundalow> #info scheduling: GitHub Actions, Travis, Zuul, Shippable, etc
18:15:50 <gundalow> So for your repo you need (at least) one from each
18:15:59 <sshnaidm|mtg> All openstack is on zuul
18:16:10 <anshulbehl> gundalow +1
18:16:29 <jillr> zuul came out of openstack, so most of the opendev foundation projects use it
18:17:09 <samccann> #info - how 'popular' are each scheduling tool in opensource may influence contributors (aka I know XXX and ansible uses XXX so I can more easily contribute)
18:18:30 <samccann> #info zuul is good at cross-project testing (aka a change in nxos collection doesn't break the ios collection etc)
18:19:16 * geerlingguy nods
18:20:13 <samccann> any other test topics y'all want to talk about?  (right now unit testing being talked about on BJ)
18:21:20 <gundalow> Unit tests are often best for `plugins/module_utils` when you want to test specific functions
18:21:57 <gundalow> Integration tests are often best for `plugins/modules` when you want to validate the interaction of a module on the system
18:22:27 <samccann> #info Unit tests are often best for `plugins/module_utils` when you want to test specific  functions.  Integration tests are often best for `plugins/modules` when you want to validate the interaction of a module on the system
18:23:26 <felixfontein> we could put it in community.internal_test_tools :)
18:23:44 <samccann> :-)  i see a volunteer!  ^^
18:23:44 <felixfontein> that collection exists precisely for containing tools that are useful for testing collections
18:24:05 <samccann> oh interesting. We should document that somewhere :-)
18:24:29 <samccann> #info community.internal_test_tools - a collection for containing tools useful for testing collections
18:25:08 * resmo still has 2 todo items for using community.internal_test_tools for 2 collections
18:25:20 <felixfontein> :)
18:25:22 <gundalow> #action document `community.internal_test_tools` (what/why) from "Developing collections" and "/dev_guide/"
18:26:43 <samccann> last call for test topics in the final 4 min?
18:26:55 <abadger1999> Here's the unittest with AnsibleModule framework that I wrote: https://github.com/ansible/ansible/blob/devel/test/units/module_utils/conftest.py
18:27:05 <gundalow> #info collection_template repo, which is what we fork when making new collection repos https://github.com/ansible-collections/collection_template. PR#4 in there update the GitHub Action
18:27:32 <abadger1999> An example of using it: https://github.com/ansible/ansible/blob/devel/test/units/module_utils/basic/test_exit_json.py
18:29:13 <samccann> #info  unittest with AnsibleModule framework : https://github.com/ansible/ansible/blob/devel/test/units/module_utils/conftest.py and example using it https://github.com/ansible/ansible/blob/devel/test/units/module_utils/basic/test_exit_json.py
18:30:47 <gundalow> #topic Plans for Ansible Galaxy and it's relationship to Automation Hub
18:31:03 <geerlingguy> https://github.com/ansible/galaxy_ng/issues/58
18:33:02 <geerlingguy> https://github.com/ansible/galaxy/issues/2253
18:35:25 <felixfontein> I'm interested in this migration question as well, as I have a role on galaxy and want to make it require collections, which only works with collections...
18:37:23 <sshnaidm|mtg> isn't it just putting role in roles/ of collection?
18:37:37 * sshnaidm|mtg hopes for simplicity
18:37:43 <samccann> https://docs.ansible.com/ansible/devel/dev_guide/migrating_roles.html#migrating-roles
18:39:06 <geerlingguy> samccann++
18:41:01 <gundalow> #chair
18:41:01 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm bcoca berkhan cybette felixfontein geerlingguy gregdek gundalow jillr jimi|ansible maxamillion misc pabelanger persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
18:41:05 <resmo> speaking of christmas and whishes, I would like to delete a collection which was migrated to another namespace but the galaxy team refused to do that
18:41:14 <gundalow> #chair shertel
18:41:14 <zodbot> Current chairs: Im0_ Pilou abadger1999 adev andersson007_ baptistemm bcoca berkhan cybette felixfontein geerlingguy gregdek gundalow jillr jimi|ansible maxamillion misc pabelanger persysted phips rbergeron resmo samccann shaps shertel sshnaidm|ruck tcraxs
18:42:25 <resmo> roles can be deprecated and deleted, collections can only be deprecated and now I guess it will confuse users finding a deprecated collection which was never used by any user until one found it
18:42:26 <anshulbehl> resmo, you can deprecate your collection, that way it won't show up in search on Galaxy
18:43:15 <felixfontein> geerlingguy: https://gist.github.com/sivel/1f850b7f577b9dc9466293034c82b19d <- it's a 'secret' gist :)
18:44:19 <shertel> Another related gist of sivel's https://gist.github.com/sivel/bca2fe56680c76f0eea647f5477dd46b
18:45:12 <geerlingguy> > Doesn't eat poptarts
18:45:22 <geerlingguy> sivel: what are you doing? Must eat poptarts in next revision
18:45:27 <sivel> Since we're sharing, also a WIP: https://gist.github.com/sivel/a3372077d8f4aa2ad862b5e074503aa0
18:46:45 <anshulbehl> also, I assumed the reason for not deleting is collection depending on other collections, but if same happens with roles as well, need to check with galaxy team
18:49:27 <anshulbehl> roles readme gets rendered
18:49:30 <anshulbehl> I just checked
18:49:45 <anshulbehl> you can check nginx one
18:50:02 * geerlingguy now I want a pop tart
18:51:25 <samccann> ok what's the link between poptarts and ...erm.. either galaxy or nginx?  :-)
18:53:22 <geerlingguy> samccann: see shertel's link "Another related gist of sivel"
18:53:43 <samccann> heh
18:53:58 <gundalow> #topic Ending up
18:53:59 <anshulbehl> all dependencies of a collection on AH right now can only come from AH
18:54:45 <geerlingguy> anshulbehl: but if you install one of the same collections from Galaxy then you'd get all the others from Galaxy right?
18:54:54 <geerlingguy> e.g. if you're not inside the AAP arena
18:55:24 <anshulbehl> geerlingguy, yes, that is right, basically depencies will get resolved from the same system only
18:55:31 <geerlingguy> ++
18:58:59 <resmo> thanks gundalow
18:59:15 <gundalow> #info THANK YOU EVERYBODY
18:59:28 <gundalow> #info Tue & Wednesday is Hackathon in #ansible-community
18:59:58 <gundalow> #info Documentation Hackathon in #ansible-docs 14:00 UTC
19:00:14 <gundalow> #info We will have a hackathon on writing some content for The Bullhorn
19:01:28 <sshnaidm|mtg> gundalow, cybette thanks folks, great meeting!
19:01:44 <baptistemm> Thanks
19:01:47 <gundalow> #info next two days is also "Open Office Hours", so feel free to ask any other questions, or more technical PR review stuff
19:02:14 <gundalow> DING DING DING: If you haven't already please register at https://www.eventbrite.com/e/virtual-ansible-contributor-summit-july-2020-registration-107691423948
19:03:29 <gundalow> #action Write summary of Contributor Summit in Bullhorn draft
19:03:40 <gundalow> Thanks again, enjoy the rest of your day
19:03:42 <gundalow> #endmeeting