#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 18:00:27 UTC (full logs).

Meeting summary

  1. agenda: https://github.com/ansible/community/issues/539 (felixfontein, 18:04:41)
  2. updates (felixfontein, 18:06:50)
    1. ansible-base 2.10.1 was delayed by one week, which means that the ansible 2.10.0rc1 will also get delayed by one week (now planned for 2020-09-15) (felixfontein, 18:08:20)
    2. ansible 2.10.0 release is currently planned for 2020-09-22 (felixfontein, 18:08:37)
    3. https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/COLLECTIONS_2_10.rst also says 17 (felixfontein, 18:14:06)
    4. meeting at 2020-09-17 18:00 UTC about whether there are blockers for ansible 2.10.0 (felixfontein, 18:21:57)
    5. rc1 means complete freeze, except for blockers: i.e. even if we have another rc, collections will only get updated if needed to remove blockers (felixfontein, 18:25:44)
    6. that means no patch releases in any collections after RC1 is created, unless it fixes a blocker (samccann, 18:26:38)
    7. ACTION: gundalow to create Etherpad for policy, assign meeting logs (felixfontein, 18:29:53)
    8. ACTION: gundalow to setup meeting, maybe felixfontein & cyberpear (EDT) could help? (felixfontein, 18:30:00)

  3. test requirements for new plugins/modules (felixfontein, 18:37:37)
    1. For new modules/plugins in community.general and community.network, we require tests, which SHOULD run in CI whenever possible (6 x +1, 1 x abstain) (felixfontein, 19:09:08)

  4. open floor (felixfontein, 19:22:29)
    1. https://www.katacoda.com/gundalow/scenarios/fixing-a-bug https://github.com/ansible-community/katacoda-scenarios/tree/master/fixing-a-bug (gundalow, 19:24:59)
    2. We've been prototyping using Katacoda.com for an interactive scenario (checkout collections, run CI (fails), fix bug, run CI (pass), add changelog, commit) https://www.katacoda.com/gundalow/scenarios/fixing-a-bug https://github.com/ansible-community/katacoda-scenarios/tree/master/fixing-a-bug (gundalow, 19:26:58)


Meeting ended at 19:31:30 UTC (full logs).

Action items

  1. gundalow to create Etherpad for policy, assign meeting logs
  2. gundalow to setup meeting, maybe felixfontein & cyberpear (EDT) could help?


Action items, by person

  1. cyberpear
    1. gundalow to setup meeting, maybe felixfontein & cyberpear (EDT) could help?
  2. felixfontein
    1. gundalow to setup meeting, maybe felixfontein & cyberpear (EDT) could help?
  3. gundalow
    1. gundalow to create Etherpad for policy, assign meeting logs
    2. gundalow to setup meeting, maybe felixfontein & cyberpear (EDT) could help?


People present (lines said)

  1. felixfontein (109)
  2. gundalow (25)
  3. samccann (19)
  4. abadger1999 (17)
  5. zodbot (14)
  6. acozine (12)
  7. andersson007_ (10)
  8. aminvakil (7)
  9. jtanner (7)
  10. gwmngilfen (5)
  11. cyberpear (5)
  12. geerlingguy (2)


Generated by MeetBot 0.1.4.