18:01:06 <gundalow> #startmeeting Ansible Community Meeting
18:01:06 <zodbot> Meeting started Wed Sep 23 18:01:06 2020 UTC.
18:01:06 <zodbot> This meeting is logged and archived in a public location.
18:01:06 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:06 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:01:08 <gundalow> Who's around?
18:02:19 * samccann waves
18:02:57 <gundalow> I know Felix isn't around
18:03:10 <gundalow> abadger1999: andersson007_ Are you joining?
18:03:14 <gundalow> hey samccann :)
18:03:22 <andersson007_> o/ (i have to take part in some work in my production now, so half here)
18:05:08 <gundalow> #chair samccann andersson007_
18:05:08 <zodbot> Current chairs: andersson007_ gundalow samccann
18:05:17 <gundalow> #topic Ansible 2.10.0 RELEASED
18:05:50 <samccann> woohoo!!!
18:06:42 <andersson007_> cool:)
18:07:14 <gundalow> #info Ansible 2.10.0 has been released. Amazing work by all. I know when we started the big migration these seemed like today long way away, though we are finally here!
18:07:41 <abadger1999> Hi
18:07:54 <abadger1999> (Sorry, got caught up in a discussion in #ansible)
18:07:57 <gundalow> #info Ansible 2.10.0 release announcement https://groups.google.com/g/ansible-devel/c/-6n_Tj_pXBQ https://www.reddit.com/r/ansible/comments/iycyqn/ansible_2100_has_been_released/
18:08:00 <gundalow> #chair abadger1999
18:08:00 <zodbot> Current chairs: abadger1999 andersson007_ gundalow samccann
18:08:20 <andersson007_> available via pip? hope tomorrow there won't be a lot of issues related to all stuff i did:)
18:08:37 <andersson007_> it was a long period
18:08:48 <andersson007_> between 2.9 and 2.10
18:09:31 <gundalow> Massive thanks to abadger1999 for a lot of this
18:09:35 <gundalow> andersson007_: haha
18:09:46 <abadger1999> Yep, it's available via pip
18:09:59 <samccann> abadger1999++
18:10:05 <andersson007_> a lot of new features, modules, fixes..
18:10:09 <gundalow> abadger1999: Could you please #info any details about which packages are available and any info about the other package formats?
18:10:18 <abadger1999> I'm working on getting it updated on the PPA this week.
18:11:19 <abadger1999> #info Ansible-2.10.0 downloadable from pypi https://pypi.org/project/ansible and pip
18:11:38 <abadger1999> #info debs uploaded to the launchpad PPA coming later this week.
18:12:05 <dmsimard> great work everyone :)
18:14:02 <aminvakil> hi everyone
18:14:19 <aminvakil> where can I follow when does 2.10.0 version gets in https://releases.ansible.com/ansible/ ?
18:14:24 <gundalow> #chair dmsimard aminvakil
18:14:24 <zodbot> Current chairs: abadger1999 aminvakil andersson007_ dmsimard gundalow samccann
18:14:49 <aminvakil> if it's not appropriate for this question right now, just ignore me:)
18:15:11 <gundalow> aminvakil: perfect question for now. Thanks for joining
18:15:34 <andersson007_> https://www.irccloud.com/pastebin/el8fwzzs/
18:16:12 <andersson007_> for more than a minute and haven't finished yet
18:16:37 <andersson007_> done, ~1min
18:16:48 <abadger1999> aminvakil: As of 2.10 release, we aren't adding new tarballs to releases.ansible.com.  The official place to get ansible now is pypi
18:16:49 <andersson007_> feels longer than usual
18:17:15 <gundalow> andersson007_: we are including `tests/* which I don't think we used to
18:17:48 <abadger1999> We did include tests in the tarball before but there could be more of them now.
18:18:05 <andersson007_> ah, clear, will be faster next time?
18:18:17 <abadger1999> It looks like pip is possibly taking longer to build wheels from the tarballs (it looks like the download completed already)
18:18:49 <andersson007_> yes, it's been downloaded fast
18:19:22 <andersson007_> the tests will be excluded, right?
18:19:23 <samccann> #action samccann - remove references to releases.ansible.com from docs. official place to get ansible is now pypi
18:20:52 <andersson007_> (i remember we were discussing something about the tests, but don't remember what we decided)
18:21:10 <abadger1999> aminvakil: If you need a URL that's appropriate for putting in an rpm, deb, or other system package here's the pypi url that you can do that with: https://pypi.python.org/packages/source/a/ansible/ansible-2.10.0.tar.gz
18:21:17 <abadger1999> andersson007_: We'll include tests, I think.
18:22:18 <andersson007_> abadger1999: ok, hope nobody will use them as examples of how to write roles:)
18:22:40 <abadger1999> andersson007_: There's a couple reasons... Maybe system packagers want to run the tests locally (that was possible with ansible-2.9 and ansible-test... I'm not sure if it is currently easy with the way we package collections or not) and I don't want to make things possibly worse for GPL compliance.
18:23:42 <abadger1999> We're in a grey area right now about what is source and what is not.  I don't want to deviate from what's in the upstream collection tarballs until I know for sure that we're on firm compliance grounds.
18:23:48 <abadger1999> Heh.
18:24:12 <andersson007_> okay:) we should look at tests more carefully then:) How they look
18:24:16 <abadger1999> Yeah, our test roles are really different from what people do for managing their systems :-)
18:24:34 <andersson007_> they are far from best standards, i'd say:)
18:24:53 <andersson007_> we are happy to see tests of any form
18:24:58 <andersson007_> but working
18:25:07 <andersson007_> :)
18:25:18 <samccann> maybe a comment on the top of each file (dunno how many there are) to say These are designed specifically for ansible test and should not be used as examples of how to write Ansible roles'
18:26:34 <andersson007_> samccann: sounds sensible, like a warning for users not to use them as an instance of truth
18:28:02 <samccann> maybe someone can create an `easyfix` issue with a pointer to the director(ies) where they live and folks in the community can  trickle through to add the comment as time permits etc
18:28:41 <andersson007_> i'll think of it, will write a script
18:28:52 <samccann> kewl thanks!
18:29:01 <andersson007_> :)
18:29:31 <abadger1999> Yay :-)
18:31:09 <abadger1999> Anything else about 2.10.0 or should we move on to another topic?
18:32:10 <gundalow> Nothing else
18:32:26 <andersson007_> nope
18:32:30 <samccann> nope
18:33:53 <abadger1999> #topic moving content between collections after 2.10
18:34:15 <abadger1999> So last meeting we made some progress
18:34:45 <abadger1999> We decided how deprecation and removal schedules should work.
18:35:07 <abadger1999> The question for further discussion was: what happens when the target collection is (not yet) contained in Ansible?
18:35:44 <samccann> abadger1999 - did anyone happen to write down those decisions somewhere?
18:36:18 <andersson007_> BTW i adjusted the documentation about included content a little bit https://github.com/ansible/ansible/pull/71854 felixfontein approved
18:36:19 <github-linkbot> https://github.com/ansible/ansible/pull/71854 | open, created 2020-09-22T07:30:22Z by Andersson007: Docsite: update Migrating Ansible content to a different collection [affects_2.11,core_review,docs,docsite,needs_triage,support:core]
18:36:40 <abadger1999> samccann: they're in the meeting minutes but not elsewhere.
18:37:01 <abadger1999> They're here: https://github.com/ansible/community/issues/539#issuecomment-693619299
18:37:05 <samccann> is this the sort of thing we document in the ansible-collections/overview ?
18:37:28 <abadger1999> ans also 3.b here: https://meetbot.fedoraproject.org/ansible-community/2020-09-16/ansible_community_meeting.2020-09-16-18.00.html
18:37:55 <abadger1999> yes, this is the sort of thing we need to get out of the meeting minutes and onto a more official, structured page.
18:38:02 <andersson007_> samccann: i originally made a PR in overview but we decided to put it in https://github.com/ansible/ansible/pull/71854
18:38:03 <github-linkbot> https://github.com/ansible/ansible/pull/71854 | open, created 2020-09-22T07:30:22Z by Andersson007: Docsite: update Migrating Ansible content to a different collection [affects_2.11,core_review,docs,docsite,needs_triage,support:core]
18:38:05 <samccann> i still struggle a bit w/ what goes in docs.ansible.com vs what goes in various repos.  Feels like a developer would look in the overview ?
18:38:34 <andersson007_> there's the reference in Collections checklist
18:38:36 <samccann> ah gotcha!  Thanks andersson007_
18:38:40 <gundalow> (got to step out for a bit)
18:38:46 <andersson007_> yw:)
18:40:04 <sivel> abadger1999: I Cced you on an issue today for depend
18:40:15 <sivel> Dell wanting to migrate
18:41:02 <sivel> just as an FYI since it's related to this discussion
18:41:03 <abadger1999> samccann: I think right now we're at the stage where any place that's centralized is better than what we're doing.
18:41:37 <abadger1999> samccann: But yes... official docs site vs other place is going to become a thing too....
18:42:32 <andersson007_> overview seems to contain all reference needed
18:42:50 <andersson007_> we should have something Living, docsite is a bit more static
18:43:16 <abadger1999> samccann: I think a pro for official docs is that then there's just one site to search for the information about anything ansible related.  A con I can think of is that updates are vresion-independent and update as we hold meetings that make policy decisions.
18:43:39 <abadger1999> Which is a little different than the traditional release cycle driven schedules.
18:44:05 <abadger1999> andersson007_: yeah... timeframe and living vs static seem to be related concerns.
18:44:26 <samccann> abadger1999 - yeah we still need something like the /overview to hold late breaking information. But we should start a process of removing what is already on docs.ansible.com (aka static)  and replace with a pointer to the official docs.
18:44:27 <andersson007_> abadger1999: yep
18:44:55 <abadger1999> sivel: If you post me the url, I can look and see about working it into the meeting (although I'm probably not the person they'll need to talk to for that information)
18:45:20 <abadger1999> samccann: <nod> That sounds good... wherever the official docs are... pointing people at those.
18:45:28 <samccann> and official docs can add a pointer back to /overview for 'see here for late-breaking updates'  or you know... something worded better
18:47:09 <abadger1999> That seems similar to an addendum in print media.  Im not sure how well it works for recording policy, though?
18:47:20 <aminvakil> abadger1999: sorry, my phone rang, thanks for the pypi url, i'm gonna tell maintainers of ansible package on archlinux. (btw i use arch:)
18:49:10 <abadger1999> Let's say the static site has a list of twenty rules that collection owners have to follow to have their collection in ansible.  And then a link to overview for changes.  Then we make a decision that replaces one of the existing rules with an incompatible new rule (so they'd contradict each other if they both were active).
18:49:49 <samccann> we can say 'check here for changes to collection development' and point to overview or something.
18:50:05 <abadger1999> samccann: In that casze, it seems like it would be very confusing for people to read the static site, get one set of rules, then read the overview site and have to unlearn something they'd just put into their buffer (or undo work if they'd already done it)
18:50:40 <abadger1999> samccann: to me it feels like we either would need to make sure the static site updates as new policies are released or we need to point people at the more dynamic site.
18:50:41 <samccann> ok let's think this through a bit.  We are at 2.10.0.  Are there items in overview that affect 2.10.1 and going forward?
18:50:51 <samccann> agreed
18:51:00 <sivel> abadger1999: https://github.com/ansible/ansible/pull/71875
18:51:01 <github-linkbot> https://github.com/ansible/ansible/pull/71875 | open, created 2020-09-23T08:46:40Z by rajeevarakkal: Update Botmeta and runtime file to reflect the dellemc collections path [affects_2.11,botmeta,core_review,docs,needs_triage,runtime,support:core]
18:51:17 <abadger1999> aminvakil: Great!
18:51:31 <abadger1999> #topic Documentation of Ansible Project Policies
18:51:37 <samccann> heh
18:51:47 <abadger1999> Seems we diverged here :-)
18:52:12 <samccann> So I think we already have the problem you mentioned - we have collection develop docs with a bunch of info.  Then we have /overview... with some overlapping info
18:52:43 <samccann> Ideally, as you say, it all lives on docs.ansible.com.  But how do we account for late-breaking items (and which ansible version do they apply to?)
18:53:11 <samccann> So would there be 1 set of rules for 2.10.1, but then a different set of rules for 2.11.x ?
18:53:43 <samccann> ...and how fast are they coming now... can we just say make a decision - go update official docs (as Andersson007_ recently did)
18:54:38 <samccann> (and then decide if it applies to 2.10, backport it)
18:54:54 <andersson007_> i'm seeing overview as a "draft", when policies are determined well, imo they should be engraved on the docsite with refs from overview to them:)
18:55:49 <andersson007_> anyway, it's a question of 1 day to put something urgent in devel and backport to 2.10
18:56:02 <andersson007_> (1 day max)
18:56:06 <samccann> that's the confusing part abadger1999 mentioned earlier. Developers read the docsite and learn one thing, then go over to overview and learn something else
18:56:51 <andersson007_> that's why we put references in overview if a topic is covered on docsite
18:57:20 <andersson007_> (at least, i'm trying to do that)
18:57:43 <abadger1999> I think there should be one rule (or one rule with conditions) for all ansible.  We wouldn't want diverging policies for 2.10 and 2.11 except when we're trying to ease people into a rule change.
18:58:18 <abadger1999> I think in the next development cycle rule changes will be coming in frequently... After two development cycles it will probably settle down considerably.
18:59:32 <gundalow> samccann: I'd personally always viewed gh/ansible-collections/overviews/*.rst as a temporary measure will things had been moved to docs.ansible.com (or blogs, or just timed out as it's pre-migration info)
19:00:12 <samccann> gundalow: yeah so I think now's a good time to try shifting as much as possible of it to docs.ansible.com.
19:00:35 <abadger1999> samccann: Idea: In the past we've talked about wanting some set of docs that should be the devel version only but have been stopped by technical issues (like the version and links).  What if we have a section of the docs that we manually remove in old versions and add stub pages that say, "read this doc in the [LINK: devel version]"
19:00:43 <samccann> so maybe once it's there, we can stop using overview for this stuff and then it's make a decision, go document it
19:01:23 <abadger1999> #info proto-proposal: Push all policy documentation to docs.ansible.com
19:01:24 <samccann> abadger1999 - we've been doing this slowly yes.  release and maint is now all stubs pointing to devel. We have an open issue to do the same for porting guides
19:02:26 <samccann> ideally, we talked about creating a release-independent set of docs for development. but that takes Deep Thoughts on what gets pulled out, and how we publish on docs.ansible.com/ansible/developers or something like that.  Aka a full docsite rethink
19:03:09 <abadger1999> #info some parts of docs.ansible.com have a workflow to stub older releases to point to devel as the release-independent version of those docs.
19:03:36 <samccann> meanwhile though, I think if we scrub existing content on Overview for what should be on docs.ansible.com, we can eliminate most of the duplication
19:03:45 <abadger1999> @info ptoto-proposal: policies that we move to docs.ansible.com should follow this workflow so that there's one version for all of ansible project.
19:03:58 <samccann> then it's a matter of update docs.ansible.com going forward (aka remove the checklist requirements entirely)
19:04:11 <abadger1999> #info ptoto-proposal: policies that we move to docs.ansible.com should follow this workflow so that there's one version for all of ansible project.
19:05:01 <samccann> So for collection owners - does the 'checklist' just work for you as is?  As in do we want to keep a one page checklist over on docs.ansible.com?  I  think a lot of the info is in the developer guide already, but not in one running list like it is over on Overview/checklist
19:05:21 <abadger1999> In fedora, we had packaging guidelines.
19:05:42 <abadger1999> And we had both a set of fully detailed pages and a checklist.
19:06:18 <abadger1999> This is the checklist version: https://docs.fedoraproject.org/en-US/packaging-guidelines/ReviewGuidelines/
19:06:28 <abadger1999> The full docs are many, many, many pages.
19:06:33 <samccann> #info likely will still want a checklist like we have in ansible-collections/overview, but have it live on docs.ansible.com as a release-independend document
19:06:54 <samccann> #info see https://docs.fedoraproject.org/en-US/packaging-guidelines/ReviewGuidelines/ for an example
19:07:03 <abadger1999> I think that was good for maintainers (and especially where we relied on maintainers to review other people's packagers before acceptance).
19:07:16 * acozine waves
19:07:17 <abadger1999> One drawback was figuring out when to list new guidelines on the checklist page.
19:07:25 <abadger1999> #chair acozine sivel
19:07:25 <zodbot> Current chairs: abadger1999 acozine aminvakil andersson007_ dmsimard gundalow samccann sivel
19:09:16 <samccann> when as in...? how to show the reader 'hey this is something new!' ?
19:09:21 <abadger1999> The full guidelines are also not organized well, there.  It should probably have been use-case driven.  If you have a python gui application package, here's the set of general purpose guidelines, python specific guidelines, and gui application specific guidelines  you need to follow.
19:09:45 <abadger1999> samccann: New was another can of worms :-(
19:09:46 <samccann> yeah will likely take us time to get our own checklist in some semblance of order
19:10:19 <acozine> samccann: we need to add an item to the release checklist for "removing devel-only pages" - as part of the "when we cut a stable branch" list
19:10:54 <abadger1999> samccann: We would approve a new packaging guideline and sometimes it was something we thought should go on the checklist (Something major and general like: Make sure you don't create new directories with 0777 permissions in the package spec file)
19:10:58 <samccann> the tricky part for me is if one set of guidelines works for 2.10.x but then we try something different in 2.11.x - that's where we can't have a release-independent page
19:11:24 <samccann> acozine: yeah was just thinking that!
19:11:32 <abadger1999> Other times we'd approve a new guideline and it wouldn't get put on the packaging checklist ("New guidelines for how to package ansible collections).... it's niche.
19:11:56 <abadger1999> samccann: I think we should avoid those when possible and when we can't we should put them on the same page.
19:11:59 <acozine> the "new" part can be handled either in The Bullhorn and/or in a note to the mailing lists,  "there's a new item in the guidelines, you should now do X. We've also added this to the comprehensive list of guidelines for collection owners (link to docs page)."
19:12:45 <abadger1999> samccann: rationale for same page is that most collection owners are going to want to have one collection version that works with all ansible versions.  So they'll need to see that they need to comply with both policies in that case.
19:13:28 <samccann> good to know
19:13:46 <abadger1999> #action docs team to add an item to the docs release checklist for removing devel-only pages
19:15:11 <samccann> issue for 'move overview docs over to official docs'  - https://github.com/ansible/ansible/issues/71890
19:15:18 <abadger1999> acozine: <nod> yeah, that's better than what we had in fedora... here we do tell collection owners they need to be signed up for certain communication channels.  There it wasn't that way.
19:15:29 <samccann> #info issue for 'move overview docs over to official docs'  - https://github.com/ansible/ansible/issues/71890
19:16:06 <abadger1999> Do we have enough people to vote on that?  (I am in favor... just wnt to make it official)
19:17:21 <samccann> #chair
19:17:21 <zodbot> Current chairs: abadger1999 acozine aminvakil andersson007_ dmsimard gundalow samccann sivel
19:17:38 <acozine> oooh, is it a poll?
19:17:41 <samccann> please see issue for 'move overview docs over to official docs'  - https://github.com/ansible/ansible/issues/71890
19:17:55 <andersson007_> so we are going to have all stable stuff on the docsite, right?
19:17:59 <samccann> Are you in favor? please vote
19:18:17 <acozine> +1
19:18:20 <samccann> yes. Ideally we no longer have 90% of that content.
19:18:31 <acozine> andersson007_: yes, that is the goal
19:18:35 <andersson007_> +1
19:18:36 <samccann> when the team makes a decision, someone opens the PR on the official docs to document it
19:18:43 <samccann> +1
19:18:44 <abadger1999> #topic https://github.com/ansible/ansible/issues/71890  -- Move policies to docs.ansible.com with partial policies around managing that content (see issue for details)
19:18:53 <andersson007_> gundalow: ?
19:19:40 <abadger1999> #info POLL: We will move policies to docs.ansible.com using the policies in https://github.com/ansible/ansible/issues/71890 for managing that content
19:19:52 <samccann> if we don't think we have enough folks to vote, we could put an action item in the minutes to go comment on that issue (aka squeek now or live w the result)
19:19:54 <abadger1999> +1 from me
19:19:59 <samccann> +1
19:20:10 <geerlingguy> oh hello there, almost forgot about this meeting again
19:20:11 <abadger1999> So far it's +4 and no one voting against.
19:20:12 <samccann> (in case we want it after the poll in the log
19:20:15 <abadger1999> #chair geerlingguy
19:20:15 <zodbot> Current chairs: abadger1999 acozine aminvakil andersson007_ dmsimard geerlingguy gundalow samccann sivel
19:20:17 <cybette> +1 (just caught up with the backlog)
19:20:58 <abadger1999> I feel funny voting without gundalow or felixfontein here but So far it's +5, none opposed.
19:21:24 <samccann> yeah, so I think we put an action item w/ their names and all in the minutes so  they can pipe in later
19:21:25 <abadger1999> I think that's apretty clear indication that it is good.
19:21:36 <geerlingguy> +1
19:21:43 <abadger1999> #action gundalow to weigh in on https://github.com/ansible/ansible/issues/71890
19:21:50 <abadger1999> #action felixfontein to weigh in on https://github.com/ansible/ansible/issues/71890
19:22:19 <abadger1999> #info 71890 (move policies to docs.ansible.com) approved with +6, none opposed.
19:22:31 <abadger1999> Okay, We're at 20 minutes over.
19:22:37 <andersson007_> felixfontein: will come tomorrow and say why this is a wrong decision:D
19:22:44 <abadger1999> #topic Open floor
19:22:48 <acozine> heh
19:23:22 <abadger1999> I think we'll probably end up thinking of more cornercases and having to add additional ideas to mitigate them to 71890.  But the framework seems good enough to get started :-)
19:23:46 <abadger1999> Does anyone have anything else they want to bring up at this meeting?
19:23:47 <acozine> I'd like to walk onto the open floor and do a little dance in honor of the release of Ansible 2.10
19:23:52 <acozine> well done, everybody!
19:23:52 <abadger1999> Hehe :-)
19:24:15 <cybette> If you'd like to attend Ansible Contributor Summit, please check this and register: https://github.com/ansible/community/wiki/Contributor-Summit
19:24:18 <geerlingguy> Yeah holy cow that was a long time (and a lotta work) coming
19:24:39 <abadger1999> https://badges.fedoraproject.org/badge/dancing-with-toshio
19:24:53 <abadger1999> #info > If you'd like to attend Ansible Contributor Summit, please check this and register: https://github.com/ansible/community/wiki/Contributor-Summit
19:25:10 <andersson007_> :)
19:25:30 <abadger1999> Thanks cybette !
19:25:32 <dmsimard> that's a prestigious badge abadger1999 :p
19:25:37 <cybette> :)
19:25:58 <abadger1999> sivel: I looked at the issue you mentioned.  I think I can comment on it in the ticket itself, at least for this week.
19:26:15 <acozine> abadger1999: great disco ball!
19:26:33 <samccann> ok now I have badge envy.  WE NEED BADGES!
19:26:49 <abadger1999> hee hee... the software is open source ;-)
19:27:00 <acozine> our mission is clear!
19:27:02 <cybette> Also calling for talk contribution for Contrib Summit day 1 (for new contributors). If you think you have something to share with potential new contributors, ping me (cybette) here on IRC
19:27:08 <sivel> abadger1999: I have no idea what behind the scenes thing you are alluding to, but gundalow also commented
19:27:13 <geerlingguy> how appropriate that abadger would have a badge with a badger...
19:27:15 <samccann> i did some volunteer work in fedora back in the day... just... for... the.. BADGES!!
19:27:16 <cybette> I may have special goodies for speakers ;)
19:27:25 <acozine> ooh, swag!
19:27:29 <abadger1999> #info calling for talk contribution for Contrib Summit day 1 (for new contributors). If you think you have something to share with potential new contributors, ping cybette here on IRC
19:31:23 <abadger1999> sivel: no behind the scenes that I know about.
19:31:32 <tadeboro> cybette: Is there any specific area that we are interested in? I did quite a lot of "you need tests"-explaining lately (both in company and at customers). So if this is something that sounds interesting, I may be able to help.
19:32:37 <sivel> abadger1999: your comment seemed weird, about some time limitation :)
19:33:21 <cybette> tadeboro: we're open to topic suggestions, and testing is certainly something useful. just keep in mind we're approaching this from new contributor point of view. let's discuss this more!
19:34:03 <cybette> tadeboro: I'll email you :)
19:34:05 <abadger1999> sivel: ah... I meant... if dell or you have some issue with what I post, it can come back to this meeting, next week.
19:34:22 <tadeboro> The sooner we start teaching them about the value of tests, the better ;)
19:34:39 <abadger1999> Okay cool.
19:34:50 <abadger1999> Anything else for this meeting?  If not I'll close in 60 seconds.
19:34:51 <cybette> tadeboro: hehe true
19:34:55 <acozine> tadeboro: catch 'em young, bring 'em up right
19:35:00 <aminvakil> installing from this link (https://pypi.python.org/packages/source/a/ansible/ansible-2.10.0.tar.gz) gives me this error, is this OK? http://ix.io/2yxu
19:35:43 <aminvakil> using this PKGBUILD: http://ix.io/2yxx
19:37:11 <aminvakil> I think this line: https://github.com/cyberark/ansible-security-automation-collection/blob/master/plugins/modules/cyberark_account.py#L634. if it's something wrong from my building, please close the meeting, I will investigate further
19:37:20 <abadger1999> aminvakil: That means there's some bugs in that module in the collection.
19:37:35 <abadger1999> I'll help you track down which github repo to file a bug report on once I close the meeting.
19:37:41 <aminvakil> thanks
19:37:48 <acozine> aminvakil: thanks for reporting that
19:37:48 <abadger1999> No problem :-)
19:37:57 <abadger1999> #endmeeting