13:53:04 <gundalow> #startmeeting Ansible Contributors Summit - General session
13:53:04 <zodbot> Meeting started Thu Oct 15 13:53:04 2020 UTC.
13:53:04 <zodbot> This meeting is logged and archived in a public location.
13:53:04 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:53:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:53:04 <zodbot> The meeting name has been set to 'ansible_contributors_summit_-_general_session'
13:53:41 <gundalow> #chair abadger1999 acozine cybette jborean93 jillr jimi|ansible matburt mattclay maxamillion mkrizek nilashishc nitzmahone Qalthos relrod samccann sdoran shertel Shrews sivel thaumos webknjaz andersson007_ felixfontein  dmsimard resmo webknjaz baptistemm gwmngilfen  newswangerd
13:53:41 <zodbot> Current chairs: Qalthos Shrews abadger1999 acozine andersson007_ baptistemm cybette dmsimard felixfontein gundalow gwmngilfen jborean93 jillr jimi|ansible matburt mattclay maxamillion mkrizek newswangerd nilashishc nitzmahone relrod resmo samccann sdoran shertel sivel thaumos webknjaz
13:54:53 <baptistemm> I can skip my work meeting also, anyway I'm leaving soonish :)
13:54:57 <sdoran> Hello hello.
13:56:37 <felixfontein> hi! :)
13:56:56 <nitzmahone> o/
13:57:28 <shertel> hello
13:58:14 <TKersten> Hello \o
13:59:03 <TKersten> Will join for about an hour. It's now 16:00 in .nl and this timeframe clashes with other appointments
14:00:21 <andersson007_> Hi
14:00:52 <gundalow> STARTING
14:00:58 <felixfontein> \o/
14:01:01 <gundalow> Is everybody on BlueJeans Primetime
14:01:18 <Shrews> o/
14:02:14 <bcoca> im there but i dont see 'everybody'
14:02:28 <maxamillion> yo yo
14:02:30 <maxamillion> \o
14:03:59 <abadger1999> Morning
14:04:14 <ole88> good morning
14:04:30 <bcoca> timezone unspecific greetings!
14:04:41 <psuboss> good morning (or afternoon depending on timezone)
14:05:09 <Qalthos> Good {{ time_period }}
14:05:16 <geerlingguy> o/
14:05:22 <gundalow> #topic Intros
14:05:31 <gundalow> urgh, sorry, didn't realise my camera was off
14:05:56 <dmsimard> gundalow: it was on at the beginning, turned off at some point
14:06:39 <apple4ever> I am watching as well!
14:07:53 <sivel> I may not be able to join for another 2-2.5 hours.
14:08:07 <sdoran> 👍
14:09:03 <misc> closed captions are weird, they appear before people say anything
14:09:06 <ole88> I'm triple booked for this time today, but am paying as much attention as I can... X)
14:09:14 <misc> and "carbonated open shift", mhhh, also a bit buggy
14:11:05 <geerlingguy> misc: oh they have cc?
14:11:17 <misc> geerlingguy: yep, in the setting (bottom right)
14:11:30 <misc> the whell open setting and you can have "caption"
14:11:33 <geerlingguy> interesting
14:11:56 <misc> I wanted to verify how it worked, but well, voice recognition didn't make lots of progress since last year :p
14:12:04 <bcoca> google meeting ones are pretty good, these are somewhat hilariouslly 'off'
14:19:43 <gundalow> #topic Stats update
14:20:19 <gundalow> #info gwmngilfen is now talking about how Ansible Community Team uses data analysis to make informed discussions
14:21:00 <gundalow> #info gwmngilfen gave a presentation on Monday about Stats, that video will be available soon on YouTube
14:21:51 <gundalow> #Info If you are interested in Contributing to Ansible please subscribe to The BullHorn: http://bit.ly/thebullhorn Community newsletter
14:23:32 <gundalow> #Issues are often slower moving than PRs
14:25:50 <gundalow> #info One of the things we are keeping in mind is are collections performing better than gh/ansible/ansible. In terms of keeping on top of the backlog, helping find new maintainers, signs of burn out.
14:28:06 <noonedeadpunk> well, seems my experience is among corner cases:) (ie https://github.com/ansible/ansible/pull/68681)
14:28:06 <github-linkbot> https://github.com/ansible/ansible/pull/68681) | open, created 2020-04-03T18:13:58Z by noonedeadpunk: Fix mask behaviour when service is enabled [affects_2.10,bug,collection,core_review,module,stale_ci,support:core,system]
14:31:22 <cybette> if you're in Bluejeans please take the poll!
14:31:39 <gundalow> Any Stats questions so far?
14:32:42 <gundalow> QUESTION: If you are a collection maintainer or owner what would you be interested in?
14:34:54 <pabelanger> for github api, there is a way to tell if user is a bot: https://api.github.com/users/welcome[bot] type=bot, but I believe this is when the user is a github app
14:35:48 <webknjaz> @pabelanger yes, that's only for GitHub Apps and won't catch any bots with regular user accounts
14:36:15 <pabelanger> right, the context was ansiblebot and merges
14:36:22 <pabelanger> not sure how it is setup
14:37:00 <webknjaz> ansibot is not a GitHub App
14:37:11 <gundalow> #action gwmngilfen To see if  https://api.github.com/users/welcome[bot] type=bot is useful (though will not help if people are using regular user accounts)
14:37:24 <pabelanger> ack
14:38:45 <gabrielzeven> Couldn't attend on monday, could someone provide me the link to the katacoda Ansible ?
14:38:53 <gundalow> gabrielzeven: https://www.katacoda.com/ansible-community/
14:39:13 <gabrielzeven> awesome! Thanks!!
14:39:35 <gundalow> #info On Monday we publiced https://www.katacoda.com/ansible-community/ for the first time. We have data that shows that it was userfull
14:39:50 <gundalow> gabrielzeven: Any feedback welcome via https://github.com/ansible-collections/overview/discussions/119
14:42:39 <gundalow> #info I hope this helps explains why we do surveys, we really need this feedback. You should get a survey link next week
14:42:41 <gabrielzeven> I love Katacoda for both for learning and for "teaching"
14:44:18 <gundalow> gabrielzeven: first time I've used it or created for it. If you know of any good scenarios, or how we can make better use it I'd love to chat
14:44:58 <jrglynn2> Monday was the first intro to Katacoda for me, looks like it could be really excellent
14:46:02 <pabelanger> is that graph public for meetups?
14:46:09 <pabelanger> ansible meetup stats
14:46:26 <baptistemm> katacoda is really great tool
14:46:50 <gabrielzeven> I used a RHEL Katacoda for teaching Ansible, with several hosts https://katacoda.com/rhel-labs/scenarios/ansible-introduction
14:46:52 <baptistemm> I was able to tests kubernetes / openshift feature quickly
14:47:25 <cybette> pabelanger: yes, let me get you the link
14:47:42 <cybette> https://stats.eng.ansible.com/apps/meetups/
14:48:00 <gundalow> Collection stats https://stats.eng.ansible.com/apps/collections/contributors/
14:48:23 <gabrielzeven> yaaaaay! My last meetup is on the stats!
14:48:55 <pabelanger> cybette: great, thanks
14:49:13 <cybette> gabrielzeven: yes!
14:49:20 <gundalow> Current bubble plot: https://github.com/ansible/community/blob/master/decks/images/community_contributions_bubbleplot.png
14:50:06 <pabelanger> It would be cool to add in stuff like checks api
14:50:49 <pabelanger> what is gregs IRC handle?
14:51:00 <misc> gwmngilfen
14:51:04 <pabelanger> danke
14:51:48 <gundalow> #topic Ansible 2.10
14:51:54 <gwmngilfen> o/
14:52:07 <gundalow> #info Ansible 2.10 was a major change to how Ansible was released. Its `ansible-base` + collections
14:52:09 <gwmngilfen> pabelanger: what checks are those?
14:52:23 <pabelanger> gwmngilfen: I'd love to chat more about getting more data into your graphs regarding testing, if there is a better place to talk about it
14:52:37 <gwmngilfen> i'm definitely interested
14:52:50 <pabelanger> https://github.com/ansible-collections/vyos.vyos/pull/94/checks for exmaple
14:53:02 <gwmngilfen> happy to schedule some time and chat, whether thats irc or video, both are fine
14:53:13 <pabelanger> we have a use chat to see how often we re-run testing on a PR
14:53:19 <pabelanger> because tests are unstable
14:53:38 <gundalow> #info New docs https://docs.ansible.com/ansible/2.10/collections/ (notice it's 2.10/collections)
14:53:55 <gwmngilfen> so, naively, that might be a distribution of number of re-runs for each PR?
14:54:06 <pabelanger> yes, exactly right
14:54:20 <gwmngilfen> that seems doable
14:54:24 <pabelanger> more re-runs, likely mean unstable tests or poor infrastructure
14:54:31 * gwmngilfen looks at the graphql api
14:54:35 <dmsimard> felixfontein++ :D
14:54:40 <pabelanger> if only takes 1 run, then things are stable and happy
14:54:52 <baptistemm> felixfontein^10
14:56:14 <resmo> he does it in his free time... can not point this out enough.
14:56:15 <webknjaz> @pabelanger: I'm not sure if you can retrieve past Checks reruns postmortem, you'd probably have to record those proactively...
14:56:24 <baptistemm> wow I lost BJ few sec
14:56:32 <gundalow> baptistemm: is it back now?
14:56:35 <baptistemm> yep
14:57:11 <pabelanger> webknjaz: agree, that api isn't the best
14:57:17 <gwmngilfen> https://docs.github.com/en/free-pro-team@latest/graphql/reference/objects#checksuite suggests there's a CheckSuite api object, worth digging in a bit
14:57:32 <pabelanger> we track it in zuul, and can dump into statsd / graphite / graphana
14:57:34 <webknjaz> check suite is a collection of check runs
14:57:47 <gwmngilfen> https://docs.github.com/en/free-pro-team@latest/graphql/reference/objects#checkrun
14:57:52 <gundalow> #info We know there aren't any deb yet. We have to update a lot of the build scripts https://github.com/ansible-community/antsibull/issues/202
14:58:03 * gwmngilfen tries it
14:58:23 <gundalow> #info We will be rewriting the `ansible` build scripts hopefully to public GitHub Actions
15:03:06 <gundalow> #info: QUESTION: Will we stick with patch releases every three weeks?
15:04:34 <resmo> btw perfect work with 2.10 from my point of view
15:04:50 <noonedeadpunk> well, we're really suffering because of https://github.com/ansible/galaxy/issues/2302 - we tried to use ansible-minimal and 80% of our CI is failing because at least one job is facing with the connection issue
15:05:43 <felixfontein> noonedeadpunk: yeah, that's pretty annoying
15:05:59 <noonedeadpunk> and installing from git - seems that not all collections which were moved to community have galaxy.yml so unable to install them from git...
15:06:16 <noonedeadpunk> ie https://github.com/ansible-collections/openvswitch.openvswitch has non-valid one
15:06:43 <felixfontein> https://github.com/ansible/community/tree/master/meetings#wednesdays
15:07:19 <felixfontein> noonedeadpunk: you can simply clone the collection repo to the correct position in many cases
15:08:10 <felixfontein> (if the collection itself is at top-level)
15:08:23 <pabelanger> for openvswitch, we don't store version in repo, as it is generated at build time via git info
15:08:36 * samccann waves in late
15:08:51 <pabelanger> noonedeadpunk: you have to inject fake version until galaxy client can do it
15:09:15 <pabelanger> https://github.com/ansible-network/releases/blob/master/ansible_releases/cmd/generate_ansible_collection.py is how we build the collection
15:09:32 <noonedeadpunk> pabelanger: well installation with galaxy results with http://paste.openstack.org/show/799085/
15:09:58 <pabelanger> right
15:10:11 <pabelanger> install from git was only recently added
15:10:25 <pabelanger> when we did our release policy, galaxy was source of truth
15:10:25 <noonedeadpunk> ok, I see
15:11:02 <pabelanger> IMO, should be able to pass version to ansible-galaxy to populate
15:11:07 <pabelanger> but haven't opened PR for that
15:11:20 <felixfontein> noonedeadpunk: for some community collection CI, we run `ansible-galaxy collection install` with up to three retries in case it fails. that works pretty well.
15:12:41 <noonedeadpunk> well I think it is possible to pass version to git? https://docs.ansible.com/ansible/latest/galaxy/user_guide.html#installing-a-collection-from-a-git-repository
15:13:14 <noonedeadpunk> but yeah, I kind of get it....
15:13:18 <gwmngilfen> pabelanger: do you have an example PR with failed runs and then succeeding?
15:13:26 <webknjaz> only when you're requesting the install, not for build
15:13:33 <gwmngilfen> just to make sure this api call is what I think it is :)
15:13:33 <gundalow> #topic Ansible 2.11, the future, policy and governance
15:13:57 <pabelanger> yah, it is build process that needs version exposed over hardcoded in galaxy.yaml
15:14:20 <webknjaz> I don't recall anybody filing an issue about that
15:14:25 <noonedeadpunk> oh, yeah. I guess this approach came from helm charts :p
15:14:26 * nitzmahone wishes collections on Galaxy still defaulted to "pointers to github" vs "storage and distribution of large binary blobs", but alas, that horse has left the barn :(
15:15:04 * webknjaz uses setuptools-scm in Python ecosystem for that
15:18:29 <geerlingguy> maintaining a collection with that galaxy.yml is a lot more work than maintaining roles on galaxy that can pick up the tags via git tags :P
15:19:27 <pabelanger> geerlingguy: yah, that's what some of our tooling we built in zuul does now, still driven by git but now needs thirdparty build scripts
15:19:29 <felixfontein> geerlingguy: depends, also on what kind of sanity checks you want to run. if you want to be informed by sanity tests that something has to be removed in this version, or that version_added is wrong, CI needs to know what the next release will be *before* you release it :)
15:19:37 <geerlingguy> And that's why I try to do something that templates the galaxy.yml and a tag release automation process can fill in the tag at build time
15:20:01 <geerlingguy> yeah but those are all features for modules, roles don't even do sanity checks
15:20:40 <felixfontein> geerlingguy: true :) I'm still mostly thinking about plugins/modules :)
15:23:10 <gundalow> QUESTION: What do people think about more content from community.general into it's dedicated collection?
15:23:37 <gwmngilfen> if it has maintainers, then seems good
15:24:17 <noonedeadpunk> well, having goolge in general is frustrating
15:24:31 <noonedeadpunk> *google.cloud
15:24:46 <noonedeadpunk> as well as community.kubernetes
15:24:59 <noonedeadpunk> then we should include openstack as well in general :p
15:27:19 <felixfontein> noonedeadpunk: most of the c.g dependencies are used by precisely one module/plugin. community.kubernetes is used by several modules (the kubevirt modules)
15:28:20 <felixfontein> noonedeadpunk: https://github.com/ansible-collections/community.general/issues/354 tracks the dependencies
15:28:35 <noonedeadpunk> despite I understand that reasoning, it doesn't sound like "general".... despite how k8s is popular...
15:28:52 <wolcen> dangit...guess I didn't register for today. could have sworn I had :(
15:28:59 <noonedeadpunk> oh, I see
15:29:00 <felixfontein> noonedeadpunk: general contains everything that didn't have another place :)
15:32:58 <noonedeadpunk> ok, that was my broken understanding then :p
15:33:12 <geerlingguy> general == kitchen sink
15:33:33 <resmo> trunk I call it
15:33:56 <geerlingguy> it'd be super nice to figure out a way to deprecate community.general modules that are not maintained (e.g. the kubevirt modules) or move them into something like 'community.unmaintained'
15:34:02 <cybette> wolcen: some people reported that the confirmation from invite@bluejeans.com went to spam
15:34:03 <noonedeadpunk> I thought it more about "minimal required", ie posix here suits well :)
15:34:09 <baptistemm> some people said ansible-base is more the kitchen sink
15:34:31 <bcoca> no, ansible-base is the 'lean core', ansible package is the kitchen sink
15:34:37 <bcoca> which includes community.general
15:35:15 <noonedeadpunk> yeah, makes sense now
15:35:30 <jrglynn2> @geerlinguy I like the .unmaintained idea, and if someone commits to reviving it, could be moved out
15:35:39 <resmo> I definitely see a benefit in dedicated collections, however, felixfontein and andersson007_ are the only really active community members taking care of c.g.
15:37:41 <aminvakil> geerlingguy jrglynn2: how can people know if that would be maintained and move back to community.something for example?
15:37:41 <tadeboro> But the benefit is there only if someone is willing to put in work of maintaining them. If there is no volunteers, then the content is better kept in a single place.
15:38:10 <geerlingguy> aminvakil: that's a good question, we would have to figure out some metrics maybe
15:38:13 <wolcen> cybette: thanks! I registered again and was just approved.
15:39:00 <cybette> wolcen: great!
15:39:08 <geerlingguy> tadeboro: then maybe we call `community.general` `community.unmaintained` and commit to "if someone doesn't pull a thing out of here and maintain it by [x date], then it will be deprecated and removed from Ansible distribution in 2.13" or something like that
15:39:36 <tadeboro> I am all for that, but people did not like my proposal in the past.
15:39:39 <ptoal> I wonder if some of these questions are also tied to how galaxy / package management works.
15:40:02 <geerlingguy> in any case it's a massive effort, and I don't think andersson007_ and felixfontein will be able to carry on with c.g maintenance indefinitely
15:40:19 <tadeboro> I rather see abandoned project die rather that keeping a zombie alive.
15:41:21 <andersson007_> geerlingguy: felixfontain and i are really taught guys:)
15:41:42 <jrglynn2> aminvakil geerlingguy: i agree, i think it would be a combo maybe of metrics (is something starting to be maintained) + communication (reach out to maintaniner, see if it should be moved)
15:42:02 <geerlingguy> haha I know I know but I want to make it so your amazing abilities can be distributed more evenly among awesome things and not maintaining the sludge that is mixed in with the good bits in community.general
15:44:23 <felixfontein> moving things back and forth between two collections (c.g and c.unmaintained), because they get a maintainer, then loose one, then get another one, ..., is also annoying, both for maintainers and users
15:44:53 <gwmngilfen> this is why i'm working on trying to gauge the things that might not be maintained
15:44:57 <jrglynn2> that is true
15:45:01 <geerlingguy> felixfontein: I think the idea is nothing will *ever* move back into c.g
15:45:31 <geerlingguy> only way to go from c.unmaintained is to go into an independent collection where it will be maintained
15:45:38 <felixfontein> geerlingguy: i.e. move tsuff from community.unmaintained to community.<specific_name> when maintainer(s) are found?
15:45:44 <geerlingguy> yes exactly
15:45:49 <jrglynn2> geerlingguy: that makes sense
15:45:50 <felixfontein> what happens if community.<specific_name> gets abandoned?
15:46:08 <geerlingguy> felixfontein: then it loses its status as being part of the main ansible package
15:46:20 <geerlingguy> and we just treat it as unmaintained (but it's not in c.unmaintained)
15:46:38 <geerlingguy> no need to have it be put into some massive collection
15:47:05 <felixfontein> I wonder how many dead community.xyz collections we'd collect over time :)
15:47:15 <geerlingguy> A lot
15:47:21 <geerlingguy> but that's going to happen one way or another
15:47:22 <aminvakil> felixfontein: +1
15:47:39 <geerlingguy> like if vmware folds, the vmware collections will be defunct... dumb example but it's not a matter of if but when
15:49:00 <geerlingguy> Plenty of vendors have gone belly-up just in the past decade. Some open source tech that we have modules for will go defunct.
15:49:14 <felixfontein> definitely
15:54:54 <acozine> users may keep those tools on life support in their local environments even after the vendor/project folds, though . . .
15:55:08 <misc> yeah
15:55:15 <aminvakil> acozine: yep
15:56:17 <gwmngilfen> pabelanger: so after playing with the GitHub GraphQL API for a bit, I *think* we can get all the prior checks on a commit. If you can give me an example one which failed and the was re-run, I can check to be sure.
15:57:56 <felixfontein> acozine: they definitely do!
15:59:26 * cyberpear wonders where the video link is
15:59:29 <gwmngilfen> cough COBOL cough
16:00:15 <felixfontein> :D
16:00:29 <felixfontein> cyberpear: I think everyone who signed up got their personal video link
16:00:39 * cyberpear checks e-mail
16:00:44 <cyberpear> I didn't sign up officially until Monday
16:00:45 <jillr> cyberpear: https://primetime.bluejeans.com/a2m/register/ufuthevw
16:00:47 <geerlingguy> acozine: but in that case I'd say the user should fork the collection and use their fork locally (same thing has already happened with many, many roles on galaxy in the past)
16:01:34 <acozine> geerlingguy: yep, it's on them to maintain the collection then, or at least it should be
16:02:49 <gundalow> #agreed Chains that start in ansible-base MUST resolve in the Ansible package
16:03:54 <felixfontein> gundalow: I guess eventually that might stop, if we kick out things from Ansible that doesn't follow the guidelines anymore
16:04:03 <dmsimard> gwmngilfen: this one had failures and was re-checked: https://github.com/ansible-collections/community.general/pull/1096
16:04:04 <github-linkbot> https://github.com/ansible-collections/community.general/pull/1096 | closed, created 2020-10-14T19:18:17Z by patchback[bot]: [PR #1082/555eb621 backport][stable-1] solaris_zone: fix zone configuration with python3 [affects_2.10,bug,community_review,module,new_contributor,plugins,python3,system,tests]
16:04:24 <gwmngilfen> dmsimard: ta
16:04:54 <cyberpear> jillr: thanks for the link! I thought signing up for normal ansible fest was the place to be, with the checkbox for "contributor summit"... no wonder I couldn't find the sessions
16:06:05 <jillr> yw!
16:06:06 <cybette> did anyone get to the 2 qns in Bluejeans Q&A (one on fqcn and the other on collections as python packages). my laptop froze and I had to rejoin
16:06:23 <cybette> 861947
16:06:25 <cybette> oops
16:08:19 <gwmngilfen> dmsimard: pabelanger yep, got all 4 checks
16:09:23 <pabelanger> gwmngilfen: dmsimard: yah, per commit is nice, because it is possible the commit in general had bad code
16:09:46 <gwmngilfen> it has to be by commit anyway, thats what GH is testing
16:09:46 <pabelanger> more looking for PR commits >1
16:09:52 <pabelanger> cool
16:10:50 <gwmngilfen> pabelanger: https://paste.centos.org/view/73f3b8ca
16:11:48 <gwmngilfen> obviously that can be run across many PRs, I singled that one out to test
16:12:15 <gwmngilfen> swap pullRequest(...) for pullRequests(last:10) or something similar
16:12:43 <gwmngilfen> once you have the JSON, wrangling it into a table is easy enough
16:15:44 <pabelanger> gwmngilfen: could you use https://github.com/ansible-collections/vyos.vyos/ ?
16:16:02 <gwmngilfen> doing one now :P
16:16:06 <gwmngilfen> but yes, the repo is named on line 2
16:16:20 <gwmngilfen> well, 4 - line 2 of the query :P
16:16:34 <pabelanger> but yah, that looks onthe right track
16:16:38 <pabelanger> 2 failures, 2 success
16:17:24 <pabelanger> sorry
16:17:30 <pabelanger> 3 failures, 1 success
16:17:39 <pabelanger> that to me, means we had to recheck 3 times for some reason
16:17:44 <gwmngilfen> yeah, which makes sense, i see 3 recheck commands in the comments
16:17:47 <pabelanger> or 25% success rate
16:17:51 <pabelanger> nice
16:18:04 <pabelanger> that is exactly what we'd want to know, at quick glance
16:18:09 <gwmngilfen> sec, i can totally table this for vyos
16:18:22 <pabelanger> ++
16:22:03 <gundalow> DING DING DING Starting back in 3 minutes
16:26:00 <gundalow> #topic Diversity and Inclusion update
16:26:39 <pabelanger> how do we mark Q/A questions, answered?
16:26:45 <pabelanger> they are starting to pile up
16:26:55 <gundalow> pabelanger: don't think you can
16:26:57 <pabelanger> kk
16:27:09 <gundalow> #info Earlier in the year we setup a D&I working Group
16:27:23 <gundalow> #info We have two D&I sessions during Fest
16:27:40 <jillr> https://github.com/ansible/community/wiki/Diversity/FAQs
16:28:03 <gundalow> #info We've saved all the questions and will add to https://github.com/ansible/community/wiki/Diversity/FAQs
16:28:03 <felixfontein> one reason why I also mute my mic is that one of our cats sometimes comes up and meows a lot for attention :)
16:28:10 <baptistemm> felixfontein: https://github.com/ansible-collections/community.general/issues/1053 can be closed or is there a reason it stayed open ?
16:28:13 <gundalow> #info Feel free to join us in #ansible-diversity
16:28:28 <gundalow> #info This is the first year we had captioning available for some sessions
16:29:16 <felixfontein> baptistemm: nope. I sometimes hope that people just close their questions once answered, resp. wait for an answer (i.e. something that triggers github notifications).
16:36:31 <gwmngilfen> pabelanger: gotta run, will finish this up tomorrow and send you a pastebin
16:36:49 <gundalow> #topic Documentation update
16:36:59 <pabelanger> gwmngilfen: tyty
16:37:42 <gundalow> #info There are some pages that shouldn't be associated with a specific releases
16:38:35 <gundalow> #info Going forward ansible & ansible-base releases will diverge more.
16:40:15 <gundalow> #info We have a documentation working group breakout at 2000UTC
16:48:01 <gundalow> #info Anyone can and should help with documentation
16:50:43 <samccann> #link https://docs.ansible.com/ansible/latest/community/how_can_I_help.html#review-fix-and-maintain-the-documentation
16:52:23 <gundalow> #topic Content Team update
16:52:57 <gundalow> #info Brad and pabelanger give an updated on Content Team
17:04:57 <gundalow> If you are interested in using Ansible with Networking join the Networking Breakout at 2000UTC https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-network and in #ansible-network
17:05:36 <gundalow> #info index_of: https://github.com/ansible-collections/ansible.utils (for Plugins that are related to data manipulation will go)
17:07:18 <gundalow> #info jillr is now giving an updated on Cloud updates
17:16:36 <gundalow> #topic Release candidates for stable branches & CHAOS (experimental feedback)
17:16:47 <gundalow> #info relrod is now speaking
17:17:19 <gundalow> #info Some features intentionally break the world for the greater-good
17:24:19 * noonedeadpunk excited about RC news
17:24:51 <gundalow> noonedeadpunk: Ace, what in particular excites you?
17:26:31 <noonedeadpunk> well, there were several nasty backports lately that kind of broke roles. So we will try to follow RC's I guess and that should prevent from releasing such changes
17:26:31 <gundalow> #info Seperate PyPi project & GitHub repository where we can experiment with features
17:26:51 <gundalow> noonedeadpunk: perfect (well not that the broke), though yup, that's part of RCs
17:27:57 <gundalow> #info Maybe a different entry point, ie `ansible-choas-playbook` so you can it installed along side `ansible-base`
17:29:04 <gundalow> QUESTION: How can we get more people to test ansible & ansible-base RCs?
17:30:12 <gundalow> #topic Role Argument Spec Validation
17:30:21 <gundalow> #info sdoran  and Shrews talking
17:30:48 <noonedeadpunk> gundalow: well, RC will be announced in ML, right?
17:34:43 <gundalow> noonedeadpunk: correct
17:35:05 * noonedeadpunk subscribes
17:40:24 <bcoca> anyone else got kicked?
17:40:47 <baptistemm> the connection is flaky to me I don't know if my ISP or BJ
17:40:53 <gundalow> bcoca: 96 people there, not sure what it was before. I don't get a quit log
17:40:55 <baptistemm> +it's
17:41:24 <cybette> it was 99 when I looked 10 min ago
17:41:33 <gundalow> noonedeadpunk: Are you interested in contributing to Ansible, what areas?
17:41:38 <cybette> we get the log after the event ends (if people quit/rejoin)
17:45:37 <noonedeadpunk> um, we're trying to follow ansible versions and new features so makes sense for us to test master against RC
17:46:13 <noonedeadpunk> I'm just actually part of #openstack-ansible team so trying to catch up with all new areas as have a lot of things to improve
17:47:03 <relrod> noonedeadpunk: Awesome news that you're able to start testing RCs! Please by all means report any bugs you find in them to ansible/ansible, or you can ping in #ansible-devel. :)
17:48:27 <noonedeadpunk> sure!
17:49:29 * gundalow -> afk
17:52:56 <bcoca> i keep getting kicked
18:03:41 <samccann> I'm wondering if we need to find a place to say where to find sphinx themes that are workable for creating your own collection-level docsite? like - https://github.com/felixfontein/felix-ansible-docsite/blob/main/_static/ansible.css
18:04:25 <samccann> not in official docs/ but maybe ansible-collections/overview?  I feel bad directing people to grow their own docs solution, but I don't know how long they'd have to wait for Galaxy to show it
18:05:15 <gundalow> DING DING DING, 55 minute break
18:05:50 <dmsimard> samccann: https://github.com/ansible/ansible/blob/devel/docs/docsite/_extensions/pygments_lexer.py is pretty neat too.
18:06:51 <dmsimard> as in, making it available outside of ansible/ansible (like the themes) would be nice
18:06:57 <felixfontein> I'm not very familiar with how sphinx themes work; would it be possible to create a "theme extension" that adds a small CSS file to an existing theme and something like https://github.com/ansible/ansible/blob/devel/docs/docsite/_extensions/pygments_lexer.py ?
18:07:12 <felixfontein> I second that
18:07:32 <felixfontein> can sphinx extensions add CSS (and be theme-independent)?
18:07:45 <felixfontein> if yes, that should be very doable
18:08:50 <gundalow> #topic BREAK
18:08:58 <bcoca> you can 'override' a theme with local customization, but i have not done that in 7yrs
18:09:05 <felixfontein> I guess the break is a good time to research on that a bit :)
18:09:25 <felixfontein> bcoca: I don't want local modifications, but to make it reusable without being theme-specific
18:09:29 <samccann> well we have the ansible theme someone already pulled out too
18:09:42 <felixfontein> (I'm using local modifications now, but that's not reusable without copy'n'paste)
18:10:14 <bcoca> felixfontein: afaik, no, but i have not been deep into sphinx in long time, you were able to either have a theme or override parts of it, but no 'semi themes' that i know of
18:10:26 <felixfontein> samccann: but that's a whole theme, not just the important parts for collection docs. it comes with a lot of baggage that for example I do not want to have, like including javascript/css/font from random places on the internet
18:11:58 <felixfontein> where "random" = "not under my control" :)
18:27:59 <bcoca> control is an illusion
18:28:01 <bcoca> ;-p
18:28:32 <felixfontein> :)
18:33:08 <felixfontein> bcoca: there's an extension which copies a .css file: https://github.com/sphinx-contrib/ansi
18:33:35 <felixfontein> bcoca: I'm now trying to find out whether that way is recommended / deprecated / there's a better one. that repo has been last modified in 2012.
18:36:11 <felixfontein> bcoca: something newer (last modified two days ago): https://github.com/sphinx-contrib/emojicodes
18:36:30 <bcoca> he, gtk
18:36:52 <bcoca> i imagine that using an extension to pile on like the 'local override' does, should not be hard to create
18:37:50 <felixfontein> yep
18:53:21 <gundalow> DING DING DING, We are starting in 6 minutes
18:53:54 <zbr> i was looking for a way to render terminal (ansi) in sphinx too
18:54:11 <zbr> i anyone finds a decent solution please let me know
18:54:28 <gundalow> zbr: maybe ask in #ansible-docs ?
18:59:29 <geerlingguy> 30 seconds!
18:59:31 <nitzmahone> zbr: you could probably just do embedded output from https://github.com/buildkite/terminal-to-html in an rst `.. raw:: html` block, but depends on what/how you want it be rendered
19:00:56 <gundalow> #topic Minimum version of Python controller increase
19:02:33 <noonedeadpunk> wow, and how about centos 8?
19:03:40 <agaffney> I pointed out that Ubuntu Xenial doesn't have py3.8 available in the default repos
19:03:55 <agaffney> Bionic at least has it as an option, even if it's not the default python
19:04:15 <noonedeadpunk> what are not older distros? like I guess only focal has 3.8 and debian sid I guess?
19:05:08 <noonedeadpunk> well yeah, 3.8 backport is present for bionic... but centos 8 my real concern
19:05:33 <agaffney> is py3.8 available via SCL for EL8?
19:05:48 <geerlingguy> 3.7 feels like it would be more achievable if targeting all the common LTSes
19:06:23 <agaffney> and why not 3.6? that's not EOL for ~14 months
19:06:29 <sdoran> @agaffney Python 3.8 is available as an appstream in EL8.
19:07:08 <agaffney> I have done very little with CentOS 8, and even less with RHEL in general. I have no idea what an "appstream" is
19:07:24 <misc> a alternative repo, with a different life cycle
19:07:30 <sdoran> @agaffney By the time Ansible 2.11 ships next Spring, Python 3.6 will be much closer to EOL. By the time we move to a hard Python 3.x requirement in speculative Ansible 2.12, Python 3.6 will be EOL.
19:07:50 <noonedeadpunk> https://docs.centos.org/en-US/8-docs/managing-userspace-components/assembly_using-appstream/
19:07:53 <agaffney> sdoran: okay, but that doesn't rule out py3.7 like geerlingguy suggested
19:08:14 <sdoran> (speculative Ansible 2.12 or beyond. I don't mean to imply we will have a hard Python 3.x requirement in Ansible 2.12)
19:08:34 <noonedeadpunk> well I also can recall some improvements in 3.8 which are really nice ones but cant name them
19:09:29 <sdoran> The walrus operator is a neat one.
19:11:09 <jrglynn2> so if i were to create a brand new "central" ansible server to install (non-tower) v2.10, what is best OS to use?
19:11:16 <gundalow> https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-morning Line 162, please add notes there
19:11:29 * agaffney joins on bluejeans to listen to the conversation
19:11:31 <sdoran> agaffney: I believe the reason for aiming for 3.8 was due to the belief that distros that have 3.7 available all have 3.8, so why not aim for 3.8.
19:14:00 <pabelanger> does centos8 support py3.8?
19:14:09 <pabelanger> I haven't checked recently
19:14:22 <sdoran> Disregard what I said earlier: seems we are planning to have a hard requirement for Python 3.wheteverwedecide in Ansible 2.12.
19:14:26 <sdoran> pabelanger: Yes.
19:14:36 <webknjaz> @noonedeadpunk: Fedora 33 already has Python 3.9 FWIW
19:14:46 <pabelanger> sdoran: thanks
19:14:53 <noonedeadpunk> webknjaz: somebody uses fedora in prod?:)
19:15:02 <webknjaz> define "prod"
19:15:13 <webknjaz> but yes, I've heard ppl using that too
19:15:16 <noonedeadpunk> well, setup openstack on it :p
19:15:39 <noonedeadpunk> But i mean fedora lifecycle is 6 month...
19:16:02 <jalexandre> pabelanger yes, centos8 runs python 3.8. Checked against some servers here.
19:16:09 <noonedeadpunk> so you need the way more maintenances to keep supported version
19:16:17 <geerlingguy> webknjaz: Fedora is like riding on a rocket
19:16:26 * webknjaz uses Gentoo
19:16:29 <dmsimard> does that make me a rocket scientist
19:16:37 <noonedeadpunk> and yeah:) agree with geerlingguy here absolutely:)
19:16:49 <noonedeadpunk> dmsimard: it does!
19:16:57 <dmsimard> \o/
19:17:42 <noonedeadpunk> well, with pyenv you can get 3.8 everywhere...
19:17:53 <gundalow> #topic Execution Environments
19:18:26 <gundalow> #info maxamillion and Shane talking about Execution Execution Environments
19:19:40 <baptistemm> noonedeadpunk: fedora lifecycle in rather 2 releases
19:20:46 <misc> yeah, I guess I will run my control host on Fedora again
19:21:23 <nitzmahone> There's also no guarantee that 3.6 stays the "official Python of RHEL8" after it's EOL- that was a huge point of platform-python and appstream pythons, so that the platform-python can be revved when needed because apps/user stuff aren't supposed to be dependent on it. It'll be interesting to see what really happens with that.
19:21:28 <baptistemm> a container is good also, you have a defined environment
19:21:55 <baptistemm> never tested that though
19:22:04 <nitzmahone> Even things that are using 3.6 on RHEL8 are *supposed* to be using the 3.6 Appstream
19:22:09 <noonedeadpunk> baptistemm: oh, yeah, sorry, it's really 13 month about. but comparing to ubuntu or centos....
19:22:26 <sdoran> #info This does not mean you will be required to use a container to run/use Ansible. EE provides a nice portable Ansible control node as an option.
19:22:33 <noonedeadpunk> while agree that for desktops it's super nice
19:22:41 <pabelanger> dmsimard: bindep!
19:23:03 <dmsimard> pabelanger: yeah I wasn't sure if I heard that correctly :O
19:23:24 <noonedeadpunk> o_O
19:23:28 <baptistemm> bindep ?
19:23:48 <sdoran> Yup. It's a good tool.
19:24:02 <noonedeadpunk> super nice
19:24:03 <noonedeadpunk> https://docs.openstack.org/infra/bindep/readme.html
19:24:11 <pabelanger> born out of openstack-infra team
19:24:12 <dmsimard> kinda like requirements.txt but for distro packages
19:25:09 <webknjaz> @noonedeadpunk: FWIW with pyenv you can get 3.9.0 final too, it's been released last week
19:25:39 <noonedeadpunk> yeah, I know. I guess it's more about how convenient it is
19:26:43 <noonedeadpunk> installing ansible controller shouldn't be a challendge that was the main point I guess
19:27:29 <webknjaz> @noonedeadpunk: it's great for development and sometimes CIs. Although it's slow because it compiles CPython from scratch. Also it's not good for prod because you may accidentally compile a partial version of the CPython distribution.
19:28:02 <noonedeadpunk> can't agree more
19:28:45 <webknjaz> Ubuntu users could use deadsnakes, though. Anthony does a great job supporting that. And RPM-based distros could look into Fedora too
19:29:23 <sivel> Ubuntu 18.04 and newer all have py3.8 already
19:29:42 <sivel> Ubuntu 16.04 will be end of standard support by release
19:29:56 <noonedeadpunk> 18.04 goes with 3.6 out of the box, but indeed has 3.8 from updates which is cool
19:30:34 <webknjaz> Although, Ubuntu/Deb don't have the best ecosystem support for Python
19:30:34 <noonedeadpunk> not sure about debian buster though - hope it has it somewhere as well
19:30:49 <noonedeadpunk> webknjaz: why so?
19:31:17 <webknjaz> they often break essential tooling like pip/virtualenv
19:31:39 <webknjaz> it stopped us from putting 20.04 into the CI, for example
19:31:43 <noonedeadpunk> hm, never faced for a years...
19:31:47 * sdoran glares at Ubuntu 20.04
19:31:57 <sivel> That was more of a debian bug, that Ubuntu inherited, but didn't automatically backport
19:32:20 <webknjaz> but then they "fixed" it in devel but not in what everyone uses
19:32:28 <bcoca> one bad thing about having 'shared' responsibilty is the buck passing that happens on fixing/backporting issues
19:32:31 <noonedeadpunk> but we bump pip/virtualenv and upgrade it to required version
19:32:39 <noonedeadpunk> so probably that's why
19:32:51 <webknjaz> not when pip tracebacks
19:33:23 <noonedeadpunk> hm, we have moved jobs to focal and works nicely...
19:34:12 <noonedeadpunk> but yeah, we might do some specific things, so not relevant
19:34:21 <webknjaz> https://github.com/ansible/ansible/issues/69203#issuecomment-663901637
19:34:53 <webknjaz> maybe it's fixed already, haven't checked in a while
19:38:11 <gundalow> #topic Galaxy Next Gen
19:38:36 <noonedeadpunk> well, I was totally frustrated with libselinux for centos 7 when centos 7 didn't have python3-libselinux for half a year or so, and they released it the way after py2 went EOL
19:38:46 <gundalow> #info newswangerd is speaking
19:38:57 <noonedeadpunk> which made impossible to switch to py3...
19:39:27 <noonedeadpunk> so everybody not ideal it seems :p
19:40:47 <gundalow> Any Execution Environment questions please add to https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-morning Line 185
19:45:31 <noonedeadpunk> question - how to integrate zuul with galaxy_ng ?:))
19:46:10 <noonedeadpunk> for cd part I guess there're api keys
19:46:31 <gundalow> pabelanger: ^
19:46:38 <bcoca> api token button that you saw in prev page
19:47:23 <pabelanger> noonedeadpunk: yah, you need a token
19:47:32 <pabelanger> we have publish jobs in zuul.a.c you can look at
19:47:54 <noonedeadpunk> oh, that's great!
19:48:07 <pabelanger> https://github.com/ansible/project-config/blob/master/zuul.d/secrets.yaml#L118 for example
19:48:52 <pabelanger> https://github.com/ansible/project-config/blob/master/zuul.d/jobs.yaml#L140 release job
19:49:18 <pabelanger> at one point, I had a buildset galaxy server working for jobs, so we could actually test against local galaxy server
19:49:23 <pabelanger> need to get that working again
20:01:12 <sivel> pabelanger: we have galaxy_ng testing in ansible CI now
20:01:20 <sivel> pabelanger: that may be something you want to look at
20:02:15 <sivel> pabelanger: you can spin up a single docker container that has it running
20:03:14 <sivel> https://github.com/ansible/ansible/pull/69605 https://github.com/ansible/ansible/pull/70303 https://github.com/sivel/ansible-pulp-galaxy-ng
20:03:15 <github-linkbot> https://github.com/ansible/ansible/pull/69605 | closed, created 2020-05-19T21:02:10Z by sivel: Test ansible-galaxy against pulp/pulp_ansible [affects_2.10,feature,needs_revision,support:community,support:core,test]
20:03:56 <sivel> pabelanger: feel free to ping me if you have any questions, I spent a long time getting that working
20:04:54 <pabelanger> cool, will do
20:05:34 <gundalow> Thanks all
20:06:13 <ktdreyer> dmsimard: I was reading about docs/docsite/_extensions/pygments_lexer.py . Do you have an example project (outside ansible) that uses that?
20:06:16 <gundalow> Network https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-network
20:06:16 <gundalow> Cloud https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-cloud
20:06:16 <gundalow> Documentation https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-Docs
20:06:16 <gundalow> Security https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-security
20:06:32 <ktdreyer> I filed https://github.com/ktdreyer/koji-ansible/issues/206 so investigate more about this :)
20:06:37 <aminvakil> gundalow: thank you!
20:08:26 <dmsimard> ktdreyer: ara used to have role docs in sphinx and used "code-block:: yaml+jinja" for nice syntax highlighting
20:09:46 <dmsimard> because the roles were split outside of ara and into a collection, there's no more sphinx so it's raw markdown nowadays
20:10:34 <ktdreyer> woah, ok
20:11:07 <cybette> did everyone get into the breakout sessions ok? let me know if you have issues with the bluejeans links
20:11:24 <dmsimard> cybette: ansible-cloud is chugging along
20:11:36 <cybette> dmsimard: great!
20:19:04 <apple4ever> where are the breakout links?
20:20:39 <gundalow> apple4ever:
20:20:40 <gundalow> Network https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-network
20:20:40 <gundalow> Cloud https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-cloud
20:20:40 <gundalow> Documentation https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-Docs
20:20:40 <gundalow> Security https://etherpad.opendev.org/p/ansible-contributor-summit-october-2020-security
20:22:01 <apple4ever> gundalow ahh they are in each etherpad thanks!
21:15:26 <cybette> gabrielzeven: sorry I just saw your message in security breakout! I was lurking in all but not really listening to any :P
21:22:53 <gundalow> Thank you everybody!
21:23:03 <gundalow> #endmeeting