#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:00:15 UTC (full logs).

Meeting summary

  1. agenda: https://github.com/ansible/community/issues/539 (the last few comments) (felixfontein, 19:01:53)
    1. HELP: (geerlingguy, 19:02:18)
    2. HELP: (dmsimard, 19:02:56)

  2. announcements (felixfontein, 19:03:27)
    1. community.docker, community.postgresql and community.routeros 1.0.0 were released this week and will be included in the next Ansible 2.10 release (felixfontein, 19:03:52)
    2. The Bullhorn 14 has been published today: https://mailchi.mp/redhat/the-bullhorn-14 (felixfontein, 19:04:34)
    3. Next two Ansible PR days are Tue 1st Dec and Thu 17th December. Calendar invite is in https://github.com/ansible/community/issues/407 Hope to see you there (gundalow, 19:04:37)
    4. Ansible-2.10.4 will be released on Tues, 1st Dec (or possibly 2nd December according to timezones ;-) (abadger1999, 19:05:48)
    5. please review https://github.com/ansible-collections/community.general/pull/1303 and https://github.com/ansible-collections/community.general/pull/1304, in particular the changelog fragments, since we will replicate them a lot (felixfontein, 19:05:56)
    6. https://github.com/ansible-collections/community.general/pull/1303 | open, created 2020-11-14T19:43:15Z by felixfontein: [WIP] Add information on docker module migration [WIP,affects_2.10,docs,has_issue,needs_triage,owner_pr] (github-linkbot, 19:05:56)
    7. No IRC Meeting next week (25th Nov) as lots of people are off that week (gundalow, 19:07:47)
    8. ansible/ansible is now `ansible-core` (previously ansible-base) https://github.com/ansible/ansible/pull/72594 (gundalow, 19:08:14)
    9. https://github.com/ansible/ansible/pull/72594 | closed, created 2020-11-12T00:53:41Z by relrod: Rename to ansible-core [affects_2.11,bug,shipit,support:community,support:core,test] (github-linkbot, 19:08:16)

  3. Semantic versioning of the ansible package (abadger1999, 19:11:47)
    1. related proposal: https://github.com/ansible/proposals/issues/179 (felixfontein, 19:12:09)
    2. AGREED: The next major release of ansible will be 3.0.0; Ansible releases will follow semantic versioning going forward from there (12 x +1, 1 x 0, 2 x -1) (felixfontein, 19:32:04)

  4. Release schedule for ansible-3.0.0 (abadger1999, 19:44:55)
    1. tentative schedule for 3.0.0: https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw (felixfontein, 19:45:40)
    2. https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw (abadger1999, 19:45:46)
    3. Proposed schedule: https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw (abadger1999, 19:45:53)
    4. 2020-12-16: Finalize rules for net-new collections submitted for the ansible release. (felixfontein, 19:48:49)
    5. 2021-01-27: Final day for net-new collections to be **reviewed and approved.** (felixfontein, 19:48:59)
    6. AGREED: approved https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-30 as the release schedule for Ansible 3.0.0 (13 x +1) (felixfontein, 19:54:09)
    7. ACTION: gundalow to copy https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-30 to reddit (gundalow, 19:54:48)

  5. inclusion of dellemc.openmanage (https://github.com/dell/dellemc-openmanage-ansible-modules/tree/collections) in 2.10.x for transfer of some content from c.g (https://github.com/ansible-collections/community.general/pull/948) (felixfontein, 19:55:27)
    1. https://github.com/dell/dellemc-openmanage-ansible-modules/pull/174 | open, created 2020-11-18T12:57:28Z by gundalow: WIP Run ansible-test sanity & units (github-linkbot, 19:59:27)
    2. https://github.com/dell/dellemc-openmanage-ansible-modules/pull/174 | open, created 2020-11-18T12:57:28Z by gundalow: WIP Run ansible-test sanity & units (github-linkbot, 19:59:30)
    3. AGREED: we will reconsider dellemc.openmanage once the rules for inclusion in 2.11 have been set up (felixfontein, 20:05:33)
    4. https://github.com/ansible-collections/community.general/pull/948 (felixfontein, 20:05:54)
    5. https://github.com/ansible-collections/community.general/pull/948 | open, created 2020-09-23T08:52:50Z by rajeevarakkal: Remove DellEMC collections from community.general collectons [affects_2.10,feature,has_issue,module,module_utils,needs_maintainer,needs_revision,new_contributor,plugins,remote_management,stale_ci,tests,unit] (github-linkbot, 20:05:55)
    6. AGREED: we will revisit including dellemc.openmanage after we've had the longer discussion around inclusion criteria. Though at the moment they don't run `sanity` https://github.com/dell/dellemc-openmanage-ansible-modules/pull/174 (gundalow, 20:08:42)
    7. https://github.com/dell/dellemc-openmanage-ansible-modules/pull/174 | open, created 2020-11-18T12:57:28Z by gundalow: WIP Run ansible-test sanity & units (github-linkbot, 20:08:43)

  6. Criteria for new collections to be included in ansible-3.0.0 (abadger1999, 20:08:48)
    1. Proposal: https://github.com/ansible/community/issues/539#issuecomment-729844717 (felixfontein, 20:09:02)
    2. We are happy for the inclusion criteria (https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst) to become stricter to help improve the quality of the collections that are shipped in `ansible`. If you have an idea please mention in IRC or raise a PR directly against collection_requirements.rst to clarify & improve (gundalow, 20:12:09)
    3. Discuss current checklist today, approve it as a basis for the guidelines no later than beginning of meeting on December-2-2020. (abadger1999, 20:13:03)
    4. Discuss and approve changes to the guidelines on December-9 and December-16 (abadger1999, 20:13:26)
    5. Guidelines that have been approved by the end of the Dec-16 meeting will be the criteria for new collections in ansible-3.0. (abadger1999, 20:13:54)

  7. Discuss and approve the current checklist (abadger1999, 20:14:07)
    1. The current checklist: https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst (abadger1999, 20:14:17)
    2. ACTION: Need email address of maintainers for CVEs (gundalow, 20:19:22)
    3. ACTION: create issue to track CI testing to match Galaxy/AH import testing (gundalow, 20:20:29)
    4. ACTION: Include strong worded comments about unit tests (module_utils) and integration tests (gundalow, 20:25:00)
    5. https://hackmd.io/4hCPYtfLQQO4O9_UfcfhUQ (abadger1999, 20:28:10)
    6. ACTION: ALL: Please write up your proposals for changes to https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst categorized by whether they should block approval of the checklist or not. We'll start discussing and voting on changes next meeting (abadger1999, 20:39:11)
    7. Reminder: next meeting is in two weeks, i.e. December 2nd, starting at 19:00 UTC (felixfontein, 20:39:54)
    8. ACTION: Write your proposals as an issue and mention it in the community agenda ticket https://github.com/ansible/community/issues/539 (abadger1999, 20:40:22)

  8. open floor (felixfontein, 20:43:17)
    1. https://github.com/ansible-collections/collection_template/issues/18 (felixfontein, 20:46:38)
    2. https://github.com/ansible-collections/collection_template/issues/18 (cyberpear, 20:46:53)
    3. need to write some text to explain what license the template is under and what licenses the collection owner can place it under (abadger1999, 20:49:17)
    4. need to CC all of the current contributors (8) to the templates about whether we can license it under a liberal license (3-clause BSD maybe?) (abadger1999, 20:49:49)


Meeting ended at 21:05:58 UTC (full logs).

Action items

  1. gundalow to copy https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-30 to reddit
  2. Need email address of maintainers for CVEs
  3. create issue to track CI testing to match Galaxy/AH import testing
  4. Include strong worded comments about unit tests (module_utils) and integration tests
  5. ALL: Please write up your proposals for changes to https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst categorized by whether they should block approval of the checklist or not. We'll start discussing and voting on changes next meeting
  6. Write your proposals as an issue and mention it in the community agenda ticket https://github.com/ansible/community/issues/539


Action items, by person

  1. gundalow
    1. gundalow to copy https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-30 to reddit
  2. UNASSIGNED
    1. Need email address of maintainers for CVEs
    2. create issue to track CI testing to match Galaxy/AH import testing
    3. Include strong worded comments about unit tests (module_utils) and integration tests
    4. ALL: Please write up your proposals for changes to https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst categorized by whether they should block approval of the checklist or not. We'll start discussing and voting on changes next meeting
    5. Write your proposals as an issue and mention it in the community agenda ticket https://github.com/ansible/community/issues/539


People present (lines said)

  1. felixfontein (148)
  2. abadger1999 (106)
  3. geerlingguy (55)
  4. gundalow (48)
  5. dmsimard (36)
  6. tadeboro (35)
  7. samccann (24)
  8. jillr (24)
  9. zodbot (23)
  10. jtanner (15)
  11. acozine (15)
  12. cyberpear (14)
  13. aminvakil (12)
  14. ikhan_ (8)
  15. cybette (7)
  16. resmo (6)
  17. github-linkbot (6)
  18. dericcrago (6)
  19. briantist (3)
  20. bcoca (2)
  21. gwmngilfen (2)
  22. lmodemal (1)


Generated by MeetBot 0.1.4.