#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:00:34 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539#issuecomment-755239495 (felixfontein, 19:00:34)
  2. Updates (felixfontein, 19:00:53)
    1. Ansible 2.10.5 has been released (felixfontein, 19:00:54)
    2. community.google, community.hashi_vault, community.kubevirt and cisco.nso have been added to Ansible 2.10.5, they contain migrated content from community.general and community.network. Coming up next is community.fortios. (felixfontein, 19:00:54)
    3. community.general 2.0.0 will be dependency free, and community.network 2.0.0 will only depend on ansible.netcommon once community.fortios is done. (felixfontein, 19:00:57)
    4. The Bullhorn 17 has been released: https://mailchi.mp/redhat/the-bullhorn-17 (felixfontein, 19:01:00)
    5. very happy to welcome ompragash to the Ansible Community Engineering Team (gundalow, 19:06:48)

  3. inclusion of inspur.sm in Ansible 3.0.0 (felixfontein, 19:11:09)
    1. https://github.com/ansible-collections/ansible-inclusion/discussions/8 (dmsimard, 19:11:52)
    2. We are using https://github.com/ansible-collections/ansible-inclusion/discussions to track requests for inclusion in `ansible` package (gundalow, 19:11:59)

  4. collection checklist template https://github.com/ansible-collections/overview/issues/140 (felixfontein, 19:21:40)
    1. andersson007_ prepared a checklist for the collection requirements in https://github.com/ansible-collections/overview/issues/140 (felixfontein, 19:22:11)
    2. the main document: https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst (felixfontein, 19:30:16)
    3. AGREED: add `Collections MUST adhere to [semantic versioning](https://semver.org/).` as the first paragraph in https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst#versioning-and-deprecation (felixfontein, 19:33:35)
    4. https://github.com/ansible-collections/overview/pull/146 contains the changes to the requirements document we decide on today (felixfontein, 19:35:58)
    5. https://github.com/ansible-collections/overview/pull/146 | open, created 2021-01-06T19:35:38Z by felixfontein: Extend collection requirements (github-linkbot, 19:35:58)

  5. collection requirements (felixfontein, 19:37:34)
    1. summary of the problem: https://github.com/ansible/community/issues/539#issuecomment-750301681 (felixfontein, 19:37:50)
    2. https://github.com/ansible-collections/overview/pull/146#issuecomment-755591187 (felixfontein, 19:50:14)
    3. AGREED: `The `ansible` package MUST NOT depend on collections not shipped in the package` as the first sentence (felixfontein, 19:55:59)
    4. AGREED: change second sentence to `If you plan to split up your collection, the new collection must be approved for inclusion before the smaller collections replace the larger in ansible.` (felixfontein, 19:58:10)
    5. AGREED: add https://github.com/ansible-collections/overview/pull/146#issuecomment-755591187 at the end of https://github.com/ansible-collections/overview/blob/79f33f9f227fbdf59fa9641dc1a9c42d66c2e0f1/collection_requirements.rst#galaxyyml ? (felixfontein, 20:01:17)
    6. https://github.com/ansible-collections/overview/pull/146 contains both changes (felixfontein, 20:01:33)
    7. AGREED: merge https://github.com/ansible-collections/overview/pull/146 (felixfontein, 20:04:47)
    8. AGREED: in both the checklist and collection requirements, replace the part on >=1.0.0 with `Collection dependencies must have a lower bound on the version which is at least 1.0.0` (felixfontein, 20:22:14)
    9. AGREED: replace `- [ ] collection dependencies must have a lower bound on the version which is at least 1.0.0` in the checklist by `- [ ] collection dependencies must have a lower bound on the version which is at least 1.0.0, and are all part of the `ansible` package` (felixfontein, 20:26:24)
    10. https://github.com/ansible-collections/overview/pull/146) | open, created 2021-01-06T19:35:38Z by felixfontein: Extend collection requirements (github-linkbot, 20:29:08)
    11. AGREED: we accept the checklist (everything until exluding `Removed from the list (if anybody disagrees, please tell us):` and the lines below) (felixfontein, 20:29:43)
    12. I've updated https://github.com/ansible-collections/overview/pull/146 (felixfontein, 20:29:58)

  6. starting the collection review process (felixfontein, 20:34:19)
  7. open floor (felixfontein, 20:43:05)


Meeting ended at 20:45:48 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. felixfontein (197)
  2. abadger1999 (62)
  3. gundalow (51)
  4. samccann (38)
  5. cybette (33)
  6. tadeboro (31)
  7. zodbot (21)
  8. acozine (17)
  9. russoz (14)
  10. dmsimard (13)
  11. dericcrago (13)
  12. geerlingguy (12)
  13. wangbaoshan (12)
  14. jtanner (11)
  15. ompragash (8)
  16. lmodemal (4)
  17. gwmngilfen (3)
  18. briantist (3)
  19. github-linkbot (2)


Generated by MeetBot 0.1.4.