#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:01:04 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 19:01:04)
  2. Updates (felixfontein, 19:02:44)
    1. Ansible 2.10.7 and Ansible 3.0.0rc1 have been released, with a bunch of security fixes (potential information leaks) (felixfontein, 19:02:44)
    2. collection maintainers should look at the last few announcements in https://github.com/ansible-collections/overview/issues/45 regarding ansible-test / CI (felixfontein, 19:02:47)
    3. A reminder that contributor summit is next month, make sure to read and add your topics to https://hackmd.io/uZDSLOOdS1Kx0xfZVIATmQ (dmsimard, 19:03:34)
    4. https://mailchi.mp/redhat/the-bullhorn-19 (dmsimard, 19:05:00)

  3. Blog post for Ansible 3.0.0, and potential delay of 3.0.0 release: https://github.com/ansible/community/issues/539#issuecomment-776930666 (felixfontein, 19:08:02)
    1. AGREED: We delay Ansible 3.0.0 until at most Thursday if the blog post with all Q&A is not ready before Thursday. If it isn't ready by Thursday either, we do not block 3.0.0 because of the blog post anymore. (felixfontein, 19:14:10)

  4. blockers for 3.0.0 -- docs split (felixfontein, 19:14:22)
    1. docs split has a PR and detailed implementation plan but it isn't completely coded yet, needs cleanup, and then needs approval from the core team and community members to get it merged. (abadger1999, 19:16:56)
    2. https://hackmd.io/mvjYig49R5SQbNHzsd5jfQ?both#2-Jenkins-jobs (abadger1999, 19:18:16)
    3. https://github.com/ansible/ansible/pull/73421 (abadger1999, 19:19:28)
    4. https://github.com/ansible/ansible/pull/73421 | open, created 2021-01-29T20:21:23Z by samccann: [WIP] Create separate core docs using 2 index files [WIP,affects_2.11,docs,needs_ci,needs_rebase,support:core,test] (github-linkbot, 19:19:29)
    5. https://github.com/ansible/ansible/pull/73362, | open, created 2021-01-25T21:05:02Z by samccann: [WIP] Make coredocs [WIP,affects_2.11,docs,docsite,has_issue,needs_rebase,networking,stale_ci,support:core,test] (github-linkbot, 19:20:19)
    6. https://github.com/ansible/ansible/pull/73299)? | open, created 2021-01-19T21:35:25Z by samccann: [WIP] Create ability to make core docs separate from Ansible docs [WIP,affects_2.11,docs,needs_rebase,stale_ci,support:core,test] (github-linkbot, 19:20:20)
    7. AGREED: no release without docs (either real solution, or hack) - so docs are a blocker for 3.0.0 (felixfontein, 19:29:40)
    8. AGREED: work on the real thing until at least next Tuesday (DaWGs meeting), and only resort to hack when it is clear by then that the real thing won't get completed anytime soon (felixfontein, 19:34:14)
    9. https://github.com/ansible-community/antsibull/pull/238 | open, created 2021-01-17T13:02:08Z by felixfontein: antsibull-docs: process routing metadata [enhancement] (github-linkbot, 19:35:06)

  5. Python compatibility: https://github.com/ansible-collections/overview/pull/151 (felixfontein, 19:40:10)
    1. https://github.com/ansible-collections/overview/pull/151 | open, created 2021-01-25T12:48:11Z by Ompragash: New Policy Regarding Python Compatibility for Collections (github-linkbot, 19:40:10)
    2. ACTION: abadger1999 will update PR, asking that both proposals are worked into the draft. (abadger1999, 20:12:54)

  6. Docs clarity: https://github.com/ansible-collections/overview/pull/152 (felixfontein, 20:13:51)
    1. Still need to talk about (*) module_utils, (*) minimum versions of python2 and python3 controller and remote side? (*) When should these versions be updated? (abadger1999, 20:14:53)

  7. Docs clarity: https://github.com/ansible-collections/overview/pull/152 (abadger1999, 20:15:17)
  8. Collection checklist: check tests/integrations/ for blobs? https://github.com/ansible/community/issues/539#issuecomment-774705929 (andersson007_) (felixfontein, 20:21:41)
    1. moving tests/ into its own distribution: legal would have to look at this first, and for that someone has to create a POC so they have something to look at (felixfontein, 20:34:08)

  9. How often should Ansible major releases be made per year? (felixfontein, 20:34:47)
    1. AGREED: Unless something changes with ansible-core release schedules, ansible will plan on six month schedules for major releases targeting about a month behind ansible-core. (felixfontein, 20:57:01)

  10. open floor (felixfontein, 20:57:08)


Meeting ended at 20:59:10 UTC (full logs).

Action items

  1. abadger1999 will update PR, asking that both proposals are worked into the draft.


Action items, by person

  1. abadger1999
    1. abadger1999 will update PR, asking that both proposals are worked into the draft.


People present (lines said)

  1. felixfontein (167)
  2. abadger1999 (79)
  3. samccann (51)
  4. acozine (38)
  5. dmsimard (34)
  6. jillr (24)
  7. gundalow (22)
  8. tadeboro (22)
  9. cybette (19)
  10. zodbot (13)
  11. briantist (9)
  12. sivel (6)
  13. github-linkbot (6)
  14. pabelanger (6)
  15. dericcrago (5)
  16. lmodemal (4)
  17. bcoca (2)
  18. misc (1)


Generated by MeetBot 0.1.4.