#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 19:00:12 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 19:00:12)
  2. Updates (felixfontein, 19:02:03)
    1. The docsite split PR has been merged to ansible/ansible's devel branch (felixfontein, 19:02:03)
    2. We are on target to have two blog posts published Thursday for the 3.0.0 release. One is story-oriented (how we got here) and the other is in a Q&A format to answer some of the questions we have seen so far. (felixfontein, 19:02:06)
    3. Register for Ansible Contributor Summit 2021.03 https://www.eventbrite.com/e/ansible-contributor-summit-202103-registration-141735886853?aff=irc (cybette, 19:02:21)
    4. Propose topics for Contributor Summit https://hackmd.io/uZDSLOOdS1Kx0xfZVIATmQ (cybette, 19:02:27)

  3. Clarity of documentation: https://github.com/ansible-collections/overview/pull/152 (felixfontein, 19:06:07)
    1. https://github.com/ansible-collections/overview/pull/152 | open, created 2021-01-27T20:17:20Z by dmsimard: Improve clarity of the documentation requirements (github-linkbot, 19:06:07)
    2. https://github.com/ansible-collections/overview/pull/152#discussion_r574049956 (acozine, 19:07:58)
    3. AGREED: merge https://github.com/ansible-collections/overview/pull/152 (felixfontein, 19:11:31)

  4. Staffing update (gundalow, 19:13:22)
    1. Please welcome andersson007_ to the Ansible Community Engineering Team (gundalow, 19:13:37)

  5. Python version requirements for module_utils (felixfontein, 19:14:41)
    1. https://github.com/ansible-collections/overview/pull/151#issuecomment-777654599 (felixfontein, 19:15:23)
    2. https://github.com/ansible-collections/overview/pull/151#issuecomment-777654599 | open, created 2021-01-25T12:48:11Z by Ompragash: New Policy Regarding Python Compatibility for Collections (github-linkbot, 19:15:23)

  6. Minimum versions of Python for controller-side and remote-side (abadger1999, 19:19:27)
    1. AGREED: We keep our previous voted on proposal: require 2.7 and 3.6+ support both for remote-side and controller-side, and suggest to also support 2.6 on remote-side and 3.5 on both sides (always assuming required libraries support this) (felixfontein, 19:43:35)
    2. AGREED: The minimal bounds are adjusted when the ansible-core we depend on stops running on specific Python versions on remote or controller side (felixfontein, 19:49:12)

  7. Any blockers for ansible-3.0.0 tomorrow? (abadger1999, 19:50:12)
    1. docsite split should be okay for tomorrow. There is some failures on backport and wonkiness in the version-switcher but those do not need to block release. (abadger1999, 19:53:07)
    2. dmsimard's blog post for 3.0.0 is ready (abadger1999, 19:53:21)
    3. No blockers for release; ansible-3.0.0 will go out tomorrow! (abadger1999, 19:53:36)

  8. Python version requirements for module_utils (felixfontein, 19:54:44)
    1. AGREED: convention for module_utils: a) no docstring = everything we recommend for remote-side is supported, b) docstring 'Python versions supported: as for controller-side' = everything we recommend for controller-side is supported, c) docstring with specific versions otherwise: 'Python versions supported: <explicit list>' (felixfontein, 20:13:27)
    2. AGREED: module_utils can be marked for only internal use in the collection, but they MUST document this and MUST use a leading underscore for filenames. Making an existing module_utils private is a breaking change and requires a major version bump. (felixfontein, 20:26:20)
    3. AGREED: collections MUST announce dropping support for Python versions in their changelog, if possible in advance (i.e. announce in previous versions when support will be dropped); if collections are aware of collection users (which import their code), they SHOULD announce it directly to their known users, and/or to https://github.com/ansible-collections/overview/issues/45, and/or The (felixfontein, 20:34:26)

  9. Open floor (felixfontein, 20:35:49)


Meeting ended at 20:39:28 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. felixfontein (159)
  2. abadger1999 (59)
  3. tadeboro (32)
  4. jillr (28)
  5. acozine (26)
  6. briantist (20)
  7. zodbot (17)
  8. cybette (17)
  9. andersson007_ (11)
  10. gundalow (9)
  11. lmodemal (7)
  12. dericcrago (6)
  13. github-linkbot (2)
  14. misc (2)
  15. sivel (2)
  16. samccann (1)


Generated by MeetBot 0.1.4.