19:00:24 <felixfontein> #startmeeting Ansible Community Meeting
19:00:24 <zodbot> Meeting started Wed Mar 17 19:00:24 2021 UTC.
19:00:24 <zodbot> This meeting is logged and archived in a public location.
19:00:24 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:24 <zodbot> The meeting name has been set to 'ansible_community_meeting'
19:00:25 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
19:00:25 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro: ping!
19:00:30 <abadger1999> hi
19:00:31 * gundalow waves
19:00:34 <dmsimard> \o
19:00:35 <andersson007_> o/
19:00:37 <felixfontein> #chair abadger1999 gundalow dmsimard andersson007_
19:00:37 <zodbot> Current chairs: abadger1999 andersson007_ dmsimard felixfontein gundalow
19:00:37 <tadeboro> o/
19:00:39 <cyberpear> o/
19:00:43 <cybette> o/
19:00:44 <briantist> o/
19:00:46 <felixfontein> #chair tadeboro cyberpear cybette
19:00:46 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dmsimard felixfontein gundalow tadeboro
19:00:52 <felixfontein> #chair briantist
19:00:52 <zodbot> Current chairs: abadger1999 andersson007_ briantist cyberpear cybette dmsimard felixfontein gundalow tadeboro
19:00:59 <felixfontein> #topic Updates
19:00:59 <felixfontein> #info Ansible 4.0.0a1 has been released
19:01:26 <felixfontein> any more furniture? :)
19:01:36 <andersson007_> + kitchensink
19:01:42 <felixfontein> :)
19:01:46 <samccann> o/
19:01:51 <felixfontein> #chair samccann
19:01:51 <zodbot> Current chairs: abadger1999 andersson007_ briantist cyberpear cybette dmsimard felixfontein gundalow samccann tadeboro
19:02:01 * dericcrago waves
19:02:07 <felixfontein> #chair dericcrago
19:02:07 <zodbot> Current chairs: abadger1999 andersson007_ briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow samccann tadeboro
19:02:40 <cybette> #info Ansible Contributor Summit 2021.03 playlist https://www.youtube.com/playlist?list=PL0FmYCf7ocraIwuMDD_TceUMneSiy3Hi1
19:03:08 <jillr> o/ sorry I'm late
19:03:12 <felixfontein> it was a really nice summit :)
19:03:14 <felixfontein> #chair jillr
19:03:14 <zodbot> Current chairs: abadger1999 andersson007_ briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
19:03:19 <felixfontein> jillr: still in time :)
19:03:20 <andersson007_> +1
19:03:31 <cybette> +1 thanks to everyone for great summit
19:03:42 <andersson007_> summit was great
19:03:51 <briantist> yeah great job
19:03:51 <cyberpear> cybette++ thanks for putting the playlist!
19:04:01 <andersson007_> feeling of community
19:04:22 <cybette> cyberpear: my pleasure!
19:04:25 <felixfontein> and seeing more faces :)
19:05:02 <apple4ever> Summit was great! Glad the videos were posted since I missed some of them
19:05:11 <felixfontein> #chair apple4ever
19:05:11 <zodbot> Current chairs: abadger1999 andersson007_ apple4ever briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
19:06:15 <gundalow> cybette: Do you have an IRC specific survey link you'd like to share?
19:06:17 <felixfontein> any more updates?
19:07:06 <cybette> gundalow: I actually didn't get a link for IRC... Gwmngilfen?
19:07:28 <gundalow> cybette: Just wondered if you wanted to share a link here
19:07:50 <gundalow> #info If you attended Contributors Summit please check your email for a survey link. Feedback is really important to us
19:07:59 <gundalow> felixfontein: Don't think there are any other updates
19:08:03 <felixfontein> ok :)
19:08:09 <felixfontein> #topic Ansible Engineering Steering Committee
19:08:09 <felixfontein> #info From next week on, this meeting will (also) be the official weekly meeting of the Ansible Engineering Steering Committee
19:08:41 <felixfontein> I don't know if anyone prepared a more elaborated announcement for this
19:08:43 <gundalow> Thanks to ompragash for making this happen. And the dozens of people that have helped get us to this point
19:09:26 <felixfontein> indeed! thanks ompragash!
19:09:38 <gundalow> I believe there will be some details in The Bullhorn tomorrow
19:09:40 <cybette> ompragash++ !
19:09:44 <abadger1999> The meeting will continue to be a lot like it is now but the steering committee members will be present and will discuss and vote on proposals
19:09:53 <abadger1999> Hip hip hooray ompragash!
19:10:14 <cyberpear> ompragash++ for all the work on Steering Commitee!
19:10:14 <zodbot> cyberpear: Karma for ompragash changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:12:49 <felixfontein> #topic Inclusion request review day: Wednesday, March 24th
19:13:15 <felixfontein> we're planning a inclusion request (https://github.com/ansible-collections/ansible-inclusion/discussions) review day for next week's Wednesday
19:13:32 <felixfontein> the current question is: which time(s) should we do this?
19:13:41 <gundalow> There was a good suggest from IRC that given we are getting close to the 4.0.0 cut off we should spend some time reviewing the open request (above URL)
19:13:53 <felixfontein> (I think tadeboro brought that up)
19:14:14 <acozine> o/
19:14:17 <felixfontein> #chair acozine
19:14:17 <zodbot> Current chairs: abadger1999 acozine andersson007_ apple4ever briantist cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
19:14:20 <gundalow> ah, yes, thanks
19:14:24 <dmsimard> I'll be there during north american eastern time and happy to pitch in to help review :)
19:14:36 <acozine> sorry I'm late, I saw the ping and then got into fixing some CI failures
19:14:38 <andersson007_> i'm going to review all tomorrow
19:14:59 <dmsimard> andersson007_: thanks for that ++
19:15:03 <felixfontein> andersson007_: thanks!
19:15:06 <cyberpear> `dellemc.enterprise_sonic` brings up a question of naming standards for collections included in Ansible... do we need the "enterprise" part there?
19:15:14 <gundalow> fixing CI is always time well spent
19:15:19 <andersson007_> the community is always welcome
19:15:21 <felixfontein> maybe the question is then more: when do the Europeans here want to start? ;)
19:15:26 <cyberpear> (but maybe a separate discussion)
19:15:29 <cybette> cybette-clock says: we're 15 minutes into the meeitng!
19:15:31 <gundalow> afternoon works for me
19:15:53 <cybette> oops cybette-clock typo-ed
19:16:16 <jillr> cyberpear: it looks like it might be the actual product name
19:16:47 <tadeboro> I am available for most of the day minus some meetings.
19:16:59 <dmsimard> cyberpear: collection names are free form and really up to the authors I think... unless it's inappropriate or vulgar that is
19:17:07 <jillr> I've got a meeting in the US-West morning otherwise I'm free all of my day
19:17:08 <felixfontein> cyberpear: good question. I have no idea what that product is. they seem to use Enterprise with it all the time though: https://www.dell.com/en-us/work/shop/productdetailstxn/sonic (and they don't seem to do that with other products)
19:17:26 <acozine> more generally, do we care if collection owners want to name their collections `my.fabulous_collection` or `our.buzzword_bingo_collection`?
19:17:46 <felixfontein> how about starting around lunchtime in CET, and continue as long as people are still around?
19:17:49 <cyberpear> my question was whether we wanted more specific guidelines to be included in the Ansible package bundle
19:17:59 <acozine> cyberpear: ah, gotcha
19:18:44 <samccann> sonic is an opensource project, and these seems to be dell's enterprise version of it
19:18:52 <gundalow> Shouldn't contain the term `ansible`
19:18:53 <samccann> s/these/this/g
19:19:05 <felixfontein> dellemc.enterprise_sonic_ansible_modules ;)
19:19:15 <cyberpear> so maybe it brings us back to the community.okd vs redhat.openshift collection names for the same collection
19:19:22 <samccann> type that 10 times fast ;-)
19:20:02 <cyberpear> I'd like to strongly encourage not having different collection names for the "supported product" and the "community project" to allow better compatibility
19:20:16 <felixfontein> I agree on that
19:20:21 <abadger1999> +1
19:20:28 <jillr> the guidance that RH gives partners is community.{projectname} OR {vendorname}.{productname} OR {projectname}.{projectname}
19:20:31 <mariolenz> shouldn't it be the job ob of dellemc to manage their namespace? if they want to name a collection "dellemc.enterprise_something" that's their thing, isn't it?
19:20:33 <felixfontein> but let's maybe switch topic first :)
19:20:45 <jillr> seems sensible to do something at least similar in community
19:20:46 <felixfontein> does starting next week 12:00 UTC  sound good?
19:20:51 <abadger1999> mariolenz: I lean towards that, yeah.
19:20:53 <acozine> heh, what is our official topic felixfontein?
19:20:55 <felixfontein> tadeboro: gundalow: andersson007_: ^
19:21:04 <cyberpear> (sorry for derailing)
19:21:05 <felixfontein> acozine: Inclusion request review day
19:21:07 <gundalow> 13:00UTC, so post (my) lunch?
19:21:13 <felixfontein> gundalow: also fine for me!
19:21:17 <tadeboro> I am fine with afternoon and evening torture ;)
19:21:28 <gundalow> tadeboro: You typod "fun"
19:21:35 <abadger1999> hee hee
19:21:35 <felixfontein> #agreed Inclusion request review day will start 13:00 UTC on Wednesday, March 24th
19:21:40 <jillr> works for me; I'll get some reviews in before then since I'll be online latest
19:21:46 <gundalow> woot
19:21:47 <felixfontein> #topic Collection naming
19:21:48 <cybette> just on irc or do you need any conference type setup
19:21:49 <gundalow> Thanks all
19:21:54 <gundalow> cybette: just IRC
19:21:56 <felixfontein> ok, so let's continue with collection names ;)
19:22:02 <tadeboro> Also, that dells collection is certified and available on AH. Do we want to force maintainers to maintain the same content under different names?
19:22:13 <felixfontein> cyberpear: I think IRC should be fine
19:22:34 <felixfontein> tadeboro: maybe they want to rename their supported collection as well ;)
19:22:39 <felixfontein> I wouldn't force them though
19:22:40 <jillr> tadeboro: I would vote very much No on that, in light of the okd situation  :)
19:22:41 <samccann> the upstream vs certified collection namechange would make FQCN a bit of a problem
19:22:49 <gundalow> I think it's better for Galaxy & AH to have the same name
19:22:53 <gundalow> yup as samccann says
19:23:06 <acozine> agreed
19:23:26 <acozine> is the dell collection currently two different names for hte same content?
19:23:30 <felixfontein> I also agree, as long as the name isn't absolutely horrible I'd prefer if AH and galaxy use the same name
19:23:31 <gundalow> There are 2 hard problems in computer science: cache invalidation, naming things, and off-by-1 errors.
19:23:41 <felixfontein> (and if it is horrible, I wonder who accepted that for AH :D )
19:24:01 <felixfontein> gundalow: why do you list 4 things? :P
19:24:13 <gundalow> felixfontein: :)
19:24:15 <cyberpear> so there's 2 issues. 1) name collections the same for "supported" vs "community" to make playbooks work with either without further changes 2) make good naming guidelines for collections to be included in Ansible package bundle
19:24:44 <felixfontein> and these issues are sometimes conflicting
19:24:45 <acozine> the example is https://galaxy.ansible.com/dellemc/enterprise_sonic, right?
19:25:14 <acozine> tadeboro: is it the same name on AH?
19:25:26 <tadeboro> I would keep out of the naming bussiness and just make sure names are not offensive. Apart from that, I would let the authors have their way.
19:25:37 <jillr> Same on AH, https://cloud.redhat.com/ansible/automation-hub/repo/published/dellemc/enterprise_sonic
19:25:55 <tadeboro> acozine: Yes, the same name is in AH.
19:26:02 <abadger1999> tadeboro: That has my vote as well.
19:26:04 <acozine> I suspect most collection maintainers don't want the hassle of "which name do I use to publish to which platform, again?"
19:26:05 <felixfontein> currently I only know of one collection that uses two different names, and that's community.okd vs. redhat.openshift
19:26:08 <gundalow> OK, so nothing to do there
19:26:15 <bcoca> i would suggest names based on technology vs 'supprt status' but  'ship sailed, sunk, refloated and is now a beached casino'
19:26:15 <cyberpear> tadeboro: I'd generally agree except that we push folks to use fqcn in many places and you can't use unqualified without declaring `collections:`
19:26:25 <gundalow> bcoca: well put
19:26:38 <cyberpear> bcoca++
19:26:48 <bcoca> felixfontein:  in that case, were legal issues  .. redhat. cannot be used for 'official ones'
19:27:18 <bcoca> but that colleciotn has had more renames than puff daddy
19:27:20 <tadeboro> I think foreman is also available under two different names.
19:27:21 <felixfontein> bcoca: I heard about legal issues, but I'm not sure I really understood what's the issue :)
19:27:25 <jillr> it's probably unlikely many folks not Red Hat will have the same trademark issues we do, so keeping them the same in galaxy and AH should be fine in most cases
19:27:35 <samccann> perhaps the caveat that nothing in AH should be named 'community.<xx>' ?
19:27:40 <cyberpear> `ansible.okd` or `ansible.openshift`? (but yes I understand folks might not want to tackle that right away)
19:27:42 <bcoca> felixfontein: i would have asked, but didnt want to know
19:27:56 <felixfontein> but could redhat.openshift be used on community galaxy?
19:28:01 <gundalow> Do we even need to get into naming?
19:28:02 <jillr> felixfontein: no
19:28:15 <cyberpear> maybe we should discourage having anything `community.*` that could ever possible become supported?
19:28:19 <felixfontein> jillr: so redhat.openshift cannot be used on galaxy, and community.okd cannot be used on AH?
19:28:27 <bcoca> felixfontein: trademakrs must be defended by owner or they get lost, so not advisable to use company names
19:28:43 <jillr> gundalow: I don't think we do unless someone shows up with a problematic name (ie; tries to use the anisble namespace) or some special circumstance
19:29:00 <jillr> felixfontein: in a tl;dr, correct
19:29:09 <jillr> I am not a lawyer  :)
19:29:10 <gundalow> cool
19:29:22 <felixfontein> jillr: and renaming to ansible.okd or something like that (that can be used in both places) is not an option?
19:29:38 <jillr> felixfontein: correct, but for different reasons  :)
19:29:39 <tadeboro> https://cloud.redhat.com/ansible/automation-hub/repo/published/redhat/satellite is downstream of foreman.foreman.
19:29:49 <jillr> the ansible namespace is special
19:29:56 <bcoca> too many ways ...
19:30:02 <felixfontein> jillr: or anything else than ansible :)
19:30:15 <bcoca> i was happier when we had banned the use of ansible as namespace ....
19:30:24 <geerlingguy> heh, if only the lawyers knew how many hours would be burned by forcing bad naming of things
19:30:27 <jillr> but relevant to our interests, we don't need to manage or gatekeep collection namespaces in the community unless some special circumstance happens
19:30:28 <gundalow> Ok
19:30:29 <gundalow> .....
19:30:31 <felixfontein> #chair bcoca geerlingguy
19:30:31 <zodbot> Current chairs: abadger1999 acozine andersson007_ apple4ever bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow jillr samccann tadeboro
19:30:34 <cybette> cybette-clock says - 9 mins on topic "Collection naming" and 30 mins into meeting!
19:30:40 <gundalow> What problem are we trying to solve in this topic?
19:30:45 <geerlingguy> "naming things is easy"
19:30:51 <jillr> lol geerlingguy
19:31:17 <jillr> "I would like to paint the bike shed purple"
19:31:19 <bcoca> all new collections to be accepted to galaxy must have names w/o voewls and at least 2 Ks
19:31:21 <acozine> original question was "why is Dell using `enterprise` in their collection name, is that a problem, and if so what do we do about it"
19:31:25 <tadeboro> Naming them is easy, renaming them after you realize you screwed up is hard ;)
19:31:41 <acozine> to which we answer: we don't know, no, and nothing
19:31:48 <bcoca> jillr: no, malva, purple is passe!
19:31:51 <jillr> acozine: 1) because it's part of the product name and it's what they use on AH 2) IMO no 3) n/a
19:32:02 <felixfontein> can we agree that it is desirable that galaxy and AH collection names should be identical if possible?
19:32:03 <gundalow> OK, so sound like the original question has been answered
19:32:06 <acozine> jillr: +1
19:32:10 <gundalow> felixfontein: +1
19:32:10 <jillr> felixfontein: +1
19:32:13 <bcoca> +1
19:32:24 <mariolenz> +1
19:32:29 <andersson007_> +1
19:32:31 <felixfontein> apparently we can't enforce it, but at least we can express that we'd like that :)
19:32:35 <gundalow> VOTE: that it is desirable that galaxy and AH collection names should be identical if possible?
19:32:41 <felixfontein> +1
19:32:41 <jillr> +1
19:32:42 <dericcrago> +1
19:32:44 <cybette> +1
19:32:44 <acozine> +1
19:32:44 <mariolenz> yep
19:32:45 <tadeboro> +1
19:32:47 <samccann> +1
19:32:50 <mariolenz> +1
19:32:50 <andersson007_> +1
19:32:51 <felixfontein> #chair mariolenz
19:32:51 <zodbot> Current chairs: abadger1999 acozine andersson007_ apple4ever bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow jillr mariolenz samccann tadeboro
19:32:54 <abadger1999> +1
19:32:54 <cyberpear> +1
19:33:00 <geerlingguy> +1
19:33:02 <bcoca> ship sailed?
19:33:06 <mariolenz> +1
19:33:12 <felixfontein> bcoca: it is, but still... :)
19:33:18 <tadeboro> bcoca: This is why "if possible".
19:33:21 <geerlingguy> I would even consider making a rule "all future collections *must* be named the same if they appear in both"
19:33:30 <bcoca> and goes against policy of other teams, so not sure how relevant
19:33:33 <geerlingguy> unless someone would intentionally like to sabotage Ansible's UX
19:33:53 <bcoca> geerlingguy: pretty sure several are actively on it
19:33:59 <mariolenz> "if possible" is a bad thin, people will always have excusions why it isn't
19:34:00 <felixfontein> whom do we need to convince/bribe/... to avoid such name differences in the future? :)
19:34:03 <geerlingguy> "Pay us money to have support, and you get to rewrite all your playbooks!"
19:34:05 <abadger1999> `ansible.libreoffice` vs `ansible.openoffice`
19:34:26 <cyberpear> geerlingguy++ yes.  For the ones that are named differently, I'd like to slap some magic compat sauce to make content written for either work with the other
19:34:41 <jillr> I don't think we need to keep rehashing the naming frustrations
19:34:54 <bcoca> i would avoid the ansible. namespace also
19:35:06 <felixfontein> #agreed it is desirable that galaxy and AH collection names are identical if possible
19:35:12 <geerlingguy> jillr: sorry, just still hot and bothered about it (will be for some time) since I was personally involved
19:35:15 <jillr> We don't have anything actionable on this topic afaict right now
19:35:20 <tadeboro> But we just included ansible.utils ... ;)
19:35:50 <felixfontein> btw, are ansible.posix and ansible.utils Supported?
19:35:53 <jillr> geerlingguy:  :)  so am I, but in the interest of respecting the time of the folks in this meeting I think we should move on-
19:35:59 <bcoca> felixfontein: one is
19:36:06 <andersson007_> ansible.posix
19:36:12 <felixfontein> ah
19:36:17 <felixfontein> so ansible.utils isn't?
19:36:32 <tadeboro> ansible.utils will probably be once other certified collections start using it.
19:36:38 <felixfontein> ok
19:36:54 <felixfontein> as for the next topic, I have one that is hopefully uncontroversial:
19:36:55 <felixfontein> #topic Collection guidelines: disallow validate-modules:no-log-needed ignore.txt entries
19:36:55 <bcoca> well, ansible.posix is 'maintained' but has no maintainers
19:37:00 <felixfontein> #info https://github.com/ansible-collections/overview/pull/158
19:37:01 <github-linkbot> https://github.com/ansible-collections/overview/pull/158 | open, created 2021-03-12T06:16:38Z by felixfontein: Collection guidelines: disallow validate-modules:no-log-needed ignore.txt entries
19:37:06 <felixfontein> bcoca: I think andersson007_ got drafted ;)
19:37:20 <bcoca> oh ... they people need to stop pinging me about it
19:37:28 <bcoca> andersson007_: you have my condolences
19:37:44 <andersson007_> :))
19:37:54 <felixfontein> bcoca: it would still be great if you could provide technical help :)
19:38:07 <gundalow> #158 LGTM
19:38:08 <bcoca> #itsonmylist
19:38:20 <jillr> +1 #158
19:38:36 <felixfontein> As you might have noticed (if you're maintaining a collection you most certainly will have), there's a new validate-modules test which checks for option names that could contain a secret that should have no_log=True
19:38:44 <acozine> I can't comment on implementation, but I support the intention
19:39:03 <bcoca> +10k 158
19:39:08 <felixfontein> the PR essentially forbids to ignore that error. people should use no_log=False for false-positives, and no_log=True for actual secret-containing options
19:39:09 <andersson007_> +1
19:39:20 <tadeboro> +1 PR 158 (to avoid people disabling the test instead of adding `no_log=False` to false positives)
19:39:26 <abadger1999> +1
19:39:29 <felixfontein> since we already have a list of ignored errors we don't want to see, I suggest adding this one :)
19:39:34 <samccann> +1 and thanks for the explanation
19:39:59 <felixfontein> any comments on the wording?
19:40:10 <felixfontein> (it's simple enough that I shouldn't have screwed it up too badly ;)
19:41:32 <abadger1999> Wording is fine with me.  I'm happy there's information on how to flag false positives :-)
19:41:58 <acozine> a "false positive" in this case is something that looks like a secret but isn't really
19:42:00 <acozine> ?
19:42:03 <felixfontein> acozine: yes
19:42:10 <cyberpear> +1 the idea sounds good and there's a way to opt-out/false-positive-flag
19:42:15 <briantist> +1
19:42:20 <acozine> and the solution is to mark it `no_log` as well?
19:42:30 <felixfontein> like `key` when used as a configuration key to look up - that's not secret at all, but will be flagged
19:42:31 <acozine> oh,I see
19:42:40 <felixfontein> acozine: no_log=False, as opposed to no_log=True
19:42:45 <bcoca> realy needs to read ``validate-modules:no-log-needed``   to solve: CONTENT CENSORED BY NO LOG
19:43:02 <acozine> it's to mark it `No_log=False` which says, basically "We thought about this, we know it looks secret, but it's not, we really meant it htis way"
19:43:16 <acozine> yeah, that makes sense
19:43:25 <felixfontein> acozine: yes :)
19:43:29 <acozine> it's a lot of negatives piled up on top of each other
19:43:35 <acozine> but it makes sense in context
19:43:39 <felixfontein> :)
19:43:52 <andersson007_> vote?
19:43:55 <felixfontein> VOTE: should we merge https://github.com/ansible-collections/overview/pull/158 ?
19:43:59 <acozine> +1
19:43:59 <andersson007_> +1
19:44:01 <jillr> +1
19:44:02 <felixfontein> +1
19:44:06 <gundalow> +1
19:44:09 <briantist> +1
19:44:10 <cybette> +1
19:44:10 <dericcrago> +1
19:44:17 <dmsimard> +1
19:44:24 <abadger1999> +1
19:44:25 <gundalow> MERGED
19:44:32 <briantist> 🎉
19:44:33 <jillr> \0/
19:44:37 <felixfontein> #agreed gundalow merges the PR
19:44:39 <felixfontein> :)
19:44:42 <acozine> heh
19:44:42 <felixfontein> thanks a lot!
19:44:49 <samccann> heh
19:44:53 <tadeboro> +1
19:44:54 <felixfontein> hope nobody looks at the timestamps too closely ;)
19:45:04 <geerlingguy> +1
19:45:15 <samccann> belated +1
19:45:28 <felixfontein> #topic Python version requirements: https://github.com/ansible-collections/overview/pull/151
19:45:29 <github-linkbot> https://github.com/ansible-collections/overview/pull/151 | open, created 2021-01-25T12:48:11Z by Ompragash: New Policy Regarding Python Compatibility for Collections
19:45:43 <felixfontein> Ompragash added a new version of the proposal as a comment to the PR
19:45:46 <andersson007_> is this 3d attempt?
19:46:05 <cybette> cybette-clock says we're 45 mins into the meeting!
19:46:16 <felixfontein> it still needs conversion to RST and being incorporated in the PR itself
19:46:45 <felixfontein> I hope that we can vote on it and merge it next time, so if someone wants something changed, please comment on the PR, or here right now so we can discuss it :)
19:48:25 <felixfontein> I think it should say 3.5 or higher, not 3.6 or higher
19:49:12 <gundalow> is https://github.com/ansible-collections/overview/pull/151#issuecomment-801161881 good?
19:49:22 <gundalow> (ignoring md vs RST
19:49:24 <gundalow> )
19:49:49 <felixfontein> (ah, it says that, I had to scroll to see it)
19:50:00 <abadger1999> s/should/must/ in the controller environment section
19:50:33 <abadger1999> Maybe list the "uses a library which is not compatible with an old version of python" exception explicitly
19:50:59 <jillr> should other-environment also use "must" in place of "needs to"?
19:51:43 <acozine> jillr: yes, for consistency
19:51:44 <briantist> +1 abadger1999 , that one applies to my collection specifically
19:51:45 <abadger1999> jillr: yeah, good point
19:52:03 <cyberpear> for the library, I'd wonder whether there's an older system version of the library that's still being patched by the distro
19:52:47 <felixfontein> cyberpear: I'm sure debian will have some ;)
19:52:59 <felixfontein> next to their Ansible 2.4? ;)
19:53:10 <jillr> cyberpear: I'd prefer to stick with what the library itself supports. maybe RHEL will patch boto3 for py2.7, but that doesn't help me support ubuntu, debian, etc for example
19:53:13 <acozine> do we really use the term `demilitarized zone` for cloud environments
19:53:17 <acozine> ?
19:53:33 <abadger1999> For network environments, yes.
19:53:37 <jillr> acozine: the DMZ in this case isn't in the cloud env, but on the user's local/corp network
19:53:47 <tadeboro> DMZ is not about cloud here.
19:53:50 <cyberpear> acozine: where? DMZ has a specific meaning in networking
19:54:07 <abadger1999> https://en.wikipedia.org/wiki/DMZ_(computing)
19:54:13 <acozine> if it's an industry term, then we can carry on
19:54:14 <felixfontein> cyberpear: "the controller might run on one machine inside a demilitarized zone which can't directly access the cloud machines"
19:54:18 <jillr> like if I can't connect to AWS directly from my laptop at work, I have to jump host through a dmz first
19:57:02 <felixfontein> so do we want something like "On the controller node, collection MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. We also suggest to support Python v3.5 if in case the required libraries support this version." for controller-environment?
19:57:56 <jillr> +1
19:58:14 <felixfontein> though hmm, it uses controller *node* and not controller *environment*
19:58:16 <cyberpear> maybe just "controller" vs "controller node"?
19:58:23 <felixfontein> so do we want something like "In the controller environment, collection MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. We also suggest to support Python v3.5 if in case the required libraries support this version." for controller-environment?
19:58:32 <abadger1999> +1
19:58:35 <acozine> `On the controller node, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v3.5 if all required libraries support this version.`
19:58:37 <jillr> oh good catch, +1
19:58:53 <abadger1999> and similar for the `other environment`
19:59:45 <acozine> (my suggestion makes the phrasing parallel - collections MUST x; collections SHOULD y - makes it easier to understand)
20:00:32 <felixfontein> "In the controller environment, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v3.5 if all required libraries support this version."
20:00:42 <cybette> cybette-clock says 15 mins on topic "Python version requirements" and 1 HOUR into meeting
20:00:59 <samccann> +1 on MUST and SHOULD
20:01:33 <abadger1999> +1
20:01:40 <jillr> +1
20:02:03 <felixfontein> "In the remote environment, collection MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v2.6 and v3.5 if all required libraries support this version.
20:02:15 <felixfontein> (s/collection/collections)
20:02:43 <felixfontein> VOTE: should we use the above verisons (with the plural s fixed in the second)?
20:02:49 <acozine> +1
20:02:51 <cyberpear> +1
20:02:54 <felixfontein> +1
20:02:56 <tadeboro> I guess we can vote on this since it seems as good as anything else we will come up today.
20:02:56 <andersson007_> +1
20:02:57 <abadger1999> +1
20:02:58 <tadeboro> ++1
20:03:04 <cybette> +1
20:03:08 <dericcrago> +1
20:03:10 <jillr> felixfontein: are we using remote or managed?
20:03:15 <apple4ever> +1
20:03:22 <felixfontein> ah crap
20:03:24 <felixfontein> *other*
20:03:27 <felixfontein> not remote/managed
20:03:40 <felixfontein> "In the other environment, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v2.6 and v3.5 if all required libraries support this version.
20:03:52 <abadger1999> +1
20:04:00 <felixfontein> (or should we always write other-environment, controller-environment with dash?)
20:04:04 <jillr> `managed` is also used in the Note section
20:04:28 <andersson007_> (would be good to add a clarification what "other" can be, imo, like a note)
20:04:38 <jillr> +1 the general text though, with whichever term we go with
20:04:59 <felixfontein> jillr: I tihnk there 'managed' is fine, since other-environment is usually the managed node, but it doesn't have to be
20:05:03 <abadger1999> andersson007_: it is defined earlier with some examples: - `other-environment`: It is possible, even if uncommon in practice, for the plugins/modules to run in a different environment than ansible-core itself.
20:05:22 <andersson007_> abadger1999: cool, thanks
20:05:32 <felixfontein> #agreed "In the controller environment, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v3.5 if all required libraries support this version."
20:05:39 <felixfontein> #agreed "In the other environment, collections MUST support Python 2 (version 2.7) and Python 3 (Version 3.6 and higher), unless required libraries do not support these versions. Collections SHOULD also support Python v2.6 and v3.5 if all required libraries support this version.
20:05:45 <felixfontein> ok.
20:05:52 <felixfontein> so let's see how that text looks like next week ;)
20:06:04 <felixfontein> I guess it's time to close this meeting, resp. switch to open floor!
20:06:09 <felixfontein> #topic open floor
20:06:18 <felixfontein> is there anything else someone wants to discuss today?
20:06:48 <dericcrago> I just wanted to provide a quick update on the ubuntu PPA
20:07:24 <dericcrago> "ansible" is now a "team" (instead of just a "user") on launchpad
20:07:36 <felixfontein> cool!
20:07:38 <apple4ever> Oh cool!
20:07:53 <cybette> yay!
20:07:57 <felixfontein> #info 'ansible' is now a 'team' (instead of a 'user') on launchpad
20:07:59 <cyberpear> does that change the required apt-add-repository command at all?
20:08:00 <jillr> awesome!
20:08:40 <dericcrago> it shouldn't change anything since the team now owns all of the ppas and the team took over the ansible name so all of the URLs are the same
20:08:50 <bcoca> cyberpear: substitute lamb for goat in ritual apt sacrifice
20:09:01 <apple4ever> That's great news
20:09:24 <cyberpear> dericcrago++ thanks for working on the PPA!
20:09:24 <zodbot> cyberpear: Karma for dericcrago changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:09:29 <dericcrago> I guess the flip side of that is, if you *do* notice anything, please let us know
20:09:49 <felixfontein> so relrod will continue to create the ansible <= 2.9 and ansible-base/ansible-core ppas, and dericcrago will work on ansible >= 2.10?
20:10:28 <felixfontein> or does the community team will also work on ansible-base/ansible-core ppas?
20:10:40 <dericcrago> we're still working out those details (as well as how to get more of the community involved)
20:11:14 <felixfontein> ok :)
20:11:21 <felixfontein> sounds good to me
20:11:36 <felixfontein> any other topics? or more on this one?
20:11:37 <dericcrago> in the short term if anyone wants to help me build / test new releases, let me know
20:12:13 <dericcrago> that's it from me on the ubuntu ppa
20:12:15 <cyberpear> Anyone here working on the packaging for Fedora?
20:13:25 <felixfontein> thanks dericcrago!
20:13:27 <dericcrago> not I
20:13:39 <abadger1999> nirik is in charge of that but dmsimard said that he's helping him with that.
20:13:41 <cyberpear> nothing else from me today
20:13:42 <abadger1999> I don'
20:13:48 <abadger1999> t have more information, though
20:14:16 <felixfontein> #endmeeting