#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 18:00:12 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 18:00:12)
    1. Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics (felixfontein, 18:00:16)

  2. Updates (felixfontein, 18:02:15)
    1. No more collections can apply for inclusion in Ansible 4 (felixfontein, 18:02:19)
    2. Deadline for approval of new collections in Ansible 4 is April 26th, i.e. in 12 days (felixfontein, 18:02:19)
    3. There's Red Hat summit coming up April 27th, there's bound to be Ansible things in it: https://www.redhat.com/en/summit (dmsimard, 18:06:27)
    4. ansible-4.0.0a4 coming out today. (abadger1999, 18:07:07)
    5. ansible-core 2.11.0 is still on track to ship end of April (dmsimard, 18:07:13)
    6. likely next ansible-4 prerelease will be ansible-4.0.0beta1 on April 27th (abadger1999, 18:07:35)

  3. Allow non-semantic versioned collections in Ansible (felixfontein, 18:10:16)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/7 (felixfontein, 18:10:16)
    2. AGREED: the versioning aspect of the netapp collections is ok for inclusion with their new versioning system (felixfontein, 18:18:02)
    3. AGREED: We still require semver. netapp's versioning is considered compatible enough that we accept it as semver for our purposes. (felixfontein, 18:27:43)

  4. Remove Python 2.6 requirement (felixfontein, 18:32:04)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/6 (felixfontein, 18:32:04)
    2. Proposal: https://github.com/ansible-collections/overview/pull/165 (felixfontein, 18:32:07)
    3. https://github.com/ansible-collections/overview/pull/165 | open, created 2021-04-07T16:50:26Z by abadger: RHEL6 went EOL on November 30, 2020. (github-linkbot, 18:32:07)

  5. What are the implications of maintaining and supporting past major releases of the ansible package (felixfontein, 18:46:22)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/1 (felixfontein, 18:46:25)
    2. writeup: https://hackmd.io/plQlGzcFRFGLnPXIeg3cwQ (felixfontein, 18:46:28)
    3. AGREED: No plan for a LTS maintenance release for the Ansible community package for now, anyone from the community can bring the topic up again for discussion at a later release and we can revisit the topic (felixfontein, 19:05:45)
    4. ACTION: dmsimard to write a summary of the LTS discussion in the bullhorn (dmsimard, 19:06:20)

  6. open floor (felixfontein, 19:06:24)


Meeting ended at 19:12:46 UTC (full logs).

Action items

  1. dmsimard to write a summary of the LTS discussion in the bullhorn


Action items, by person

  1. dmsimard
    1. dmsimard to write a summary of the LTS discussion in the bullhorn


People present (lines said)

  1. felixfontein (94)
  2. dmsimard (48)
  3. abadger1999 (40)
  4. tadeboro (27)
  5. zodbot (18)
  6. cyberpear (14)
  7. jillr (14)
  8. cybette (12)
  9. samccann (11)
  10. andersson007_ (8)
  11. gundalow (8)
  12. lmodemal (6)
  13. nitzmahone (5)
  14. acozine (5)
  15. dericcrago (5)
  16. apple4ever (2)
  17. aminvakil (2)
  18. github-linkbot (1)
  19. bcoca (1)


Generated by MeetBot 0.1.4.