#ansible-community: Ansible Community Meeting

Meeting started by felixfontein at 18:00:02 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (felixfontein, 18:00:02)
    1. Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics (felixfontein, 18:00:06)

  2. Updates (felixfontein, 18:03:34)
    1. Deadline for approval of new collections in Ansible 4 is April 26th, i.e. in 5 days (felixfontein, 18:03:34)
    2. Deadline for new major releases of collections to be released so they show up in Ansible 4 is also April 26th (felixfontein, 18:03:37)
    3. community.general and community.network 3.0.0 will be released by then (felixfontein, 18:03:40)
    4. The next Ansible Contributor Summit will be held on June 8, 2021 (Tuesday). Please propose topics for the agenda: https://hackmd.io/@ansible-community/contrib-summit-202106 (cybette, 18:03:52)
    5. changes to ansible-test units behavior https://github.com/ansible-collections/overview/issues/45#issuecomment-822858320 (dericcrago, 18:04:22)
    6. Short overview of where the inclusion candidates stand (according to tadeboro, edits welcome): https://github.com/ansible-community/community-topics/issues/10 (tadeboro, 18:06:25)

  3. State of the inclusion candidates for Ansible 4 (felixfontein, 18:06:49)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/10 (felixfontein, 18:06:49)
    2. We will try to review collections and decide at the meeting next week which ones will get included (felixfontein, 18:15:26)

  4. Licenses for new collections: relax requirements? (felixfontein, 18:15:30)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/2 (felixfontein, 18:15:30)
    2. https://github.com/ansible-collections/overview/blob/main/collection_requirements.rst#licensing is the relevant part of the requirements (felixfontein, 18:20:11)
    3. AGREED: Apache 2.0 license for modules and module_utils, and GPL for everything else is ok for hpe.nimble (felixfontein, 18:21:28)

  5. Remove Python 2.6 requirement (felixfontein, 18:22:28)
    1. Discussion: https://github.com/ansible-community/community-topics/issues/6 (felixfontein, 18:22:28)
    2. Proposal: https://github.com/ansible-collections/overview/pull/165 (felixfontein, 18:22:31)
    3. https://github.com/ansible-collections/overview/pull/165 | open, created 2021-04-07T16:50:26Z by abadger: RHEL6 went EOL on November 30, 2020. (github-linkbot, 18:22:32)
    4. https://github.com/ansible-collections/overview/pull/165/files (abadger1999, 18:23:56)
    5. AGREED: we merge https://github.com/ansible-collections/overview/pull/165/files as-is (felixfontein, 18:27:22)
    6. https://github.com/ansible-collections/community.general/pull/2213 | open, created 2021-04-09T08:41:12Z by saranyasridharan: Module to get disk information [affects_2.10,ci_verified,integration,module,needs_revision,new_contributor,new_module,new_plugin,plugins,system,tests,unit] (github-linkbot, 18:34:25)

  6. Should we include a disk_facts module into community.general: https://github.com/ansible-collections/community.general/pull/2213 (abadger1999, 18:40:17)
    1. https://github.com/ansible-collections/community.general/pull/2213) | open, created 2021-04-09T08:41:12Z by saranyasridharan: Module to get disk information [affects_2.10,ci_verified,integration,module,needs_revision,new_contributor,new_module,new_plugin,plugins,system,tests,unit] (github-linkbot, 19:00:45)
    2. https://docs.ansible.com/ansible/latest/user_guide/complex_data_manipulation.html (bcoca, 19:07:32)
    3. ACTION: felixfontein create discussion issue for this so we can discuss again next week (felixfontein, 19:15:02)

  7. open floor (felixfontein, 19:15:33)


Meeting ended at 19:25:32 UTC (full logs).

Action items

  1. felixfontein create discussion issue for this so we can discuss again next week


Action items, by person

  1. felixfontein
    1. felixfontein create discussion issue for this so we can discuss again next week


People present (lines said)

  1. felixfontein (121)
  2. abadger1999 (36)
  3. samccann (36)
  4. acozine (35)
  5. bcoca (26)
  6. tadeboro (19)
  7. zodbot (17)
  8. andersson007_ (15)
  9. gundalow (15)
  10. jillr (15)
  11. cybette (14)
  12. russoz[m] (7)
  13. dmsimard (7)
  14. aminvakil (6)
  15. cyberpear (5)
  16. dericcrago (5)
  17. github-linkbot (3)
  18. sivel (3)
  19. lmodemal (2)
  20. resmo (1)


Generated by MeetBot 0.1.4.