#ansible-community: Ansible Community Meeting

Meeting started by gundalow at 18:00:40 UTC (full logs).

Meeting summary

  1. Agenda https://github.com/ansible/community/issues/539 (gundalow, 18:00:56)
    1. Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics (gundalow, 18:01:19)

  2. Updates (gundalow, 18:02:12)
    1. ansible 3.4.0, the last ansible 3 release, went out on Tuesday (abadger1999, 18:02:56)
    2. ansible-4.0.0rc1 was released on Tuesday (abadger1999, 18:03:11)
    3. Barring any blocker bugs, ansible-4.0.0 final will be out next Tuesday, 18, May, 2021. (abadger1999, 18:03:36)
    4. ansible 3.4.0, the last ansible 3 release, went out on Tuesday (abadger1999, 18:04:17)
    5. ansible-4.0.0rc1 was released on Tuesday (abadger1999, 18:04:19)
    6. Barring any blocker bugs, ansible-4.0.0 final will be out next Tuesday, 18, May, 2021. (abadger1999, 18:04:22)
    7. Next Contributors summit is Tuesday, June 8th 0700UTC. https://hackmd.io/0lOyfyEpQ1uKimC4mD6xdw Please add topics to the agenda (Login with GItHub to be edit) (gundalow, 18:06:02)

  3. Ansible Community Galaxy next steps (gundalow, 18:06:42)
    1. https://www.reddit.com/r/ansible/comments/na4end/ansible_community_galaxy_next_steps_help_needed/ https://github.com/ansible-community/community-topics/issues/17 (gundalow, 18:06:58)
    2. We're updating galaxy.ansible.com to use GalaxyNG, the code that powers Ansible Automation Hub, because it is well maintained and efficient. Help us make sure your use cases are addressed in this transition! (gundalow, 18:07:13)
    3. If extra use-cases are identified we will add them to the list. Then we will do a survey to see what the priority is (gundalow, 18:08:10)
    4. http://galaxy.ansible.com/ansible/posix (gundalow, 18:30:18)
    5. https://cloud.redhat.com/ansible/automation-hub/repo/published/ansible/posix (gundalow, 18:30:18)
    6. Currently we disallow uploading a role or collection whose namespace+name would conflict with another role or collection. (abadger1999, 19:02:50)
    7. So when we migrate into galaxyng, there will be no conflicting role and collection names. (abadger1999, 19:04:00)
    8. geerlingguy requests that we have a requirement for continuity of URLs for roles from the current galaxy to the galaxyng implementation (abadger1999, 19:04:50)
    9. continuity of URLs doesn't fit easily into the galaxyng architecture but should be possible given that the code enforces non-conflicting namespace+names (as stated previously). (abadger1999, 19:06:20)
    10. ACTION: geerlingguy to add the continuity of urls requirement to gundalow's roles in galaxy use case's doc (abadger1999, 19:07:47)

  4. Open Floor (abadger1999, 19:12:28)


Meeting ended at 19:14:59 UTC (full logs).

Action items

  1. geerlingguy to add the continuity of urls requirement to gundalow's roles in galaxy use case's doc


Action items, by person

  1. geerlingguy
    1. geerlingguy to add the continuity of urls requirement to gundalow's roles in galaxy use case's doc
  2. gundalow
    1. geerlingguy to add the continuity of urls requirement to gundalow's roles in galaxy use case's doc


People present (lines said)

  1. abadger1999 (64)
  2. gundalow (61)
  3. geerlingguy (54)
  4. nitzmahone (41)
  5. bcoca (21)
  6. zodbot (14)
  7. newswangerd[m] (10)
  8. acozine (9)
  9. tadeboro (6)
  10. zbr (4)
  11. awcrosby (3)
  12. samccann (3)
  13. jillr (2)
  14. lmodemal (2)
  15. andersson007_ (1)
  16. dmsimard (1)


Generated by MeetBot 0.1.4.