18:00:20 <felixfontein> #startmeeting Ansible Community Meeting
18:00:20 <zodbot> Meeting started Wed Jun  2 18:00:20 2021 UTC.
18:00:20 <zodbot> This meeting is logged and archived in a public location.
18:00:20 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:20 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:20 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:20 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:24 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:26 * gundalow waves
18:00:30 <andersson007_> o/
18:00:32 <felixfontein> #chair gundalow jillr andersson007_
18:00:32 <zodbot> Current chairs: andersson007_ felixfontein gundalow jillr
18:00:52 <briantist> o/   (as usual in another meeting though)
18:00:54 <felixfontein> #topic Updates
18:00:55 <abadger1999> Bom dia!
18:01:01 <felixfontein> #chair briantist abadger1999
18:01:01 <zodbot> Current chairs: abadger1999 andersson007_ briantist felixfontein gundalow jillr
18:01:35 <andersson007_> The collection maintainer guidelines have been merged today in https://github.com/ansible/community-docs/. There are also other documents that can be used across the collections like the Review checklist, Releasing guidelines, contributing.rst, and Quick-start guide. Thanks everyone who helped! Feel free to open PRs and share your ideas. Also feel free to refer to the documents from your READMEs, CONTRIBUTING.mds, and
18:01:36 <andersson007_> so on. When they find their permanent location, we will find and correct all the references in the repositories under the ansible-collections organization.
18:01:38 <felixfontein> #info community.crypto 1.7.0 has been released
18:01:39 <andersson007_> felixfontein: ^
18:01:52 <felixfontein> #info The collection maintainer guidelines have been merged today in https://github.com/ansible/community-docs/
18:01:54 * samccann slides in late
18:02:04 <felixfontein> #chair samccann
18:02:04 <zodbot> Current chairs: abadger1999 andersson007_ briantist felixfontein gundalow jillr samccann
18:02:04 <gundalow> #chair samccann
18:02:04 <zodbot> Current chairs: abadger1999 andersson007_ briantist felixfontein gundalow jillr samccann
18:02:04 <cybette> o/
18:02:05 <lmodemal> o/
18:02:08 <gundalow> :)
18:02:09 <felixfontein> #chair cybette lmodemal
18:02:09 <zodbot> Current chairs: abadger1999 andersson007_ briantist cybette felixfontein gundalow jillr lmodemal samccann
18:02:12 <felixfontein> :)
18:02:17 <abadger1999> Yay!
18:02:19 <gundalow> as usual, felixfontein is tooo fast :)
18:02:20 * tadeboro is here physically, but his brain is tired because meetings all day
18:02:29 <felixfontein> gundalow: you almost got me ;)
18:02:31 <felixfontein> #chair tadeboro
18:02:31 <zodbot> Current chairs: abadger1999 andersson007_ briantist cybette felixfontein gundalow jillr lmodemal samccann tadeboro
18:03:18 <abadger1999> #info Draft Ansible-5.0.0 schedule: https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw  We can probably discuss and vote on it at the next meeting.
18:03:45 <felixfontein> sounds good. can you create an issue for that?
18:03:49 <abadger1999> If anyone has midweek thoughts or concerns about the schedule, let me know :-)
18:03:52 <cybette> #info Ansible Contributor Summit in 6 days! https://hackmd.io/@ansible-community/contrib-summit-202106
18:03:53 <abadger1999> felixfontein: Will do.
18:04:02 <felixfontein> thanks!
18:05:51 <cyberpear> o/
18:05:55 <felixfontein> #chair cyberpear
18:05:55 <zodbot> Current chairs: abadger1999 andersson007_ briantist cyberpear cybette felixfontein gundalow jillr lmodemal samccann tadeboro
18:06:39 <abadger1999> #info  Discussion ticket for the Ansible-5 draft schedule: https://github.com/ansible-community/community-topics/issues/21
18:06:55 <felixfontein> +1
18:07:04 <felixfontein> any more updates for today?
18:07:55 <felixfontein> well, if not, let's start with the topics :)
18:07:58 <felixfontein> #topic Ansible Community Galaxy next steps
18:07:58 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/17
18:08:07 <gundalow> cool
18:08:24 <felixfontein> gundalow: do you want to present this?
18:08:28 <gundalow> #info background https://www.reddit.com/r/ansible/comments/na4end/ansible_community_galaxy_next_steps_help_needed/
18:08:46 <gundalow> #info 2 minute survey https://www.surveymonkey.co.uk/r/2V7ZVK8
18:09:11 <gundalow> #info If you have any further questions feel free to add them to Reddit post, or as in #ansible-galaxy on Libera.chat
18:09:25 <gundalow> #chair acozine
18:09:25 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear cybette felixfontein gundalow jillr lmodemal samccann tadeboro
18:09:27 <acozine> o/
18:09:46 <dmsimard> o/ sorry I'm late
18:09:53 * acozine didn't realize I wasn't in this channel
18:09:58 <gundalow> #info It aims to inform the core Galaxy development team as to what features need to be prioritized for porting over from the old Galaxy codebase.
18:10:07 <felixfontein> #chair acozine dmsimard
18:10:07 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear cybette dmsimard felixfontein gundalow jillr lmodemal samccann tadeboro
18:10:12 <gundalow> dmsimard: nps
18:10:15 <gundalow> acozine: welcome :)
18:10:36 <felixfontein> acozine: all the things you have been missing... ;)
18:10:56 <acozine> I know, I know!
18:12:13 <gundalow> Anyone got any question on GalaxyNG?
18:12:42 <felixfontein> when will role support be ready? ;)
18:13:21 <gundalow> felixfontein: It's likely 12-18 months of work. Though I hope we will have test servers up so people can play and give feedback early on through the process
18:13:46 <felixfontein> gundalow: I know, it also depends on which features should be there and which aren't needed :)
18:14:25 <andersson007_> Will there be a demo stand of sort when users can try it and provide feedback?:)
18:14:35 <felixfontein> if everyone filling out the survey, or why is it so quiet? :)
18:14:42 <andersson007_> s/when/where/g
18:14:53 <acozine> I can't see the topic or any history, so . . .
18:15:04 <gundalow> andersson007_: yup
18:15:05 <tadeboro> felixfontein: Because it is Friday ... wait ... ;)
18:15:11 <cybette> cyb-clock chimes 15 minutes into the meeting, 8 minutes on topic "Ansible Community Galaxy next steps"
18:15:11 <felixfontein> acozine: https://github.com/ansible-community/community-topics/issues/17 "Ansible Community Galaxy next steps"
18:15:12 <andersson007_> gundalow: cool:)
18:15:41 <gundalow> Nothing else from me
18:16:10 <felixfontein> #topic What to do with inventory and vault scripts in community.general?
18:16:13 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/16
18:16:35 <felixfontein> I think we started discussing this a little bit in open floor two weeks ago (?)
18:17:21 <felixfontein> inventory scripts and plugins don't really fit in collections, especially the ones in community.general, so my suggestion would be to move them into a separate repository (not a collection, and not necessarily contained in Ansible)
18:18:37 <felixfontein> also it seems that a lot of people download them directly instead of using them from inside c.g (though I have no stats on that - I don't use any of them)
18:18:57 <jillr> I think I said last week, but I'm generally in favor of a separate repo for this stuff
18:19:12 <andersson007_> under ansible-collections?
18:19:25 <jillr> that's an excellent question
18:19:30 <felixfontein> I guess under ansible-community would be fine as well, since it's not a collection
18:19:35 <acozine> we could create a community.legacy collection, perhaps
18:19:43 <tadeboro> I would move it somewhere outside (community maybe).
18:20:04 <felixfontein> acozine: that collection would be 'empty', since there is nothing that ansible thinks of as collection content in there
18:20:11 <jillr> I'd probably lean ansible-community
18:20:18 <tadeboro> SInce this content cannot be part of collection is a way other plugins can, I see no point in having them in ansible-collections or having a collection for them.
18:20:31 <felixfontein> tadeboro: I agree
18:20:32 <gundalow> felixfontein: Whyt don't inventory *plugins* fit in collections?
18:20:50 <felixfontein> ooops
18:20:52 <felixfontein> did I wrote plugins?
18:20:54 <felixfontein> I meant scripts!
18:20:55 <felixfontein> sorry :)
18:20:58 <tadeboro> gundalow: Inventory plugins do, inventory scripts do not ;)
18:21:16 <gundalow> `inventory scripts and plugins don't really fit in collections` by felixfontein
18:21:16 <felixfontein> darn, I wrote "inventory scripts and plugins" and meant "inventory and vault scripts"
18:21:19 <berkhan> felixfontein: I want to give an example about Jails inventory. Community can maintain a jails collection with jails inventory in it.
18:21:21 <gundalow> ah, cool
18:22:03 <berkhan> I am still on Ansible 2.7 and I really don't want to switch to above 2.8; however, this is the first think that came in my mind.
18:22:05 <felixfontein> berkhan: if a collection wants to have an inventory scrpit, they can have one, but they should really switch to inventory plugins
18:22:06 <bcoca> until we make scripts fqcn referencible
18:22:28 <felixfontein> berkhan: the scripts are still part of ansible 2.7/2.8/2.9, so they're not gone
18:22:32 <bcoca> berkhan: you are already using inventory plugins
18:23:02 <felixfontein> berkhan: also with 2.7 you don't have collections anyway, so it's just another URL to download them from :)
18:24:09 <berkhan> felixfontein: I wanted to give an example to manage, maybe jails, or other collections and associated inventory plugins
18:24:30 <berkhan> felixfontein: and yes, I use 2.7 because it doesn't have collections :)
18:25:08 <felixfontein> berkhan: I'm not sure what you want to say with the example. inventory plugins are native citizens of collections. and inventory scripts won't go away, they would just live in another place (at least the ones in c.g, other collections can do whatever they want)
18:25:37 <bcoca> the 'script' inventory plugin guarantees support for inventory scripts
18:26:05 <abadger1999> Would we want to produce a tarball of this?  (If so, where would we host it... it's not visible to someone who installs pypi either... unless we placed them in /usr/bin/)
18:26:12 <felixfontein> also this is not about removing support for inventory scripts and vault scripts. it's just about where they live.
18:26:37 <berkhan> I feel like I misunderstood GH-16
18:26:47 <felixfontein> abadger1999: right now, docs recommend to download the scripts from github, put them in the correct place, and make them executable
18:27:20 <berkhan> scripts != plugins :face_palm:
18:27:23 <abadger1999> <nod>  So I suppose unles someone complains, we can just update the docs to point to the new location.
18:27:57 <felixfontein> abadger1999: so I'm not sure whether they need to be packaged, since I'm not sure if anyone wants all at once. (and if they want, they can download the main.tgz provided by github)
18:28:06 <bcoca> the 'feature' would be to add fqcn support to the script inventory plugin and the vault password file mechanims
18:28:07 <felixfontein> berkhan: happens. see me above ;)
18:28:17 <abadger1999> felixfontein: wfm
18:28:27 <felixfontein> bcoca: is anyone asking for such a feature, resp. is core planning to implement it?
18:29:12 <bcoca> people have asked, even for template/arbitrary files, magic 8 ball is 'most dont want to'
18:29:29 <bcoca> imho it will be inevitable
18:30:22 <cybette> cyb-clock chimes 30-min into the meeting, 14-min on topic "Inventory and vault *scripts* in c.g."
18:30:39 <abadger1999> sivel: ^ Could you clarify the above?  If that's something that's coming, then maybe we don't want to move the scripts out.
18:30:52 <felixfontein> if we kick out the inventory and vault scripts from c.g, there might be less incentive to add that feature to core :)
18:30:54 <cyberpear> I'd like to see such a feature
18:31:00 <felixfontein> (and vice versa, as abadger1999 is asking...)
18:31:46 <felixfontein> if FQCN gets supported, I'd also want a way to properly deprecate these things :)
18:31:56 <sivel> fqcn support for scripts?
18:32:00 <sivel> I highly doubt it
18:32:22 <abadger1999> sivel: yeah... making inventory and/or vault scripts first class collection-izablele plugins
18:32:36 <bcoca> abadger1999: im saying i dont see how that feature will not be implemented in the end, yet many will be dragged kicking and screaming to avoid it
18:33:12 <bcoca> like there was never going to be serialization at task level .. yet throttle
18:33:37 <abadger1999> sivel: Cool.  We'll assume that it won't happen then.
18:33:50 <felixfontein> wfm :)
18:33:59 <abadger1999> felixfontein: Given sivel's statement, I'm still +1 to move them to another repo.
18:34:10 <felixfontein> ok, maybe we should vote to see what people think
18:34:27 <felixfontein> VOTE: should we move inventory and vault *scripts* from community.general to another repository?
18:34:36 <felixfontein> #chair
18:34:36 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear cybette dmsimard felixfontein gundalow jillr lmodemal samccann tadeboro
18:34:37 <abadger1999> +1
18:34:42 <felixfontein> +1
18:34:45 <berkhan> +1
18:34:47 <jillr> +1
18:34:51 <andersson007_> +1
18:34:54 <tadeboro> +1 (to ansible-community)
18:34:55 <acozine> +1
18:34:56 <cybette> +1
18:35:10 <samccann> +1
18:36:02 <gundalow> +1
18:36:54 <lmodemal> +1
18:37:16 <felixfontein> #agreed we move inventory and vault *scripts* from community.general to another repository
18:37:25 <cyberpear> -0
18:37:52 <bcoca> they were only included in c.g last minute from migration we always intended them to go to new repo
18:38:16 <felixfontein> if ansible supports addressing them by FQCN, we can still move the ones that are actively supported to fitting collections
18:38:37 <felixfontein> should we use a repo like https://github.com/ansible-community/scripts/ ?
18:38:38 <bcoca> i dont expect fqcn support soon, but eventually
18:38:38 <cyberpear> probably fine if they're still included in Ansible
18:38:44 <felixfontein> or https://github.com/ansible-community/inventory-vault-scripts/ ?
18:39:23 <felixfontein> and do we want the repo's contents to be included in Ansible?
18:39:25 <andersson007_> +1 to the last one (if there are no other similar kinds)
18:39:34 <samccann> is there a reason to separate scripts in different repos?
18:39:45 <jillr> +1 inventory-vault-scripts
18:39:50 <felixfontein> samccann: do you mean have one repo for inventory, and one for vault?
18:39:51 <bcoca> samccann: didnt you just +1 it?
18:39:58 <cybette> +1 inventory-vault-scripts
18:40:12 <samccann> seems like the /inventory-vault-scripts/ make it an option to have /foo-scripts/ in the future
18:40:32 <felixfontein> samccann: maybe we want /scripts/ for other kind of scripts in the future
18:40:36 <bcoca> fyi, there is 'password scripts' feature that might make 2.12
18:40:36 <samccann> felixfonein - yea just wondering if we need to future-proof the repo
18:40:46 <jillr> do any other types of scripts exist?
18:40:54 <jillr> ah
18:41:13 <samccann> the overarching question - does it matter if they are all in /scripts/?  like /scripts/vault  /scripts/inventory etc
18:41:14 <sivel> just go back to calling it contrib :)   /contrib-scripts/
18:41:19 <bcoca> the thing is password scripts would be the same or similar to vault scripts
18:41:29 <felixfontein> I just heard of password scripts for the first time :) but generally it's better to use more explicit names IMO
18:41:42 <felixfontein> /contrib-scripts/ also sounds good to me
18:41:53 <felixfontein> it's also more neutral, and password scripts can be added easily without having to rename it
18:42:06 <samccann> yeah my nickel is put them all in one repo unless there's a reason to separate them into different repos
18:42:13 <jillr> contrib-scripts wfm
18:42:20 <andersson007_> +1
18:42:20 <samccann> +1
18:42:27 <felixfontein> should we vote?
18:42:27 <cybette> +1
18:42:41 <bcoca> felixfontein: was feature to make easier to interface with runner
18:42:53 <felixfontein> VOTE: should the scripts go to github.com/ansible-community/contrib-scripts ?
18:42:54 <abadger1999> +0 (I don't care either way)
18:43:06 <jillr> +1
18:43:08 <andersson007_> +1
18:43:08 <felixfontein> +1
18:43:18 <tadeboro> +1 (this name is as good as any other)
18:43:26 <gundalow> +1 (this name is as good as any other)
18:43:34 <cybette> +1
18:43:53 * andersson007_ this name is as good as any other
18:43:54 <samccann> +1
18:44:38 <acozine> 0
18:45:00 <acozine> my internet connection is bouncing
18:45:15 <felixfontein> #agreed the scripts should go to github.com/ansible-community/contrib-scripts
18:45:16 <cybette> cyb-clock chimes 45-min into the meeting, 29-min on topic "Inventory and vault scripts in c.g."
18:45:31 <felixfontein> ok, last question on this topic is: do we want the scripts to be still part of the Ansible pypi package?
18:46:03 <felixfontein> if people mainly install them with curl/wget, then they don't need to. but I have 0 experience on this. cyberpear do you have some insight? (I think you want them to be included in the package)
18:46:08 <jillr> would that imply a level of support above what we anticipate actually providing?
18:46:15 <tadeboro> I would say no since all instructions for using them I saw say "copy this script ..." at the start.
18:46:54 <gundalow> https://github.com/ansible-community/contrib-scripts exists
18:47:06 <cyberpear> I tended to point to the location where the RPM installed them
18:47:14 <felixfontein> jillr: good question. right now there's no real support either :)
18:47:20 <felixfontein> gundalow: thanks!
18:47:31 <abadger1999> Is anyone volunteering to maintain the scrpts?
18:47:41 <jillr> felixfontein: my inclination would be to not include them since afaik no one is maintaining them
18:47:49 <tadeboro> gundalow: You scared me a bit. I though you said we voted for a name that is already taken ;)
18:47:58 <jillr> or rather, if we include them they should be subject to all the same critera as anything else we include
18:48:02 <felixfontein> jillr: maybe we should kick out some collections and collection contents as well ;)
18:48:03 <gundalow> Isn't the aim to get people to move to the *plugin* version. So we should make some (minor) effort to break people so they realise their is The New Thing
18:48:05 <gundalow> tadeboro: :)
18:48:38 <felixfontein> gundalow: I think the main problem is that for quite a few of these scripts, no plugin alternative exists
18:48:48 <acozine> ah
18:48:57 <gundalow> felixfontein: oh
18:48:58 <bcoca> gundalow: there is no plan to make scripts non functional in core, its too good a feature for those with custom inventory systems to allow them to interface with ansible
18:49:03 <felixfontein> gundalow: especially for vault plugins there is none. though I don't know if one can use them without editing them first anyway
18:49:07 <gundalow> bcoca: yup agreed
18:49:24 <gundalow> So in the README.md in that repo we should highlight if there is a plugin version
18:49:54 <felixfontein> it's not that hard to convert a script into a simple plugin though. but for inclusion in c.g you have to do some more work, like properly document it, add tests, ..., so the bar is somewhat higher than doing a dirty conversion :)
18:50:11 <cyberpear> there's definitely some complex inventory scripts in the wild...
18:50:19 <gundalow> Is there a safe way for inventory/vault scripts to print out info without breaking users, so we can print a warning if people should be using a maintained plugin, rather than old script?
18:50:22 <bcoca> felixfontein: scripts can be done in 'non python' , which is main reason a lot of shops rely on em, they have 'other' expertise
18:50:35 <bcoca> using json as the output, makes it easy to create in any language
18:50:40 <felixfontein> bcoca: ok I meant Python scripts :)
18:50:55 <felixfontein> (i.e. the ones we have in c.g)
18:50:58 <abadger1999> gundalow: We can print to stderr.  But it's another question whether anyone would see that.
18:51:11 <bcoca> felixfontein: they never let me add the perl ones ...
18:51:16 <gundalow> abadger1999: cool. Might be better than nothing
18:51:45 <bcoca> stderr output will be detected as an error
18:51:49 <gundalow> Though then again, for someone to download the scripts they'd need to have looked up the new location, and that might have been enough to realise a plugin exists
18:52:01 <gundalow> Maybe this is something we should Blog/Reddit
18:52:12 <gundalow> (afk)
18:52:17 <felixfontein> cyberpear: how important is it for you to have the scripts included?
18:52:55 <felixfontein> or to anyone else who prefers them to be included
18:52:58 <dmsimard> in any case I see this as a breaking change if they were previously included so it would need to land for 5.0 ?
18:53:19 <dmsimard> unless we want a longer deprecation than that
18:53:27 <felixfontein> dmsimard: yep, they will stay in community.general 3.x.y and only vanish from c.g's main branch (and thus will not be in c.g 4.0.0, and thus not in Ansible 5.0.0)
18:53:44 <bcoca> dmsimard: even if included, they were never installed in a 'usable' location
18:53:53 <bcoca> the instructions were always 'download from here'
18:54:00 <cyberpear> 7/10 important to be in "Ansible" package
18:54:01 <bcoca> 'copy into a dir'
18:54:05 <dmsimard> yeah /me recalls openstack inventory script
18:54:19 <bcoca> why i created plugins ...
18:54:25 <bcoca> at least one reason
18:54:28 <felixfontein> cyberpear: do you know other users who use them directly from Ansible?
18:54:37 <cyberpear> "download from internet" usually doesn't work in my environments
18:54:59 <bcoca> felixfontein: they dont, you would need to edit config files in the ansible distro dirs
18:55:07 <bcoca> so its always 'copy to location'
18:55:08 <felixfontein> cyberpear: no `curl xx | sudo bash`? :D
18:55:13 <cyberpear> I'll take an action to survey the existing scripts
18:56:20 <abadger1999> stderr is not detected as an error for inventory scripts.  I haven't checked vault.
18:56:25 <felixfontein> if we want the scripts to be included in Ansible, we need to have special code in antsibull to handle this, and it should better be ready for the first Ansible 5.0.0 alpha
18:57:05 <felixfontein> which is in mid September
18:57:12 <felixfontein> (according to the proposed schedule)
18:57:58 <felixfontein> so there's no need to decide this today; since we have disagreement I propose to wait with the decision at least for a bit
18:58:05 <felixfontein> is that ok for everyone?
18:58:10 <abadger1999> yeah.  New code would need to be written (unless it gets placed in a collection with no plugin content).  We might want to revisit making a tarball.
18:58:41 <abadger1999> (since we need to have some stable source of the scripts with no-backwards-incompatible-changes guarantee)
18:59:00 <abadger1999> I'm okay waiting.
18:59:05 <tadeboro> But do we really want to ship something that no one takes care of on a regular basis?
18:59:42 <bcoca> tadeboro: sooo 1/2 of c.g?
18:59:50 <abadger1999> tadeboro: Yeah. I don't want to ship it unless someone is volunteering to maintain it.
19:00:12 <jillr> I have a hard stop for another meeting, generally I prefer not to ship anything that isn't being maintained
19:00:32 <tadeboro> bcoca: c.g at least has someone that makes sure sanity test pass.
19:00:34 <felixfontein> we can start moving the plugins to the new repo, and see how many people complain after they are removed from the c.g repo. maybe some people want to step up maintaining some of them then :)
19:00:49 <cybette> cyb-clock chimes 1 HOUR into the meeting, 44-min on scripts
19:00:56 <abadger1999> bcoca: Unfair to felixfontein, tadeboro and the other people that *are* maintaining pieces of c.g that they don't have a personal stake in.
19:00:56 <felixfontein> tadeboro: 'sanity' basically means pep8 and pylint for scripts
19:00:59 <felixfontein> (if at all)
19:01:29 <felixfontein> abadger1999: there's still around 1/2 which nobody touched for a looong time, and probably nobody will touch :)
19:01:39 <bcoca> not how i meant it, but plenty of stuff in cg never gets updates
19:01:45 <felixfontein> (I have no idea how close 1/2 comes to reality though)
19:02:02 <tadeboro> Just wanted to say that bcoca still hit the sore point ;)
19:02:12 <bcoca> as much as those mentioned do, its too big a task even for x5 the ammount of people
19:02:42 <abadger1999> felixfontein: yeah.  the difference, though, is that with the inventory scripts in another repo, we don't even have a volunteer that will be going through and merging sensible PR requests, etc.
19:02:43 <bcoca> tadeboro: its no different from when it was in core, just not enough people to manage the ammount of code
19:02:58 <bcoca> also lack of universal expertise
19:03:09 <felixfontein> ok, I think we kind of agree that we don't agree yet on whether to include them :)
19:03:22 <goneri> vmware.vmware_rest 2.0.0rc1 https://galaxy.ansible.com/vmware/vmware_rest has been pushed on Galaxy. It comes with a new set of modules to manage VCSA appliance. Feedbacks are welcome.
19:03:41 <felixfontein> abadger1999: that is true. at least if nobody wants to do that.
19:04:22 <felixfontein> #agreed whether they will be included in Ansible 5+ will not be decided today. the decision needs to be made and implemented by mid September for 5.0.0 alpha 1
19:04:52 <felixfontein> ok, since we're already at 64 minutes, let's switch to open floor if nobody comes up with an important topic for today
19:04:56 <felixfontein> #topic Open Floor
19:05:28 <felixfontein> I'll update the discussion issue for the scripts
19:05:33 <berkhan> Any plan on to make LTS versions?
19:05:49 <felixfontein> is anyone else interested in moving the scripts? (if nobody wants to, I'll do it)
19:06:08 <felixfontein> berkhan: we have an issue for that: https://github.com/ansible-community/community-topics/issues/1 ;)
19:06:19 <felixfontein> basically it would be nice, but someone would have to do the work
19:06:27 <berkhan> 2nd :face_palm:
19:06:31 <bcoca> gundalow: x2 check iirc i created a repo with the scripts during migration or did you remove that?
19:06:53 <felixfontein> which includes getting security fixes in collections and making sure that compatible bugfix releases will be made. which can be a lot of work.
19:07:18 <felixfontein> (especially due to unresponsive/uninterested collection maintainers)
19:07:20 <abadger1999> berkhan: the summary of that ticket is no but if someone wants to volunteer, we will help them to make it happen.  There are a lot of things that would have to be worked out, though, which are not applicable to the latest versions.
19:07:42 <abadger1999> So a volunteer would be taking on quite a bit of work.
19:08:01 <berkhan> abadger1999: is the issue about distributed collections or core?
19:08:36 * lmodemal hard stop - need to leave.
19:08:38 <abadger1999> berkhan: The ansible package which includesboth ansible-core and a selection of collections.
19:08:57 <felixfontein> berkhan: it's about the Ansible package, i.e. core + collections. and 'LTS' here means maybe 2 years, so similar to what core already does, so nothing compared to Debian etc. :)
19:09:09 <felixfontein> lmodemal: bye!
19:09:24 <abadger1999> berkhan: If you want to talk about just ansible-core, you probably should attend one of the core irc meetings.  (I believe they're still meeting on Tuesdays and Thursdays)
19:09:43 <felixfontein> they are alternating between Tuesdays and Thursdays
19:09:57 <felixfontein> this week it is Tuesday, next Thursday, the one after Tuesday, etc.
19:10:45 <abadger1999> "Core Team Meeting" on this page: https://github.com/ansible/community/blob/main/meetings/README.md
19:10:45 <berkhan> abadger1999: I will definitely checkout ansible-core
19:10:48 <felixfontein> berkhan: what kind of LTS do you think of? something similarly long supported than previous ansible 2.x versions, or more like Debian/Ubuntu LTS range?
19:11:22 <berkhan> felixfontein: thinking of Debian-like LTS
19:11:39 <felixfontein> so more the extreme end of the LTS range ;)
19:11:58 <felixfontein> (from the current situation's POV)
19:12:25 <sivel> ansible-core is not doing an LTS fwiw, we evaluated it, and were in the process of defining a team and responsibilities, and market research ultimately decided no one really wanted it. So we abandoned it.
19:13:10 <bcoca> now just need way to stop peopel from saying we do it anyways
19:13:20 <felixfontein> :D
19:14:02 <berkhan> sivel: thanks for the response! I sens the same felling the opening issues on GitHub
19:15:03 <cyberpear> maybe could team up with deb maintainers? sometimes they backport security fixes to old ansible versions
19:15:18 <bcoca> most distro maintainers do that
19:15:33 <bcoca> since they end up supporting version much older than the upstreams do
19:16:33 <berkhan> cyberpear: Debian stable offers 2.7.7 and 2.9.16 (https://packages.debian.org/search?keywords=ansible)
19:17:26 <bcoca> ^ they also tend to have a patch insertion system and flow, cause they dont always have time to wait for maintainers or maintainers wont patch those versions
19:17:28 <felixfontein> huh, 2.9.16 is seriously outdated for 2.9.x
19:17:37 <berkhan> felixfontein: I use 2.7.7 :D
19:18:17 <berkhan> I did not check 2.9 for whether they backported bug fixes
19:18:46 <felixfontein> the latest 2.9.x release is 2.9.22 from 9 days ago
19:18:50 <berkhan> The last update March 29, 2021 (https://metadata.ftp-master.debian.org/changelogs//main/a/ansible/ansible_2.9.16+dfsg-1~bpo10+2_changelog)
19:19:47 <felixfontein> maybe they just update when there are security fixes
19:19:56 <bcoca> probably
19:20:15 <cyberpear> berkhan++ 2.7.7 is the oldest that supports jinja in tasks names IIRC (or was it tag names?)
19:22:37 <berkhan> cyberpear: I really don't know but Debian packaging works and offers great _LTS_ experience for me. That's why I didn't think for a second to manage with `pip` (oh my god). Maybe I am the only one who wants security features over enhancements ¯\_(ツ)_/¯
19:23:50 <cyberpear> you're not the only one. many folks on IRC do use the pip method, though.
19:24:28 <tadeboro> berkhan: I like ansible-core mostly because it allows me to drop all the ansible content I do not need on one hand and tightly control the version of content I do need.
19:24:38 <acozine> berkhan: what would an "LTS Ansible" give you that you do not get now via the Debian packages?
19:25:56 <tadeboro> acozine: I am not sure if Debian will offer "LTS" packages for ansible>=2.10. Doing that would be a considerable undertaking.
19:26:17 <acozine> ah, I must have misunderstood
19:26:43 <acozine> anyway, we don't need to indulge my curiosity in the community meeting
19:27:18 <bcoca> debian just supports what they released
19:27:28 <bcoca> sometimes that means removing a packagae
19:27:58 <bcoca> until they mark that distro as 'archived'
19:28:44 <berkhan> tadeboro: that's great! I manage only Debian Buster machines, and available Ansible package is helping a lot. That's why I really didn't see myself going into using pip.
19:29:27 <acozine> are we still discussing scripts? do we have more topics on the agenda?
19:29:29 <berkhan> bcoca: I didn't come a cross with this situation and I really don't want to keep Ansible IRC with Debian only content :)
19:29:52 <bcoca> berkhan: for that you havfe ppas and backport repos
19:30:16 <abadger1999> acozine: We're on open floor.  berkhan brought up LTS (but we don't seem to have anything to add to that)
19:30:24 <acozine> ah, I missed the topic change
19:30:32 <berkhan> bcoca: that's correct!
19:30:33 <felixfontein> it was already 26 minutes ago. I think it's time to close :D
19:30:36 <acozine> my internet here is . . . not great
19:30:56 <felixfontein> anyone opposes ending the meeting?
19:31:03 <cybette> let's close the meeting, LTS discussion can continue in here or https://github.com/ansible-community/community-topics/issues/1
19:31:07 <felixfontein> :+1:
19:31:08 <felixfontein> #endmeeting