18:00:08 <felixfontein> #startmeeting Ansible Community Meeting
18:00:08 <zodbot> Meeting started Wed Jun 16 18:00:08 2021 UTC.
18:00:08 <zodbot> This meeting is logged and archived in a public location.
18:00:08 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:08 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:08 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:09 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:13 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:20 <felixfontein> #chair dmsimard gundalow abadger1999 jillr
18:00:20 <zodbot> Current chairs: abadger1999 dmsimard felixfontein gundalow jillr
18:00:23 <cyberpear> o/
18:00:25 <felixfontein> #topic Updates
18:00:29 <felixfontein> #chair cyberpear
18:00:29 <zodbot> Current chairs: abadger1999 cyberpear dmsimard felixfontein gundalow jillr
18:00:33 <andersson007_> o/
18:00:34 <briantist> o/
18:00:37 <samccann> \o
18:00:40 <felixfontein> #chair andersson007_ briantist samccann
18:00:40 <zodbot> Current chairs: abadger1999 andersson007_ briantist cyberpear dmsimard felixfontein gundalow jillr samccann
18:00:58 <felixfontein> #info Ansible 4.1.0 has been released
18:00:58 <felixfontein> #info ansible-core 2.11.2rc1, ansible-base 2.10.11rc1 and ansible 2.9.23rc1 have been released (fixing CVE-2021-3583)
18:00:59 * gundalow waves
18:01:09 <acozine> o/
18:01:14 * dericcrago waves
18:01:17 <felixfontein> #chair acozine dericcrago
18:01:17 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear dericcrago dmsimard felixfontein gundalow jillr samccann
18:03:01 <felixfontein> any more news, announcements, ...?
18:04:03 <gundalow> #Info Matrix <--> Libera.chat bridge is progressing. we should have some details to share soon
18:04:21 <gundalow> nothing else from me
18:04:41 <felixfontein> cool!
18:05:24 <dmsimard> o/
18:05:25 <felixfontein> #info The Bullhorn 28 is out: https://mailchi.mp/redhat/the-bullhorn-28
18:06:38 <felixfontein> ok, I guess we can start then :)
18:06:39 <felixfontein> #topic Ansible 5.0.0 schedule
18:06:39 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/21
18:07:00 <abadger1999> Hey
18:07:06 <mgraves> o/
18:07:16 <gundalow> #chair mgraves
18:07:16 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear dericcrago dmsimard felixfontein gundalow jillr mgraves samccann
18:07:16 <felixfontein> #chair mgraves
18:07:16 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear dericcrago dmsimard felixfontein gundalow jillr mgraves samccann
18:07:22 <tadeboro> o/
18:07:26 <felixfontein> gundalow: this time you were faster :)
18:07:28 <felixfontein> #chair tadeboro
18:07:28 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear dericcrago dmsimard felixfontein gundalow jillr mgraves samccann tadeboro
18:07:35 <gundalow> felixfontein: first and last time :)
18:07:57 <felixfontein> gundalow: I definitely disagree on 'last' ;)
18:08:04 <abadger1999> So Here's the proposed schedule: https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-50
18:08:07 <dmsimard> #info link to ansible-core 2.12 roadmap around which 5.0 is scheduled: https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_12.rst
18:08:56 <felixfontein> so basically the same as the 4.0.0 schedule, just shifted by ~6 months, right?
18:09:24 <abadger1999> yes
18:09:28 <acozine> nice and predictable
18:09:40 <felixfontein> sounds good to me :)
18:09:53 <felixfontein> does anyone want to discuss this, or should we just vote?
18:09:55 <abadger1999> Key dates: Last day for new collections to have been approved: 2021-10-12 ;  feature freeze: 2021-10-25 ; release: 2021-11-16
18:10:22 <gundalow> I like the consistency of keeping the same as 4.0.0
18:10:40 <acozine> abadger1999: those first two dates in the hackMD are in the past, is that deliberate?
18:10:41 <gundalow> Are people happy with the inclusion review dates
18:10:58 <abadger1999> I also added some information in that document about when changes to existing collections should be submitted.  However, that information won't live in the actual schedule so we can vote on those separate from the schedule if we want.
18:11:10 <abadger1999> acozine: It is.
18:11:14 <cybette_> o/
18:11:19 <felixfontein> I hope the reviews (and the reactions on the reviews!) will be done earlier this time ;)
18:11:22 <acozine> sp weI think `2021-04-14 - New Collections may be reviewed for inclusion in ansible-5.`
18:11:24 <felixfontein> #chair cybette_
18:11:24 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear cybette_ dericcrago dmsimard felixfontein gundalow jillr mgraves samccann tadeboro
18:11:27 <abadger1999> (Although, I should swap the two lines)
18:11:28 <acozine> yarg
18:11:34 <acozine> oh, i see
18:11:49 <acozine> `may be reviewed` is the start of the season, so to speak
18:11:56 <abadger1999> Yep.
18:12:01 <acozine> +1
18:12:04 <jillr> we'll want to be mindful of Fest when doing reviews (so we give ourselves enough time) but overall I think it looks good
18:12:51 <acozine> do we know the dates for Fest? maybe put those in as informational?
18:12:56 <tadeboro> AnsibleFest is scheduled for end of September, right?
18:13:12 <dmsimard> right
18:13:25 <jillr> #info AnsibleFest Sept 29th and 30th
18:13:28 <jillr> #link https://www.ansible.com/ansiblefest
18:13:41 <felixfontein> so ansible-core 2.12 will only be released after the Fest (and Ansible 5 as well)
18:14:05 <jillr> felixfontein: yep, but there will probably be upwards of 2 weeks when people are super busy leading up to it
18:14:54 <felixfontein> jillr: to the Fest, to the release, or both? ;)
18:15:12 <jillr> yes?  :)
18:15:47 <felixfontein> ok, let's vote
18:16:18 <felixfontein> VOTE: plan Ansible 5.0.0 to be released according the schedule https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-50 ?
18:16:25 <andersson007_> +1
18:16:25 <jillr> +1
18:16:29 <dericcrago> +1
18:16:29 <tadeboro> +1
18:16:30 <acozine> +1
18:16:32 <mgraves> +1
18:16:33 <samccann> +1
18:16:48 <felixfontein> +1
18:16:48 <bcoca> arent plan and schedule redudant?
18:17:03 <cybette_> +1
18:17:34 <felixfontein> bcoca: I guess someone with better english skills could have formulated that better :)
18:17:36 <abadger1999> +1
18:17:44 <bcoca> felixfontein: that means, not me
18:17:58 <dmsimard> +1
18:18:07 <abadger1999> plan == verb and schedule noun in that sentence ;-)
18:18:10 <tadeboro> I read that initial plan as "we will do our best, but we do not promise anything".
18:18:14 <felixfontein> #agreed plan Ansible 5.0.0 to be released according the schedule https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw#Proposed-Schedule-for-Ansible-50
18:18:20 <felixfontein> tadeboro: that's always what we do ;)
18:18:40 <gundalow> +1
18:18:50 <felixfontein> ok, and we have a follow-up topic for this:
18:18:52 <felixfontein> #topic Deprecation and removal schedule for community.kubernetes
18:18:53 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/22
18:19:07 <felixfontein> background: community.kubernetes is in the process of being renamed to kubernetes.core
18:19:50 <felixfontein> there is a PR for community.kubernetes to replace everything by redirects (for c.k 2.0.0): https://github.com/ansible-collections/community.kubernetes/pull/425
18:19:50 <github-linkbot> https://github.com/ansible-collections/community.kubernetes/pull/425 | closed, created 2021-05-03T06:09:55Z by Akasurde: Redirect everything to kuberentes.core  
18:20:15 <cybette_> cyb-clock chimes 20 minutes into the meeting
18:20:25 <felixfontein> the question is now: what do we have to do so we can finally remove c.kubernetes from Ansible?
18:21:29 <cyberpear> seems like it should be very low cost to keep the redirects around?
18:21:33 <felixfontein> IMO it would be good if we could have a version of the collection where the redirects are deprecated in Ansible 5 (or Ansible 6, if in 5 the redirects are not deprecated), so it's harder for users to miss that the community.kubernetes.* FQCNs go away
18:21:33 <dmsimard> That's for 5.0 ?
18:22:26 <mgraves> cyberpear: it isn't onerous, but I'd prefer to not have to do so in perpetuity
18:22:29 <felixfontein> dmsimard: I think the cloud team would prefer to actually remove the collection in Ansible 5
18:22:37 <tadeboro> I already commented on that issue and I think deprecation should happen at the same time as the redirects.
18:22:46 <abadger1999> I am okay with both the proposals which were mentioned in the tickets.  I slightly favor the one that deprecates at the same time as the redirects are introduced, removing it in Ansible-6, but I'm also okay if people think that the other plan is better for users.
18:23:04 <samccann> it feels problematic to remove w/o at least one Ansible release where the user gets deprecation warnings
18:23:36 <samccann> was leaning toward deprecate in 5 along with the redirects, and remove in 6 as well.
18:23:42 <tadeboro> samccann: That is not an option (at least it way not when I read the proposal a few days ago).
18:23:46 <felixfontein> in Ansible 4, community.kubernetes and kubernetes.core are already identical, so people can already start switching FQCNs now, I think. is that correct?
18:24:06 <mgraves> felixfontein: that's correct
18:24:08 <cyberpear> agreed, don't remove it w/o a full release cycle w/ the deprecation
18:26:12 <felixfontein> my proposal would be: 1) add a deprecation changelog fragment to the next 4.x.0 release; 2) release community.kubernetes 2.0.0 with deprecated redirects and include it in Ansible 5; 3) remove community.kubernetes from Ansible 6 or later (I'm fine with 6, but I don't mind if someone prefers a later version. as long as we remove it eventually :) )
18:26:41 <abadger1999> felixfontein: +1
18:26:42 <andersson007_> +1 to it
18:26:46 <dmsimard> I wouldn't go further than 6, it's already a good chunk of time
18:27:00 <jillr> felixfontein: so you want a 1.2.2 collection release with just a changelog?
18:27:22 <jillr> or a changelog just in the ansible package?
18:27:25 <felixfontein> jillr: I think we can also include the changelog directly in the Ansible 4 changelog without having a collection release
18:27:29 <jillr> ack
18:27:34 <acozine> +1 to felixfontein's proposed timeline
18:27:52 <mgraves> +1
18:27:56 <cybette_> +1
18:28:00 <samccann> +1
18:28:05 <jillr> +1
18:28:10 <tadeboro> I think we can vote ;)
18:28:13 <jillr> hehe
18:28:14 <felixfontein> jillr: basically a PR on https://github.com/ansible-community/ansible-build-data/blob/main/4/changelog.yaml which adds 4.2.0 with the correct data
18:28:29 <cyberpear> +1
18:28:36 <felixfontein> VOTE: 1) add a deprecation changelog fragment to the next 4.x.0 release; 2) release community.kubernetes 2.0.0 with deprecated redirects and include it in Ansible 5; 3) remove community.kubernetes from Ansible 6 or later
18:28:37 <aminvakil> +1
18:28:40 <felixfontein> #chair
18:28:40 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cyberpear cybette_ dericcrago dmsimard felixfontein gundalow jillr mgraves samccann tadeboro
18:28:41 <andersson007_> +1
18:28:48 <jillr> +1
18:28:51 <tadeboro> +1
18:28:52 <felixfontein> or do we want to remove the "or later"?
18:28:52 <acozine> +1
18:28:58 <cybette_> +1
18:29:09 <felixfontein> (we can also discuss it again after 5.0.0 has been released :) )
18:29:10 <felixfontein> +1
18:29:14 <mgraves> +1
18:29:27 <samccann> +1
18:29:39 <tadeboro> I would leave "or later" there just in case. It does no harm IMO.
18:30:19 <felixfontein> sounds good
18:30:22 <dmsimard> +1
18:30:25 <cyberpear> +1
18:30:28 <felixfontein> #chair aminvakil
18:30:28 <zodbot> Current chairs: abadger1999 acozine aminvakil andersson007_ briantist cyberpear cybette_ dericcrago dmsimard felixfontein gundalow jillr mgraves samccann tadeboro
18:30:36 <abadger1999> +1
18:30:38 <dericcrago> +1
18:31:25 <felixfontein> #agreed 1) add a deprecation changelog fragment to the next 4.x.0 release; 2) release community.kubernetes 2.0.0 with deprecated redirects and include it in Ansible 5; 3) remove community.kubernetes from Ansible 6 or later
18:31:29 <felixfontein> great :)
18:31:54 <felixfontein> I can create a PR for the changelog; who wants to create a PR for c.k to deprecate the redirects?
18:32:33 <mgraves> felixfontein: I can do that
18:32:39 <felixfontein> mgraves: cool, thanks!
18:33:06 <felixfontein> ok, next topic:
18:33:08 <felixfontein> #topic Improve ansible-collections issue templates (ask for collection version)
18:33:11 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/23
18:33:14 <felixfontein> dmsimard: do you want to say something here?
18:33:59 <dmsimard> It's hopefully clear in the issue but mariolenz suggests we add a question in the default ansible-collections issue template to ask what version of the collection the reporter is using and how it was installed
18:34:31 <dmsimard> Since it's a default that applies to every repository under ansible-collections, I figured it would be best to ask for input here
18:35:34 <andersson007_> i think many users have no idea if they get collections with ansible package
18:35:47 <felixfontein> I think it's a great idea. uses often only provide the ansible-core/-base/ version when being asked for the Ansible version, which doesn't help at all
18:36:03 <gundalow> If we give a clear set of instructions on how to get this info
18:36:05 <andersson007_> of course it would be nice to have this info
18:36:05 <dmsimard> Should we provide a one-liner command that retrieves the list of installed collections ?
18:36:07 <jillr> can we link to a "how to tell what collection rev you have" helper in the template?
18:36:20 <tadeboro> But we also need to add instructions on how to get that version.
18:36:20 <andersson007_> sounds good
18:36:25 <felixfontein> jillr: we definitely should
18:36:38 <jillr> hehe we clearly have a consensus on this
18:36:44 <felixfontein> referring to `ansible-galaxy collection list` is definitely a good idea
18:36:45 <gundalow> FYI Collection templates are just Markdown, so we can include formatted stuff, or links to whatever reference info already exists
18:36:47 <aminvakil> I guess it can be one line command instead of a link, right?
18:36:48 <dmsimard> Is that "ansible-galaxy collection list" ?
18:37:09 <felixfontein> dmsimard: yep
18:37:17 <jillr> that should be fine
18:37:29 <aminvakil> | grep ?
18:37:30 <dmsimard> And I suppose the maintainers can determine whether the collections are part of the package or installed manually by the path
18:37:33 <felixfontein> aminvakil: that, or both. just having a command users can copy'n'paste is fine for me.
18:37:34 <abadger1999> Something like paste the output of `ansible-galaxy collection list [Namespace].{collection]`
18:37:45 <andersson007_> does this command cover non standard paths?
18:37:48 <felixfontein> dmsimard: depending on how much information the users actually paste, yes :)
18:38:08 <felixfontein> abadger1999: ah, I didn't knew it had a filter option :)
18:38:22 <dmsimard> neither did I, TIL
18:38:38 <abadger1999> andersson007_: It should cover whatever ansible/ansible-playbook will find.
18:38:39 <felixfontein> andersson007_: if your ansible can find the collection, `ansible-galaxy collection list` will list it
18:38:42 <andersson007_> many users don't use FQCNs i guess
18:38:55 <felixfontein> (except for old versions of ansible-base when the collections are installed by the Ansible package...)
18:39:03 <andersson007_> abadger1999: ok, thanks
18:39:16 <andersson007_> felixfontein: thanks
18:39:18 <tadeboro> I would avoid adding a link. Adding oneliner directly to the template removes one level of indirection.
18:39:31 <dmsimard> ok, I'll record what we said in the issue and we'll raise a PR to update the issue template, I don't think we need a formal vote for this
18:39:38 <acozine> maybe include an example in the directions?
18:39:48 <dmsimard> I'll share a link to the PR once it's up
18:39:52 <samccann> thinking about corner cases, but will execution environments become 'common' in community use and if so, will the same command work?
18:40:00 <felixfontein> I'm fine with no vote. does anyone insist on a vote?
18:40:19 <cybette_> cyb-clock chimes 40 minutes into the meeting
18:40:20 <acozine> it'll be a lot easier to vote on an open PR once dmsimard has one
18:40:29 <andersson007_> +1
18:40:34 <felixfontein> that too :)
18:40:35 <jillr> I dont think we need a vote here, verbiage can be hashed out in the PR
18:40:38 <gundalow> I agree with inline example, people aren't going to click links
18:41:25 <tadeboro> samccann: EEs will probably bring its own set of problems and I am pretty sure commands listed here will not work.
18:41:37 <dmsimard> maybe there is an ansible-navigator equivalent command
18:42:13 <samccann> dmsimard yes you can get the info from ansible-navigator, but wasn't sure if that's something we need to add to the template yet, or wait and see if a bunch of issues get opened by EE users
18:42:40 <felixfontein> I guess ansible-navigator is too new for mentioning it already now
18:42:43 <dmsimard> we can always adjust down the road if it turns out to be necessary
18:43:03 <gundalow> no premature optimizations :)
18:43:13 <tadeboro> +1 for waiting until we need it.
18:43:20 <samccann> heh
18:43:31 <andersson007_> `ansible-galaxy collection list or ansible-galaxy collection list NAMESPACE.COLLECTION` in case of when users don't know about namespaces
18:43:56 <dmsimard> andersson007_: I would hope that the person reporting an issue in ansible-collections/namespace.collection knows about the namespace
18:44:12 <andersson007_> dmsimard: i would hope too but anyway
18:44:16 <felixfontein> :)
18:44:25 <dmsimard> "hope is not a strategy" - someone wiser than me
18:44:26 <jillr> dmsimard: that's very optimistic
18:44:41 <andersson007_> i'd avoid situations when such users drop reporting stumbled upon namespaces
18:45:36 <dmsimard> on to the next topic if there's nothing else on this one, I'll update the issue
18:45:44 <felixfontein> dmsimard: do you have enough info to write a proposal?
18:45:51 <felixfontein> +1
18:45:51 <dmsimard> I believe so, yes
18:45:58 <felixfontein> good. next topic then :)
18:45:58 <felixfontein> #topic Define personas/user stories/use cases for the community docsite
18:46:02 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/24
18:46:02 <gundalow> `ansible-galaxy collection list` will return 90+ entries when someone is using `ansible` package
18:46:05 <felixfontein> acozine: samccann: ^
18:46:09 <samccann> Thanks
18:46:35 <samccann> basically someone at some point during the contributor summit suggested we think about personas for the new community docsite I think
18:46:36 <andersson007_> gundalow: any admin knows grep:)
18:46:54 <samccann> at least that's what I remembered, so we slapped together a few ideas at https://hackmd.io/lAJfWYrlT3Gg1VXYGBoZtA
18:47:11 <acozine> yeah, if we're starting a new set of documentation, we have an opportunity to re-organize the content in a way that makes sense for the community
18:47:16 <samccann> and would like community folks to take a look and help us decide if it's an accurate list, missing something? or splitting it too finely etc
18:47:56 <samccann> yep, so first step is who are the different types of people coming to community info, and what questions are they asking etc
18:48:28 <acozine> for example, should we have a section for newbies? a section for folks making the transition from *using* Ansible to contributing?
18:48:49 <andersson007_> samccann: acozine this is on my agenda. I'll copy-past several options from my draft to the issue tomorrow, I think
18:48:55 <samccann> the two questions in my mind - is 'ansible content creator (aka playbooks, roles, ) really a person coming into the community docsite?
18:49:12 <samccann> and ditto for content developer (aka collection creator, contributor,maintainer)
18:49:36 <aminvakil> I guess almost everyone fills that criteria, how many users do not use ansible and start contributing?
18:50:02 <felixfontein> aminvakil: probably most :) contributing is something that most people do not do, I think
18:50:02 <samccann> aminvakil yep - and that's the fundamental problem we face if we consider splitting up existing docs into separate docsites.
18:50:40 <acozine> the old index page for the community guide tried to organize topics by "level" (getting started, going deeper, etc.) - see https://docs.ansible.com/ansible/devel/community/
18:51:58 <samccann> maybe at this point, if andersson007_ has more details to add, this is a topic for next week?
18:52:12 <abadger1999> role and execution environments  may bring content creators to the community site.  Although probably not yet.
18:52:34 <acozine> yeah, everyone in the community is either a user or a developer or both
18:52:40 <andersson007_> it would be nice if everyone gives feedback
18:52:46 <samccann> abadger1999 yeah that's my big question - would they look for this in a new community/contributor site, or in the existing user/dev guides
18:53:01 <abadger1999> (We've been focused on more python-oriented contributions.  But roles currently and execution evironments in the future could both be deliverables that people want to build a community presence around)
18:53:20 <samccann> <nods>
18:53:29 <felixfontein> documenation contributions are also welcome for community collections :)
18:53:37 <felixfontein> (which does not require Python knowledge)
18:53:46 <andersson007_> outreach contributions?
18:53:51 <acozine> andersson007_: sounds like we should wait until you post you drafts, then use those as a starting point for discussion
18:54:00 <acozine> s/you drafts/your drafts
18:54:08 <andersson007_> :)
18:54:57 <abadger1999> What is the difference between Ansible contributor and Ansible content developer?
18:55:18 <andersson007_> folks please think of that too and put your thought to the issue
18:55:23 <acozine> a contributor can do things like fix typos in docs or run a meetup
18:55:23 <samccann> a contributor could be someone fixing a small bug or a documentation fix. May not be that good at python, aren't creating modules etc
18:56:25 <acozine> differentiating those terms is one of the goals, in line with a long tradition of telling people "don't be intimidated, you can contribute too, even if you don't code"
18:56:26 <samccann> so I thought of it as levels of community engagement - ya start with where are the meetups and meetings... then how can I fix something small or help out with issues... then maybe I have a module/role I want to create or add to... all the way up to I have a spiffy collection I want to include in Ansible the Package
18:56:31 <abadger1999> Hmmm...  then what's the difference between an Ansible contributor and an Ansible Content Creator?
18:57:07 <cybette_> I think of contributor as a wider group that will include content creator and content developer...
18:57:08 <samccann> content creator to me is playbooks, roles, maybe EE .  No python for sure.
18:57:25 <felixfontein> maybe we should draw a Venn diagram :)
18:57:29 <acozine> heh
18:57:31 <cybette_> hehe yeah
18:57:35 <abadger1999> So maybe... Ansible Contributor is a supercategory of both Content Creator and Developer?
18:57:37 <aminvakil> :)
18:57:38 <samccann> but yeah, this is the tricky part - determining who the people are and whether we are splitting up too finely etc
18:57:57 <felixfontein> abadger1999: I think it is. and it's not the union of the two.
18:58:17 <acozine> agreed
18:58:33 <abadger1999> Cool
18:58:48 <samccann> I think a 'creator' only becomes a 'contributor' when they... ahem... 'contribute' what they created back to the community
18:59:09 <samccann> I can create my own collection, but if it's only for me and my company, I'm not a contributor to the community
18:59:17 <felixfontein> hmm, true. so it's not a subset
18:59:21 <samccann> but again.. yah.. venn diagram time heh
18:59:49 <acozine> a contributor might be someone who manages an AWX installation, attends a meetup, and joins a working group . . . all using collections and even playbooks other people write
19:00:25 <jillr> I have a hard stop for another meeting, thanks y'all!
19:00:30 <jillr> #unchair jillr
19:00:30 <zodbot> Current chairs: abadger1999 acozine aminvakil andersson007_ briantist cyberpear cybette_ dericcrago dmsimard felixfontein gundalow mgraves samccann tadeboro
19:00:34 <abadger1999> Thank you jillr !
19:00:35 <felixfontein> bye jillr!
19:00:48 <cybette_> cyb-clock chimes 1 HOuR into the meeting
19:00:54 <gundalow> abadger1999:
19:00:55 <gundalow> contributor = someone that gives back to the community
19:00:55 <gundalow> content developer = someone that makes something (might per for personal/company only use, ie not given back)
19:02:11 <abadger1999> For the purposes of personas for the community docs.... contributor might be too amorphous or all-encompassing.
19:02:11 <andersson007_> so we should determine first who is a contributor. Giving something back feels like a fundamental thing
19:02:49 <felixfontein> I would say that's basically the definition
19:03:59 <gundalow> zero or more contributors are content developers
19:03:59 <gundalow> zero or more content developers are contributors
19:04:14 <gundalow> (well, we know it's not zero, though hopefully you get the point)
19:04:56 <cybette_> they intersect, but are not subsets of each other
19:04:59 <gundalow> give back = Attend an event; Do anything on {GitHub, IRC, Matrix, Meetup, email, reddit, etc],
19:05:07 <felixfontein> cybette_: and they intersect non-trivially :)
19:05:07 <gundalow> cybette_: That's much clearer thanks
19:05:10 <acozine> fill out a survey
19:05:34 <cybette_> I would think attending an event is more like community member. organizing/speaking at an event would be a contributor.
19:05:34 <acozine> ^^^ another way of giving back/participating
19:05:48 <gundalow> cybette_: yup, I guess that's fair
19:05:54 <andersson007_> felixfontein: please develop a math model to the next meeting:)
19:05:56 <samccann> cybette - yeah that gets to the point of - did I split it up too much?
19:06:15 <samccann> and just say community member == contributor if we are saying any interaction with community is a contributor?
19:06:20 <felixfontein> cybette_: I guess giving advice to other attendees at a meetup also counts, even if you don't give a presentation. but just passively being there does not count :)
19:07:03 <acozine> so maybe it's best to split the docs by action, rather than by persona? Something like Learn/Participate/Contribute/Develop?
19:07:03 <cybette_> felixfontein agree, that's similar to responding and helping on irc/mailing lists etc. :)
19:07:13 <samccann> maybe it comes down to  new vs experienced. I'm new, where are the meetups, discussions... I'm experienced, I want to give a presentation at a meetup... etc
19:07:37 <cybette_> acozine I like the sound of that, action oriented rather than putting people in boxes.
19:07:37 * samccann needs to drop in 7 min
19:07:52 * samccann puts cybette in a box for saying that
19:07:55 <samccann> ;-)
19:07:56 <felixfontein> acozine: I also like that!
19:08:11 <felixfontein> "think outside the box"? :D
19:08:15 <abadger1999> Use, Extend, Share
19:08:19 <samccann> #info maybe it's best to split the docs by action, rather than by persona? Something like Learn/Participate/Contribute/Develop
19:08:24 <acozine> why don't we let andersson007_ finish his draft, then revisit the conversation next week?
19:08:39 <cybette_> samccann :D
19:08:45 <felixfontein> sounds good to me!
19:08:48 <samccann> sounds good. Feel free to hack at the existing hackmd or create a different one...
19:08:53 <felixfontein> it's time to slowly stop this meeting anyway :)
19:08:59 <andersson007_> no no, this conversation is fine:) please continue:)
19:09:02 <andersson007_> joking
19:09:28 <acozine> andersson007_: you forgot the `sarcasm` and `/sarcasm` tags
19:09:39 <andersson007_> I feel I have a lot ideas to analyze tomorrow:)
19:09:50 <andersson007_> acozine: ok, will know, thanks:)
19:10:01 <acozine> good, that means the conversation was productive
19:10:10 <andersson007_> definitely
19:10:13 <felixfontein> I thought it is {% sarcasm %}...{% endsarcasm %} in jinja2 land ;)
19:10:25 <acozine> heh
19:10:58 <acozine> time for open floor?
19:11:02 <cybette_> +1
19:11:17 <felixfontein> #topic open floor
19:11:19 <felixfontein> here we go :)
19:13:26 <acozine> quiet, isn't it/
19:13:51 <felixfontein> I like the sounds of silence ;)
19:14:14 <dmsimard> I was trying to come up with something but I don't have anything :p
19:14:36 <dmsimard> It will be vacation season soon-ish for perhaps many of us, maybe something to take into account
19:15:02 <acozine> yeah, good thing our next release is in the autumn
19:16:40 <acozine> five minutes, no new topics
19:16:50 <abadger1999> Unless we slip into Thanksgiving/Christmas ;-)
19:17:03 <acozine> heh
19:17:18 <acozine> it's a fine line between vacation season and holiday season
19:17:21 <felixfontein> or New Year's Eve :)
19:17:39 <acozine> pessimists!
19:17:46 <acozine> or maybe realists?
19:18:07 <felixfontein> a bit of both ;)
19:18:12 <felixfontein> #endmeeting