18:00:03 <felixfontein> #startmeeting Ansible Community Meeting
18:00:03 <zodbot> Meeting started Wed Jul 14 18:00:03 2021 UTC.
18:00:03 <zodbot> This meeting is logged and archived in a public location.
18:00:03 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:03 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:03 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:03 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:07 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:10 <gundalow> me waves
18:00:12 <tadeboro> o/
18:00:13 <cyberpear> o/
18:00:15 <andersson007_> o/
18:00:15 * gundalow waves
18:00:21 <samccann> o/ half in and out tho
18:00:27 <acozine> o/
18:00:35 <felixfontein> #chair gundalow jillr tadeboro cyberpear andersson007_ armin samccann acozine
18:00:35 <zodbot> Current chairs: acozine andersson007_ armin cyberpear felixfontein gundalow jillr samccann tadeboro
18:00:41 <lmodemal> Hello
18:00:47 <felixfontein> #chair lmodemal
18:00:47 <zodbot> Current chairs: acozine andersson007_ armin cyberpear felixfontein gundalow jillr lmodemal samccann tadeboro
18:00:54 * dericcrago waves
18:00:54 <acozine> also half and half, listening to an all-hands
18:00:58 <cidrblock> hello all
18:01:03 <felixfontein> #chair dericcrago cidrblock
18:01:03 <zodbot> Current chairs: acozine andersson007_ armin cidrblock cyberpear dericcrago felixfontein gundalow jillr lmodemal samccann tadeboro
18:01:26 <cybette> o/
18:02:07 <cybette_> o/
18:02:14 <felixfontein> #chair cybette_ cybette
18:02:14 <zodbot> Current chairs: acozine andersson007_ armin cidrblock cyberpear cybette cybette_ dericcrago felixfontein gundalow jillr lmodemal samccann tadeboro
18:02:25 <felixfontein> #topic Updates
18:02:30 <felixfontein> do we have any updates today?
18:02:53 <abadger1999> hello
18:03:13 <abadger1999> docs are building (with breadcrumbs) again.
18:03:23 <felixfontein> #info ansible-core 2.11.3rc1, ansible-base 2.10.12rc1 and ansible 2.9.24rc1 have been released
18:03:26 <felixfontein> #chair abadger1999
18:03:26 <zodbot> Current chairs: abadger1999 acozine andersson007_ armin cidrblock cyberpear cybette cybette_ dericcrago felixfontein gundalow jillr lmodemal samccann tadeboro
18:03:37 <felixfontein> #info docs are building (with breadcrumbs) again.
18:03:51 <gwmngilfen> Relates to last meeting's notes, the promised blogpost on Matrix is up. On mobile so I don't have the link handy, @cybette:ansible.im can you oblige?
18:03:55 <abadger1999> samccann and acozine were able to get more memory allocated to the build so we should be good for a while.
18:04:20 <felixfontein> which are great news!
18:04:22 <cybette> #info Blog post on Ansible and Matrix https://ansible.github.io/community/posts/matrix_and_ansible.html
18:04:28 <gwmngilfen> I have another in the works with some stats to flesh out some of my arguments there :)
18:04:43 <gwmngilfen> OK, kids are running amok, layers :)
18:04:44 <felixfontein> so we can use that extra margin to fill it with more docs features ;)
18:05:31 <cybette> #info You can add your thoughts/comments about the blog post here https://www.reddit.com/r/ansible/comments/og5y0l/ansible_and_matrix/
18:05:44 <tadeboro> felixfontein: Or just wait a bit until we have n more collections included in Ansible 5 ;)
18:05:54 <gwmngilfen> I even registered on reddit now :)
18:05:58 <felixfontein> tadeboro: yeah, that as well ;) whatever comes first!
18:07:30 <felixfontein> #topic Contributor Summit
18:07:30 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/30
18:07:40 <felixfontein> let's start with a topic, since we want to stop in time again :)
18:07:41 <gundalow> Thanks
18:09:06 <dmsimard> o/ sorry I'm late
18:09:17 <gundalow> #info We will be running 2 days of of Contributor Summit as part of Ansible Fest. Plan is for 1st day to be aimed for new contributors and people wanting to understand what's involved. 2nd day is more technical discussions. See https://github.com/ansible-community/community-topics/issues/30 for more info
18:09:35 <felixfontein> #chair dmsimard
18:09:35 <zodbot> Current chairs: abadger1999 acozine andersson007_ armin cidrblock cyberpear cybette cybette_ dericcrago dmsimard felixfontein gundalow jillr lmodemal samccann tadeboro
18:09:47 <gundalow> I know we talked about this a bit last week, though I'm wondering what other ideas people have for 1st day of Contributors Summit?
18:10:31 <dmsimard> gundalow: maybe we could we start labelling some issues as low hanging fruits or otherwise good opportunities for first timers to pick up ?
18:10:42 <gundalow> Good idea
18:10:53 <gundalow> Any ideas how we could do that, or which repos to start with?
18:11:01 <acozine> Maybe a review of things we've done to respond to community concerns since Fest 2020?
18:11:32 <gwmngilfen> Ooh I like that @acozine:libera.chat
18:11:36 <gundalow> acozine: What type of things are you thinking of?
18:11:47 <felixfontein> gwmngilfen: for not being there, you are typing a lot ;)
18:11:47 <gundalow> as in, "You said, we did"
18:11:53 <acozine> yeah
18:12:02 <jillr> the cloud team tries to label easyfix bugs during our regular triage so we already have some things we could use
18:12:04 <gundalow> acozine: Love it
18:12:11 <gwmngilfen> Android client :)
18:12:13 <acozine> I've just been looking at the survey results for docs and highlighting things we've already fixed
18:12:23 <acozine> like breadcrumbs and the module index page
18:12:33 <acozine> there must be other things too
18:12:49 <gwmngilfen> Surveys++
18:13:15 <gundalow> #action Contributors Summit: Highlight what people asked for, and what's been done (Docs & Community surveys)
18:13:17 <felixfontein> acozine: I guess adding extra docs for collections qualifies as something in regard with more docs/examples
18:13:26 <acozine> yeah, that's a great example
18:13:41 <acozine> and presumably there are things outside of docs too
18:14:44 <acozine> oh, based on the survey I'm thinking of creating a set of examples in a table, showing Data >> Filter >> Results
18:15:04 <acozine> that would be a great thing for community folks to contribute to
18:15:05 <gundalow> Thanks, added as https://github.com/ansible-community/community-topics/issues/30 (feel free to edit to add other items
18:15:26 <cybette_> cyb-clock chimes 15 minutes into the meeting, 8 minutes on Contributor Summit
18:16:39 <felixfontein> I guess a summary of the latest news on galaxy would be great
18:16:53 <felixfontein> (for the summit, not now :) )
18:17:09 <gundalow> I think we've got Galaxy on the hackmd already, though thanks for the reminder
18:17:27 <gundalow> Anyone interested in helping out on 1st day (Tuesday)
18:17:48 <felixfontein> (I'm trying to think of things 'the community' wanted to have improved; I only remember galaxy and some docs stuff right now)
18:17:55 <cybette> #info Contributor Summit 2021.09 hackmd https://hackmd.io/@ansible-community/contrib-summit-202109
18:18:17 <felixfontein> gundalow: depends what 'help out' means, but I can try :)
18:18:49 <acozine> we can take a look at issues in the various repos that have been addressed and closed
18:19:02 <gundalow> felixfontein: Anything from "Help produce content, to run a session"
18:19:12 <gundalow> (not sure why I put that in quotes)
18:20:00 <tadeboro> I can help with the thing I proposed a week ago. I think it was about setting up the dev env? Man, I am getting old ... ;)
18:20:19 <felixfontein> tadeboro: yes, I think you said that last week :)
18:20:20 <gundalow> tadeboro: That would be great
18:20:28 <cidrblock[m]> The content teams maintain a tool for documenting a collection (README table + docs in the collection doc folder)  Would there be interest in someone showing it in use?  https://github.com/ansible-network/collection_prep
18:20:55 <felixfontein> if we do something hackathon-like, I can definitely help with that (i.e. helping beginners with creating PRs and polishing them)
18:20:59 <cidrblock[m]> might be interesting for collections not headed to the community pkg, or enterprise collections (internal)
18:21:08 <tadeboro> cidrblock[m]: I know I would be. I meant to have a look at that tool but never had the time.
18:21:21 <gundalow> felixfontein: I think hackathon would be great
18:21:48 <dmsimard> +1 hackathons are great
18:22:03 <gundalow> acozine: samccann Are there easy(ish) docs fixes, such as things we know need updating though we don't have the technical information to be able to improve the docs?
18:22:17 <gundalow> I think dericcrago has been to some of the PyCon hackathons before
18:22:29 <acozine> nothing comes to mind immediately, but we can look
18:22:33 <dericcrago> yep, I'm all for it
18:22:48 <acozine> the "bring us your data examples" idea would be good for a hackathon
18:22:56 <samccann> there's always asks for clarifying the developer guide
18:23:16 <jillr> gundalow: we have 2 docs bugs in amazon.aws. 1 should be straightforward, the other might be?
18:23:21 <felixfontein> acozine: you mean like helping with creating funny filter chains to transform foo into bar?
18:23:46 <abadger1999> It would be great to have a "collaboration between all the docs tools devs" session.
18:23:47 <sivel> The pycon hackathons in many cases turned out poor, because the "easyfix" issues, aren't always as easy as we thought, and devs with lack of experience went off in the weeds, and came back with crazy PRs
18:23:57 <felixfontein> abadger1999: +1
18:24:08 <sivel> We got the most benefit, by basically asking people to go verify issue reports, instead of writing code
18:24:22 <gundalow> sivel: Thanks good feedback thanks. I know `easyfix` is a very loaded term
18:24:25 <acozine> felixfontein: examples of using filters ranging from simple (finding my IP address from the Ansible Facts) to complex (filter chains for ???)
18:24:26 <cybette> what about checking for inclusive language?
18:24:48 <gundalow> FYI andersson007_ is going to be writing some docs on how to create integration tests
18:25:00 <sivel> gundalow: yeah, sdoran can tell you about issues I flagged as easyfix, that instead became "nearly the most complicated issue and fix we've encountered" ;)
18:25:01 <dericcrago> yeah, I think we'd need support from whomever the hackathon is for, docs, core, whatever collection(s), etc.
18:25:01 <jillr> cybette: we have this to work from  http://test-test-clc.apps.ospo-osci.z3b1.p1.openshiftapps.com/analysis.html?project=ansible.git
18:25:06 <felixfontein> cybette: usually the hard part is changing it once it's not just in the text, but option/module/... names
18:25:15 <jillr> clc == conscious language checker project
18:25:39 <briantist> acozine: I love the filter chaining documentation idea, can't tell you how much time I spent trying to figure that stuff out in the early days
18:25:40 <jillr> some of those need to be ignored (style guide that says not to use certain terms) but some are valid
18:26:06 <cybette> could that be something we work on during contrib summit?
18:26:10 <jillr> definitely
18:26:17 <felixfontein> briantist: in some cases, most of us still do that (if we don't go the lazy route and just create a new filter plugin instead ;) )
18:26:32 <briantist> so true, myself included for sure
18:26:32 <abadger1999> I think that's a problem with how we ran the sprints there, though.  having people verify issue reports is overall  discouraging for contributors.
18:26:38 <jillr> we started this for the idea of a docs hackfest https://github.com/ansible/community/issues/616
18:27:02 <dericcrago> depending on the level of experience, there's also quite a bit of setting of the development environment, maybe tadeboro's session should be first / a prerequisite
18:27:03 <abadger1999> Pair programming fixes might be a good thing to try out.
18:28:49 <gundalow> jillr: cybette I like the idea of reviewing CLC, thanks
18:29:14 <felixfontein> dericcrago: I agree, getting a dev environment set up is pretty imporant before you can actually do something *and test it*
18:29:17 <acozine> can we point that analysis of CLC at the devel branch?
18:29:17 <jillr> gundalow: I can add "ignores" to it for things like the style guide before fest
18:29:45 <acozine> I can't remember how far back we backported the latest fixes
18:30:05 <cybette_> cyb-clock chimes 30 MIN into the meeting, time to move on to next topic?
18:30:23 <andersson007_> dericcrago: felixfontein the problem of dev environment should be solved with https://github.com/ansible/community-docs/blob/main/create_pr_quick_start_guide.rst. However people don't know about it often
18:30:40 <jillr> acozine: maybe?  I'm hunting in the UI...
18:31:17 <felixfontein> ok, let's warp this topic up in ~5 minutes.
18:31:19 <acozine> we can look at everything, but for docs it would be frustrating to go to fix something and find it had already been updated on the only branch open to PRs
18:32:28 <jillr> acozine: I'll find out for sure
18:32:39 <acozine> jillr: awesome!
18:32:48 <jillr> I suspect it's default branch?
18:33:51 <acozine> oh, then it should be devel
18:33:58 <acozine> cool
18:34:36 <gundalow> Oh, so I think we've got
18:34:36 <gundalow> 1. Hackathon - dericcrago
18:34:37 <gundalow> 2. CLC triage, fix & https://github.com/ansible/community/issues/616 - jillr & cybette
18:34:37 <gundalow> 3. Setup Dev environment - tadeboro
18:34:37 <gundalow> 4. Identify "easy fix" - jillr  dmsimard
18:35:05 <gundalow> (taking advantage of putting work on my teams plate, thanks dericcrago and dmsimard )
18:35:29 <gundalow> Did I miss anything?
18:36:44 <gundalow> Thanks, all. Lots of great suggestions.
18:36:53 <acozine> \o/
18:36:54 <felixfontein> #topic Community execution environments
18:36:54 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/31
18:36:56 <gundalow> And I really appreciate the offers of help
18:37:09 <gundalow> abadger1999: cidrblock[m] ^
18:37:21 <felixfontein> this came up last week when we were talking about reducing size of the Ansible package
18:37:27 <cidrblock[m]> RE #31, I added some discussion topics to it earlier today
18:38:02 <felixfontein> cidrblock[m]: ah, you edited the initial post, that's why I didn't notice :)
18:38:13 <felixfontein> I just wondered why it's suddenly so long ;)
18:38:36 <cidrblock[m]> lol
18:38:46 <cidrblock[m]> I think this might be a good place to start: "What would the goal of embracing EEs be within the community?"
18:38:55 <abadger1999> <nod>
18:39:25 <jillr> I agree with your first 2 bullet points of goals
18:40:07 <gundalow> cidrblock[m]: Is there an existing write up of "What are EEs and how they can make your life better"
18:40:27 <jillr> I think there was some idea of linking this idea to the desire to reduce the size of the ansible package though and I'm not sure that size is going to be a great use of EEs because of python dep inclusion
18:40:34 <felixfontein> and "how to make your collection ready for EEs"? :)
18:40:35 <dmsimard> IMO it needs to start with a use case -- users have their own habits around distro or pypi packaging and workflow, why would they be interested ?
18:41:28 <cidrblock[m]> gundalow: I suspect there are upstream docs
18:41:31 <felixfontein> jillr: I think the idea was to have a EE tailored to what you need, i.e. see EEs more as a stripped-down Ansible package (which happens to come with dependencies so it's with even more batteries included)
18:41:33 <cidrblock[m]> * gundalow: I suspect there are upstream docs, not confirmed
18:41:44 <jillr> felixfontein: we'll be producing some internal docs on how to test a collection with EEs later this quarter that I'll be looking at upstreaming too
18:41:58 <jillr> internal meaning, for our team's onboarding/training by our team
18:42:20 <felixfontein> jillr: that would be great, because right now I'm really missing information on that (but then I didn't search, maybe it already exists in the open?)
18:42:33 <jillr> felixfontein: if it exists we're also missing it  :)
18:43:04 <jtanner> the initial intent of EEs was to answer the question "How will redhat customers who won't use galaxy cli, get their collections installed"
18:43:29 <abadger1999> Is there such a thing as "an ee ready collection"?  ie, an ee that has all of its requirements specified?
18:44:03 <cidrblock[m]> Since the focus for EEs has been upstream, platform, the lack of docs is not unexpected...  Doc would be one piece of work if there is a decision to "embrace" EEs within the community (if not, I would expect docs to be organic and a mix of tweets and blog posts)
18:44:28 <tadeboro> abadger1999: Certified collections are treated that way, yes. They need to have python and collectin requirements specified.
18:44:33 <felixfontein> it's kind of hard to embrace something you don't really know yet :)
18:45:04 <cidrblock[m]> true
18:45:12 <tadeboro> All information about EEs I have I got from the ansible-runner docs. But that is not much.
18:45:18 <abadger1999> <nod>
18:45:31 <cidrblock[m]> I can give a super brief summary.... if there is interest
18:45:41 <felixfontein> cidrblock[m]: please do so :)
18:46:02 <felixfontein> (just in case someone doesn't know - TBH I'm not sure whether I know ;) )
18:46:12 <cybette_> cyb-clock chimes 45 min into the meeting, 9 min on Community EE
18:46:36 <cidrblock[m]> An EE is just a container really.  Inside, collections, python packages, ansible and ansible runner (based on UBI8 for the platform)  EEs are defined in a definition file and build by ansible builder
18:47:29 <jillr> think how, we use --docker with ansible-test because the test image is maintained and has all the right dependencies.  kind of like that but for users.
18:47:33 <felixfontein> and then you basically mount your playbook/data dir into the container and run ansible-playbook in there?
18:47:42 <cidrblock[m]> To execute automation within the EE, ansible runner is used on the "outside" of the container......   Either ansible-navigator or controller (awx, tower) use runner's python API to initiate the automation withing the container
18:47:53 <jillr> my example is an oversimplification, but hopefully helps?
18:48:20 <cidrblock[m]> for the dev, ansible-navigator takes care of mounting the CWD or playbook dir for you..........  controller (awx/tower) does the same there
18:48:22 <felixfontein> jillr: it matches the idea I had about EEs :)
18:48:57 <felixfontein> do users interact with ansible-runner directly, or do they exclusively use ansible-navigator, aws or tower?
18:49:08 <felixfontein> or maybe, *can* users interact ...?
18:49:25 <cidrblock[m]> ansible-navigator and tower would be the recommended entry points moving forward
18:49:43 <cidrblock[m]> ansible-runner is positioned as a back-end library, not really user facing
18:49:48 <felixfontein> does navigator have a "no UI" mode which just runs a playbook in an EE?
18:50:23 <cidrblock[m]> navigator has 2 modes, stdout and interactive  (stdout looks like good ole playbook)
18:51:08 <felixfontein> hmm, does nobody else want to ask questions as well? :)
18:51:27 <andersson007_> we are trying to imagine this
18:51:48 <cidrblock[m]> The "win" of EEs IMO is that the defintion of automation now goes past the playbook, role, collection and now include the enviroment in which it will run....  basic container win here
18:52:13 <cidrblock[m]> (it is a big change in the way automation happens for sure)
18:53:36 <felixfontein> I think we need more docs on this :)
18:53:49 <gundalow> Would be good, yup
18:53:57 <cidrblock[m]> here is the flow a automation creator might go through........  write playbook and run with navigator + venv ansible,  run same playbook using navigator + EE, push to EE to AH, and run the same playbook using the same EE on controller (awx)
18:53:58 <dmsimard> If there is a presentation about navigator and EEs at fest, I would like to use it as a reference to point people at them
18:53:59 <felixfontein> is there a how-to "build a small test EE and run a playbook in it with ansible-navigator"?
18:54:21 <cidrblock[m]> felixfontein:
18:54:29 <cidrblock[m]> * felixfontein: not in a single doc
18:54:39 <acozine> not yet, no
18:54:43 <cidrblock[m]> * felixfontein: not in a single doc (downstream)
18:54:46 <abadger1999> How are users exposed to EEs?  Is there a listing somewhere?  Does it have a summary of the EEs purpose?
18:54:48 <felixfontein> :)
18:55:09 <felixfontein> FYI: we'll switch to open floor in ~1-2 minutes
18:55:10 <cidrblock[m]> abadger1999: no noise about this until 2.1 GA + fest
18:55:28 <gundalow> felixfontein: ack
18:55:35 <felixfontein> what is 2.1 GA?
18:55:39 <felixfontein> (2.1 of what?)
18:55:48 <sivel> 2.1 of Ansible Automation Platform
18:55:53 <abadger1999> meaning, nothing now but it's a piece that's being worked on?
18:55:54 <cidrblock[m]> Red Hat Ansible Automation Platform 2.1 Fall 2021
18:56:12 <felixfontein> thanks :)
18:56:13 <tadeboro> felixfontein: GA == General Availability
18:56:15 <gundalow> felixfontein: The only thing we (Ansible) sell
18:56:24 <felixfontein> tadeboro: that part I knew, but not more ;)
18:56:29 <cidrblock[m]> abadger1999: yes, but everything will be upstream focused
18:56:32 <sivel> I'm not aware of any community effort for a place where EEs would have a central listing
18:56:54 <dmsimard> is there a repository on quay.io or something ?
18:57:04 <cidrblock[m]> sivel: right, there has been no real focus on EE's downstream
18:57:18 <sivel> dmsimard: just a users or orgs repo, so it's just like any other container image
18:57:23 <felixfontein> I guess a howto which explains 1) how to create an EE, 2) how to use it, 3) how to push it to a registry and pull it from there, could already help random community members to try this out and become addicted :)
18:57:30 <cidrblock[m]> dmsimard: only some test images, nothing "real"
18:57:30 <abadger1999> It kind of sounds like there's nothing that community can really do with EEs at the moment... there's not enough infra for us to create EEs for other people to use and there's not enough docs on building EEs for us to usefully create infra of our own.
18:57:37 <tadeboro> I know that I had to prepare sensu.sensu_go collection for EE, but I have no idea where that collection ednded up in the end.
18:58:08 <felixfontein> ok, we have to stop this topic for today :)
18:58:14 <felixfontein> #topic Open Floor
18:58:16 <cidrblock[m]> It is early days for EE's, navigator, awx EE support, should we revisit again, closer to fest?
18:58:36 <felixfontein> if you have anything quick that hasn't been discussed yet, feel free to put it up now!
18:58:52 <cidrblock[m]> nada here
18:59:06 <sivel> 2.12+ support for collection defined action_groups was merged today
18:59:07 <tadeboro> I would say that EE should wait until there are some decent docs tha community can use to determine if this is something we can benefit from.
18:59:13 <felixfontein> cidrblock[m]: sounds like a good idea. I don't know what would be a good time since I don't really track progress of that stuff :)
18:59:31 <abadger1999> I'll bring a summary of what we feel blocked on to an internal meeting as wel.
18:59:31 <felixfontein> sivel: right, that would have been something for Updates :)
18:59:48 <sivel> felixfontein: I don't even know where I am right now, let alone when updates was done ;)
18:59:59 <felixfontein> for the ones who don't know: action_groups is the generalization of module_default groups, now arbitrary collections can define their own
19:00:10 <felixfontein> sivel: updates were approx. one hour ago ;)
19:00:20 <cyberpear> sivel++ happy to hear about action_groups for collections
19:00:20 <zodbot> cyberpear: Karma for sivel changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:00:34 <felixfontein> shertel++ for implementing them :)
19:00:53 <gundalow> I don't have anything else
19:00:57 <cybette_> cyb-clock chimes: 1 HOUR into the meeting, time to wrap up!
19:01:02 <gundalow> woot
19:01:04 <felixfontein> :)
19:01:05 <felixfontein> #endmeeting