18:00:08 <felixfontein> #startmeeting Ansible Community Meeting
18:00:08 <zodbot> Meeting started Wed Sep 15 18:00:08 2021 UTC.
18:00:08 <zodbot> This meeting is logged and archived in a public location.
18:00:08 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:08 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:00:08 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:00:08 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:00:11 <dmsimard> o/
18:00:12 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:00:14 <jillr> o/
18:00:15 <andersson007_> o/
18:00:17 <felixfontein> #chair dmsimard jillr andersson007_
18:00:17 <zodbot> Current chairs: andersson007_ dmsimard felixfontein jillr
18:00:25 <tadeboro> o/
18:00:27 <abadger1999> Bom dia
18:00:28 <gundalow> o/
18:00:38 <felixfontein> #chair tadeboro abadger1999 gundalow
18:00:38 <zodbot> Current chairs: abadger1999 andersson007_ dmsimard felixfontein gundalow jillr tadeboro
18:00:40 <cybette> o/
18:00:44 * dericcrago waves
18:00:51 <felixfontein> #chair cybette dericcrago
18:00:51 <zodbot> Current chairs: abadger1999 andersson007_ cybette dericcrago dmsimard felixfontein gundalow jillr tadeboro
18:00:52 <felixfontein> #topic Updates
18:00:52 <felixfontein> #topic ansible-core 2.11.5, ansible-base 2.10.14 and ansible 2.9.26 have been released
18:00:55 <felixfontein> #info updates: EMS has plumbed #social:ansible.im (#ansible-social) so please feel free to start saying good morning, etc. News posts are welcome there too. There is an ongoing technical issue which is causing some display issues, but it's fine to use.
18:00:59 <felixfontein> #undo
18:00:59 <zodbot> Removing item from minutes: INFO by felixfontein at 18:00:55 : updates: EMS has plumbed #social:ansible.im (#ansible-social) so please feel free to start saying good morning, etc. News posts are welcome there too. There is an ongoing technical issue which is causing some display issues, but it's fine to use.
18:01:02 <felixfontein> #undo
18:01:02 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f6312bdcc18>
18:01:07 <felixfontein> #info ansible-core 2.11.5, ansible-base 2.10.14 and ansible 2.9.26 have been released
18:01:10 <felixfontein> #info updates: EMS has plumbed #social:ansible.im (#ansible-social) so please feel free to start saying good morning, etc. News posts are welcome there too. There is an ongoing technical issue which is causing some display issues, but it's fine to use.
18:01:11 <samccann> o/
18:01:15 <felixfontein> sorry...
18:01:17 <felixfontein> #chair samccann
18:01:17 <zodbot> Current chairs: abadger1999 andersson007_ cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
18:02:13 <gundalow> #info The concerns around `netbox.netbox` collection are been worked on. New maintainers have been setup. CI is been fixed. So we can keep the collection in the ansible package
18:02:33 <andersson007_> that's great
18:03:25 <abadger1999> #info cidrblock sends his apologies and he won't e able to make today's meeting.  He authorized us to record him as a +0 on any votes that come up.
18:03:57 <dmsimard> oh, I have something
18:05:08 <dmsimard> #info The version of ansibullbot running on community.general has been updated with support for AZP amongst other things
18:05:23 <andersson007_> good news:)
18:05:33 <felixfontein> great news on netbox.netbox indeed!
18:05:46 <felixfontein> and the new bot is great as well :) it finally supports AZP!
18:06:07 <andersson007_> yeah:)
18:06:09 <felixfontein> i.e. no more stale_ci / ci_missing labels, and it copies sanity check error messages into the PR
18:06:37 <andersson007_> this will make life much easier
18:06:57 <felixfontein> ok, so what we do want to discuss today?
18:07:13 <felixfontein> as jillr noted earlier, we don't really have topics that must be discussed now
18:07:57 <jillr> I'm sure we have plenty of things to spend the time on though  :)
18:07:59 <felixfontein> we could talk about the attributes feature, but I guess that feature already has enough discussions going on, so having one more won't improve the situation :)
18:08:11 <felixfontein> (if someone is interested in this, please go to #ansible-docs)
18:08:38 <tadeboro> Maybe we should just say a word or two about https://github.com/ansible-community/community-topics/issues/42 and close it?
18:08:40 <felixfontein> how about resurfacing the "New content for community.general and community.network" discussions?
18:09:02 <tadeboro> Since that issue seems to be "done".
18:09:07 <dmsimard> need to afk momentarily, be back in a bit
18:09:22 <andersson007_> tadeboro and i reviewed community.ciscosmb collection - things look good there, does anyone else want to review it or we can vote on its inclusion.
18:09:23 <felixfontein> tadeboro: let's assign it to Greg and let him close it, and perhaps write something before :)
18:10:07 <felixfontein> #action GregSutcliffe write an update to https://github.com/ansible-community/community-topics/issues/42 and close it
18:10:15 <tadeboro> felixfontein: OK, works for me.
18:10:40 <tadeboro> andersson007_: I though we will vote on inclusions just before the release (forgot the exact date).
18:10:41 <felixfontein> collection review sounds good to me
18:11:03 <felixfontein> I guess we can already vote on candidates before the deadline, so we have more time for problematic ones on that date :)
18:11:09 <jillr> +1
18:11:21 <felixfontein> (I think last time we had a pretty long meeting because of that)
18:11:31 <andersson007_> the maintainer of community.ciscosmb is very responsive
18:11:32 <gwmngilfen> felixfontein sure :)
18:11:40 <tadeboro> That is true ;)
18:11:54 <felixfontein> #topic Inclusion of community.ciscosmb in Ansible 5
18:12:04 <tadeboro> So maybe we can vote on two collections that have two positive reviews?
18:12:09 <andersson007_> so i personally don't see any obstacles not to include the collection
18:12:12 <andersson007_> tadeboro: yeah
18:12:16 <andersson007_> thought of the same recently
18:12:17 <felixfontein> #info Discussion: https://github.com/ansible-collections/ansible-inclusion/discussions/26
18:12:39 <felixfontein> tadeboro: sure, if we have at least two :)
18:12:52 <andersson007_> tadeboro: i mean the lower bound of review number
18:12:59 <andersson007_> imo should be at least two
18:13:12 <andersson007_> but two is enough
18:13:13 <andersson007_> imo
18:13:15 <felixfontein> #info Collection repo: https://github.com/ansible-collections/community.ciscosmb
18:13:24 <mator> andersson007_, felixfontein do we need another sample of a trivial community.general PR for hackfest? for example, c.g/plugins/modules/system/aix_inittab.py could be changed with module.get_bin_path(required=true)
18:13:29 <felixfontein> I'm looking at that repo a bit
18:13:48 * jillr also looking at repo
18:14:03 <andersson007_> mator sounds like a good idea, let me find the document
18:14:29 <samccann> interesting, the readme for ciscosmb at the bottom points to what looked to be common contributor etc files. but if I click any of those links in Galaxy, they come up missing.
18:15:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:15:14 <jillr> samccann: they're not full URLs in the README.md file, they're relative paths to the codebase
18:15:28 <andersson007_> mator: https://hackmd.io/CqUQNTEqRBCHBTC4WF-9Aw?both feel free to add the issue to the doc
18:15:36 <jillr> `See [RELEASE_POLICY.md](./RELEASE_POLICY.md)`
18:15:47 <samccann> jillr - makes the readme a bit useless in that section then.
18:15:51 <jillr> fixing that would be good
18:16:13 <samccann> ok I'll create an issue if one doesn't already exists for it
18:16:58 <jillr> thanks!
18:17:28 <tadeboro> Ugh, yeah. Maybe we should have a check for absolute links in README somewhere otherwise things will point into the void on galaxy.
18:18:03 <andersson007_> i stumbled upon same thing
18:18:28 <andersson007_> in the collections i maintaned
18:18:36 <andersson007_> thanks felixfontein for spotting that
18:19:08 <felixfontein> collection looks good to me, besides that
18:19:27 <felixfontein> I didn't spot that, I think?
18:19:47 <felixfontein> (or I'm confused what you mean)
18:19:55 <andersson007_> i mean in collections that i maintain
18:19:59 <felixfontein> ah
18:20:02 <felixfontein> so some time ago :)
18:20:09 <andersson007_> yeah
18:20:28 <andersson007_> i think in this case the issue would be enough
18:20:37 <andersson007_> and it's not an obstacle
18:20:43 <felixfontein> agreed
18:20:51 <andersson007_> as we've started to discuss its inclusion
18:20:57 <samccann> opened the issue - https://github.com/ansible-collections/community.ciscosmb/issues/47
18:21:06 <felixfontein> should we vote at :25?
18:21:06 <andersson007_> samccann: thanks!
18:21:12 <felixfontein> in case someone wants a bit more time to browse
18:21:22 <jillr> that works for me
18:21:23 <felixfontein> if someone wants even more time, please announce it before we vote so we can wait longer
18:22:26 <andersson007_> +1 for voting in this meeting (if there are no major issues spotted)
18:23:49 <jillr> modules just named "facts" and "command" feels like a trap for users
18:24:33 <andersson007_> why? name conflicts?
18:24:35 <felixfontein> don't use `collections:` :)
18:24:44 <tadeboro> IIRC, this is somewhat standard practice in the netowrking collections.
18:24:50 <jillr> andersson007_: yeah, if you have more than one colleciton using that name and don't FQCN every task
18:24:56 <jillr> tadeboro: fair enough then
18:25:01 <felixfontein> other network collections also do that
18:25:24 <jillr> I only cross-checked the cisco.ios collection which are all ios_$something
18:25:25 <andersson007_> thankfully examples use FQCNs:)
18:25:44 <samccann> heh just checked that same one jillr!
18:25:54 <felixfontein> ok, it's :25, anyone wants to have more time?
18:25:59 <felixfontein> (before we vote?)
18:26:07 <abadger1999> with fqcn, it would be community.ciscosmb.facts and community.ciscosmb.command.... Is there something else that could be added to the module names that won't duplicate the namespace.colletcion information?
18:26:13 <samccann> but that typically means all the network collections handled by the internal ansible team probably use <plaform>_facts
18:26:13 <jillr> the sysadmin in me dislikes the potential for "surprise network device management" but if that's the expectation for networking *shrug*
18:26:33 <tadeboro> ios stuff came from ansible 2.9 and was not renamed would be my guess.
18:26:37 <abadger1999> Alternately, should there be a short list of module names that are too central to some ansible concept that they shouldn't be used?
18:26:51 <felixfontein> (community.routeros also uses command and facts)
18:27:16 <tadeboro> facts module is actually used by the fact gathering mechanism on network collections.
18:27:32 <samccann> eos uses eos_facts, iosxr uses iosxr_command etc etc
18:27:38 <jillr> I don't think it's a blocking thing, it's just definitely not my personal preference
18:27:53 <samccann> so in terms of certified collections, the trend is to NOT have it just facts or command as the module name.
18:27:57 <abadger1999> tadeboro: Ah, so it's already a convention that's being made use of in code.
18:28:42 <felixfontein> hmm, looks like community.routeros is the only collection currently included in Ansible which uses `command` and `facts`
18:29:29 <samccann> yeah looking at the other collections in the Cisco space, the four I've looked at all include the platform in all module names
18:29:58 <tadeboro> I personally do not mind the short names since we advocate using FQCNs and refix contains enough info for disambiguation.
18:30:01 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:30:23 <abadger1999> Im okay either accepting or having them changed.  I just want us to encode the rule in the guidelines if we decide to make them change it.
18:30:25 <andersson007_> namespaces exist to prevent name collisions and we encourage users to use FQCNs
18:30:28 <sivel> man of those collections use runtime.yml to redirect
18:30:32 <sivel> many*
18:30:48 <felixfontein> I agree with tadeboro
18:30:53 <sivel> https://github.com/ansible-collections/cisco.ios/blob/main/meta/runtime.yml#L27-L28
18:31:36 <andersson007_> +1 to what abadger1999 is saying
18:31:50 <samccann> fwiw - i've checked 10 of the cisco collections and only 2 so far do not include the platform name.
18:32:07 <felixfontein> sivel: interesting, so ios_command is a module, and command simply points to the action plugin? (which might use the ios_command module?)
18:32:15 <samccann> tho i realize we aren't in the business of enforcing consistancy across their own collections
18:32:31 <sivel> it's done for a module too: https://github.com/ansible-collections/cisco.ios/blob/main/meta/runtime.yml#L167-L168
18:32:52 <felixfontein> ah
18:32:53 <sivel> I just linked the first redirect I found :)
18:33:31 <tadeboro> The openstack went the other way IIRC: they removed the os_ prefix from all of their modules.
18:33:55 <felixfontein> should we first vote on whether we accept the "short names"?
18:34:02 <tadeboro> So I would personally stay from the naming business and let maintainers use whatever they feel is OK.
18:34:08 <felixfontein> (or do you want to discuss this further before voting?)
18:34:13 <andersson007_> tadeboro: +1
18:34:32 <samccann> yeah leaning toward tadeboro's idea that maybe we aren't in the business of enforcing module names like this
18:34:36 <felixfontein> assuming some standard convention are satisfied, like using the _info and _facts suffixes correctly :)
18:35:02 <samccann> I'm assuming someone checked that facts is really facts in the code? ;-)
18:35:06 <abadger1999> Re openstack: <nod> yeah, I don't think we should make "short names" illegal in general.  If we make them illegal, I'd like to see that scoped to specific short names or when there's extra information that needs to be included in the name.
18:35:35 <felixfontein> samccann: for this collection, I looked at it :)
18:35:40 <samccann> it does get repetative (ffr.ffr.ffr... i'm lookin at you!)
18:35:44 <andersson007_> we have a mechanism (encouraged to use) - FQCNs
18:36:02 <felixfontein> awx.awx.awx?
18:36:07 <samccann> heh yep
18:36:32 <abadger1999> feYeah, let's vote on allowing  command and facts as valid module names and if that passes we can move on to vote on inclusion of this collection.
18:36:52 <andersson007_> +1
18:36:53 <felixfontein> VOTE: are collections that want to get included in Ansible free to use short names (like `command` or `facts`) for modules/actions?
18:36:57 <felixfontein> #chair
18:36:57 <zodbot> Current chairs: abadger1999 andersson007_ cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
18:37:04 <tadeboro> +1
18:37:05 <abadger1999> +1
18:37:06 <andersson007_> +1
18:37:15 <felixfontein> +1
18:37:15 <dericcrago> +1
18:37:16 <jillr> +1 (I dont have to like it, but I'll support it :))
18:37:27 <abadger1999> jillr: heh :-)
18:37:35 <jillr> y'all have convinced me  :)
18:37:50 <cybette> +1
18:37:58 <samccann> +1
18:38:02 <felixfontein> "`collections:` is evil!" ;)
18:38:03 <samccann> (same as jillr lol)
18:38:13 <andersson007_> jillr: now you can say as cyberpear "I told you..."
18:38:19 <andersson007_> you canNot
18:38:31 <andersson007_> later
18:38:38 <jillr> lol, I can say whatever I want on this side of my keyboard anyway!
18:38:43 <felixfontein> hehe :)
18:38:58 <felixfontein> I think we need more steering committee member votes
18:39:05 * cyberpear late
18:39:10 <felixfontein> #chair cyberpear
18:39:10 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
18:39:19 <felixfontein> cyberpear: just in time for a vote :)
18:39:30 <abadger1999> There is one +0 (cidrblock) as well.
18:39:48 <cyberpear> +1 allow short names IIUC
18:40:09 <gundalow> +1 since they are new modules & plugins and will always need `collections:` or FQCN
18:40:13 <felixfontein> #agreed collections that want to get included in Ansible are free to use short names (like `command` or `facts`) for modules/actions
18:40:25 <felixfontein> cool :)
18:40:36 <andersson007_> so how about the inclusion?
18:40:42 <felixfontein> ok, more discussion on community.ciscosmb, or should we vote on whether to include it?
18:41:03 <felixfontein> cyberpear: it's a small network collection having basically two modules (command and facts), repo is https://github.com/ansible-collections/community.ciscosmb
18:41:25 <felixfontein> tadeboro and andersson007_ reviewed it and are happy (https://github.com/ansible-collections/ansible-inclusion/discussions/26)
18:41:32 <tadeboro> I am +1 on vote and +1 on inclusion
18:41:51 <felixfontein> VOTE: should we include community.ciscosmb in Ansible 5?
18:41:52 <felixfontein> #chair
18:41:52 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
18:41:56 <andersson007_> +1
18:41:57 <felixfontein> +1
18:41:57 <tadeboro> +1
18:42:14 <jillr> +1
18:42:42 <cybette> +1
18:42:52 <samccann> (not sure if you want nonSteering people but +1)
18:43:06 <gundalow> +1
18:43:09 <abadger1999> +1
18:43:16 * samccann considers calling it  the rabble-vote +1
18:43:20 <cyberpear> +1
18:44:04 <felixfontein> samccann: sure, everyone can vote!
18:44:19 <felixfontein> we just have to make sure we got enough steering committee votes for the vote to be valid in the end
18:44:31 <samccann> ok cool. didn't want to complicate your math any
18:45:00 <remindbot[m]> @cybette:ansible.im cyb-clock chimes every 15 minutes during the community meeting
18:45:07 <andersson007_> i think non steering committee votes should be encouraged
18:45:19 <felixfontein> definitely!
18:45:25 <felixfontein> #agreed community.ciscosmb will get included in Ansible 5
18:45:35 <felixfontein> cool! one collection less to look at ;0
18:45:36 <felixfontein> ;)
18:45:41 <jillr> woohoo!
18:45:45 <andersson007_> šŸŽ‰
18:45:45 <felixfontein> is there another one that's close to inclusion?
18:45:52 <felixfontein> (though probably for next week and not today)
18:46:05 <tadeboro> https://github.com/ansible-collections/ansible-inclusion/discussions/22
18:46:30 <andersson007_> i thought we included that one:)
18:46:37 <tadeboro> That one also has two +1 reviews.
18:46:40 <felixfontein> that one still needs a 2.0.0 release ;) but that will come soon
18:47:04 <felixfontein> I'm basically waiting for feedback from someone who's a bit short on time (since he became father recently)
18:47:39 <tadeboro> 2.0.0 is a nice to have as far as the inclusion goes. The version I reviewed was OK for inclusion.
18:47:51 <andersson007_> yeah
18:48:04 <tadeboro> But we can postpone the vote with no problem.
18:48:38 <felixfontein> do you want to vote on it today?
18:48:50 <andersson007_> i'd vote
18:48:57 <tadeboro> Me too.
18:49:03 <felixfontein> I'm more asking all the others, who probably haven't reviewed it yet ;)
18:49:15 * jillr looking but happy to vote in a couple minutes
18:49:25 <felixfontein> #topic Inclusion of community.dns in Ansible 5
18:49:31 <felixfontein> #info Discussion: https://github.com/ansible-collections/ansible-inclusion/discussions/22
18:49:42 <felixfontein> #info Repository: https://github.com/ansible-collections/community.dns/
18:50:08 <felixfontein> #info Documentation: https://ansible.fontein.de/collections/community/dns/
18:51:16 <felixfontein> this collection is a bit special since it includes a MPL 2.0 licensed data file
18:51:48 <felixfontein> (it fortunately does not invoke the ā€œIncompatible With Secondary Licensesā€ notice)
18:53:34 <jillr> lgtm
18:54:03 <Toshio[m]> +1 from me as well
18:54:19 <felixfontein> let's vote, before time runs out
18:54:19 <samccann> lgtm from the docs side
18:54:30 <felixfontein> VOTE: should we include community.dns in Ansible 5?
18:54:31 <andersson007_> <nod>:)
18:54:35 <felixfontein> #chair
18:54:35 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dericcrago dmsimard felixfontein gundalow jillr samccann tadeboro
18:54:35 <andersson007_> +1
18:54:37 <jillr> +1
18:54:39 <tadeboro> +1
18:54:39 <samccann> +1
18:54:51 <felixfontein> I abstain since I'm involved a lot in that collection
18:55:09 <andersson007_> :)
18:55:18 <cyberpear> +1
18:56:22 <Toshio[m]> +1
18:56:39 <felixfontein> I assume that Toshio[m] == abadger1999?
18:56:56 <andersson007_> :)
18:56:56 <Toshio[m]> Oops, sorry. yes.  I hve both matrix and irccloud open :-)
18:57:37 <felixfontein> :)
18:58:07 <felixfontein> hmm, we need one more steering committee vote I think
18:58:24 <felixfontein> (next to cidrblock[m]'s +0)
18:58:30 <felixfontein> (and my +0)
18:58:39 <jillr> maybe the folks we're missing can look over the next couple days and vote in the GH discussion?
18:58:55 <felixfontein> hum, or wait, does abstain mean +0?
18:59:00 <samccann> acozine is I think on vacation until  the end of next week
18:59:25 <andersson007_> would be great to see more votes from non steering committee who are present in the meeting.. in general
19:00:00 <andersson007_> maybe they just hesitate or something
19:00:12 <felixfontein> ok, let's do a quick open floor
19:00:14 <andersson007_> or don't know that they should
19:00:29 <abadger1999> felixfontein: I think they're equivalent, yeah.
19:00:40 <felixfontein> #info Vote for inclusion: 5 x +1, 2 x +0 (steering committe); 1 x +1 (non-steering committee)
19:00:49 <felixfontein> #topic Open floor
19:01:21 <felixfontein> ok, does anyone have something for the open floor?
19:01:23 <andersson007_> congratulations felixfontein and markuman and maybe someone else!
19:01:33 <andersson007_> on the inclusion
19:01:51 <andersson007_> and thanks for your hard work there
19:01:59 <felixfontein> thanks!
19:02:19 <andersson007_> nothing from me besides that:)
19:02:22 <felixfontein> (I guess I could have added an #agreed then...)
19:02:29 <felixfontein> (vote counting is hard :D )
19:02:46 <andersson007_> :)
19:04:21 <markuman> I've contributed just one single character of code. felixfontein did all the hard work!
19:04:44 <felixfontein> markuman: I did some copy'n'pasting from your code, though not much survived :)
19:05:00 <andersson007_> heh
19:05:15 <felixfontein> ok, if there's no topic for the open floor, let's close the meeting! (just 5 mins over time ;) )
19:05:18 <felixfontein> #endmeeting