18:01:08 <felixfontein> #startmeeting Ansible Community Meeting
18:01:08 <zodbot> Meeting started Wed Aug 25 18:01:08 2021 UTC.
18:01:08 <zodbot> This meeting is logged and archived in a public location.
18:01:08 <zodbot> The chair is felixfontein. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:08 <zodbot> The meeting name has been set to 'ansible_community_meeting'
18:01:08 <felixfontein> #topic Agenda https://github.com/ansible/community/issues/539
18:01:08 <felixfontein> abadger1999 acozine andersson007_ baptistemm bcoca briantist cyberpear cybette dericcrago dmsimard felixfontein geerlingguy gundalow gwmngilfen ikhan_ jillr jtanner lmodemal misc nitzmahone resmo samccann tadeboro cidrblock thaumos zbr: ping!
18:01:12 <felixfontein> #info Agenda: https://github.com/ansible/community/issues/539 / Topics: https://github.com/ansible-community/community-topics
18:01:13 <andersson007_> o/
18:01:15 <felixfontein> #topic Updates
18:01:17 <tadeboro> o/
18:01:18 <dmsimard> \o
18:01:19 <abadger1999> Bom día
18:01:19 <felixfontein> sorry, had to walk to a machine to see why it isn't on the network anymore...
18:01:28 <cyberpear> o/
18:01:29 <cybette> o/
18:01:36 <felixfontein> #chair andersson007_ tadeboro dmsimard abadger1999 cybette cyberpear jill
18:01:36 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dmsimard felixfontein jill tadeboro
18:01:41 * dericcrago waves
18:01:43 <resmo> o/
18:01:48 <felixfontein> #chair dericcrago resmo
18:01:48 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dericcrago dmsimard felixfontein jill resmo tadeboro
18:01:52 <samccann> \o
18:02:09 <felixfontein> #chair samccann
18:02:09 <zodbot> Current chairs: abadger1999 andersson007_ cyberpear cybette dericcrago dmsimard felixfontein jill resmo samccann tadeboro
18:02:19 <cidrblock[m]> hello all!
18:02:41 <felixfontein> #chair cidrblock[m]
18:02:41 <zodbot> Current chairs: abadger1999 andersson007_ cidrblock[m] cyberpear cybette dericcrago dmsimard felixfontein jill resmo samccann tadeboro
18:03:23 <felixfontein> we're still missing votes (since last week) by acozine zbr1 cidrblock[m] and thaumos on https://github.com/ansible-community/community-topics/issues/37
18:03:34 <acozine> o/
18:03:42 <felixfontein> #chair acozine
18:03:42 <zodbot> Current chairs: abadger1999 acozine andersson007_ cidrblock[m] cyberpear cybette dericcrago dmsimard felixfontein jill resmo samccann tadeboro
18:03:52 * acozine looks at issue 37
18:04:26 <samccann> I 'think' thaumos is out for another week and a half
18:04:44 <cybette> #info Registration for Ansible Contributor Summit 2021.09 https://ansiblecs202109.eventbrite.com/?aff=irc
18:05:03 <dmsimard> ^ reach out and invite your friends, it's free and it'll be fun
18:06:06 <felixfontein> hmm, do I have to register once per date?
18:06:10 <dmsimard> felixfontein: yes
18:06:18 <felixfontein> ok :)
18:06:31 <felixfontein> do we have more updates?
18:06:40 <dmsimard> the two days are tailored to different audiences so it may make sense for people to register for one or the other (or even both)
18:06:49 <acozine> felixfontein: I vote for B for the Ansible 5 schedule
18:07:05 <felixfontein> acozine: can you add it to the issue?
18:07:22 <acozine> done
18:07:24 <briantist> o/
18:07:28 <felixfontein> acozine: thanks!
18:07:30 <felixfontein> #chair briantist
18:07:31 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cyberpear cybette dericcrago dmsimard felixfontein jill resmo samccann tadeboro
18:07:53 <felixfontein> #topic Adding community-contributed examples to docs or a github repo
18:07:53 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/39
18:07:55 * gundalow waves
18:08:00 <felixfontein> samccann: acozine: ^ do you want to talk about this?
18:08:02 <felixfontein> #chair gundalow
18:08:02 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cyberpear cybette dericcrago dmsimard felixfontein gundalow jill resmo samccann tadeboro
18:08:25 <samccann> sure
18:08:36 <gundalow> felixfontein: fyi thaumos is on holiday
18:08:55 <samccann> so part of the Docs Survey we ran at the start of the year asked about more examples (more real world, more in general).
18:09:10 <samccann> There was a specific ask about templating so we thought that would be a good place to start
18:09:35 <samccann> So we would like community help in gathering and testing these examples.
18:09:43 <felixfontein> with templating, you mean writing jinja2 expressions?
18:09:48 <samccann> And will need to decide where to put them (in the docs, in a github repo)
18:10:03 <samccann> I think so yeah.. acozine do you agree it's jinja2 examples?
18:10:06 <acozine> yes, it would be a sort of "patternbook"
18:10:29 <acozine> I found one that was sent to the mailing list that I thought was excellent
18:11:03 <sivel> We have some docs with examples currently at https://docs.ansible.com/ansible-core/2.11/user_guide/complex_data_manipulation.html
18:11:08 <acozine> it included a `vars` section, so you could see the inputs, a short playbook, and a debug statement so you could see the output
18:11:27 <acozine> sivel: yes, that's a great start
18:11:42 <felixfontein> https://github.com/ansible-community/sphinx-ansible could be useful for this
18:11:58 <jill> we've got some recent PRs in aws that swap out c.g.json_query statements for jinja we could contribute
18:12:25 <acozine> jill: sounds awesome
18:13:00 <samccann> andersson007_ also had ideas about setting up a github repo with CI tests to validate the examples when a PR is created there.
18:13:09 <andersson007_> yep
18:13:19 <felixfontein> having some validation is definitely a very good idea!
18:13:36 <briantist> yeah that's a great idea
18:13:39 <felixfontein> from its description https://github.com/ansible-community/sphinx-ansible would help with that as well I think. did anyone try it?
18:13:42 <andersson007_> i.e. do not accept examples without testing them
18:13:50 <dmsimard> felixfontein: goneri is lurking here, we can ask him about it :)
18:13:52 <samccann> so we could put some of the existing stuff there (like what jillr has, acozine found, etc) and get CI set up like andersson007_ suggests
18:14:18 <samccann> and then we can get goneri's help in using that extension to get the examples into docs.ansible.com
18:14:21 <acozine> felixfontein: I haven't tried that, but it looks very useful
18:15:05 <acozine> are there any websites where you can plug in a jinja expression and some data and get out a result?
18:15:15 <sivel> https://ansible.sivel.net/test/
18:15:32 <acozine> seek and ye shall find!
18:15:45 <sivel> it uses ansible under the hood, so it's contextually aware of our use case
18:15:46 <dmsimard> I've found one or two other on google too, sivel needs to work on his SEO :p
18:16:02 <acozine> how much traffic is that site designed to bear sivel?
18:16:03 <cidrblock[m]> https://td4a.codethenetwork.com/
18:16:35 <sivel> acozine: *shrug* I have no idea. It's production deployed
18:16:44 <acozine> heh, fair enough
18:17:35 <felixfontein> sivel: it's probably ansible-core and not Ansible (community package), right?
18:17:58 <sivel> felixfontein: it's not using the community package, but does contain a large number of collections
18:19:07 <samccann> so would we still require integration tests/CI on the jinja2 examples repo (and just point people to these other testing options in the readme to validate a bit before they submit the PR)?
18:19:15 <felixfontein> sivel: though not really the latest versions it seems :)
18:19:45 <felixfontein> samccann: we definitely need that, since nobody wants to do that checking manually
18:20:04 <sivel> should be rebuilt nightly to update collections and ansible-core. Unless something is broken right now
18:20:08 <acozine> samccann: yeah, and those sites could also be listed as "when you've adapted an example here for your use case, you can test it with X"
18:20:45 <acozine> because jinja template examples will almost always require a little tweaking
18:21:01 <cybette> cyb-clock chimes: 20 MIN into the meeting, 14 min on adding community-contributed examples
18:21:21 <felixfontein> sivel: I just noticed I tried to use a lookup plugin as a filter, so my comment might be very inaccurate ;)
18:21:46 <felixfontein> acozine: I think these sites are best for that use-case :)
18:22:03 <felixfontein> especially sivel's, since that allows to use Ansible filters/lookups/...
18:22:26 <samccann> so perhaps the next steps are to talk more to andersson007_ on how to set up this example repo with CI testing, and get one or two examples in it from jillr and acozine?
18:22:46 <felixfontein> ah, and https://td4a.codethenetwork.com/ apparently belongs to cidrblock[m], so it might also use ansible under the hood :)
18:22:53 <acozine> sounds like next steps include: decide which repo to use for these examples, set up CI for new additions, try one or two to make sure the system works, then put out a call for contributions and update the core docs to point to the new content (assuming it gets hosted elsewhere)
18:23:22 <dmsimard> I kind of want to say that there is a universe of examples on galaxy, though of variable quality
18:23:23 <felixfontein> sounds reasonable to me
18:23:52 <dmsimard> like, I may have looked at stuff from geerlingguy on an occasion or another to find out how to do something properly :p
18:23:57 <andersson007_> acozine: sounds like a plan
18:24:09 <samccann> ok I'll add the above info to the issue. thanks everyone!
18:24:18 <felixfontein> maybe https://github.com/ansible-community/ansible-examples as a repo?
18:24:49 <dmsimard> there is already https://github.com/ansible/ansible-examples
18:24:49 <felixfontein> dmsimard: the problem is that there's also a lot of low-quality content, so either we point to very specific stuff, or we better don't point there, as newbies will most likely find someting that isn't good ;)
18:24:50 <cidrblock[m]> td4a doesn't directly use ansible for rendering, but can use ansible and other filter plugins, and an ansible inventory for data
18:25:39 <dmsimard> felixfontein: yeah, I don't know -- galaxy has the concept of ratings so perhaps we could leverage that to bubble up/highlight good examples
18:25:59 <dmsimard> not mutually exclusive with an approach that includes a dedicated repo with examples
18:26:08 <dmsimard> just saying there are a lot of written examples already :)
18:27:08 <acozine> yeah, there are some rich resources out there already, but clearly many of our users aren't finding them
18:27:53 <felixfontein> if you are looking for a solution to a specific templating problem, galaxy is not a good place to start searching since there's no good way of finding what you search for
18:28:19 <felixfontein> so having a website with examples will definitely help as well
18:28:25 <samccann> I'm wondering if we should modify the title of "Data Manipulation" - (the existing page of examples). To Jinja2 data manipulation?  something that let's readers know it exists?
18:28:32 <sivel> people submit examples of templating semi-regularly, and they are often pretty terrible
18:28:32 <tadeboro> Just pointing people to galaxy would be the same as telling people that most of the code is already available on stackoverflow. And we all know this can be a recipe for disaster  when it comes to inexperienced users.
18:28:51 <felixfontein> tadeboro++
18:29:19 <andersson007_> +1
18:29:20 <felixfontein> samccann: might be a good solution from SEO point of view
18:29:30 <felixfontein> ok, let's switch to another topic in a minute :)
18:29:46 <felixfontein> so if you have more to add, either be quick now, or add it to the issue!
18:29:59 <sivel> I'd say one of the biggest problems, is that users don't often understand that jinja2 is the thing that powers templating
18:30:07 <sivel> and almost never have read the jinja2 upstream docs
18:30:32 <felixfontein> #topic How to make meeting / discussion process more inclusive?
18:30:32 <felixfontein> #info Discussion: https://github.com/ansible-community/community-topics/issues/38
18:30:48 <sivel> now understand that the ansible version doesn't dictate jinja2 features
18:30:52 <sivel> nor*
18:31:31 <felixfontein> this is a topic which comes back regularly :)
18:31:48 <felixfontein> the current meeting times aren't very good for a large part of the population on this planet
18:32:16 <sivel> do like what core did? Alternating weeks with offset meeting times?
18:32:19 <felixfontein> (and no fixed time will ever be...)
18:32:52 <bcoca> why we alternate, to ensure all timezones can appear, even if not same time
18:32:56 <felixfontein> also we usually have way too much stuff to talk about, and we never get some things discussed because always more important newer stuff turns up
18:33:03 <tadeboro> sivel: I also saw the opposite thing: where Ansible uses wanted to use plain Jinja and did not realize that quite a few filters available in playbooks do not work with bare jinja.
18:33:04 <abadger1999> zbr, who finds the current meeting time hard, has spoken against alternating meeting times.
18:33:06 <andersson007_> sivel i suggested that in the issue, we discussed it a bit there
18:33:38 <bcoca> the other solution would be async discussion, using forum/mailing list instead of live chat
18:33:41 <felixfontein> we probably have to manage to have more async discussions
18:33:45 <bcoca> then 'all' timezones work
18:33:49 <felixfontein> exactly
18:33:56 <abadger1999> Additionally to TZ, some people would rather meeting times occur during working hours and others prefer that they occur outside of working hours.
18:34:09 <felixfontein> though I think there were also voices who didn't like that :)
18:34:15 <acozine> heh
18:34:22 <bcoca> it never rains to please everyone
18:34:35 <felixfontein> bcoca: rain is great while I'm indoors :D
18:34:41 <gundalow> I think we need to make it easier & promote async discussion
18:34:54 <abadger1999> Although okay with the idea, the problem I see is that chat is the best medium for discussion.
18:34:57 <bcoca> felixfontein: the tomato farmer wants more rain, the potatoe one less
18:34:57 <acozine> I confess, I have grown dependent on the chat meetings, because I know if I missed something (like the vote on the new dates), I will get a reminder at the next weekly meeting
18:35:26 <acozine> and I can imagine how frustrating it must be to want to participate, but have that meeting be in the middle of the night
18:35:30 <acozine> or right at breakfast time
18:35:31 <acozine> or something
18:35:38 <andersson007_> felixfontein: bcoca but both want it outside:)
18:35:49 <andersson007_> or don't
18:35:52 <gwmngilfen-work> I also struggle with this timeslot. I think live discussion is useful, but async for decision-making, possibly with a final-comment-period would work.
18:36:05 <sivel> From at least my perspective, I'm much less likely to participate in async mediums. It's much more difficult to actually have a discussion. Plus I can set aside a time period for a meeting
18:36:07 <bcoca> andersson007_: not the person who has to mop up the mud dragged inside
18:36:23 <andersson007_> :)
18:36:42 <abadger1999> gwmngilfen-work: <nod>  Discussions, good summaries of discussion minutes, voting async all help.
18:36:51 <samccann> so keep live discussions (esp as there are meeting minutes/logs for those who want to know what was discussed) but votes happen asych in the issue(s)
18:37:08 <felixfontein> we could use a pseudo-random 24 week schedule to have a discussion at different hours every week (until it repeats), and try to do more stuff async - then everyone who can/wants can come to the discussions, and everyone else can continue discussing async
18:37:09 <acozine> could we drop topic reminders into the chat once a day, or something like that, to remind folks who can't make the meetings that they should look at specific issues this week?
18:37:17 <gwmngilfen-work> Many communities use some kind of RFC process for this reason, although setting it up and making it work is hard
18:37:23 <tadeboro> I alreasy commented about this, but just stating my oppinion here once more: I think async would be great, but we need to set some rules about response times because right now, hardly anyone is commenting since we are all waiting for themeeting.
18:37:47 <gwmngilfen-work> @acozine that could help. There are reminder bots we could use
18:38:04 <gundalow> acozine: topic reminders are a good idea. Esp if we (say) do them every 4 hours (or other smallish interval)
18:38:11 <felixfontein> gwmngilfen-work: and then you come back from vacation to find out that the bot wrote you 2341 messages ;)
18:38:22 <acozine> heh
18:38:23 <gwmngilfen-work> Hehe
18:38:42 <felixfontein> but for the remainder of the year, that would be great
18:38:53 <jill> felixfontein: they can get filed with my 17k github notices from the same time period  :)
18:39:27 <abadger1999> I think the heart of the matter is: "Person A has opinions on Foo.  Person B has opinions on Foo.  But Person A and Person B don't have overlapping times for meetings.  How do we make it so that both Person A and Persson B feel like they have been heard, understood, and their opinions have been taken into account in the final proposal?"
18:39:28 <andersson007_> anyway the process should be as simple as possible
18:39:29 <felixfontein> 17k...'s a lot
18:39:36 <gundalow> sooooooooooooo
18:39:38 <gundalow> I love you all
18:39:45 <gundalow> Though you aren't the people that have the problem
18:39:46 <dmsimard> gundalow: <3
18:39:51 <gundalow> It's everybody that isn't here
18:40:08 <felixfontein> indeed
18:40:24 <jill> most of the communities I've been in that did decent-ish async were very mailing-list-centric, I feel like Ansible is not a community that likes to do work on MLs so I'm not sure what other ideas to try that haven't been noted yet
18:40:28 <acozine> abadger1999: well put
18:40:29 <felixfontein> maybe we should make a survey
18:40:37 <gwmngilfen-work> We already raise topics on Github, perhaps we need to start by expanding that workflow? And see if it does/nt fit
18:40:47 <cybette> cyb-clock chimes: 40 MIN into the meeting, 10 min on making meeting/discussion process more inclusive
18:41:04 <tadeboro> We do have a problem because, in a way, we are making decisions without being fully informed.
18:41:19 <gwmngilfen-work> Anyway, to the point, I now go back to putting kids to bed :)
18:41:28 <felixfontein> the problem with a survey though is that I'm not sure how to reach everyone who's interested
18:41:36 <acozine> perhaps a meeting summary sent to the mailing lists before and/or after each meeting?
18:42:11 <acozine> a sort of preview-then-review, with links to "if you missed the meeting you can add your opinions in `this issue`"?
18:42:51 <felixfontein> in the last weeks, the meeting summary was mostly like this - we hardly finished discussing a topic, so there was always the possibility to write something in the issues
18:43:11 <felixfontein> the problem with sending something before the meeting is that someone needs to prepare it in advance :)
18:43:18 <acozine> yeah, we rarely get through something in a single meeting
18:43:25 <andersson007_> felixfontein: true:)
18:43:25 <acozine> true
18:43:39 <felixfontein> I often only have time ~30 mins before the meeting, which is ok for collecting a list of topics, but not really for sending it out in time
18:43:46 <samccann> it's also possible more urgent topics pop up and get discussed instead so the 'before' meeting summary may not be valid
18:44:20 <felixfontein> we should try to avoid 'urgent' such topics, and most of the time they aren't *that* urgent
18:44:29 <acozine> perhaps someone on gundalow's team could do the preview/review emails?
18:44:29 <andersson007_> +1
18:44:30 <gundalow> I think there are a few themes here, thanks for all the suggestions.
18:44:30 <gundalow> 1. Reminders of the topics
18:44:31 <gundalow> 2. Defining mix/max timeframes for topics
18:44:31 <gundalow> 3. publicising topics (I'll hold my hand up and say we haven't been good at putting `community-topics` in The Bullhorn, for example
18:44:31 <gundalow> 4. We may need to get better at refining/defining the community-topics so there is enough context.
18:44:31 <gundalow> 5. Maybe agenda needs to get "locked in" a few days before, to allow publication
18:45:06 <gundalow> 6. Speak to all the people we'd love to see here, though can't make it, and see what *they* would like
18:45:45 <acozine> nice summary
18:46:23 <felixfontein> I guess we need some secretary role, at least one person per meeting has to do some work 1-2 days in advance and compile a list of topics and send it around
18:46:25 <gundalow> acozine: well, I cheated a bit, as we were talking about similar things 5 hours ago
18:46:56 <bcoca> ^ same convo had in core ... but also our load of topics went down a lot after collections
18:47:20 <gundalow> bcoca: So we move everything back, ala ansible-modules-extra -> ansible/anisble. Problem solved \o/
18:47:22 <abadger1999> Things like 6 feel like the role is more like executive assistant, than just secretary ;-)
18:47:43 <andersson007_> should it be an issue in community-topics for agenda? Everyone who subscribed to the repo will get notifications.
18:47:45 <jill> or a community manager  ;)
18:47:51 <abadger1999> jill: <nod> :-)
18:47:53 <gundalow> jill: fully you say that
18:47:54 <felixfontein> lol
18:47:59 <gundalow> oh, where is your `r`, that's confused me
18:48:00 <bcoca> gundalow: damn .. i walked rightintothatone
18:48:11 <gundalow> bcoca: shouldhaveseenitcoming
18:48:17 <gwmngilfen-work> I can have a look around at other communities and see what inspiration we could take
18:48:24 <gundalow> gwmngilfen-work: that would be great, thank you
18:48:29 <felixfontein> +1
18:48:29 <jill> oh woah, I didn't notice (I've had mega problems with getting ghosted and re-nicking on libera)
18:48:46 <felixfontein> heh, I noticed that already a couple of weeks ago :)
18:48:57 <gundalow> Also, unless someone from the Community wants to take this, I'll ask someone in my team to
18:49:00 <felixfontein> (but never mentioned it...)
18:49:08 <felixfontein> I thought it was intentional
18:49:23 <gundalow> jillr: woot
18:49:30 <tadeboro> What 'r'? I only know ji<Tab> ;)
18:49:36 <jillr> hehe
18:49:37 <acozine> heh
18:49:45 <bcoca> you should also look at making 'scopes', for example we have ansible/proposals for major design issues , which requires long discussion and enables easy async
18:49:50 <felixfontein> gundalow: it's probably easiest if someone from the team does it. or rotate it between multiple persons
18:49:52 <abadger1999> If we're willing to have someone do that full time, it could work (and be awesome).  It's a tough job, though, and when done right, probably slows decision making down quite a bit.
18:49:56 <bcoca> we keep irc meetings for short issues or final decisions
18:50:12 <gundalow> #action gwmngilfen-work to look at inspiration for other communities wrt better discussion
18:50:19 <acozine> abadger1999: better some slow decisions that stick than quick ones we revisit again and again and again
18:50:29 <abadger1999> You basically need someone who an get inside of multiple other people's thought processes and then represent all of those points of view to the people who are present at the meeting
18:50:31 <gundalow> acozine: well put
18:50:49 <gundalow> I think we can start small. Any improvement is an improvement
18:51:04 <felixfontein> definitely
18:51:15 <andersson007_> bcoca: we keep irc meetings for short issues or final decisions - sounds sensible
18:52:09 <bcoca> in core meetings we also limited the time and pushed longer discussions to other channels and/or proposals
18:52:10 <abadger1999> (The slowness comes because the person can never be fully in someone else's head and so when a new aspect is brought up in the meeting, you'll have to wait for the next meeting to know for sure if that is acceptable/can be made more acceptable/etc to the missing people)
18:52:39 <andersson007_> we can make many meetings inefficient discussing "heavy" topics
18:52:45 <andersson007_> on the spot
18:52:52 <felixfontein> (like this one :) )
18:52:56 <andersson007_> yeah:)
18:53:02 <bcoca> the other part is 'heavy topics' should involve everyone in meeting having had time to read/think through
18:53:05 <abadger1999> andersson007_: Sort of a -1; Big issues probably need the most engagement from the people who are opinionated about it.
18:53:13 <jtanner> not all conversations need to be "efficient". this is an oss community, not a business
18:53:19 <abadger1999> Something like one-off meetings might be a way to skirt that, though.
18:53:29 * gundalow waves to jtanner
18:53:37 <gundalow> So, what do people think the next steps are?
18:53:41 <acozine> #chair jtanner
18:53:41 <zodbot> Current chairs: abadger1999 acozine andersson007_ briantist cidrblock[m] cyberpear cybette dericcrago dmsimard felixfontein gundalow jill jtanner resmo samccann tadeboro
18:53:43 <bcoca> jtanner: but also does not mean they should all be rabbit hole expeditions
18:53:50 <felixfontein> jtanner: that's 100% correct, but it still feels a bit inefficient... even though this is really important to discuss
18:54:15 <abadger1999> Can we get A, B, and C who have opinions into a meeting together with Mediator/Secretary Z.  Issue is discussed in real time.  Secretary Z summarizes the points for the wider audience.
18:54:37 <andersson007_> jtanner: abadger1999 i'm trying to say that async discussions before real-time discussions would be nice to have
18:55:22 <andersson007_> people would be more prepared thinking of heavy issues a bit in advance
18:55:28 <samccann> another benefit of async is it gives people time to think/absorb before responding.
18:55:34 <gundalow> yup
18:55:35 <jtanner> the choice (whether intentional or not) to have realtime irc discussions about topics was made with the tradeoff of always inconveniencing someone along the way. it's unavoidable ... mailing lists would be better, but you still end up excluding people who do not speak/type english.
18:56:01 <cybette> cyb-clock chimes: 55 min into the meeting!
18:56:02 <jtanner> this is one of the reasons proposals were put out a long time ago
18:56:06 <abadger1999> andersson007_: possibly, yeah.  (Althouh, I could see the opposite order working well as well.)
18:56:14 <gundalow> This is what I'd like to achieve with Contributor Summit. Give people more information in advance so they can think/absorb in advance. Otherwise no one has anything to contribute
18:56:32 <abadger1999> I think in either case, the important bit is that someone has to be able to accurately represent the viewpoints of the people who are not there.
18:56:32 <felixfontein> ok, I think we have to wrap up for today
18:56:44 <felixfontein> (so we can have at least a tiny open floor)
18:57:05 <felixfontein> #topic Open Floor
18:57:07 <gundalow> My ask, is for people to look at other communities they are involved in to see how they operate
18:57:07 <jtanner> summit(s) are even worse with time constraints and limited podium time
18:57:48 <jtanner> lkml (regardless of controversy) is probably the best you'll find
18:58:22 <acozine> lkml linux kernel ? ?
18:58:27 <bcoca> the mailing list
18:58:31 <acozine> ah, thanks
18:58:33 <bcoca> 'async' form
18:59:12 <felixfontein> looks like nobody wants to stop this topic :)
18:59:15 <lilatomic> I think this idea is like referring things to a committee (in Robert's Rules). Everyone who has things to say can join that committee. The committee has the mandate to gather people's input on the subject, prepare a summary, and present that to the main group.
18:59:30 <dmsimard> for open floor, I've talked about it before but I've finally properly set it up: https://rss.community.eng.ansible.com/ -- it's a aggregation of rss feeds (not yet exhaustive: https://github.com/ansible-community/rss-feed-aggregator/blob/fe00ab39f4b3d0571c15c724ecb2751c9f8286bd/roles/feed-aggregator/defaults/main.yaml#L26-L134) so people can
18:59:30 <dmsimard> quickly browse through recent releases
18:59:45 <bcoca> felixfontein: since 50k years of history still has not come up with a good way for humans to meet and decide, i dont expect us to do so in 10m
18:59:46 <andersson007_> felixfontein: this is definitely a good example of "heavy" one:)
18:59:57 <felixfontein> bcoca: definitely :)
19:00:15 <cybette> thanks dmsimard !
19:00:47 <andersson007_> the fastest open floor:)
19:00:55 <felixfontein> dmsimard: is there a combined .rss link?
19:01:29 <dmsimard> felixfontein: not that I know about but I can check
19:02:02 <cidrblock[m]> good 2 see you all, tty
19:02:08 <felixfontein> #endmeeting