16:02:04 <chouseknecht> #startmeeting ansible-container
16:02:04 <zodbot> Meeting started Mon Oct 16 16:02:04 2017 UTC.  The chair is chouseknecht. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:04 <zodbot> The meeting name has been set to 'ansible-container'
16:02:41 <j00bar> And _that's_ the story of how I ended up with a dozen 30-gallon drums of low-fat mayonnaise.
16:02:53 <j00bar> Okay, about time to start this meeting. Good thing the minutes just started now.
16:03:06 <j00bar> Luckily it didn't record any of the story.
16:03:08 <chouseknecht> Here's last week's minutes: https://github.com/ansible/community/wiki/Container-Minutes-09-Oct-2017
16:03:10 <j00bar> XD
16:03:14 <j00bar> Sorry. I'll be serious.
16:03:54 <chouseknecht> open floor
16:05:21 <j00bar> I owe y'all a couple of things, but the first half of my week is going to be icky.
16:05:41 <j00bar> I'm starting my new role as developer advocate today. And I've got to be in Raleigh tomorrow all day for a meeting.
16:05:53 <j00bar> So likely not until Wednesday before I can deliver on deliverables.
16:06:48 <j00bar> Looked like there was some cool movement on the ansible-kubernetes-modules repo.
16:07:10 <fabianvf> yeah, the modules are coming along nicely
16:07:41 <fabianvf> might be talking with more openshift guys later this week about reusing them in other pieces of openshift infrastructure
16:07:54 <j00bar> Cool - and getting some hands, I hope.
16:08:04 <fabianvf> crossing my fingers
16:08:06 <j00bar> CRI-O v1.0 is out.
16:08:13 <j00bar> We should consider an engine for it.
16:08:58 <j00bar> #idea Make an engine for CRI-O
16:09:20 <j00bar> (Is that how you boss around the bot?)
16:10:32 <chouseknecht> i think there is an #action
16:10:47 <chouseknecht> #action j00bar to make a cri-o engine
16:10:53 <j00bar> Make it so!
16:10:53 <chouseknecht> hmm...
16:11:01 <j00bar> zodbot: you still with us there, buddy?
16:11:54 <chouseknecht> #topic ansible-container
16:12:09 <chouseknecht> #topic j00bar's farewell tour
16:12:16 <chouseknecht> well that works
16:12:40 <j00bar> lawlz.
16:13:01 <j00bar> #action Give zodbot 30% more zod.
16:13:24 <j00bar> Possibly zodbot just doesn't give any confirmation?
16:13:53 <j00bar> Anyway. Moving on.
16:14:00 <j00bar> ttomacek is at dockercon, yeah?
16:15:06 <chouseknecht> maybe
16:15:21 <chouseknecht> dunno about ttomecek and dockercons
16:15:31 <j00bar> That's cool. It's theorized that they're going to announce k8s support.
16:15:39 <chouseknecht> whoa
16:15:58 <j00bar> Swarm is losing big-time. And they can't possibly compete with Google/RH/CF
16:16:18 <j00bar> But we're meeting this week to talk Buildah engine, yeah?
16:17:19 <chouseknecht> Wed at 12:00
16:17:40 <chouseknecht> There is a "Ask an Expert Containers" on Thur
16:17:57 <chouseknecht> at 2:00
16:18:08 <chouseknecht> what do we have to talk about?
16:18:24 <chouseknecht> gregdek
16:18:34 <j00bar> A walk through of the hello-world would be best?
16:18:40 <gregdek> Yeah, probably.
16:18:47 <j00bar> We can talk about the modules available....
16:18:47 <gregdek> That seems reasonable to me.
16:19:04 <chouseknecht> a walk through of hello-world sounds good
16:19:08 <j00bar> And some light sprinkling of some devops on that shit.
16:19:16 <chouseknecht> who's driving?
16:19:21 <j00bar> It's like the MSG of IT.
16:19:30 <j00bar> Sprinkle some on for better results.
16:19:34 <gregdek> How about a very brief overview of Ansible modules, a walkthru of A-C hello world, and DevOps Accent!
16:20:30 <j00bar> I can do the walkthrough. House, you wanna do the modules; gregdek, you wanna do the devops pontificating?
16:20:47 <chouseknecht> sure
16:21:28 <gregdek> No, I'll pass on the devops pontificating.
16:21:50 <j00bar> House?
16:22:11 <chouseknecht> i'm not good at pontificating
16:22:29 <chouseknecht> i can give a little dog and pony on the modules
16:24:13 <chouseknecht> #topic Ansible Container roadmap
16:24:34 <j00bar> Okey doke. Roadmap.
16:24:36 <chouseknecht> funzo was asking last week for a status update.
16:25:09 <chouseknecht> apparently the project is on an upstream management status report somewhere
16:25:20 <j00bar> Fun.
16:25:30 <j00bar> Wednesday afternoon I'll knock out your virtualenv work, House.
16:25:51 <funzo> heh, it has been since I joined ansible in Feb
16:26:05 <j00bar> And then Thursday afternoon I should be able to do some work on the idempotent builds.
16:26:17 <j00bar> My tests are throwing an error I'm still working on grokking.
16:26:28 <j00bar> But I can push the code to a branch for earlier inspection as a WIP.
16:26:45 <chouseknecht> so we're still working on 0.9.3, yes?
16:28:48 <j00bar> Yes.
16:29:59 <j00bar> Or I am, anyway. 🙄
16:30:33 <chouseknecht> do we have a release date in mind for 0.9.3, because later this week or maybe next week, funzo will be asking me.
16:31:55 <j00bar> I think it's featureset driven, not time driven.
16:32:05 <j00bar> I think EOM is reasonable.
16:32:09 <j00bar> I know I've said that before too.
16:32:44 <funzo> just want to make sure i'm communicating consistently with what the plan is, not trying to TPS report anyone
16:33:17 <j00bar> I hear ya. Expectation setting is important.
16:34:07 <j00bar> Algo mas?
16:35:41 <chouseknecht> nada de mi
16:36:16 <j00bar> Cool.
16:36:18 <j00bar> Move to adjourn?
16:36:31 <chouseknecht> sounds good
16:36:41 <chouseknecht> meeting adjourned
16:36:47 <chouseknecht> #endmeeting