15:31:28 <acozine> #startmeeting Ansible DaWGs
15:31:28 <zodbot> Meeting started Tue Feb 26 15:31:28 2019 UTC.
15:31:28 <zodbot> This meeting is logged and archived in a public location.
15:31:28 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:31:28 <zodbot> The meeting name has been set to 'ansible_dawgs'
15:31:38 <acozine> who's around?
15:31:53 <samccann> o/
15:32:03 <acozine> #chair bcoca sivel samccann
15:32:03 <zodbot> Current chairs: acozine bcoca samccann sivel
15:32:54 * gundalow waves
15:33:05 <acozine> we don't have anything pre-set on the agenda, but there are a couple of topics we could discuss, and we have some PRs we might be able to merge today
15:33:09 <acozine> #chair gundalow
15:33:09 <zodbot> Current chairs: acozine bcoca gundalow samccann sivel
15:33:49 <acozine> felixfontein: Xaroth: dag: orthanc: Pilou: shaps: you folks around and up for chatting about docs?
15:34:37 <acozine> first PR I think we could cheer across the finish line today is https://github.com/ansible/ansible/pull/47895
15:35:21 <acozine> bcoca: I think the examples addressed your comment about single lookups vs. multiple lookups - do you agree?
15:36:27 <acozine> feedback welcome on the loop PR ^^^ from everyone/anyone
15:37:04 <felixfontein> acozine: sorry, not really :(
15:37:06 * alongchamps waves
15:37:09 <felixfontein> (being around)
15:37:20 <acozine> felixfontein: no problem, I won't make you a chair then
15:37:27 * gundalow reads the PR
15:37:27 <acozine> alongchamps: hi! glad to see you here
15:37:31 <acozine> #chair alongchamps
15:37:31 <zodbot> Current chairs: acozine alongchamps bcoca gundalow samccann sivel
15:37:34 <samccann> are we waiting on specific feedback/approval, or can we merge if there's no disagreement here?
15:37:35 <alongchamps> hi acozine!
15:38:11 <bcoca> lgtm
15:38:18 <acozine> samccann: if there's general consensus that the PR addresses bcoca's comments, I'm +1 to merging
15:38:20 <acozine> but I'm biased
15:38:29 <acozine> bcoca: excellent, thanks
15:38:37 <acozine> samccann: will you do the honors?
15:38:52 <gundalow> +1 to merging, it's a big improvement over what we have
15:38:59 <samccann> sure!
15:40:22 <samccann> merged
15:40:37 <gundalow> woot
15:40:46 <acozine> hooray! thanks
15:40:51 <acozine> next in the queue is https://github.com/ansible/ansible/pull/33740 - this one includes code as well as docs, has been tested, has been rebased quite a few times
15:41:22 <acozine> the other half of this name change was merged a while back
15:41:30 <acozine> (changing the module name)
15:42:08 <acozine> that was merged in https://github.com/ansible/ansible/pull/33071
15:42:57 <acozine> definitely feels like both changes (module and plugin) should go into the same release
15:44:03 <acozine> any thoughts?
15:44:32 <gundalow> I think it's OK to merge
15:45:26 <samccann> +1
15:45:38 <acozine> okay, I'm going to merge it and ping mhalano again to confirm his use case has been addressed
15:46:05 <acozine> (mhalano is the person who opened a related issue, #42437
15:46:43 <acozine> done
15:46:57 <acozine> #topic main table of contents
15:47:35 <acozine> looking at https://docs.ansible.com/ansible/devel/index.html
15:47:49 <acozine> the Scenario Guides section is getting quite long
15:48:12 <acozine> and the VMWare guide should really be part of Scenario Guides rather than its own top-level section
15:48:13 <gundalow> acozine: set so just the headings
15:48:43 <gundalow> ?
15:49:05 <acozine> yeah, I've been thinking about making an index page for that section so it would function more like https://docs.ansible.com/ansible/devel/porting_guides/porting_guides.html
15:49:23 <acozine> does anyone here maintain a Scenario Guide?
15:49:51 <acozine> or have ideas about the left TOC?
15:50:08 <acozine> or other things about the navigation that could be fixed?
15:50:10 <gundalow> I think just heading 1, no sub headings so it would look like
15:50:11 <gundalow> Scenario Guides
15:50:11 <gundalow> * Cisco ACI
15:50:11 <gundalow> * Alibaba Cloud Compute Services Guide
15:50:11 <gundalow> * Amazon Web Services Guide
15:50:38 <acozine> yeah, that's better than a deeper TOC
15:50:41 <alongchamps> correct me if I"m wrong but the scenario guides seem to be product specific interoperations from ansible to $product
15:50:51 <acozine> alongchamps: yes, that's correct
15:50:55 <samccann> So if we make it like the porting guides, then all those headings don't show up unless you click 'scenario guides' right?
15:50:58 <alongchamps> if so, then I'm not sure the VMware one needs to be separated like it is
15:51:03 <acozine> and they are community maintained
15:51:21 <acozine> alongchamps: agreed, that was a mistake we made along the way
15:51:45 <samccann> I wonder if 'scenario guides' is the correct title then.  I dunno if I would think to click scenario guide to see the info about cisco vs vmware vs... etc
15:52:18 <acozine> interesting - what other titles could we consider?
15:52:18 <samccann> (though I do agree we should hide them all under 'something' guides to simplify the main navigation)
15:52:21 <gundalow> `Ansible for VMWare` - should be `VMware` (lower case `w`)
15:52:38 <acozine> I believe I've checked that and the cap-W is correct
15:52:43 <alongchamps> +1 for lowercase w, they get particular about it
15:52:46 <samccann> I'd almost hink platform guides but is that correct?
15:53:01 <samccann> like alongchamps said - they are product-specific 'information'
15:53:02 <alongchamps> platform guides seems right to me
15:53:07 * gundalow is testing with `:maxdepth: 1`
15:53:08 <acozine> samccann: we need something catch-all, since ACI, for example, isn't a platform
15:53:29 <acozine> it's quite a heterogenous collection of things
15:53:31 <gundalow> "Integration Guides"
15:53:39 <acozine> gundalow: ooh, I like that
15:53:52 <alongchamps> +1
15:53:53 <acozine> integrating Ansible with a variety of platforms, products, and technologies
15:53:54 <samccann> yeah that's something I would click if I was looking for cisco or vmware etc
15:54:00 <alongchamps> same here
15:54:02 <samccann> catchy! :-)
15:54:09 <alongchamps> sounds like we all like that name
15:54:26 <gundalow> Not sure if I'd bother changing the directory name
15:54:31 <acozine> #action rename Scenario Guides section to Integration Guides
15:54:43 <gundalow> #action VMware (lower case w)
15:54:52 <acozine> gundalow: yeah, if we change the filetree we need a symlink
15:55:18 <acozine> #action move VMware guide into Integration Guides area, with symlink from original location
15:55:42 <gundalow> Just built `:maxdepth: 1` looks good
15:55:50 <acozine> excellent, thanks
15:55:56 <gundalow> (devel is currently `2`)
15:56:10 <samccann> gundalow can you turn that into an action here so we don't forget (we as in me... cuz I'd forget how you did that)
15:56:12 <acozine> you mean, the dev_guide?
15:56:19 <acozine> gundalow ^^^
15:56:34 <acozine> or you mean the main TOC for Scenario Guides?
15:57:35 <gundalow> #action set to use `:maxdepth: 1` under integration guides https://github.com/ansible/ansible/blame/devel/docs/docsite/rst/index.rst#L50
15:57:47 <acozine> thanks gundalow
15:58:33 <gundalow> #action `Getting Started with Kubernetes and OpenShift` -> `Kubernetes and OpenShift` (or similar)
15:58:42 <acozine> should we try to alphabetize the section? that gets tricky, because the titles are all over the map - if all of them started with
15:59:10 <gundalow> should `Using Scaleway with Ansible` -> `Scaleway`?
15:59:20 <acozine> gundalow: if we're doing that, we should change them all,  I think
15:59:22 <gundalow> Not sure if `with Ansible` is useful
15:59:24 <gundalow> yup
15:59:25 <alongchamps> should we take out extra words like 'using'
15:59:31 <samccann> agreed
15:59:35 <alongchamps> because when I'm looking for Cisco, for example, I'm going to 'C'
15:59:45 <samccann> this one seems odd - https://docs.ansible.com/ansible/devel/scenario_guides/guide_rolling_upgrade.html
15:59:48 <alongchamps> the header in the nav can show that they are integration docs
15:59:52 <samccann> does it belong there at all?
16:00:12 <acozine> samccann: I think in the past we just put anything we couldn't place elsewhere into this section
16:00:29 <acozine> but that particular content might go better in the User Guide
16:00:30 <gundalow> `Continuous Delivery and Rolling Upgrades` is a scenario guide, but not an integration topic
16:00:52 <gundalow> yup, maybe better in Use Guide?
16:01:53 <acozine> #action move Continuous Delivery and Rolling Upgrades to User Guide, with symlink from original location
16:02:11 <acozine> heh, did I jump the gun there?
16:02:36 <samccann> it makes sense to move it for sure
16:02:37 * acozine sometimes leaps over discussion to decision a little to quickly
16:03:16 <acozine> cool
16:03:21 <gundalow> #action remember server side redirects will need updating
16:03:23 <samccann> +1 for putting it under user guide
16:03:27 <gundalow> +!
16:03:29 <gundalow> +1
16:03:31 <acozine> heh
16:03:51 <acozine> alongchamps: opinion on the CD/Upgrades content?
16:04:00 <acozine> (location thereof)
16:05:13 <alongchamps> I agree that it's a scenario guide
16:06:06 <acozine> and not an integration guide, so you're in favor of moving it when we change the section name?
16:06:40 <alongchamps> +1
16:06:45 <acozine> awesome
16:07:37 <gundalow> This will be a nice usability improvement
16:07:39 <gundalow> What's next?
16:07:40 <acozine> thanks everybody for brainstorming on updating that section, that's real progress
16:07:56 <acozine> those were the two things I had most on my brain this week
16:08:36 * gundalow has one
16:08:50 <gundalow> https://github.com/ansible/ansible/pull/52986
16:08:53 <acozine> gundalow: the floor is yours, set the topic at will
16:09:06 <gundalow> #topic Docs for Testing (Sanity)
16:09:08 <gundalow> #info https://github.com/ansible/ansible/pull/52986/files
16:09:42 <gundalow> Currently we have https://docs.ansible.com/ansible/devel/dev_guide/testing_sanity.html
16:09:42 <gundalow> which doesn't link to https://docs.ansible.com/ansible/devel/dev_guide/testing/sanity/
16:10:14 <acozine> oh, interesting
16:10:40 <acozine> how and to what page does `docs/bin/testing_formatter.sh` get published?
16:10:55 <acozine> this is a part of the docsite I find a bit opaque still
16:12:05 <acozine> +1 for the approach,
16:12:39 <gundalow> acozine: yup
16:12:44 <gundalow> called by `Makefile`
16:13:22 <gundalow> need Matt Clay to review, I don't *think* we need the other info I've deleted, though want him to confirm
16:13:41 <gundalow> I built it locally, template is updated
16:14:34 <acozine> I'm having trouble envisioning the diff between what we have now and what this PR would give us
16:15:11 <acozine> this PR will change https://docs.ansible.com/ansible/devel/dev_guide/testing_sanity.html#testing-sanity
16:15:23 <samccann> acozine - view the file then compare w what we have at https://docs.ansible.com/ansible/latest/dev_guide/testing_sanity.html#testing-sanity
16:15:57 <samccann> I think if Matt agrees that we don't need that other info (smell test, list of build-in tests) then it LGTM
16:16:56 <acozine> where will this toctree end up? https://github.com/ansible/ansible/pull/52986/files#diff-9ec28c0d5971a715f0488765ee16d265R16
16:18:27 <acozine> does that content replace an existing page? will it be appended to `dev_guide/testing_sanity.html`?
16:19:08 <acozine> I'm asking mostly for my own education, not as an objection/review of the PR
16:19:40 <gundalow> acozine: https://github.com/ansible/ansible/blob/c6fd34f264b0f45673a14ef3db004cf678f4b265/docs/docsite/rst/dev_guide/testing_sanity.rst
16:20:28 <gundalow> 2) top of https://docs.ansible.com/ansible/devel/dev_guide/testing/sanity/ will have a link back to ^
16:21:23 <acozine> ahhh, so that toctree is the content on https://docs.ansible.com/ansible/devel/dev_guide/testing/sanity/
16:21:28 <acozine> (or will be)
16:21:36 <acozine> thanks gundalow
16:22:53 <gundalow> acozine: I don't think the toctree would change
16:22:59 <gundalow> as I'm just adding a link
16:23:03 <gundalow> not creating new pages
16:23:07 <gundalow> though I maybe missing something
16:23:35 <acozine> yeah, you're not changing that part, except by adding an anchor
16:23:56 <acozine> I just couldn't figure out where that content was going - i knew I
16:24:12 <acozine> knew I'd seen it, but just couldn't envision the final page
16:24:23 <acozine> +1 to the PR
16:24:40 <gundalow> Thanks
16:24:42 <acozine> I don't think we should privilege certain sanity tests over others the way the existing page does
16:24:49 <acozine> so this is a good improvement
16:25:34 <acozine> I'll add a review to the PR itself
16:25:48 <acozine> I have one last thing in the last five minutes of this meeting
16:26:55 <acozine> #topic preparing for next week
16:27:58 <acozine> could folks test, fiddle with, and otherwise swarm around https://github.com/ansible/ansible/pull/49289 - it would be great to get that fully tested and ready to merge at next week's DaWG meeting
16:28:38 <acozine> I'll add it as an agenda item, and try to post periodic reminders to the channel
16:29:39 <acozine> as a reminder, the problem this PR addresses is that we have two Sphinx themes and are only using one
16:29:56 <acozine> the goal is to fix that, and to make sure that any formatting changes we want to keep are represented in the theme we keep
16:30:01 <samccann> would be great to nix that one
16:30:25 <samccann> gundalow was going to do some testing as well I think
16:30:32 <gundalow> oh, yes, thanks for the reminder
16:30:54 <acozine> yep - it's a real problem and good work by Xaroth and if the community can focus on that this week I think we can merge it next Tuesday
16:31:14 <acozine> and that's it for the DaWGs this week
16:31:30 <acozine> thanks everybody!
16:31:33 <gundalow> Thanks!
16:31:46 <alongchamps> thanks!
16:32:04 <acozine> #endmeeting