15:02:00 <acozine> #startmeeting Documentation Working Group aka DaWGs
15:02:00 <zodbot> Meeting started Tue Jun 11 15:02:00 2019 UTC.
15:02:00 <zodbot> This meeting is logged and archived in a public location.
15:02:00 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:00 <zodbot> The meeting name has been set to 'documentation_working_group_aka_dawgs'
15:02:04 <acozine> who's around?
15:02:13 * samccann waves
15:02:19 <acozine> #chair samccann
15:02:19 <zodbot> Current chairs: acozine samccann
15:02:34 <acozine> anybody else?
15:03:06 * acozine looks at the agenda for pre-set items
15:04:00 <acozine> ah, we've got adopt-an-issue on the agenda
15:04:48 <samccann> a fun game for the whole family!!
15:05:04 <acozine> alongchamps andersson007_ felixfontein mrproper orthanc Pilou Xaroth zoredache you folks around?
15:05:06 * bcoca is not allowed to adopt in most states
15:05:14 <samccann> heh
15:05:29 <acozine> #chair bcoca
15:05:29 <zodbot> Current chairs: acozine bcoca samccann
15:05:37 <alongchamps> I'm not around this week acozine
15:06:14 <acozine> alongchamps: too bad! enjoy whatever you're up to and see you next week
15:06:54 <acozine> #topic latest on the version-changer and 404 page
15:07:31 <andersson007_> acozine: i’m here but i can’t discuss anything now, will just read by phone
15:07:51 <acozine> I've been working with the creator of the `sphinx-notfound-page` extension, and the 0.4 release will work for the Ansible docsite
15:08:04 <acozine> andersson007_: glad to have you reading along
15:08:35 <acozine> it's https://github.com/rtfd/sphinx-notfound-page if anyone wants to check it out
15:09:35 <acozine> if the release comes out today or tomorrow, we'll merge and backport the PR to incorporate it, and then we can do final testing of samccann's version-changer work
15:09:51 <samccann> progress!!!
15:10:10 <acozine> that will let us close a bunch of tickets all at once
15:10:19 <acozine> progress indeed!
15:11:28 <acozine> #topic adopt-an-issue
15:12:16 <samccann> #link https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Adocs+label%3Aeasyfix
15:13:02 <samccann> That's a set of simple docs issues that most anyone should be able to pick up and help improve our documentation. We're using the `easyfix` label (which is used on other Ansible projects as well if you are looking for something beyond docs to help with)
15:13:16 <samccann> Share that link with friends and family :-)
15:13:21 <acozine> Yes!
15:13:54 <samccann> joking aside - if you know someone interested in opensource but not sure how to get their feet wet, the `easyfix` label, especially on docs, is a relatively painfree way to get started!
15:14:12 <acozine> We will review the Ansible docs issue backlog (not all at once, because it is large) and add the `easyfix` label as we find good candidates
15:14:30 <samccann> feel free to aggravate your teenaged children with that as well :-)
15:14:45 <acozine> there's not much low-hanging fruit left in the PR backlog, but the Issues backlog probably has lots of it
15:15:02 <samccann> yep it probably does.
15:15:26 <samccann> I was wondering if there were other ways we can get the word out that we have these easy fixes waiting?
15:15:44 <acozine> I was thinking we could forward it to any "teaching kids tech" programs in our communities
15:15:59 <acozine> where "it" == that link
15:16:00 <samccann> twitter comes to mind, but I don't have an account. Maybe Write t he Docs or something?
15:16:07 <acozine> oh, that's a good idea
15:16:31 <samccann> oo I don't have twitter but I do have linkedIn!  TIME FOR LINKEDIN SPAM!!  :-)
15:16:39 <acozine> I'm not on Twitter, but I bet lots of DaWGs are
15:16:51 <acozine> and here at Ansible, the Community folks are, and so are the Marketing folks
15:16:53 <samccann> #action samccann to blog about `easyfit` on linkedIn
15:17:32 <samccann> yes I can ask the marketing/community channels for ideas on how to spread the word
15:17:48 <acozine> are there LinkedIn groups for tech retraining programs?
15:17:59 <samccann> hmm dunno but that's a good idea!
15:18:37 <samccann> #action investigate other places to spread the word, like WriteTheDocs, tech retraining programs, twitter, etc
15:18:47 <samccann> (are those actions working?)
15:18:58 <samccann> always forget how irc works
15:19:08 <acozine> here in MN we've got The Software Guild, Prime Academy, and a few more, I think
15:19:43 <samccann> hmm, we also have interns here at RH.. they may have ideas on where to spread the word to their peers as well
15:21:47 * acozine tries another syntax
15:22:20 <acozine> hm, nope, that didn't work
15:22:28 <samccann> #help
15:22:38 <acozine> heh, a cry in the wilderness
15:22:39 <samccann> hahaha!! a cry in the wilderness!
15:22:46 <samccann> jinx! u owe me a beer
15:22:54 <acozine> sounds good!
15:23:46 <samccann> google'd it and I think we are using the right commands.
15:24:12 <cyberpear> #halp
15:24:29 <samccann> #info DaWGs now labeling easy docs fixes with the `easyfix` and `docs` labels and will broadcast these as easy ways to get into opensource projects
15:24:42 <acozine> samccann: https://wiki.opnfv.org/display/meetings/Meetbot+Tips
15:24:47 <samccann> cyberpear++
15:25:06 <acozine> heh, y'all are way ahead of me
15:25:34 <acozine> #topic open floor
15:26:12 <acozine> thanks felixfontein and orthanc for commenting on PR 57450
15:26:40 <acozine> very helpful
15:27:30 <samccann> do we want to go through some open PRs?
15:27:41 <acozine> we're holding steady at just under 80 open docs PRs for the last few weeks
15:27:52 <acozine> which is good, but I'd like to see it get under 50
15:27:58 <acozine> samccann: sure
15:28:28 <acozine> #topic docs PR triage
15:28:32 <samccann> have we determined if that's possible? (the under 50) given Ansible doesn't close out old/stale PRs from bygone years?
15:28:46 <acozine> https://github.com/ansible/ansible/pulls?utf8=%E2%9C%93&q=is%3Apr+is%3Aopen+label%3Adocs
15:29:33 <acozine> samccann: I hope we can eventually change that culture
15:29:38 <acozine> patience
15:29:41 <acozine> and persistence
15:29:44 <acozine> work wonders
15:30:15 <acozine> but yes, it will be difficult and may not happen soon
15:31:15 <acozine> Actually, looking at the backlog: https://github.com/ansible/ansible/pulls?utf8=%E2%9C%93&q=is%3Apr+is%3Aopen+label%3Adocs
15:31:21 <acozine> only 9 of those are more than a year old
15:31:24 <samccann> yeah. when I look at the old old ones, we have 25 from last year (calling those the ones that will be hard to close)
15:31:37 <samccann> que? you see only 9?
15:32:02 <acozine> only 9 from before June 11, 2019
15:32:11 <acozine> plenty more from 2018
15:32:46 <acozine> I thought we had more ancient ones
15:32:55 <acozine> (2015/2016)
15:32:56 <samccann> 2017 for some of them
15:33:09 <samccann> ah ok. I haven't seen that old
15:33:18 <acozine> This one just needs a maintainer to step up: https://github.com/ansible/ansible/pull/24550
15:33:32 <acozine> it's a plugin for using country codes
15:33:33 <samccann> oh I take it back, 2015 is the oldest outlier.
15:34:01 <samccann> new lookup plugin: LMDB #24550
15:34:12 <samccann> ^^ for those not able to follow the link right now
15:34:49 <acozine> This one needs testing: https://github.com/ansible/ansible/pull/41722 - Consul on a remote server with ACL enabled
15:37:04 <acozine> Here
15:37:09 <acozine> ahem
15:38:12 <acozine> Here's one that needs fleshing out - it's adding examples to the section on debugging as you develop a module: https://github.com/ansible/ansible/pull/50197/files
15:39:44 <acozine> with a couple of reviews, we could merge this one dealing with how to set services installed by apt to NOT start up by default right away: https://github.com/ansible/ansible/pull/56479/files
15:40:52 <acozine> #56479 ^^^ includes links to blog posts about the behavior on Debian . . . since apt is more widely used, it would be great to get feedback from non-Debian apt users
15:41:55 <samccann> #info older PRs that we can likely help push along include #link https://github.com/ansible/ansible/pull/50197/files (add more examples) and #link https://github.com/ansible/ansible/pull/56479/files (review/verify)
15:45:32 <acozine> A mixed PR of docs and code: https://github.com/ansible/ansible/pull/56617/files allows `ansible-galaxy` to download any tarball (not just `tar.gz`) - testing and comments on the code would be helpful on that one
15:47:20 <acozine> and if anyone has insight about how to fix https://github.com/ansible/ansible/pull/57508, which is failing with `literal-block-lex-error` even though the page in question has no codeblocks whatsoever . . . please post ideas here!
15:48:14 <acozine> I think that's plenty for today ;-)
15:48:22 <acozine> #topic open floor
15:48:55 <acozine> does anyone have a PR they'd like to discuss, an issue they'd like to prioritize, or other topics for the group?
15:50:43 <samccann> i'm still trying to round up reviews for -https://github.com/ansible/ansible/pull/57498
15:50:50 <samccann> from network peeps.
15:51:26 <acozine> ah . . . sorting lists of VLANs
15:52:06 <samccann> yep. noticed it was in the code but had no matching docs, so I pulled what was available from the original pr and turned it into that.
15:52:19 <acozine> nice!
15:54:05 <acozine> I'm not the right person to comment on the technical content of that one, though
15:54:31 <samccann> was worth a try :-)
15:54:40 <acozine> absolutely
15:55:01 <acozine> okay, I think we're done for today . . .
15:55:40 <acozine> for anyone who has a PR to discuss, an issue to bring up, a suggestion to make, a question to ask . . .
15:55:48 <acozine> of course you can post to this channel any time
15:56:22 <acozine> but you can also add a comment to https://github.com/ansible/community/issues/389 to get your topic added to next week's agenda
15:56:31 <acozine> thanks everybody!
15:56:35 <acozine> #endmeeting