#ansible-docs: Docs Working Group aka DaWGs
Meeting started by acozine at 14:31:37 UTC
(full logs).
Meeting summary
- opening chatter (acozine, 14:31:47)
- https://www.irccloud.com/pastebin/rf8N9AQx/docsite%20repo%20PR%2025
(acozine,
14:39:49)
- redirects updates (acozine, 14:40:11)
- the current redirects are targeted on urls with
`latest` or `devel` that use the old 2.4-style url pattern. This
complicates the new collection-based module urls. (samccann,
14:46:53)
- the rule basically inserts "modules/" into any
URL that ends with `_module.html (samccann,
14:47:15)
- consider stub pages such as
https://docs.ansible.com/ansible/latest/modules/acme_account_facts_module.html
for when modules move between collections. This gives the user the
info that they need to change things (samccann,
15:25:22)
- AGREED: acozine to
investigate whether the docsite repo needs to remain a private repo
or not (acozine,
15:30:41)
- ACTION: acozine to
investigate whether the docsite repo needs to remain private or
not (acozine,
15:31:10)
- https://github.com/ansible/community/wiki/Docs:Redirects
(abadger1999,
15:31:22)
- details on the types of redirects we need to
consider -
https://github.com/ansible/community/wiki/Docs:Redirects
(samccann,
15:31:44)
- standardizing boolean values (acozine, 15:33:03)
- https://github.com/ansible/community/issues/521#issuecomment-656833594
(acozine,
15:33:23)
- https://github.com/ansible/community/issues/521#issuecomment-656833594
(samccann,
15:34:03)
- ansible.com convertst boolean to yes/now,
ansible-doc to true/false - not sure what AH does. And of course the
docstrings can be either (samccann,
15:59:18)
- consistency may be difficult to achieve
(samccann,
15:59:51)
- AGREED: we should be
consistent in our outputs at least. If we convert to one style
(yes/no or true/false) this needs to apply to AH, ansible-doc and
docs.ansible.com (samccann,
16:02:34)
- ACTION: create a
proposal for creating consistency in the boolean values (acozine,
16:19:46)
- open floor (acozine, 16:21:06)
- open floor (felixfontein, 16:21:06)
- changelog output (samccann, 16:22:37)
- changelog output now groups by change type
(minor, major, etc) and then lists by collection (samccann,
16:25:57)
Meeting ended at 16:28:21 UTC
(full logs).
Action items
- acozine to investigate whether the docsite repo needs to remain private or not
- create a proposal for creating consistency in the boolean values
Action items, by person
- acozine
- acozine to investigate whether the docsite repo needs to remain private or not
People present (lines said)
- acozine (132)
- felixfontein (113)
- samccann (64)
- abadger1999 (19)
- zbr (19)
- cyberpear (13)
- Jmainguy (12)
- zodbot (10)
- baptistemm (7)
- andersson007_ (2)
- zbr|ruck (2)
- geerlingguy (2)
Generated by MeetBot 0.1.4.