14:34:05 <acozine> #startmeeting Docs Working Group aka DaWGs
14:34:05 <zodbot> Meeting started Tue Aug 11 14:34:05 2020 UTC.
14:34:05 <zodbot> This meeting is logged and archived in a public location.
14:34:05 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:34:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:34:05 <zodbot> The meeting name has been set to 'docs_working_group_aka_dawgs'
14:34:17 <acozine> #topic opening chatter
14:34:21 <acozine> who's around?
14:34:44 <felixfontein> hi!
14:35:08 <acozine> hi Felix!
14:35:12 <acozine> #chair felixfontein
14:35:12 <zodbot> Current chairs: acozine felixfontein
14:35:20 <baptistemm> hi
14:35:27 <acozine> hi Baptiste!
14:35:30 <acozine> #chair baptistemm
14:35:30 <zodbot> Current chairs: acozine baptistemm felixfontein
14:36:36 * samccann waves late
14:36:53 <felixfontein> hi alicia!
14:36:56 <felixfontein> and hi everyone else :)
14:37:07 <acozine> gundalow: samccann andersson007_ briantist cbudz cyberpear gwmngilfen jhawkesworth Jmainguy madonius persysted shaps you folks talking docs today?
14:37:20 <acozine> #chair samccann
14:37:20 <zodbot> Current chairs: acozine baptistemm felixfontein samccann
14:37:32 <cyberpear> o/
14:37:47 <acozine> hi James!
14:37:51 <acozine> #chair cyberpear
14:37:51 <zodbot> Current chairs: acozine baptistemm cyberpear felixfontein samccann
14:37:57 * gundalow waves
14:38:01 <acozine> #chair gundalow
14:38:01 <zodbot> Current chairs: acozine baptistemm cyberpear felixfontein gundalow samccann
14:39:00 * acozine digs for the agenda
14:39:20 <acozine> here we go:
14:39:21 <acozine> https://github.com/ansible/community/issues/521#issuecomment-668744313
14:39:34 <andersson007_> hi
14:39:41 <felixfontein> #chair andersson007_
14:39:41 <zodbot> Current chairs: acozine andersson007_ baptistemm cyberpear felixfontein gundalow samccann
14:39:47 <acozine> hi andersson007_ !
14:39:59 <felixfontein> good to see you around for the docs meeting andersson007_ :)
14:40:08 <andersson007_> heh
14:40:09 <acozine> +1
14:40:20 <samccann> +1 for everyone!
14:40:46 <acozine> samccann: I think our first agenda item is yours - you ready to do an update on `latest`?
14:41:09 <samccann> sure
14:41:16 <samccann> #topic Update on latest url
14:41:53 <samccann> So we have two deliverables at this point - ansible-base, and ansible (the package).  At this point, a lot of our docs are focused on Ansible
14:42:21 <samccann> ansible-base releases hopefully later this week. We'll have changelog/porting guide etc ready for that
14:42:52 <samccann> but we won't switch the version switcher to include 2.10, or change the pages that /latest/ refers to until Ansible releases later
14:43:18 <samccann> oh I should have info'd that.  doh!
14:43:37 <cyberpear> sounds like a plan
14:43:39 <felixfontein> just use arrow-up and prepend #info ;)
14:43:43 <samccann> #info ansible-base 2.10 release happening soon. We'll have changelogs and porting guides for that
14:43:47 <acozine> #info we will update the `latest` symlink for the docs only after ansible 2.10 is released
14:43:54 <samccann> #info but we won't switch the version switcher to include 2.10, or change the pages that /latest/ refers to until Ansible releases later
14:44:10 <samccann> felixfontein++ woot! never knew that trick
14:44:29 <samccann> I think that's all there was for that agenda item
14:44:49 <acozine> I have one thing to add
14:44:50 <felixfontein> samccann: arrow keys work wonderfully both for command lines and most sensible irc clients ;)
14:44:58 <samccann> :-)
14:45:36 <acozine> release of ansible-base should be this Friday, if all goes well . . . and the release automation pipeline used to update the `latest` link automatically
14:45:55 <acozine> we will try to intervene, and to update the pipeline so those two steps are separate
14:46:01 <acozine> but we might mess up
14:46:26 <acozine> so please drop a note in chat if that goes wrong and you notice it first
14:47:46 <baptistemm> ok
14:47:57 <acozine> thanks!
14:48:18 <andersson007_> +1
14:48:34 <samccann> fwiw I think if the release happens as scheduled, it's Thursday
14:48:43 <felixfontein> depends on time zone :)
14:49:02 <samccann> heh true
14:50:45 <acozine> yeah, I'll sleep better knowing that we have a worldwide network of eyes on the docs
14:50:52 <acozine> day and night
14:51:26 <baptistemm> normally that is called monitoring :)
14:51:32 <acozine> heh, yeah
14:51:50 <acozine> I used to run a nagios server, and maybe we could develop some monitoring . . .
14:52:02 <acozine> but it's not going to happen this week
14:52:30 <samccann> #info Thursday's release of ansible-base should not change the /latest/ url to 2.10 (it should stay 2.9) - if you see problems, please let us know here in irc
14:52:50 <samccann> oooo... now that sounds like fun acozine!  for another day of course
14:52:59 <acozine> #topic FQCN changes and PR 70530
14:53:26 <felixfontein> https://github.com/ansible/ansible/pull/70530
14:53:32 <samccann> This one is hopefully easy. It's passing shippable now and changes the docs to use FQCN for `ansible.builtin'
14:53:49 <samccann> I didn't want to hit the merge just in case anyone had lingering doubts etc.
14:54:06 * samccann really wants to hit the merge cuz she thinks it will get rid of a batch of docs build errors
14:54:23 * acozine looks at review comments
14:55:33 <baptistemm> I'm ok but I'm biased, that's my patch
14:55:40 <samccann> :-)
14:56:04 <acozine> I think it's good to go - most of the questions were "do we really want this construction everywhere" and we've agreed that yes, we do
14:56:06 <samccann> I'm pretty sure we were all in agreement after some initial clarification with core team folks
14:56:11 <felixfontein> looks good to me
14:56:16 <samccann> ok gonna merge.. thanks!
14:56:21 <samccann> #info PR is ready to merge
14:56:24 <acozine> hooray!
14:56:24 <felixfontein> awesome work, baptistemm!
14:57:09 <acozine> thanks baptistemm for the PR and andersson007_ for the detailed review
14:57:31 <baptistemm> so if docs is broken you can blame me
14:57:38 <baptistemm> s/is/are/
14:57:38 <acozine> heh
14:57:51 <andersson007_> community is always welcome:)
14:59:59 <acozine> the docs wouldn't be even half as good as they are without contributors
15:00:30 <acozine> the FQCN transition is likely to mean minor breakages for a while
15:01:02 <acozine> but the DaWGs make a huge, positive difference
15:01:27 <samccann> we need capes... we so need capes
15:01:39 <samccann> superhero DaWGs!  (with capes)
15:01:58 <acozine> heh, I want leather jackets with the DaWGs logo, like a nerdy motorcycle gang
15:02:14 <baptistemm> samccann: acozine: so you're going to push to /devel soon ยง
15:02:25 <baptistemm> s/$/?/
15:02:32 <acozine> baptistemm: yes, we'll republish today
15:02:40 <acozine> and backport to 2.10 later this week
15:02:51 <acozine> (republish `devel` today)
15:03:12 <samccann> yep. I'm going to build locally and see if it does get rid of some build errors!
15:03:48 <samccann> omgosh just read the leather jacket comment and thought the DaWGs Tricycle Gang!
15:03:52 <acozine> fingers crossed!
15:03:57 <baptistemm> https://github.com/ansible/ansible/pull/71194 humm IBM style guide
15:04:34 <baptistemm> hey bcoca
15:04:55 <samccann> did you have a comment or question on that PR baptistemm ?
15:05:26 <samccann> The background of it is - we know what the top 10 most read pages are on the docs, so our summer intern is doing some tidying up of those pages
15:05:32 <baptistemm> no just came across that while looking at docs labeled PR
15:05:40 <samccann> heh ok.
15:05:46 <samccann> should we move to the next agenda item?
15:05:50 <acozine> sure
15:05:52 <acozine> #topic release and maintenance page
15:06:24 <acozine> https://docs.ansible.com/ansible/latest/reference_appendices/release_and_maintenance.html
15:06:27 <samccann> so bit of background - right now the releaese and maintenance page talks about our release cycles and then links to the changelogs for all the releases going back 'abit'
15:06:47 <baptistemm> acozine: samccann: Is the Style guide reference this one https://www.ibm.com/developerworks/library/styleguidelines/index.html ?
15:07:03 <samccann> with ansible-base coming out this week, and some of the comments on the PR, I got to thinking maybe that's another page where we need to make a difference between ansible and ansible-base
15:07:23 <felixfontein> samccann: I agree
15:07:40 <acozine> baptistemm: that's part of it, but there's a huge IBM Style Guide
15:07:40 <baptistemm> yes
15:07:57 <baptistemm> acozine: I'm not surprised, so I'll ask later
15:08:01 <baptistemm> :)
15:08:23 <samccann> should I POLL??? cuz it wouldn't be a meeting w/o a POLL!!
15:08:48 <acozine> oooh, a poll!
15:08:56 <samccann> POLL - We should separate ansible-base release/maint from Ansible release/maint, preferrably before this week's release.  +1 is agree, -1 disagree
15:09:12 <felixfontein> +1
15:09:17 <baptistemm> +1
15:09:19 <andersson007_> +1
15:09:21 <acozine> +1
15:09:23 <felixfontein> (not necessarily a separate page though, but at least a separate section)
15:09:43 <felixfontein> I guess abadger1999 and gundalow need to get involved for the content of the ansible part, though
15:09:49 <samccann> good point felixfontein
15:10:17 <acozine> well, some way to differentiate, so users understand what is and what is not maintained
15:10:41 <samccann> oh forgot my vote - +1  :-)
15:10:59 <samccann> #chair
15:10:59 <zodbot> Current chairs: acozine andersson007_ baptistemm cyberpear felixfontein gundalow samccann
15:11:17 <acozine> heh, the pollster must participate!
15:11:19 <samccann> closing the vote - 5 in favor, 1 abstain
15:11:41 <gundalow> +1
15:11:48 <samccann> #agreed - separate ansible-base from Ansible on the release-maintenance page, preferably before Thurs
15:11:55 <acozine> it's a mail-in poll ballot!
15:12:00 <samccann> WOOT!
15:12:11 <samccann> 6 in favor,, we are UNANIMOUS!
15:12:33 <gundalow> I believe Tower Docs did something recently to ensure people were always looking at the newest version of that page
15:12:37 <acozine> I think we still have one non-voting member
15:12:37 * abadger1999 shows up
15:12:50 <acozine> welcome abadger1999
15:12:51 <felixfontein> #chair abadger1999
15:12:51 <zodbot> Current chairs: abadger1999 acozine andersson007_ baptistemm cyberpear felixfontein gundalow samccann
15:13:00 <baptistemm> as we are on this page wo managed to update Release Status https://docs.ansible.com/ansible/latest/reference_appendices/release_and_maintenance.html#release-status
15:13:05 <gundalow> (the Tower equlilevent of supported versions)
15:13:11 <samccann> #action samccann to ask tower folks how they ensured people always looked at the newest version of that release page
15:13:30 * acozine hopes it didn't involve endless backprots
15:13:33 <gundalow> samccann: I think it was URL redirects
15:13:50 <acozine> oh . . . oh dear
15:13:50 <samccann> yeah I think the ..server person did the magic for them, but it's a good idea for us as well
15:14:21 <samccann> #action samccann to create a quick PR to make the release/maintenance page have separate sections for ansible-base vs ansible
15:14:33 <acozine> we'll need to add text to that page letting people know they "aren't on the version they started on" and may need to version-switch back
15:14:39 <acozine> if we put in a redirect
15:16:46 <samccann> on to the next topic?
15:16:50 <acozine> sure!
15:17:09 <acozine> #topic updates on porting guide, changelogs, and pipeline
15:17:21 <acozine> I merged the next two topics
15:17:26 <samccann> :-)
15:17:36 <felixfontein> from my side, there's no real update for today
15:18:10 <felixfontein> some collections started conversion of their existing changelogs / adding changelogs, and at least one collection wants a link to their changelog (https://github.com/ansible-community/ansible-build-data/issues/28)
15:19:01 <abadger1999> Yay!  Soon your changelog tool will take over the world ;-)
15:19:15 <acozine> cool, so folks took notice of that "What Collection Owners Need to Know" post!
15:19:25 <felixfontein> only when it also supports projects other than ansible-base and ansible collections ;)
15:19:37 <felixfontein> acozine: indeed
15:19:50 <acozine> that is good news indeed
15:21:00 <abadger1999> For pipeline, continuing work on redirects, nitzmahone contributed some good code to find all of the runtime.yml listed redirects on Friday.  I'm integrating that into the redirect script right now.  Then finishing up  outputting apache conf files for that.
15:21:09 <samccann> #info some collections are converting their changelogs to use our tool. We have one request so far for a direct link to a collections changelog due to format requirements unique to that community.
15:21:18 <acozine> abadger1999: awesome
15:21:34 <acozine> does anyone know of blockers for any of this work?
15:21:51 <samccann> #info pipeline redirects work starting. We will open an issue 'someplace logical' to explain the strategy of the redirects
15:22:29 <acozine> progress!
15:22:45 <samccann> #info this would redirect someone who had a bookmark to /latest/some-module so it goes to /latest/collections/blabla/some-module... and the reverse.. so to speak. See issue when it is created for more details
15:23:03 <samccann> #action samccann to create a tracking issue for the redirects
15:23:03 <acozine> gundalow: could you give us the latest on closing out collections-related issues and PRs from ansible/ansible?
15:24:52 <acozine> hm, gundalow must have stepped away
15:25:17 <acozine> #topic priority issues for 2.10 docs
15:25:53 <acozine> samccann has been organizing the docs issues in https://github.com/ansible/ansible/projects/27#column-2809177
15:26:00 <acozine> er, well, in that project
15:26:15 <acozine> that column reflects the high-priority work we know about
15:27:30 <acozine> everyone can see the project page, right?
15:27:49 <baptistemm> yes, and I saw card moving live...
15:28:00 <baptistemm> first time experience
15:28:17 <acozine> it's . . . MAGIC
15:29:06 <samccann> haha sorry. I've been lazy and forgot to keep it up to date. Some of those priority things are done
15:29:26 <abadger1999> :-)
15:29:40 <acozine> samccann: you've been fixing things!
15:29:41 <felixfontein> which is good!
15:30:12 <samccann> oh not just me! I'm just coming in with the broom to sweep things away as they are done
15:30:51 <samccann> #info check https://github.com/ansible/ansible/projects/27#column-2809177 for list of priority items we are tracking for Ansible 2.10 release. Let us know if you see something else we need to track
15:31:06 <baptistemm> https://github.com/ansible/ansible/issues/59226 is it still accurate ?
15:31:34 <acozine> baptistemm: I think so, yes
15:32:33 <acozine> that would be a great one to fix
15:32:46 <acozine> speaking of issues . . .
15:33:01 <acozine> #topic the Great Issue and PR Autoclose
15:33:39 <samccann> dun da dun!!
15:33:42 <acozine> gundalow knows more of the details than I do, but we are close to letting the bot close issues and PRs in ansible/ansible that relate to modules/plugins that have moved to collections
15:33:49 <felixfontein> baptistemm: it's still accurate - except that for doc fragments which used to be in ansible/ansible there's a redirection
15:34:34 <acozine> What This Means for Us: legacy issues and PRs will go away, and our open PR/issue count for docs will drop
15:34:53 * felixfontein is curious by how much the PR/issue count will drop
15:34:59 <samccann> sadly not as much as I thought it would (on the PRs).  7
15:35:05 <samccann> issues were more like 30?
15:35:13 <acozine> What This Also Means for Us: if we have open issues or PRs that are still relevant, we need to copy them to the right repos
15:36:07 <felixfontein> alltogether, ~2200 issues and PRs will be closed, if the label needs_collection_redirect is accurate
15:36:19 <felixfontein> out of ~5000 issues+PRs in total
15:36:24 <acozine> #info check your PRs and issues to see if you have any old ones you want to move
15:36:38 <acozine> so that's, what, 40% or so?
15:36:47 <samccann> #info use the needs_collection_redirect label to find them
15:37:03 <acozine> it may help a bit, anyway
15:37:18 <gundalow> acozine: issues and PRs will start being closed from today I believe
15:37:19 <acozine> but we don't want to lose relevant stuff if we can avoid it
15:37:25 <acozine> gundalow: ah, thanks
15:37:38 <samccann> #info or bot_closed to see what was automatically closed after the bot runs
15:37:44 <acozine> #info the bot is starting to work on closing old issues and PRs today
15:38:22 <Shrews> fyi, i think that will begin tomorrow
15:38:34 <acozine> ah, thanks Shrews
15:38:39 <felixfontein> if you want to find PRs/issues created by *you*, use the following URL and insert your github username: https://github.com/ansible/ansible/issues?q=is%3Aopen+label%3Aneeds_collection_redirect+author%3A<USERNAME>
15:39:05 <baptistemm> I can see issue with needs_collection_redirect since May 25
15:39:16 <acozine> heh, not everyone got the memo
15:39:38 <felixfontein> baptistemm: that label has been added for some time now
15:40:05 <baptistemm> Shrews: tomorrow in the USA ?
15:40:28 * acozine needs to leave for a family thing, turns the reins over to samccann and current chairs
15:40:30 <acozine> thanks everybody!
15:40:31 <Shrews> yes
15:40:35 <felixfontein> see you acozine!
15:40:47 * acozine waves
15:41:26 <samccann> alrighty then!
15:41:41 <samccann> #topic General Status updates
15:42:13 <samccann> #info work still going to get the docs to say collections/FQCN where needed. Volunteers most welcome to help out!
15:42:56 <samccann> I'm working through the network docs, but if you have a favorite doc or set of pages and are up for making sure they make sense in the collection world, please do adopt it and update it. PRs most welcome!
15:43:13 <samccann> anyone else have general updates not mentioned yet?
15:44:02 <baptistemm> samccann: you mean updating the example ? or replacing terms "modules", "plugins" ... ?
15:44:49 <felixfontein> out of curiosity, how many docs build errors do we have left (when building collection docs)?
15:45:02 <samccann> two things really, which could happen in the same PR or different ones:
15:45:15 <samccann> 1 - update for FQCN as needed.  That's fairly easy to run through.
15:45:36 <samccann> 2 - Read through and decide - should some of this be talking about collections instead of just modules?  That one is harder
15:45:53 <baptistemm> samccann: so you have an example of PR ?
15:46:03 <samccann> because some of the docs are reflecting ansible-base modules, and some might be talking about modules that are now in a collection
15:46:12 <abadger1999> Sort of an update, sort of a correction:  earlier it was said that ansible-base is releasing on Friday.  It's actually releasing on Thursday.
15:46:26 <samccann> so the FQCN you already did with that buildin PR we just merged. So looking around for more of that
15:46:37 <samccann> thanks abadger1999 !
15:47:16 <samccann> baptistemm - this is an example of a PR that does both  - https://github.com/ansible/ansible/pull/71188
15:47:23 <felixfontein> let's say it will be released on Friday, then it's correct for both US + Europe ;)
15:47:31 <abadger1999> Heh :-)
15:47:33 <samccann> most of it is FQCN, but occassionally I found a spot where it should be saying collections.
15:47:37 <felixfontein> be=have been ;)
15:48:17 <samccann> felixfontein - docs build for 2.10 (that includes all collections) has something upwards of 800 warnings :-(
15:48:28 <samccann> though that was last week. I haven't checked today
15:48:45 <felixfontein> samccann: I hope it gets better! also, I guess these are just the RST warnings, and not broken HTML links?
15:49:08 <samccann> and woot!! baptistemm's PR that we just merged dropped the devel build warnings from 303 to 123!!!
15:49:40 <samccann> felixfontein - I 'think' most of them are just undefined labels, so sphinx just puts the text and no link
15:49:44 <felixfontein> cool!
15:49:56 <samccann> ok gonna open the floor in case anyone has been lurking and waiting
15:50:00 <samccann> #topic Open Floor
15:50:18 <samccann> Anyone around who wanted to pipe in on docs but hasn't had the chance yet?
15:51:31 <abadger1999> Friday of this week is a red hat "recharge day".  Most red hat employees will have the day off.
15:51:44 <samccann> oh yeah good point!
15:51:49 <abadger1999> In case ya'll wonder why things are so quiet ;-)
15:51:59 <andersson007_> "recharge day" sounds good
15:52:36 <baptistemm> good for you
15:52:42 <samccann> ok gonna close this meeting out if there's nothing else?
15:53:05 <abadger1999> #info Friday of this week is a red hat "recharge day".  Most red hat employees will have the day off.
15:53:14 <samccann> :-)
15:53:34 <samccann> #endmeeting